5ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

オープンソースDataBase

1 :名無しさん@お腹いっぱい。:03/05/01 04:52
PostgreSQL,MySQL,Firebird,その他
UNIX / BSD / Linux で使える
オープンソースなDataBaseに関する雑談・相談スレ

110 :みつぼし:03/06/18 16:52
>>105
ご回答ありがとうございます。

後者はちょっとやれないので、前者で・・・。

>ODBC経由でOracleに接続してデータを取得して

ここなんです。LinuxでもODBC接続のツールがあるのですか?
Windowsだけの世界かと・・・。
ODBC接続のドライバとかはpostgresとかをインストールすると
ついてくるのでしょうか?
別プログラム(postgresと全然関係ないグループが開発している?)なのでしょうか?

111 :名無しさん@お腹いっぱい。:03/06/18 20:53
>>110
unixODBC ってのがあるからググレ


112 :名無しさん@お腹いっぱい。:03/06/18 21:12
>>110
ちょっと誤解している。>>105が変なこと書いたせいだが。

ODBCは通信プロトコルじゃない。Oracleに接続するには
Net8クライアントが必要。Linux用はLinux用サーバー製品に
同梱されている。入手できないなら、JDBCのType4ドライバが
公開されているから、これを使うのが一番手軽。

113 :名無しさん@お腹いっぱい。:03/06/18 21:47
>>112
>>110 が質問してるのはLinuxからOracleに接続するって意味じゃないの?
LinuxのOracleに接続する方法を質問してるんじゃないと思うけど
その辺りは >>110 的にはどーなんだろ。

114 :名無しさん@お腹いっぱい。:03/06/18 23:51
異なるデータベース間を JDBC でデータ移動?
コードを書き進めるにつれ泣き見る気が。。。

115 :名無しさん@お腹いっぱい。:03/06/19 00:35
>>110 Perl+DBIは?

116 :名無しさん@お腹いっぱい。:03/06/19 00:36
>>110
俺ならC/Sなシステム書くよ、
どの程度のデータを取って来たいのかわからないけど
その方が安定してて速度も速いだろ

117 :名無しさん@お腹いっぱい。:03/06/19 21:29
PostgreSQLをインストールしようとしました。

./configure --with-perl --with-java --with-openssl
を実行。

まず、readlineがないと文句を言われる。
仕方がなくwithout-readlineをつけた。

しかし、zlibがないと文句を言われる。
仕方がなくwithout-zlibをつけた。

--with-openssl オプションでopensslが見つからないというメッセージ。
それでfindで検索 /usr/bin/openssl を見つけた。
--with-openssl=/usr/bin/openssl とした。
すると以下のようなメッセージ。

checking for library containing getopt_long... none required
checking for main in -lunix... no
checking for library containing crypt... -lcrypt
checking for __inet_ntoa in -lbind... no
checking for library containing fdatasync... none required
checking for shmget in -lcygipc... no
checking for CRYPTO_new_ex_data in -lcrypto... no
configure: error: library 'crypto' is required for OpenSSL

findでcryptを検索したが見つからず。
crypt関数のライブラリが必要なのですか?
zlibは使えるならインストールしてでも使ったほうがいいのでしょうか?
PostgreSQLはJ2EEやTomcat、PHP、perlで使う予定ですが、
OpenSSLはあったほうがいいでしょうか?


118 :名無しさん@お腹いっぱい。:03/06/20 00:25
>>117
通勤用の車を買おうとしています、
盗難防止用のアラームも付けたほうがいいでしょうか?
と質問してるのと同じレベルの質問だと思うよ、
他人に尋ねるような事じゃないよね。

いるなら要るんじゃない? SSL使わないならいらないよね。
としか答えられない。

119 :三ツ星改め110:03/06/20 01:08
110です。
>>113
Sunのうえにoracleで、場所は別のデータセンターにあります。
会社からはWinでODBCで接続しています。
自分の席にlinuxをたてたので、オラクルから自分のlinux上のDBに
自動取り込みをしたいというのが目的です。


>>115
なんかいけそうでよさそうですね。
PHPでもいけるのでしょうか?
http://www.rfs.jp/sitebuilder/perl/dbi/



120 :名無しさん@お腹いっぱい。:03/06/20 01:29
>>113
Linuxからだろうと何だろうと、Oracleに接続するにはNet8
クライアントが必要だよ。逆にNet8クライアントがあれば
Linux用でもSolaris用でもどのOracleにでも繋がる。

121 :三ツ星改め110:03/06/20 02:03


ということは期待したDBIでもNet8を入手して初めて
実現できるということですか?

68 KB
■ このスレッドは過去ログ倉庫に格納されています

★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.04.00 2017/10/04 Walang Kapalit ★
FOX ★ DSO(Dynamic Shared Object)