5ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

Vine Linux Thread 其の28

1 :login:Penguin:04/12/25 02:17:11 ID:Y+vAmPiQ
質問をする前に http://linux2ch.bbzone.net/ を読み
>>2 で調べ、スレの検索も忘れずに。

●前スレ
Vine Linux Thread 其の27
http://pc5.2ch.net/test/read.cgi/linux/1101356529/

●過去ログ検索 (Vine Linux Thread 其の13 75さん提供)
http://2chlinux.dtdns.net/2ch-linux-vine/

●VineLinux ホームページ
http://vinelinux.org/

●FTPサイト
http://vinelinux.org/getvine.html#ViaFTP


2 :login:Penguin:04/12/25 02:17:52 ID:Y+vAmPiQ
●ドキュメント・FAQ

Vine Linux 3.0 Tips
http://vinelinux.org/vine30.html

オンラインマニュアル
http://vinelinux.org/documentations.html

Vine Linux 3.x FAQ
http://vinedocs.sourceforge.jp/index?FAQ

RPM/APT によるパッケージ管理
http://vinelinux.org/manuals/using-rpm.html

2ch Linux Beginners FAQ-ディストリビューション別-Vine Linux
http://linux2ch.bbzone.net/index.php?FaqDistributionVine

Vine Linux's FAQs
http://www.asahi-net.or.jp/~cg3h-mt/linux/FAQ.html

Vine Linux で ADSL
http://www.utchy.com/linux/

VineUsers-ML 全文検索システム (更新されていません)
http://vine.ic.sci.yamaguchi-u.ac.jp/

Linux 関連ドキュメント検索システム
http://search.luky.org/

質問の多い FTP 版と製品版 (CR 版) の違いについてはこちらを参考にしてください。
http://vinelinux.org/getvine.html


3 :login:Penguin:04/12/25 02:18:21 ID:Y+vAmPiQ
●セキュリティ

定期的に、root権限でapt-get update; apt-get upgradeを実行し、
バグフィックス/セキュリティ修正アップデートを行う。
(kddlabs と jaist はミラーリングが止ってるかもしれないので注意)

Vine Linux更新/障害/セキュリティ情報
http://vinelinux.org/errata.html

Errata 3.x RDF
http://vinelinux.org/errata3x.rdf

Errata 2.5/2.6 RDF
http://vinelinux.org/errata.rdf

Linux バグ・セキュリティ情報
http://www.linux.or.jp/security/

Vine Linux 3.1 は 3.0 に対してセキュリティフィクスおよびバグフィクスを
適用したマイナーアップグレードバージョンという扱いになっているようです。
よって 3.X に対するセキュリティフィックスおよびバグフィクスは、3.1 を
対象に行なわれるようです。3.0 を使っている方は特別な事情がないかぎり
3.1 にアップグレードした方がよいと思われます。


4 :login:Penguin:04/12/25 02:18:59 ID:Y+vAmPiQ
●過去スレと関連スレ

27 http://pc5.2ch.net/test/read.cgi/linux/1098350544/
26 http://pc5.2ch.net/test/read.cgi/linux/1098350544/
25 http://pc5.2ch.net/test/read.cgi/linux/1094831763/
24 http://pc5.2ch.net/test/read.cgi/linux/1092820313/
23 http://pc5.2ch.net/test/read.cgi/linux/1091614123/
22 http://pc5.2ch.net/test/read.cgi/linux/1090324132/
21 http://pc5.2ch.net/test/read.cgi/linux/1087581260/
20 http://pc5.2ch.net/test/read.cgi/linux/1084294058/
19 http://pc5.2ch.net/test/read.cgi/linux/1080401644/
18 http://pc3.2ch.net/test/read.cgi/linux/1076088476/
17 http://pc.2ch.net/test/read.cgi/linux/1070886677/
16 http://pc.2ch.net/test/read.cgi/linux/1066403433/
15 http://pc.2ch.net/test/read.cgi/linux/1061746337/
14 http://pc.2ch.net/test/read.cgi/linux/1055604491/
13 http://pc.2ch.net/test/read.cgi/linux/1051436146/
12 http://pc.2ch.net/test/read.cgi/linux/1047747664/
11 http://pc.2ch.net/test/read.cgi/linux/1043375119/
10 http://pc.2ch.net/test/read.cgi/linux/1039024291/
9 http://pc.2ch.net/linux/kako/1036/10361/1036171785.html
8 http://pc.2ch.net/linux/kako/1034/10341/1034140238.html
7 http://pc.2ch.net/linux/kako/1029/10296/1029655159.html
6 http://pc.2ch.net/linux/kako/1024/10240/1024030037.html
5 http://pc.2ch.net/linux/kako/1021/10213/1021343354.html
4 http://pc.2ch.net/linux/kako/1019/10190/1019001710.html
3 http://pc.2ch.net/linux/kako/1016/10160/1016085342.html
2 http://pc.2ch.net/linux/kako/1008/10085/1008556539.html
1 http://pc.2ch.net/linux/kako/997/997886457.html
2.1.5リリース http://pc.2ch.net/linux/kako/985/985745359.html
Vain Caves設立! http://pc.2ch.net/linux/kako/1006/10068/1006818001.html


5 :login:Penguin:04/12/25 02:19:36 ID:Y+vAmPiQ
●2.6 -> 3.0

vine-users ML の [vine-users:066774] upgrade to 3.0 from 2.6 by apt
http://search.luky.org/vine-users.6/msg06774.html
から始まるスレッド

http://slashdot.jp/comments.pl?sid=200155&cid=600211&threshold=0
などを参照。自己責任でどうぞ。

tee などを使ってログを残すようにすると、はまっても対処
しやすいです。(転んでも泣かない)


6 :login:Penguin:04/12/25 03:35:46 ID:2CdzF8jU
>>1


7 :login:Penguin:04/12/25 10:27:39 ID:Zgp7CG+x
Sylpheed 1.0.0 released!
ttp://www.tmtm.org/cgi-bin/w3ml/sylpheed-jp/msg/2774

初期の頃から標準 MUA として採用してきた Vine だから,
Seed 以外でも upgrade してくれるかな.

8 :login:Penguin:04/12/25 14:48:06 ID:AKm/imju
Vineの標準メーラーはvmailだろw

9 :login:Penguin:04/12/25 15:23:28 ID:V/TN3J3L
mozilla mailの扱いはどうなってるんだろう…


10 :login:Penguin:04/12/25 21:59:36 ID:YC6YQqbM
MagicKeyを有効にしたいと思い、
kernel.src.rpmを
mkkpkg --rpmarg="--target i686" kernel.src.rpm
として、kernel hackingのところのkerneldebugとmagickeyを*つけて再構築。

で、出来上がった
kernel.i686.rpmをrpm -ivhで、
kernel-source,kernel-headers,kernel-docをrpm-Uvhで
インストールしました。
liloも編集し、/sbin/liloもしました。

で、新しいカーネルで起動したのですが、
/proc/sys/kernel/sysrqというファイルが無く、
sysctl -w kernel.sysrq="1"としても
error: 'kernel.sysrq' is an unknown key
と出ます。

どうしたらMagickeyが使えるようになるんでしょうか?

11 :login:Penguin:04/12/26 01:59:09 ID:4LEQ8xFa
前スレの819でも出ていましたが、私もsambaを3.0.7->3.0.9にしたらWindowsクライアントから接続不能になりました。
いろいろ調べてみたところ、"display charset"の値を"eucJP-ms"から"CP932"へ変更したところ正常に動作するようになりました。
同様の現象でお困りの方は試してみてください。

### 3.0.7
[global]
dos charset = CP932
unix charset = eucJP-ms
display charset = eucJP-ms

### 3.0.9
[global]
dos charset = CP932
unix charset = eucJP-ms
display charset = CP932


12 :login:Penguin:04/12/26 04:48:41 ID:kS1NXPkk
>>10
> /proc/sys/kernel/sysrqというファイルが無く、

ということは、その前の作業のどこかで失敗している


13 :前スレ904:04/12/26 08:57:34 ID:TQgiEBzI
前スレでFW内側からの、意図しないポートスキャンについて
質問した者です。

結論としてはFWの設定を誤って削除していた為、
不正中継されていたようでした。
なお、ポートスキャンは53番ポートから発射されていました(DNS?)

御回答いただいた方々、本当にありがとうございました。



14 :login:Penguin:04/12/26 11:47:01 ID:oZ3I0kgH
それはそうと、VineSeed に kitty-guy が湧いてるんだが、
そろそろ Vine も終りかね?

15 :login:Penguin:04/12/26 11:51:27 ID:ksgWpLTO
VineでMTU値とかRWIN変えるにはどうすればいいんでしょうか?

16 :10:04/12/26 13:27:28 ID:VC6NwnKd
>>12

コンパイルで出来上がったi686はsysrq無いのですが、
同じコンパイルで出来上がったi386のカーネルはちゃんとsysrqがちゃんとあります。

なぜでしょうか?

17 :login:Penguin:04/12/26 13:46:29 ID:EzNkWSI2
>>16
それはやり方が間違ってるから。
i386 用の config ファイルを編集しても、i686 用にカーネルをビルドする時には
反映されないだろ。
--rpmarg ではなく、直接 --target i686 と指定してみたら?

18 :10:04/12/26 15:10:41 ID:MdwoIYj9
>>17

出来ました!!thx

しかし、今度はsource,doc,headersが作成出来ません。

mkkpkg kernel.src.rpmで
i686用のconfigファイルを読み込ませて出来上がった
source,doc,headers
をインストールすればイイんでしょうか?

19 :login:Penguin:04/12/26 15:23:15 ID:c9+3urtp
spec に
%ifnarch i586 i686 athlon sparc64
# START BASE ARCHES ONLY
%ifarch i386 alpha sparc ppc
と書いてあるから

20 :前スレ819:04/12/27 01:17:42 ID:uZOoPKog
>>11
情報ありがとう。
試してみます。

これって仕様が変更になったということなのか、
はたまた何かの間違いなのか…???

21 :login:Penguin:04/12/27 04:42:21 ID:O/UUWm/6
>>15
jman ifconfig
で、/MTU とか打ってみたらいいんじゃない?

22 :login:Penguin:04/12/27 06:43:11 ID:OdiMqxLN
>>21
# ifconfig eth0 mtu 1492

でMTUは変わりますがRWINの変更がわからなかったり。

23 :login:Penguin:04/12/27 08:00:45 ID:Lkbbbr9e
>>22
ttp://www.atmarkit.co.jp/fnetwork/netcom/netcom02/netcom01.html
でも読め


24 :login:Penguin:04/12/27 10:44:36 ID:OdiMqxLN
>>23
――経路の追加
route[ -v][ -F] add{ -host| -net} 宛先IPアドレス[/プレフィックス][ gw ゲートウェイIPアドレス]
[ metric メトリック数][ netmask サブネットマスクアドレス][ mss MSSサイズ][ window TCPウィンドウサイズ]
[ irtt 初期ラウンドトリップ時間][ mod][ dyn][ reinstate][[dev] インターフェイス名]


何これ。 window TCPウィンドウサイズを変更するにはどう記述すればいいのよさ。

25 :login:Penguin:04/12/27 13:35:25 ID:wONrz+jE
>11
やってみたけど、
Starting SMB services: [FAILED] となる。

smb.log に
[2004/12/27 13:21:26, 0] lib/fault.c:fault_report(36)
===============================================================
[2004/12/27 13:21:26, 0] lib/fault.c:fault_report(37)
INTERNAL ERROR: Signal 11 in pid 1356 (3.0.9)
Please read the appendix Bugs of the Samba HOWTO collection
[2004/12/27 13:21:26, 0] lib/fault.c:fault_report(39)
===============================================================
[2004/12/27 13:21:26, 0] lib/util.c:smb_panic2(1510)
PANIC: internal error
[2004/12/27 13:21:26, 0] lib/util.c:smb_panic2(1518)
BACKTRACE: 11 stack frames:
#0 smbd(smb_panic2+0x111) [0x81d3831]
#1 smbd(smb_panic+0x1a) [0x81d371a]
#2 smbd [0x81c0ab8]
#3 /lib/i686/libc.so.6 [0x401f0908]
#4 /lib/i686/libc.so.6(malloc+0x93) [0x40237d23]
#5 smbd(bitmap_allocate+0x1b) [0x81c892b]
#6 smbd(init_rpc_pipe_hnd+0x12) [0x8150b42]
#7 smbd [0x82328e6]
#8 smbd(main+0x27b) [0x8232b7b]
#9 /lib/i686/libc.so.6(__libc_start_main+0xbf) [0x401ddc1f]
#10 smbd(chroot+0x35) [0x80755e1]
がでている・・・。
display charset = eucJP-ms
のままだと起動するけど、接続できない。


26 :login:Penguin:04/12/27 14:58:38 ID:uDdEbJxx
あえて
dos charset = CP932
unix charset = UTF-8
display charset = UTF-8

にするとどうなる

27 :login:Penguin:04/12/27 15:09:17 ID:NmU3Ctmu
うっかりprelinkでsamba動かなかったことはあるけど。


28 :25:04/12/27 17:05:16 ID:wONrz+jE
>26

起動はするけど、接続できません。


29 :login:Penguin:04/12/27 18:11:33 ID:nhTVnbof
>>11
助かったよ。ありがトン。

30 :login:Penguin:04/12/28 10:24:33 ID:6WxSMets
Vine3.1のすれでこちらに誘導されたので来ました。

Vine3.1にしたらASUS A7V8X内蔵のLAN(ギガビットイーサ)が使えなくなりました。
3.0の時はインストール時に認識されて何事もなく使えました。
ネットワークの設定でeth0にポチッとチェック入れても
すぐ消えてしまいます,何回か入れてると固まります。
カーネルの再構築しないとだめなのでしょうか。


31 :login:Penguin:04/12/28 11:11:34 ID:vXXUedSs
lspciをする
Ethernetのデバイス名を確認
私は
> 00:11.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 02)
と出たのでsis900をメモ

/etc/module.confを開く
alias eth0 xxx
となってる部分にさっき確認したデバイス名を入力

#ifup eth0
ネットワークが立ち上がれば成功

32 :login:Penguin:04/12/28 11:20:43 ID:+WiRd6Kk
初歩的な質問で申し訳ありません。
Vine Linux 3.1 で、「apt-gat update」 と 「apt-get upgrade」 を、
定期的に自動実行させる方法は無いでしょうか?
やはり、セキュリティを高める為には常に最新のパッケージを
使いたいので。
「cron」 あたりで出来そうな雰囲気ですが、問題点として、
コマンド実行時にパッケージのアップグレードの確認メッセージが
表示されてしまうので、そこで 「Y」 を自動的に選択する必要が
あるんですよね…。
パッケージのアップグレード後には再起動させないと適用されない
かもしれないし…。
良い方法を教えて下さい。

33 :login:Penguin:04/12/28 11:26:57 ID:FhKu5KbU
>>32
apt-get --help してみればいいんじゃないの?馬鹿タレ君。

34 :login:Penguin :04/12/28 11:40:39 ID:6WxSMets
>>31
早速のレスどうもありがとうございます。
今,会社なので家に帰ってから試させていただきます。


35 :login:Penguin:04/12/28 12:12:02 ID:nNC3Ez6P
>>32
$ apt-cache search apt |grep cron

36 :login:Penguin:04/12/28 12:32:40 ID:jMCLPIjN
SeedのMozilla持ってきてrebuildしてみたら、GnomeのメニューにMozillaさんが
いません。

mozilla.desktopなんかが入れ替わってるみたいだけど、これは戻したらマズイ
もんですか?


37 :32:04/12/28 15:21:54 ID:+WiRd6Kk
>>33
>>35

ご教示ありがとうございます。
参考にして設定させて頂きます。

38 :login:Penguin:04/12/28 17:41:44 ID:vYfBy70y
Vine3.1でMRTGインストールできた人。
初心者向け解説作って。

39 :login:Penguin:04/12/28 18:33:32 ID:uqtzpdkg
>>36
あ、ホントだ。気付かんかった。
カテゴリが消えているのが原因だね。
# たぶん Fedora Core の 1.7.5 をベースにした時に意図せず入れ替わったんだと。
VineSeed-ML へ Go

40 :login:Penguin:04/12/28 18:36:17 ID:W3wZ2mgm
Vine3.1を使っています。
デフォルトのデスクトップ環境はGNOMEでShiift+SPACEで日本語の入力が
できたのですが、KDEに変えたところ、Shift+SPACEでは日本語の入力が
できなくなりました。
Linuxでは日本語入力の方式は使用するデスクトップ環境によって設定し直す必要が
あるのでしょうか?

41 :login:Penguin:04/12/28 19:14:09 ID:/W/Rmi3g
>>38
おれのwikiに書いた

42 :login:Penguin:04/12/28 20:37:48 ID:Nz1SZP2L
>>41
dクス

43 :login:Penguin:04/12/29 01:22:01 ID:zhybo4dx
>>41
おれのwikiってどれのことっすか?

44 :login:Penguin:04/12/29 01:24:46 ID:FM+dgeSU
>>43
それもおれのwikiに書いた

45 :login:Penguin:04/12/29 01:29:38 ID:zhybo4dx
>>44
なぬーΣ(´Д`; )

46 :login:Penguin:04/12/29 01:36:37 ID:HAcCLZtp
  _  ∩
( ゚∀゚)彡 おれのwiki!! おれのwiki!!
 ⊂彡


47 :login:Penguin:04/12/29 01:44:54 ID:Zk4EvKln
>>41
間違ってたので修正しといた。

48 :login:Penguin:04/12/29 01:47:15 ID:d4pQBCjU
結局Vineって、Fedora(Redhat)とDebianのパクリディス鳥に成り下がった?
SPECのコメント見ていても、「RedHatからパッチもらってきた」とかそんなのばっか。

49 :login:Penguin:04/12/29 01:55:40 ID:O/CARkZa
>Fedora(Redhat)とDebianのパクリディス鳥に成り下がった?
No

>SPECのコメント見ていても、「RedHatからパッチもらってきた」とかそんなのばっか。
No

50 :login:Penguin:04/12/29 01:56:33 ID:FM+dgeSU
成り下がったって...

51 :login:Penguin:04/12/29 01:57:17 ID:1RQVYKlU
成り下がるも何も昔も今も日本語がはじめから(PJEとかいれずに)使えてCD-ROM1枚に収まるRedHat
上でも下でもない

52 :login:Penguin:04/12/29 02:24:09 ID:tIzCzy9J
意味のない千のディストリよりも道にかなうたったひとつのVineの方が価値がある

53 :login:Penguin:04/12/29 02:29:13 ID:GWyi2jDB
RedHat系とかrpm系なんていうのは死語?

54 :login:Penguin:04/12/29 09:22:58 ID:sB6aDOJK
MRTGって必要とする人が多い割に解説が少ないね。
あっても古すぎるものが多くて正直使えない。

なんとかしてよエロイ人!

55 :login:Penguin:04/12/29 09:40:19 ID:x/REg2e9
>>54
MRTGの設定方法自体が環境依存のところが多いから大変なのであって、
古いからというのはちと違うんじゃないですかね。
残念ながら一度はちまちま勉強しながら設定するしかなかよ。

56 :login:Penguin:04/12/29 11:52:04 ID:sB6aDOJK
>>55
そうなんだ。
俺賢くないけど頑張ってみるよ。

57 :login:Penguin:04/12/29 12:21:28 ID:x/REg2e9
vine2.6だと、MRTGはRedHat7.3のSRPMをもってきて、
specファイルを少しいじって入れるのが楽かも。
あとSNMPで値がとれないことにははじまらないので、
snmpwalkコマンドでいろいろ遊んでみるのがいいです。
この値がハードウェア構成やOSのバージョンによって、
あと確かSNMPのバージョンによっても変わってくるので、
解説の通りだとうまくいかないことがあります。
http://www.atmarkit.co.jp/flinux/rensai/root08/root08a.html
これをいきなりやろうとするとしんどそうなので、
http://www.itmedia.co.jp/help/howto/linux/0007master/06/
(ページ数多いけど)こっちの方が簡単かも。
SNMPやMRTGで検索かけて自分の要求に合ったところを探してください。

58 :login:Penguin:04/12/29 13:30:05 ID:sB6aDOJK
>>57
ありがとう。親切な人だね。
http://www.itmedia.co.jp/help/howto/linux/0007master/06/28.html
の「./configure」する所まではいったんだけど「make」って打つと

>make: *** ターゲットが指定されておらず、makefile も見つかりません。中止。
って表示されちゃうんだよね。これどうすればいいんでしょう。
ファイルの検索するとmakefileって言うのはいくつかあるみたいなんだけど・・・。

59 :login:Penguin:04/12/29 14:06:21 ID:x/REg2e9
>>58
SRPMリビルド派なのでコンパイルする方はあまり詳しくないんですが、
まずVineとMRTGのバージョンはなんでしょう?
Vine3.1ならdev系のものがほとんど入っていないらしいので、
configureが通っても何か足りてない可能性とかないでしょうか。
うちにはまだ3.1がないもので詳しくわかりませんが。

3.1で試したことはないですが、
RedHat7.3の mrtg-2.9.17-3.src.rpm をリビルドする場合は、
contentdirがRedHatスタイルの/var配下になってるのでvineスタイルに修正して、
あとReleaseを 2.9.17-3my1 とでもして、
$ rpm -ba --clean mrtg.spec 2>&1 | tee mrtg.rpmlog
とかすればリビルドできます。
3.1だとdev系のものをインストールしておくことを要求されるかもです。
これでうまく通れば、出来上がったRPMをインストールすれば済みます。

60 :login:Penguin:04/12/29 14:21:56 ID:sB6aDOJK
>>59
Vineは3.1
MRTGはmrtg-2.9.12.tar.gzってのです。

./configure をすると以下のように出ます。
flash-link.cjb.net/uploader/src/346.txt

noって言うのが足りていないのでしょうか。

61 :login:Penguin:04/12/29 14:58:52 ID:x/REg2e9
>>60
gdが有効になってないですね。
gd-develとかいると思います。
3.1ではdevel系がごっそりないということなので、
コンパイルとかするのであればdevel系一式は入れといた方がいいかと。
http://www.vinelinux.org/vine30.html

62 :login:Penguin:04/12/29 15:01:21 ID:LCwgQBrH
>>60
オリジナルを配布しているサイトや tar.gzに同梱されているドキュメントを
よく読みましょう。
たいてい必要なライブラリやビルドについての注意点など書かれているもんですよ。



63 :login:Penguin :04/12/29 15:14:33 ID:DCBGbCY7
>>30です>>31さんの言うとおりやってみました。
1回目は上手くいきました,ネットにも繋がりオォうれしや。
念のため再起動してみたら繋がりません
もう一度同じ手順で試してみたのですがlspciでは
認識されているのにifup eth0を実行すると
「brodcomを確認できないのでeth0の起動を遅らせます」(意訳)
が出てきます。
自分でもこれからGoogleで検索してみますが
ご存知の方がいらしたら,教えてください。



64 :login:Penguin:04/12/29 16:23:28 ID:uLQ30R7C
>>31 のやり方ではドライバの名前までは分からないのでは

例えばウチで使ってるM/Bオンボードだと
04:04.0 Ethernet controller: Broadcom Corporation: Unknown device 1654 (rev 03)
これのドライバは bcm5700.o だったりする。
lspciの情報からでは分かりようがない。(ぐぐればどこかで引っかかるかも知れんが)

まぁ、「1回目はうまくいった」っつーから問題点が違うのかもしれないけど。
一番確実なのはソースからドライバをインストールし直すことだと思う。
最近のM/Bなら、付属CD-ROMにLinux用のソースも入ってると思う。

65 :login:Penguin:04/12/29 16:30:10 ID:ZyRLe/Qk
っつーか
よく考えたら M/B のマニュアル見れば
使ってる NIC のチップくらい書いてあるか。

66 :login:Penguin:04/12/29 16:30:50 ID:ZyRLe/Qk
あれ?
ID変わってるな。
64 == 65

67 :login:Penguin:04/12/29 16:49:35 ID:+GAc9q9H
3.1にするとモナーフォントがない。
しょうがないのでrootでzipを落としてfonts:///に丸投げ。

使えるからよしとする。

68 :login:Penguin:04/12/29 17:11:36 ID:SLgQc8BV
>>67
extras にあるんじゃないか?

69 :60:04/12/29 18:01:49 ID:sB6aDOJK
>>61 >>62
devel系一式を入れたところmake出来ました!

それで、あと少しな感がするんですが

#>/usr/local/mrtg-2/bin/mrtg /usr/local/mrtg-2/date/mrtg.cfg

と入力したところ以下のようなエラーが出てしまいます。
ttp://flash-link.cjb.net/uploader/src/347.txt

192.168.1.22と言うのはサーバー機のローカルIPアドレスです。
非常に恐縮ですが・・・たすけて

70 :login:Penguin:04/12/29 18:14:05 ID:x/REg2e9
>>69
ざっくりとした直観ですが、mrtg.cfgに間違いがありませんかね。
mrtg.cfgさらしませんか?
warningは最初2回だか出ますが、それは無視していいです。
(前のデータがないので差分が取れなくてwarningが出るだけなので)

71 :60:04/12/29 18:26:29 ID:sB6aDOJK
>>70
小出しですいません。

/usr/local/mrtg-2/date/mrtg.cfgです

ttp://flash-link.cjb.net/uploader/src/348.txt
な感じです。

72 :login:Penguin:04/12/29 19:43:54 ID:x/REg2e9
>>71
snmpdが動いていないような気がしないでもないでもないですが、動いてますか?
それと、snmpd.confの設定はどうですか?

mrtg.cfgではsetenvの行はうちのにはないですね。
調べてないので書式が妥当なのかわかりませんが、
ちなみにうちではこんな感じです(traffic部分)。

WorkDir: /home/httpd/html/stat/mrtg
IconDir: /stat/mrtg/images

# for Traffic
Target[traffic]: 5:private@localhost
Directory[traffic]: localhost
Options[traffic]: growright
MaxBytes[traffic]: 13107200
WithPeak[traffic]: wm
YLegend[traffic]: Traffic (B/s)
kilo[traffic]: 1024
kMG[traffic]: ,K,M,G,T,P
Title[traffic]: Traffic [localhost]
PageTop[traffic]: <H1>Traffic [localhost]</H1>

73 :login:Penguin:04/12/29 19:50:25 ID:iIfOcNZ8
Vine3.1で京ぽんを使用してネットに接続してる方いますか?
wikiにあるacmドライバを修正して京ぽんを認識させる方法は見つけたのですが、
acm.cが見つからなくて設定できませんでした。
代わりに /lib/modules/2.4.27-0vl7/kernel/drivers/usb/acm.oを
修正すれば良いかと考えましたが、やり方が悪いのか失敗に終わりました。
どなたかアドバイスを頂けないでしょうか

74 :login:Penguin:04/12/29 20:08:25 ID:E62v4j1N
>>73
acm.o をどうやって修正したかの方が漏れは気になるな

75 :60:04/12/29 21:20:24 ID:sB6aDOJK
>>72
snmpdに関してはこういう感じなのですが。う、動いてませんかね。

#> ps -ax | grep snmpd
1570 ? S 0:00 snmpd
1807 pts/1 S 0:00 grep snmpd


snmpd.confは以下にあげてみました。
ttp://flash-link.cjb.net/uploader/src/351.txt

手間取らせてすいません。

76 :login:Penguin:04/12/29 21:50:41 ID:x/REg2e9
>>75
$ snmpwalk -v 1 192.168.1.22 public | more
(60さんの設定に準じてます)
を実行すると値が返ってきますか?
これで値が帰ってこなければ、snmpdの設定が間違っています。
MRTGのエラーが「no response received」といっている通り、
snmpで値が取れないのでMRTGがエラーになってます。
snmpd.confもなかなかややこしく、
かつてトライ&エラーで設定しましたが、
うちではざっとこんな感じになってます(ローカルのみ抜粋)。

com2sec local localhost private
group MyROGroup v1 local
group MyROGroup v2c local
view all included system 80
access MyROGroup "" any noauth exact all none none

ちなみにこの設定の場合は、
$ snmpwalk -v 1 localhost private | more
で確かめることになります。

77 :ポール:04/12/29 21:59:30 ID:Km8UMPU6
>>75
その設定を公開することは、セキュリティ上非常に危ないので
設定を変える事をお勧めします

78 :login:Penguin:04/12/29 22:08:27 ID:x/REg2e9
>>77
そうですね。
デフォルトのものはオフにし、
とりあえずローカル(サーバー自身)でチェックするための設定をして、
他のマシンから監視させるのであれば別途その設定を追加する、
というのがいいかと思います。

79 :login:Penguin:04/12/29 23:14:56 ID:g2wRAhLf
Thinkpad R30にVinelinux3.1をインストールして使用しています。
バッテリー駆動したいのですが、どのようにしたらいいのでしょうか?

80 :login:Penguin:04/12/29 23:39:38 ID:LWL1w+b/
Vine Linux 3.1 を使用しております。

「apt-get upgrade」 を実行すると、「kernel-headers」 という
パッケージが保留されていると表示されています。

これは、2004年12月23日 に 「kernel にセキュリティホール」
として公開されたパッケージに関係するのでしょうか?

また、下のURLの方法でカーネルのアップグレードをやる必要
があるということなのでしょうか?
http://www.vinelinux.org/manuals/kernel-upgrade.html

ご教示お願い致します。



81 :login:Penguin:04/12/29 23:47:14 ID:2wLj1ue5
>>80

関係するかと言えばするけど。

セキュリホールの件について言えば、
http://www.vinelinux.org/manuals/kernel-upgrade-2.html
に書いてあるとおりアップグレードしておいた方がいい。

82 :login:Penguin:04/12/29 23:59:21 ID:LWL1w+b/
>>81
ご教示ありがとうございます。

「apt-get install kernel」 を実行すると、次のようなパッケージが表示されました。

  kernel#2.4.26-0vl15 2.4.26-0vl15 [インストール済]
  kernel-smp#2.4.27-0vl7.2 2.4.27-0vl7.2
  kernel-smp#2.4.26-0vl16 2.4.26-0vl16
  kernel-BOOT#2.4.27-0vl7.2 2.4.27-0vl7.2
  kernel-BOOT#2.4.26-0vl16 2.4.26-0vl16
  kernel#2.4.27-0vl7.2 2.4.27-0vl7.2
  kernel#2.4.26-0vl16 2.4.26-0vl16 [インストール済]
  kernel22-smp#2.2.20-0vl10 2.2.20-0vl10
  kernel22#2.2.20-0vl10 2.2.20-0vl10
  kernel-smp#2.4.27-0vl7 2.4.27-0vl7
  kernel-BOOT#2.4.27-0vl7 2.4.27-0vl7
  kernel#2.4.27-0vl7 2.4.27-0vl7

カーネルが複数表示されるん度絵念の為に教えて頂きたいのですが、
次に実行するべきコマンドは、
「apt-get install kernel-smp#2.4.27-0vl7.2」 で良いんですよね。

本当に何度も質問して申し訳ありません。


83 :login:Penguin:04/12/30 00:06:43 ID:7qNTSuqu
>>82
マルチプロセッサ環境 or HT対応プロセッサ使ってるの?

84 :82:04/12/30 00:08:13 ID:Im6vBRfE
>>83
返答ありがとうございます。
HTにも対応していませんし、マルチプロセッサなんかじゃありません。



85 :login:Penguin:04/12/30 00:17:41 ID:a+H0SjSu
インスコ済カーネルの後継バージョンを選べばよいです。
デフォルトに不満なら再構築すべし。

86 :82:04/12/30 00:21:59 ID:Im6vBRfE
>>85
本当にありがとうございます。

  kernel#2.4.26-0vl15 2.4.26-0vl15 [インストール済] 
   ↓
  kernel#2.4.26-0vl16 2.4.26-0vl16 [インストール済] 

ということは、

  kernel#2.4.27-0vl7.2 2.4.27-0vl7.2 

をインストールすれば良いんですね。

親切な回答ありがとうございました。

87 :login:Penguin:04/12/30 00:57:37 ID:jZJPvrWD
XfceよりGNOME使ってるほうがだいぶ動作が軽い気がするんだが気のせいだろうか?

88 :login:Penguin:04/12/30 02:44:20 ID:aaWs+C1M
Vine3.1のNautilusでSMB:///と入力しても繋がってるマシン共らが見られないのですが・・・
XFceの方だと一応アクセスできるんですけれども。
一応ぐぐってみたりしたのですがどうにもならず(つω;)
どうにかならないものでしょうか、ご教授よろしくお願いします。

89 :login:Penguin:04/12/30 08:33:24 ID:4Pu65Gll
>>88
gnome-vfs2-extras


90 :82:04/12/30 10:19:19 ID:Im6vBRfE
では、いよいよカーネルのアップデートを・・・。
apt-get install kernel#2.4.27-0vl7.2 2.4.27-0vl7.2  


91 :60:04/12/30 10:28:19 ID:LOBY5pdu
>>76
snmpが動いていなかったようで設定ファイルを作り直したところ
先ほどグラフが出現しました!(動いてませんが)

今後少し放置してみまして、駄目だったらIPアドレスの指定ミスだと
思うので(サーバー機のアドレスなのかルーターのアドレスの方を入れればいいのか良くわかってません)
何とかできるかと思います。

とりあえず作業工程を一通り学べたので、機会があれば一からやってみたいと思います。
本当に何から何までお世話になりました。
ちょっと遅れたクリスマスプレゼントと、少し早いお年玉でした。ありがとうございます。
良いお年をお迎えできるよう祈っております。

ワーイ。



92 :ゲイツ:04/12/30 10:28:48 ID:/nGniM9P
AAサロンのニダーマンセースレかなり盛り上がっちゃてるみたいだが…AAサロンのニダーマンセースレかなり盛り上がっちゃてるみたいだが…AAサロンのニダーマンセースレかなり盛り上がっちゃてるみたいだが…

93 :82:04/12/30 10:35:15 ID:Im6vBRfE
再起動しますた。
新しいカーネルで正常に起動していますように。。。

94 :88:04/12/30 10:51:37 ID:aaWs+C1M
>>89
ありがとうございました、できました

95 :82:04/12/30 10:59:16 ID:Im6vBRfE
カーネルのアップデート後も正常に起動できました。
ご教示して頂いた皆さん、本当にありがとうございました。

96 :login:Penguin:04/12/30 15:35:42 ID:bHhaSVgH
>>91
おめでとうございます。
/etc/crontabには登録しました?
0-59/5 * * * * root /usr/bin/mrtg /etc/mrtg/mrtg.cfg
などと登録して定期実行させます。
あと、SNMP対応機器ならなんでも利用できますよ。
調べたい、監視したい機器を指定します。もちろんサーバー自身も可です。
どんな値が取得できるかは機器によって違い、snmpwalkコマンドでルートを指定すればざっと眺めることができます。
ただし、ルータやファイアウォールを越える際には、
SNMPのポート(161/tcp&udp, 162/udp)が通れるようにする必要があります。
あと、NICを変えるとか、OSをアップデートしたりすると
SNMPのツリー番号(だっけ)が変わることがありますので、
そうした際にはsnmpwalkコマンドで確認・修正が必要になります。
いろいろいじって楽しんでください。

97 :login:Penguin:04/12/30 16:04:11 ID:LTqdDjOk
Vine3.1にVine2.5から抜いてきたsamba2系をインストールしたてみたら
とりあえず動いているようだ。

98 :login:Penguin:04/12/30 22:33:15 ID:o4WKtpPs
apt、cyrus-sasl、indexhtml、sharutils、sudo、xpdf あたりは、Seed よりも
3.1 + updates の方が新しくなってるな。
apt や indexhtml はともかく、他のはセキュリティホールの修正だから、
Seed にも持ってくるべきじゃ?

99 :login:Penguin:04/12/30 23:53:56 ID:4a6iHP0B
samba2系が使いたいなら、古いvineから抜くより
sambaユーザー会のとこからダウンロードした方がいいんでない?

100 :login:Penguin:04/12/31 00:24:54 ID:csTZTVXE
VineってPHPは放置?
セキュリティ的にどうなんだろう

101 :login:Penguin:04/12/31 00:29:20 ID:TSFqUJ+X
>>100
メンテナ が アフォ だから仕方無いと思われ。

102 :login:Penguin:04/12/31 08:57:58 ID:W9WnexS6
>101
SeedPlusはとっとと5.03になってるみたいだから、修正をバックポートしようとして
苦しんでいるんじゃないかと邪推してみる。

# PHPのメンテナさんは自分が使うついでにパッケージageてるような雰囲気なので、
# Apache/PHP/DB関係は使いたいものを自分で入れたほうが良いような気がする。

103 :login:Penguin:04/12/31 11:27:05 ID:NgW0zQaE
>102
2.6用の4.3.10も出してほしいなぁ。ずっと4.2.3で止まってるし。

104 :login:Penguin:04/12/31 13:23:20 ID:5NbC0u0Y
Vine3.0を使ってたんですが、このPCをWin2000にインストールし直したいんです。
Cドライブにインストールしていたんですが
・Dドライブに置いてあったイメージから復元
・FDISKで全てのパーティションを削除→作成
 その後にWin2000のCD-ROMから新規インストール
するも、起動時にVineの起動文字が出てエラーになります。

あと削除するものとかいじる箇所ってありますでしょうか?

105 :login:Penguin:04/12/31 13:34:25 ID:0m4/1Wgp
まぁ、ageたらageたで
ウゴカネーってなりそうだけどねphp
phpは内向けにしか使ってないんであまり(・ε・)キニシナイ!!

106 :login:Penguin:04/12/31 13:41:34 ID:B+qo9BSu
>>104
fdisk /mbr

107 :login:Penguin:04/12/31 13:47:39 ID:+Va9Miwo
>>106
それ95/98/Meの場合とちゃう?

108 :login:Penguin:04/12/31 14:04:59 ID:XZPymoG0
fixmbr

109 :login:Penguin:04/12/31 14:11:46 ID:5NbC0u0Y
ありがとうございます。
Win2000インストールの途中でVineの起動画面になったので
fdisk /mbrやっちゃいましたら出なくなりました。
このままインストール続けていきます。

110 :login:Penguin:04/12/31 14:14:46 ID:+Va9Miwo
>>109
2000にもfdiskあったんかい?( ゚д゚)ポカーン

111 :login:Penguin:04/12/31 14:31:01 ID:+6UdYIVA
起動ディスク持ってたんじゃない?

112 :login:Penguin:04/12/31 15:34:51 ID:MTongAP4
Windows環境から Vine31-i386.iso をダウンロードし、CDには焼かずに
FAT32でフォーマットされた領域に置いて、ハードディスクインストールを
試みたのですが、インストール作業自体は無事に完了したものの
最後のXの設定のところでエラーが発生してしまいました。

現在はランレベル3の状態でVineが動いてる形です。
恐らくは手動でXのファイル関係を設定すればXも立ち上がって行く形に
なるとは思いますが、まだ試していません。

isoイメージをCDに焼いてCDからのインストールをした際は、Vineオリジナルの
グラフィカルなインストーラー画面で作業が進んで、Xの設定もすんなり通って
いたのですが、今回のハードディスクインストールでは青を基調とした旧式の?
(Redhatの?)インストーラーのまま進行してXの設定でコケたといった具合です。

元は同じデータを使用しているのに、CDからとHDDからではインストーラーが
変わってしまうその分岐点はどこにあるのでしょうか?
isoイメージのHDDインストールでもVineオリジナルのインストーラーを稼働
させることが出来るのかどうかということです。

113 :109:04/12/31 16:07:04 ID:5NbC0u0Y
ありがとうございます。
Win98の起動ディスクもってました。

114 :login:Penguin:04/12/31 16:19:51 ID:mQOfPEiN
>>112
>CDからとHDDからではインストーラーが変わってしまうその分岐点はどこにあるのでしょうか?

自分の経験からだから、限定的な話になるけど、インストーラーがグラフィカルかテキストベースになるかは、
メインメモリの量とビデオカードのメモリ量(これによって解像度と発色数が決まってしまう)とによって決まるみたいです。
自分の場合だと、同じ96年式FMVで、
メモリ32M、ビデオカードATI RAGE2(2M)だと、テキストベース。(これがFMVの標準)
メモリ48M、ビデオカードATI RAGEPro(8M)だと、グラフィカルでした。(余ったパーツを全入して増強)

これは推測だけど、CDイメージをマウントするのにメモリをかなり使っていて、空きメモリが少ないのではないでしょうか。


115 :login:Penguin:05/01/01 00:55:50 ID:FS1KpF9M
>>112
どっちのインストーラも同じredhatのanacondaだ。

116 :login:Penguin:05/01/01 18:51:15 ID:kOUTxDeJ
VNC経由でVine3.1のマシンにログインすると、
XMMSだけメニューが文字化けるのだけど・・・。


117 :login:Penguin:05/01/01 22:43:33 ID:2SuPtxrZ
vine 3.1 を install したけど、
apt-get install で
xanim や FreeWnn をネットワーク経由で install しようとすると、
そんなのないよ!って怒られます
3.0 の時は OK だったんで、ザーバーのせいでしょうか?

118 :login:Penguin:05/01/01 23:07:08 ID:maszTok1
>>117
Vineの場合インストールしたてだとapt-get installが使えないって常識だから覚えといて。
source.listを開いてを適当な行をコメントアウトしてからやってみて。

119 :login:Penguin:05/01/01 23:10:00 ID:iY9RJT9Y
ついでにsources.listの場所は
/etc/apt/sources.list

120 :login:Penguin:05/01/02 00:12:16 ID:VEggiLVm
>>118 apt-get install で tamago とかは、
何もしないでもできましたよ

sources.list のサーバー変えてみましたが、
正月のせいか、サーバー無いよって怒られました。
default のサーバーがいいみyたいです。

121 :login:Penguin:05/01/02 00:17:29 ID:I5kHFfuf
結局 php のセキュリティホールはどうするんだ?
直す気無いなら、RPM の管理から外して野良ビルドするんではっきりしてくれ。


122 :login:Penguin:05/01/02 00:48:32 ID:VEggiLVm
xanim は入るようになりました
FreeWnn はまだです。。。

123 :login:Penguin:05/01/02 00:56:03 ID:Bpro4t1X
## 標準では extras カテゴリは除外されています。extras カテゴリ内のパッケージ
## が必要な場合はコンポーネントリストに "extras" を追加してください。



124 :login:Penguin:05/01/02 00:58:01 ID:PKtG4uCK
>>121
マジで悩むよな
これじゃ全然サーバ用途で使えやしない
PHPの問題見つかってからポート閉じたままなんだが・・・
こういうメジャーなパッケージはもうちょっとまともな人にパッケージャになって欲しい

125 :login:Penguin:05/01/02 01:12:48 ID:VEggiLVm
>>123 Thanks !

126 :login:Penguin:05/01/02 01:17:34 ID:Aw1ShZxo
>>118
知ったか厨。

127 :login:Penguin:05/01/02 01:53:38 ID:FOZlSUt8
>>124
使うなって事だろ。

128 :login:Penguin:05/01/02 02:01:45 ID:6jJjWTBz
PHPですが、2.6だと依存関係が多過ぎてリビルドが通りませんね。
4.2.3-0vl5まではなんとかリビルド通りましたが。
3系列になる前のseedのSRPMもってきて、
ソースを4.3.10に入れ替えてちょこちょこっといじってリビルドしてみようかと思ったんですが、
依存関係も多いしパッチも山ほどあって…。
大変だからほっとこうって感じじゃないでしょうかね。
3.1系だとできるかも?
うちにはまだ3.1環境がないので試せません。

129 :login:Penguin:05/01/02 02:07:51 ID:I5kHFfuf
永遠にメンテし続けろ、とは言わないけど、新しいバージョン(3.0/3.1)が出た後に、
2.5/2.6のメンテをいつまで続けるのか明確にして欲しい。
「3.1出たから全員とっとと新版に乗り換えろ」というわけにもいかんわけだし。

130 :login:Penguin:05/01/02 04:27:21 ID:W/1UPqVD
FDDレスCDレスで3.1を新規インスコする手段も提供してくれ…

131 :login:Penguin:05/01/02 04:59:04 ID:F8WEbiHI
マシンが対応してるならネットワークブート
インスコ時だけFDDつなぐとか

132 :login:Penguin:05/01/02 07:00:00 ID:6jJjWTBz
PHPなんですけどね、FedoraCoreのSRPMもとってきて覗いたんですが、
Vine版ともども、すごく環境(OS Ver.)依存なspecファイルな気がしちゃいます。
理想は完全共通のspecファイルでしょうが、
せいぜいコメントアウトするくらいで共用できるようには書けないものなんでしょうかね。
あいにくspecファイルをごりごり書くスキルはないので、
その辺の難易はわかりかねるのですが。

133 :login:Penguin:05/01/02 07:20:35 ID:hHVsq3E9
>>132
FedoraCore 使えばいいんじゃないの?

134 :login:Penguin:05/01/02 08:13:30 ID:6jJjWTBz
>>133
同じことでしょうが。
Fedora(RedHat時代も含む)だって、
バージョン間での互換性の低いspecファイルのパッケージは少なくないです。
それにOS入れ替えをすぐにはしないという前提での話です。

135 :login:Penguin:05/01/02 08:37:16 ID:hHVsq3E9
>>134
spec 書いたりするのって、それほど難しいことではないので、
互換性がある書き方とやらにチャレンジしてみては?

それから、こんなスレで中途半端に書き逃げしてないで、
VineSeed{,-Plus} なり fedora-devel なりで
結論を出せるように議論してください。

136 :login:Penguin:05/01/02 09:44:09 ID:6jJjWTBz
>>135
VineのでもFedoraのでもいいですが、それらのPHPパッケージのspecファイルをみたことのある人ですか?それともみたことなくて喋ってる人ですか?

137 :login:Penguin:05/01/02 09:52:25 ID:hHVsq3E9
>>136
Vine のなら見たことがありますし、php*-apache を作るように提案したことが
ある人です。([VineSeed-Plus:02463])

あなたが希望するなら、単なる煽りでしゃべっていることにしてもいいですよ。
私にとっては、ディストロ間の互換性の解決なんてどうでもいいことですし。

138 :login:Penguin:05/01/02 09:54:39 ID:hHVsq3E9
ワイルドカードの位置間違えた。php-apache* だ。

139 :login:Penguin:05/01/02 13:20:18 ID:6jJjWTBz
>>137
ディストロ間の互換性とは言ってないですけどね。
同じディストロのバージョン間でのspecファイルの互換性が上がれば、
2.5/2.6用のPHPパッケージが全く放置されたままということはないのではないか、ということです。
現状では負担が大きくて放置せざるを得ない状況のようにみえますからね。
まぁspecファイルはそのパッケージの一番最初に書いた人次第で方向性が決まってる感じですし、
PHPパッケージレベルの複雑なspecファイルになると一から書ける人は限られると思いますけどね。

140 :login:Penguin:05/01/02 13:36:41 ID:hHVsq3E9
>>139
chroot な環境作れば、その環境用に --rebuild できるわけだから
メンテナがさぼってるだけでしょう。
クレクレ厨のために動くなんてアホらしいから漏れはやらんけど。

あの程度の spec なんて複雑でも何でもないと思うけど。
少しは読む努力でもしたら?
でね、2.5 とか 2.6 で rpm --rebuild php*.src.rpm やってみて、
依存性のエラーが出た部分だけ修正すればいいんじゃない?

http://ayo.freshrpms.net/fedora/linux/3/i386/SRPMS.freshrpms/
ここらへん見るとわかると思うけど、各版ごとにアフォのように
分岐してるよ。


141 :login:Penguin:05/01/02 14:10:33 ID:BxOVMDNK
WinMXみたいなソフトで、VINEで動くものは内の?

142 :login:Penguin:05/01/02 14:14:31 ID:hHVsq3E9
>>141
lopster

143 :login:Penguin:05/01/02 14:40:06 ID:NMSYWtJJ
「cron」についての質問です。
例えば、「rm」を実行する際に削除の確認メッセージが出たとします。
その場合は、
1.「cron」が終了せずに残留する。
2.「cron」が強制終了される。
のどちらでしょうか?
教えて下さい。

144 :login:Penguin:05/01/02 14:56:42 ID:zyMI70aK
確認メッセージはbashからコマンドラインで呼ぶとき限定です。


145 :login:Penguin:05/01/02 14:57:43 ID:zyMI70aK
>>140
僕にはできません。でいいじゃん。
お前はそれほど偉い人間というわけでなし。


146 :login:Penguin:05/01/02 15:17:32 ID:0Rh5reGs
どひゃっと perl が来ちゃった.

147 :login:Penguin:05/01/02 15:37:44 ID:hHVsq3E9
とりあえず、僕にはできませんと言っておこう。

148 :login:Penguin:05/01/02 17:36:03 ID:TjfOJhl5
俺も言っておくか。

僕にはできません。

149 :login:Penguin:05/01/02 20:54:18 ID:IsLtjQV+
漏れはできるぜ!

150 :login:Penguin:05/01/02 20:56:00 ID:Q5iiilJh
specかけない香具師はVine使っちゃいかん。
ゲイツOSでも使っていろ

151 :login:Penguin:05/01/02 21:10:53 ID:IsLtjQV+
>>150
emacsの設定の仕方もよくわからない香具師ですが、
Vine使わせてください。m(_ _)m


152 :login:Penguin:05/01/02 21:14:30 ID:15s7jHPa
>>150
spec は、どこで勉強すればかけるようになりますか?

153 :login:Penguin:05/01/02 21:20:53 ID:lKihnpcX
PHPで何が出来るかわかんない人にはspecも書けない気がする。

PHPがわかってる人なら自分で入れた方が早い。



どうしたもんか。

154 :login:Penguin:05/01/02 21:27:32 ID:zyMI70aK
>>153
死んでみる。


155 :login:Penguin:05/01/02 21:31:34 ID:IsLtjQV+
>>153
そうだよ、詩ねよ!俺なんか 自分でインターネットの設定やれるんだぜ!

156 :login:Penguin:05/01/02 21:39:14 ID:Bpro4t1X
1. 他のディストリにする
2. php5-5.0.3-0vl1にする
3. php-4.3.9-0vl1にパッチをあててrpmを作る
4. 本家から4.3.10を取ってきてrpmを作る
5. 本家から4.3.10を取ってきて/usr/localに入れる
6. PHPの使用をやめる

こんなもんか


157 :login:Penguin:05/01/02 21:46:37 ID:IsLtjQV+
Vineにすんなりインストールできるアスキーアート製作ソフトありますか?

158 :login:Penguin:05/01/02 23:17:26 ID:6huzJeg+
すません。curses.hの入ってるパッケージってなんですか?


159 :login:Penguin:05/01/02 23:28:25 ID:ioTqAM3e
すません。VineでVBを使って開発できるパッケージってなんですか?

160 :login:Penguin:05/01/02 23:35:05 ID:Xv732WI3
すいません。調べもしないで質問する馬鹿どもはスルーしてよいですよね

161 :login:Penguin:05/01/02 23:40:27 ID:GGZzzzpV
すません。スルーしちゃっていいですよ

162 :login:Penguin:05/01/02 23:56:10 ID:Tda8llCh
>>158
apt-cache search curses

163 :login:Penguin:05/01/03 00:34:50 ID:0TpdUDIl
ncurses5-develだっけ?

164 :login:Penguin:05/01/03 00:36:46 ID:M1xO8gUY
lopsterがanother user is online とかで全然つながらん。
解決策ない?

165 :login:Penguin:05/01/03 00:39:01 ID:0TpdUDIl
死んでみる

166 :俺の日記:05/01/03 00:58:09 ID:/Xhv/M4p
Mathematica for Linux購入しますた
Windows版と比べるとフォントがかなり汚いけど、これでLinuxに完全移行できます

167 :login:Penguin:05/01/03 09:28:07 ID:dpklKeQS
Firefox のパッケージって無いよね。
嫌いなのかな…

168 :login:Penguin:05/01/03 09:44:25 ID:QGXS5Jfk
>>167
そんなこと書いてると、バイナリ tar.gz を i386.rpm に詰め直したような
ものが貼られるぞ。

169 :login:Penguin:05/01/03 10:06:38 ID:dpklKeQS
正直それでもいいっちゃいい。
ていうか聞いちゃいけなかった…?

170 :login:Penguin:05/01/03 10:09:00 ID:blhQCF64
>168
それで十分じゃね? rpm なんぞコマンド一発さっくり削除が
出来るだけだと思うんだが・・・。むしろ、下手にポリシー
設定しないで、あると良さ気な物はどんどん追加して欲しい。

171 :login:Penguin:05/01/03 10:09:21 ID:MjJMS/wH
Vineにつめる必要は無いと思うな。
自分でFirefoxのサイト行って落として簡単にインスコできるんだから。

172 :login:Penguin:05/01/03 10:18:47 ID:dpklKeQS
rpmパッケージってあったっけ?
今探してみたけど見つからず。知ってたら教えてください。

173 :login:Penguin:05/01/03 10:26:22 ID:QGXS5Jfk
ttp://www.syssupo.co.jp/net_hal/vine25_31.html

ここにバイナリ詰め直しがあるはずなんだが、つながらん。

174 :login:Penguin:05/01/03 10:37:34 ID:bfU83nNu
ttp://fedoranews.org/tchung/firefox/

ここにFedora用のバイナリ詰め直しSPECファイルがある。

175 :login:Penguin:05/01/03 12:30:41 ID:SCe3V3E9
>>174
で入れてうまく動いてる人居る?


176 :login:Penguin:05/01/03 12:35:59 ID:QGXS5Jfk
>>175
公式に配布されているバイナリを tar.gz? から i?86.rpm に詰め替えているだけ
なので、公式に配布されているバイナリが動けば動くと思うよ。

177 :login:Penguin:05/01/03 13:21:26 ID:dNB9bOk1
tar.gzはバイナリとは言いませんよ。
そのspecファイルを使ってSRPMからリビルドがうまく通るか、ってことでしょ?>175さん


178 :login:Penguin:05/01/03 13:31:10 ID:QGXS5Jfk
>>177
> tar.gzはバイナリとは言いませんよ。

>>174 にある spec が何をしているのかちゃんと読んだかい?


179 :172:05/01/03 13:59:55 ID:dpklKeQS
できたできた。今 Firefox から書いてるYO
サンクス!

>>175
>>174 の spec をとってきて、~/rpm/SPEC に配置
firefox-1.0.tar.gz を ~/rpm/SOURCES に配置
% touch ~/rpm/firefox.desktop ~/rpm/firefox.png # 手抜き
で rpmbuild -bb すれば OK だった

180 :login:Penguin:05/01/03 14:06:03 ID:dNB9bOk1
>>178
がーん。バイナリをコピーしてるだけですか…。
tar.gzも固めてるだけで中身バイナリですね。
失礼つかまつりました。

181 :login:Penguin:05/01/03 16:41:49 ID:/Xhv/M4p
みんな動画プレイヤー何つかってるの?
ってかそもそもVineで動画見るってのがおかしいのだろうか。
どれもインストールが面倒そうで・・・

182 :login:Penguin:05/01/03 17:19:25 ID:EzcyaAwt
シノバー神にすがりなさい。

183 :login:Penguin:05/01/03 19:13:29 ID:+St6BsUC
vine2.6から3.1にアップーグレドしました。

ctrl alt backspace でXが落ちなくなりました。
これは何が原因なんでしょうか?

184 :login:Penguin:05/01/03 20:29:13 ID:KPjqX3Oe
エスパー募集
カーネル変わったせいだとは思うけどな。

185 :login:Penguin:05/01/03 20:40:16 ID:gRJ5QetS
>>183
Vine 3.1なら
$ xdpyinfo | grep version
X.Org version: x.x.x
って表示するよね?
# cat /etc/X11/xorg.conf | grep Xkb
こっちはどうなるかな?

186 :login:Penguin:05/01/03 20:49:16 ID:LLqyBi/T
>>181
Mplayerインストールして使っています。Redhat9にインストールした時と比べてかなり
しんどかったけれど、以下のサイトを参考にしたら出来た。

http://shino.pos.to/linux/mplayer.html

187 :181:05/01/03 23:15:57 ID:/Xhv/M4p
>>186
レスどうもです。このページ見てaptでMPlayer入れてみました。
http://homepage1.nifty.com/~hide822/vl31_mplayer.html
結構動作が怪し気ですが、とりあえずはこれで我慢しようかと思います。

188 :login:Penguin:05/01/03 23:48:57 ID:Bngkd1Ko
>>187
ざっと見、Redhat7.3用のRPMをSynaptic使って入れようということだと思うけれど、
「これで一応使えるようになったはず云々」等と書いてある点、かなり微妙。

俺が先に紹介したところは、ソースからのコンパイルだから当然そういった心配はない
けれど、元々Mplayer自体の動作が怪しいところあるしね。。。

正月休みを利用して、SAMBA/NFS/SSH迄設定は完了。もうRedhat9は要らないかな?
明日はBIND構築予定。

189 :login:Penguin:05/01/04 00:00:51 ID:wr0uMNft
日本語の情報が欲しいのはわかるが
一度はオリジナルのサイトのドキュメントや
ソース・パッケージに同梱されている
README,INSTALL,CHANGELOGとかdocディレクトリ以下を
読んだほうがいいと思うよ


190 :login:Penguin:05/01/04 06:49:09 ID:zdQtbNpa
>>187
真似してみたらちゃんと動きました。多謝。

191 :login:Penguin:05/01/04 09:08:11 ID:QgcDWuhd
Vine3.1が付録CD-ROMでついてくる雑誌
・Linux World ('05/1月号) 12/24発売
・LinuxMagazine ('05/2月号) 1/8発売
・UNIX USER ('05/2月号) 1/8発売
(日経Linuxもたぶん1/8発売の'05/2月号に)

192 :login:Penguin:05/01/04 10:17:47 ID:/zLTLL1v
人気だな Vine

193 :login:Penguin:05/01/04 10:19:44 ID:ZQ6Tj3Xp
おかげで、インスコ記事をろくに読まない皆さんがインスコし、トラブり、
スレがエスパー募集中のみなさんであふれかえるわけだ。

194 :login:Penguin:05/01/04 10:36:20 ID:B4W4fVBf
>>192>>193
実際良いディストリビューションだと思いますよ。1週間前迄Redhat9使っていたけれど、
もう要らないや。Redhat9でやっていたこと全部出来るし、パッケージも比較的最近の
もので固められているから、一々アップデート掛けたりソースからコンパイルしなくても
良いしね。

Vineというと日本語対応が強いけれど、パッケージは古いという先入観があったので、
正直驚いているのが本音。


195 :login:Penguin:05/01/04 10:41:34 ID:oHer1IsI
>>193へのレスにはなってないと思った

196 :login:Penguin:05/01/04 11:04:28 ID:LnlhYKjB
3.1ってapt-getでwebminインストールできる?

197 :login:Penguin:05/01/04 11:07:59 ID:ZQ6Tj3Xp
>>196
http://ring.asahi-net.or.jp/pub/linux/Vine/apt/3.1/SRPMS.extras/

あるみたいよ。使いものになるかどうかは知らんけど。

198 :login:Penguin:05/01/04 11:47:56 ID:QgcDWuhd
>>191
間違ってました。Linux Worldも2月号です。訂正。

Vine3.1が付録CD-ROMでついてくる雑誌
・Linux World ('05/2月号) 12/24発売
・LinuxMagazine ('05/2月号) 1/8発売
・UNIX USER ('05/2月号) 1/8発売
(日経Linuxもたぶん1/8発売の'05/2月号に)

199 :login:Penguin:05/01/04 14:51:35 ID:3YUNEs72
>>181
http://linux2ch.bbzone.net/index.php?FAQ%2FDistribution%2FVine%2FVineMPlayer

200 :login:Penguin:05/01/04 14:52:19 ID:3YUNEs72
今時uudeviewかよ、と思ったら、
セキュリティーホールがあったのか...

201 :183:05/01/04 21:46:55 ID:9w5REO8g
X.Org version:6.7.0

でした

202 :183:05/01/04 21:50:09 ID:9w5REO8g
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#Option"XkbDisable"
#Option"XkbModel""pc102"
#Option"XkbModel""microsoft"
#Option"XkbLayout""de"
#Option"XkbLayout""de"
#Option"XkbVariant""nodeadkeys"
#Option"XkbOptions""ctrl:nocaps"
Option"XkbRules""xfree86"
Option"XkbModel""jp106"
Option"XkbLayout""jp"
#Option"XkbVariant"""
#Option"XkbOptions"""

でした

203 :185 :05/01/04 22:42:43 ID:Mzm2IKyN
>>202
# cat /var/log/Xorg.0.log | grep "Using config file"
(==) Using config file: "/etc/X11/xorg.conf"
このようになりますよね?

Option"XkbRules""xfree86"→Option"XkbRules""xorg"
#Option"XkbDisable"→Option"XkbDisable"
これでどうでしょうか。











204 :185 :05/01/04 23:06:15 ID:Mzm2IKyN
追加
もしだめなら、
# Xconfigurator
やってみて。
新しいxorg.conf作成されるから。

205 :login:Penguin:05/01/05 00:09:35 ID:cJPhJOWm
Vine 3.1 で AirH (pcmcia card) の設定できた人います?

206 :login:Penguin:05/01/05 05:26:47 ID:ihjU89ku
>>187
確かにdefaultなskinが設定されなくて、gmplayerのメニューからの起動が出来ませんでした。
リンクを作ってやれば動作します。

207 :login:Penguin:05/01/05 07:01:02 ID:lKNPgues
>>205
よほど特殊なディストリじゃない限り問題なく使えるはずだが、


208 :login:Penguin:05/01/05 10:58:34 ID:KvIuUryh
Vineはいつになったらカーネル2.6になるのだろう

209 :login:Penguin:05/01/05 11:08:33 ID:adjqZpC+
http://vinelinux.org/roadmap.html
これを見る限り夏ですかね

210 :login:Penguin:05/01/05 19:51:11 ID:sObkEHLf
vine3.0でlyxというtexのフロントエンド(数式機能充実のワープロともいえる)を気持ちよく使ってましたが、
3.1ではなぜかkinput2による日本語入力ができなくなっていました。どなたか関連情報ありましたらお願いします。


211 :183:05/01/05 20:02:49 ID:qgAPVmcT
>>203

ありがとうございます!
ばっちしできました。

うれしいです。
なんでそうなるかはわからないんですけど
とりあえずX落とせるようになりました。

実際は、
#Option"XkbDisable"
のコメントを取るだけでもOKでした。



212 :教えてくださいませ。:05/01/05 20:16:17 ID:CHhtNuW6
古いノートPCを入手したので、Vine2.6でWEBサーバを立ち上げたいと思っています。
なんか、HDが810MBしかないのですが、可能でしょうか?
また、カスタムインストール時に選択すべき、パッケージを教えてください。
公開するデータは10MBほどです。

213 :login:Penguin:05/01/05 20:23:09 ID:adjqZpC+
debianのほうがいいんでない?

214 :login:Penguin:05/01/05 20:23:34 ID:LBpiq6Ef
>>212
Vine じゃなくて、debian woody でも入れておけ。

215 :login:Penguin:05/01/05 20:26:11 ID:kRSKMOM9
>>212
Vine3.1で最小インストールにされる方がよいかと。2.6は納得がいくような最小
インストールはできなかったように聞いた。

216 :212:05/01/05 20:26:57 ID:CHhtNuW6
213、21ヨンさま、
ご教示かたじけない。

217 :212:05/01/05 20:28:00 ID:CHhtNuW6
>215
さんきゅうです。

218 :login:Penguin:05/01/05 20:34:45 ID:hUF8Slep
3.1CR で
/usr/share/doc/tetex-macros-2.0/kanjifonts-1.1/ricoh/ora.tex
をplatex ora.tex; dvips ora.dvi; ggv ora.ps
したら文字化けしませんか?


219 :login:Penguin:05/01/05 21:01:16 ID:S2yBpmWJ
3.1+KDEで一般ユーザーの場合のみサウンドが使えなくって困ってます。
この件に該当するサイトを参照しパーミッションを
/etc/security/console.permsからと
/dev/audio* & /dev/dsp
から変更してみたんだけどダメです。同じ様な症状を解決した人いますか?

220 :login:Penguin:05/01/05 21:01:38 ID:hUF8Slep
自己フォロー
[vine-users:069188]
で話が出てるけど 解決策はまだ出ていないんだね ...


221 :login:Penguin:05/01/05 22:02:08 ID:S2yBpmWJ
>>220
CDやRealPlayerの音は大丈夫です。

KDEがスタートアップした時の音とか無くても困らない問題
なんですが解決できたらいいなと。

222 :login:Penguin:05/01/06 00:43:39 ID:bsDHVpLu
>>219
synapticでいれたkde-3.3.1ですけどサウンドは全然問題ないですよ。起動時もxineやrealplayer10も問題なし。vineをインストール時にも特に変わったこともしてません。

223 :login:Penguin:05/01/06 02:17:57 ID:CgrtGkaX
>>221
禿しくディスクアクセスしてたりしますか?
スタートアップ時だけならディスクアクセスにCPU使われてるだけ鴨。

224 :login:Penguin:05/01/06 04:19:06 ID:rCrw9cJz
Part26の終わりでクリーンインスト直後に
apt-get script install-devel.lua
するとエラー出るって話題出てたけど、治らないね。
MLに投稿するのが良いのかな。

それとrpmfindをapt-get source rpmfind
rpmbuild --rebuild rpmfind1.7..
するとldbエラーで終了しちゃうんだけど、これって
db1 db2 db3 db4 db4-develが入っててもダメなのかな。
誰か教えてもらえませんか?お願いします。

225 :login:Penguin:05/01/06 05:09:39 ID:f3kLBFpE
>>224
何で使えもしないrpmfindをリビルドするんですか


226 :login:Penguin:05/01/06 12:22:08 ID:VLQbPmGu
amd64版vine チン☆⌒ 凵\(\・∀・) まだぁ?

227 :login:Penguin:05/01/06 13:34:12 ID:1yZ28D6N
>>226
AMD 64ビットCPUでLINUXしよう Part2
ttp://pc5.2ch.net/test/read.cgi/linux/1082641986

228 :login:Penguin:05/01/06 21:20:23 ID:bsDHVpLu
>>219 KDE-3.3.1から3.3.2にアップグレードしたら音がならなくなったけど、su → # /sbin/sndconfig で復活しましたよ。


229 :login:Penguin:05/01/06 22:44:58 ID:M6DwWFef
SeedPlusにphpが!
2.6用も作ってぇ♥

230 :login:Penguin:05/01/07 02:42:30 ID:7/iS7dAO
AirH (pcmcia card) 繋がりません。。。Vine 3.1 です
tkppxp を使っていて、log は途中からですが

Jan 07 02:39:00 [6448] TIMER: PAUSE
Jan 07 02:39:00 [6448] OS : open(/dev/modem)=9
Jan 07 02:39:00 [6448] TIMER: START
Jan 07 02:39:00 [6453] CHAT : write "ATH0E1\r"
Jan 07 02:39:01 [6453] CHAT : ignore until 'AT'
Jan 07 02:39:01 [6453] CHAT : read "ATH0E1\r"
Jan 07 02:39:01 [6453] CHAT : read "\r"
Jan 07 02:39:01 [6453] CHAT : read "\n"
Jan 07 02:39:01 [6453] CHAT : found "OK"
Jan 07 02:39:01 [6453] CHAT : write "ATDT****-**-*******\r" <==電話番号
Jan 07 02:39:03 [6453] CHAT : read "\r"
Jan 07 02:39:03 [6453] CHAT : read "\n"
Jan 07 02:39:03 [6453] CHAT : read "ATDT****-**-*******\r"
Jan 07 02:39:03 [6453] CHAT : read "\r"
Jan 07 02:39:03 [6453] CHAT : read "\n"
Jan 07 02:39:03 [6453] CHAT : found "ERROR"
Jan 07 02:39:03 [6448] OS : dialer[6453] FAIL
Jan 07 02:39:03 [6448] PHASE: Dead =DOWN=> Dead
Jan 07 02:39:03 [6448] CHAT : delay 500ms
Jan 07 02:39:03 [6448] CHAT : write "+++"
Jan 07 02:39:04 [6448] CHAT : delay 500ms
Jan 07 02:39:04 [6448] CHAT : write "ATH0\r"
Jan 07 02:39:05 [6448] OS : close(9)
Jan 07 02:39:05 [6448] TIMER: PAUSE
Jan 07 02:39:05 [6448] TIMER: STOP

dial ができてないようです。dual boot の win ではcard は正常に動作しています

231 :login:Penguin:05/01/07 03:09:52 ID:1m2N9qIT
3.1を新規インストールしてsources.listにtaskを追加し
aptでtask-kdeをインストールしようとしたのですが
依存関係のエラーがたくさん出て、パッケージが壊れてるとなります。
みなさん普通にkdeをインストールできますか?

232 :login:Penguin:05/01/07 03:29:43 ID:PM9K9fnH
つい今しがた漏れも同じ問題にぶちあたった。
ためしにextrasも足したらうまくいったよ

233 :login:Penguin:05/01/07 09:30:24 ID:uuIuxcwU
taskは依存関係縛り無いんだっけ?
main,plusのみに依存としたほうがいいような。


234 :login:Penguin:05/01/07 12:07:18 ID:TUFHlvP7
>>233
kde-3.3.2がlibidnを要求してるが、何故かextrasにしか入ってない。それだけ。

235 :login:Penguin:05/01/07 15:08:48 ID:65xK7dqB
jedって標準で入ってる割に、日本語の情報皆無だなぁ。
本家のスクリプト拾ってきても、使い方よく分からんし・・・。
vineのメンテナは自分で使ってるのかな?

236 :login:Penguin:05/01/07 16:42:24 ID:qARUkALL
Vine Linux 3.1では、g77(FORTRANのコンパイラ)は使えないのですか?

237 :login:Penguin:05/01/07 16:45:07 ID:vcxR3yCK
使えるよ

238 :login:Penguin:05/01/07 16:59:34 ID:PVkIiIUq
>>236
使えなかったの?

239 :236:05/01/07 17:36:32 ID:qARUkALL
Command is not found
と出るんだが・・・

240 :login:Penguin:05/01/07 17:38:13 ID:vcxR3yCK
apt-get install gcc-g77

241 :login:Penguin:05/01/07 18:02:01 ID:PVkIiIUq
>>239
http://linux2ch.bbzone.net/index.php?FAQ%2FAfterInstall#e1a43e26

242 :236:05/01/07 18:21:43 ID:WjO2cCGx
>>240
それをやると

E: E:パッケージ gcc-g77 がg77 が見付かりません

というエラーが出てしまいます・・

243 :login:Penguin:05/01/07 18:25:43 ID:PM9K9fnH
wine使ってみようと、SUSE8.2用のソースRPMをrebuildしてみた。
だけどlibntdll.soが無いって文句言われた・・・そのファイル探してみたけど見つからないんで
Vine用バイナリがあったら使ってみたいのです。
Plusにもあるってどっかで読んだけどこれまた見つからないorz

244 :236:05/01/07 18:46:43 ID:5vF3Rj0h
>>241
"g77"でファイルを検索してみましたが、
何も見つかりませんでした。

245 :login:Penguin:05/01/07 18:47:12 ID:vcxR3yCK
>>242
apt-get update はしてあるのか?
あと、plusも指定しておかないと駄目かも知れん

>>243
ttp://rpmfind.net//linux/RPM/suse/8.2/i386/suse/i586/wine-20030217-32.i586.html
wine自身にlibntdll.soは含まれてるようだが。

246 :login:Penguin:05/01/07 18:49:46 ID:Y+1Y1k59
>>243
TestPkg に wine{,-utils}-20040121-0vl1.i386.rpm ならあるよ。
# ちと古いが。

247 :243:05/01/07 19:05:05 ID:PM9K9fnH
>>245 >>246
レスどうもです。
plus追加とupdateはしましたがメッセージが何も出ませんでした・・・

もうちともがいてみます。多謝。


248 :login:Penguin:05/01/07 21:46:57 ID:GyKEnQL4
[vine-users:069188]
[vine-users:069241]
[vine-users:069258]
は対処方法はないのか?


249 :login:Penguin:05/01/07 21:54:48 ID:MpfDUicG
サーバー証明書について質問です。

ttp://acorn.zive.net/~oyaji/www/certs.htm
ここを参照にして、最後のsign.shでサーバー用証明書の作成で以下の
エラーが表示されます。対処方法を教えて下さい。

[root@rans certs]# /usr/bin/sign.sh server.csr
CA signing: server.csr -> server.crt:
Using configuration from ca.config
1485:error:0E06D06C:configuration file routines:NCONF_get_string:no value:conf_l ib.c:329:group=CA_own name=unique_subject
Enter pass phrase for /usr/local/certs/ca.key:
unable to load CA private key
1485:error:06065064:digital envelope routines:EVP_DecryptFinal:bad decrypt:evp_e nc.c:450:
1485:error:0906A065:PEM routines:PEM_do_header:bad decrypt:pem_lib.c:423:
/usr/bin/sign.sh: line 61: 1485 セグメンテーション違反です openssl ca -config ca.config -out $CERT -infiles $CSR
CA verifying: server.crt <-> CA cert
Error opening certificate file server.crt
1486:error:02001002:system library:fopen:No such file or directory:bss_file.c:27 6:fopen('server.crt','r')
1486:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:278:
unable to load certificate

250 :login:Penguin:05/01/07 22:46:53 ID:daG8Mo9/
>>249
おちつく


251 :login:Penguin:05/01/08 11:16:36 ID:Olqj5OYm
>>249
もちつけ

252 :login:Penguin:05/01/08 13:18:20 ID:gfEKya7M
>230
http://www.a-yu.com/vine/vine_ppxp.html

これ見て出来ましたよ。Vine3.1です。内容はVine2.5ですがやってることは同じなので。

253 :login:Penguin:05/01/08 17:29:40 ID:IJL+kjf6
/var/log/でXのログを見ると
Open APM failed (/dev/apm_bios)
でエラー吐いてるんだが、これの解消法は何かあるのか??

254 :login:Penguin:05/01/08 21:58:37 ID:Bfq0TEZp
Vine 3.1をインストールしましたが、システムに追加する言語でJapaneseを選択しませんでした。
そのせいか、アルファベットでないメッセージが文字化けして表示されてしまいます。

日本語表示できるよう
apt-get install XXXXX で対処したいので、XXXXにはなにをすべきか教えてください。

255 :login:Penguin:05/01/08 22:08:14 ID:IpuxGHCr
>>254
入れ直しの際に日本語選択した方が早くないか?

256 :login:Penguin:05/01/08 22:11:16 ID:Bfq0TEZp
>255
そうですね、再インストールを今はじめました。
Pentium120、2倍速CDなんで再インストールに、なみだちょちょぎれそうです。

257 :login:Penguin:05/01/08 22:20:08 ID:M6eof8TV
普通フォントは、ただ置いただけじゃ認識されなかったよね。
Vine3.1はただフォントのファイルをコピーして/usr/X11R6/lib/X11/fonts/TrueTypeにペーストしたら、そのまま使えた。(Vineは前からですか?)
デュアルブートならシンボリックリンク張るだけでいいかも。
こいつは簡単でいいや。


258 :login:Penguin:05/01/09 01:31:51 ID:SzHqeETk
>>252
いろいろ試したけど駄目だったんで
インストールし直しました
/usr/sbin/ppxpadduser USRID
で、結局駄目でした。
誰か、同じ症状のひといませんか?
カードは AH-S405C です

259 :login:Penguin:05/01/09 07:14:51 ID:yupqHnd2
>>257
日記は広告の裏に...(AA略

260 :login:Penguin:05/01/09 08:03:42 ID:cB9jOcSk
LinuxMagazineやらUNIX USERやらを買った人、インストールはもう済みましたか?

261 :login:Penguin:05/01/09 10:10:31 ID:nuRB88aD
jmpostのパッケージ入れて欲しいなぁ・・・
こういう要望ってどこにすればいいのだろう?

262 :login:Penguin:05/01/09 22:13:05 ID:a6E6t78p
[VineSeed-Plus:02841]

> /usr/bin/ld: cannot find -lrpm
> collect2: ld returned 1 exit status
>
> このへん、何か関係ありますか?

rpm こねくりまわすなら、エラーメッセージくらい読んで、
-l が何をしているか理解しろよ。

263 :login:Penguin:05/01/09 22:15:04 ID:SzHqeETk
mozilla mailer でスペルチェック使いたいんですが
というより、どうして、入ってないの?

264 :login:Penguin:05/01/09 22:18:11 ID:5jSvmgkd
   ☆      ドムドム
        ☆   ダダダダ!   x86-64版Vine Linuxマダーー
  ドシャーン!  ヽ         オラオラッ!!    ♪
         =≡= ∧_∧     ☆
      ♪   / 〃(・∀・ #)    / シャンシャン
    ♪   〆  ┌\と\と.ヾ∈≡∋ゞ
         ||  γ ⌒ヽヽコ ノ  ||
         || ΣΣ  .|:::|∪〓  ||   ♪

265 :login:Penguin:05/01/09 22:25:20 ID:yD3GoClI
>>263
そんなあなたにEmacs

266 :login:Penguin:05/01/09 23:20:46 ID:dQj32544
初めまして、昨年からFedoraCoreでサーバー立ち上げを行おうと思い勉強していたのですが
このたびVineに乗り換えました。

で質問です。
起動HDDとは別に250GBのHDDを購入しているのですが、
Webminにてハードウェア内ローカルディスクののパーティション項目に、
その250GBHDDが「パーティーションが有りませんでした」と出ているのですが(当然ですが)
ここで「プライマリパーティション追加」と「拡張パーティションを追加」のどちらを
選択すればよろしいのでしょうか?

267 :login:Penguin:05/01/09 23:40:47 ID:dQj32544
このたびFC3からVine3.1に乗り換えた者です。
起動HDDとは別にFTPサーバ用に250GBHDDを購入したのですが、
Webmin上での設定にてハードウェア内、ローカルディスクのパーティション内で
当然ですが250GBhddが「パーティションが有りませんでした」とでるのですが、
このとき、「プライマリパーティションを追加」と「拡張パーティションを追加」の
どちらを選択すればよろしいのでしょうか?

268 :login:Penguin:05/01/09 23:43:38 ID:dQj32544
このたびFC3からVine3.1に乗り換えた者です。
起動HDDとは別にFTPサーバ用に250GBHDDを購入したのですが、
Webmin上での設定にてハードウェア内、ローカルディスクのパーティション内で
当然ですが250GBhddが「パーティションが有りませんでした」とでるのですが、
このとき、「プライマリパーティションを追加」と「拡張パーティションを追加」の
どちらを選択すればよろしいのでしょうか?

269 :login:Penguin:05/01/10 00:00:26 ID:OrpU0H5D
お好みに応じて。

270 :login:Penguin:05/01/10 00:04:07 ID:OrpU0H5D
お好みに応じて。

271 :login:Penguin:05/01/10 01:56:40 ID:zpqaA/au
subversionのパッケージを現状の1.0.6をベースにした1.1.2版を作ってみようと思い立ち、ゴソゴソやってるところでつ。

1.0.6のパッケージに加えた修正は以下のとおりです:
* ベースを1.0.6から1.1.2に更新
* svn-1.1.2-perl.patch for 1.1.2を追加
* subversion-0.24.2-swig.patchを外した
* subversion-1.0.2-blame.patchを外した
* subversion-r8822.patchを外した
* BuildPreReq?にswig-runtime >= 1.3.16を追加
* 1.0.6の時にsubversion/bindings/swig/perlにあったモジュールがsubversion/bindings/swig/perl/nativeに移動していたのでビルド部のspecを修正
* docからIDEAS PORTINGSを削除(というかファイルが無い)、STATUS TRANSLATINGを追加
* bdb4.0でbuildするようになっていたので、現行のbdb4.2でbuildするよう変更

んで、fsfsでのリポジトリ作成はうまくいって、ちゃんと使えるんだけど、bdbの方がうまくいきません。
> # svnadmin create --fs-type bdb repos
> svn: Berkeley DB error while creating environment for filesystem repos/db:
> ?\204?\181?\184?\250?\164?\202?\176?\250?\191?\244?\164?\199?\164?\185
> svn: bdb: Berkeley DB library configured to support only DB_PRIVATE environments


272 :271続き:05/01/10 01:56:57 ID:zpqaA/au
とりあえずメッセージをたよりに情報を漁ったところでは、
http://www.contactor.se/~dast/svnusers/archive-2004-09/0337.shtml
にあるように、NPTL対応のbdbとNPTL非対応のkernel、glibcの組み合わせで起こるらしいのですが、
一応見た感じでは、kernel、glibc、db4ともNPTL非対応でビルドされてるっぽく(db4に関しては、--disable-posixmutexesは無かったですが)、
念のためdb4に関しては、--disable-posixmutexesを追加してビルドしたものに入れ替えて試してもみましたが、結果は同じでした。

1) やっぱりsubversion側に原因があり、何か処置しないといけない?
2) db4のNPTL非対応ビルドがうまくいってない?
というあたりをもうちょっと詳しく確認してみたいのですが、うまいアイデアを思いつきません。

どなたか「こうすればいいじゃん」とかのアイデアや、「いやそんなんでなくこれが原因」とかいう情報をお持ちの方はいませんか?
自分的にはfsfs使ってそれでおっけーなんだけど実用域のパッケージじゃないので悔しかったり……

db4-devel-4.2.52-6vl3
db4-4.2.52-6vl3

glibc-common-2.3.3-3vl1
glibc-devel-2.3.3-3vl1
glibc-2.3.3-3vl1

kernel-2.4.28-0vl1 (mkkpkgでxfsとtg3ドライバを組み込みに変更)


273 :login:Penguin:05/01/10 03:17:14 ID:lP2Bwze9
http://equis.ya.com/coletassoft/non_pb/linux_pie/imagepages/image8.html

274 :login:Penguin:05/01/10 03:24:28 ID:JESQp3V/
xchatのチャネルの部分の日本語が文字化けしてしまいます。(vine3.0)

どうすれば直りますか?

275 :login:Penguin:05/01/10 04:35:40 ID:bVfwK1P0
>>274
2.6用のを入れろ

276 :GA-8I915G-PRO-Rev2:05/01/10 10:40:58 ID:uvNE4oSs
915G マザー に 3.1CR を 乗せたいと思っています。
標準インストールでは、 XのバージョンがX.org R6.7なので、
オンボードVGA(MGA 900)が使えなさそうです。
X.org R6.8からは、915GのオンボードVGA(MGA 900)が、使えるらしいのですが、、、

どなたか、試された方はいらっしゃいますか?
もしくは、Vine Seed の X.org R6.8.x をすでに入れておられる方が
いらっしゃいましたら、その感想をお聞かせいただけないでしょうか?

277 :login:Penguin:05/01/10 18:14:23 ID:rr8C/sU8
とりあえずfedoraなら使えてる。

278 :login:Penguin:05/01/10 20:35:26 ID:se4lSh4d
>>276
testにsrpmが有った希ガス
でもtestだから出来は知らない


279 :login:Penguin:05/01/10 20:36:05 ID:1Ix3d7Gk
Vine3.0でサーバー証明書を作成しています。
参考URL
ttp://acorn.zive.net/~oyaji/www/certs.htm

最後でエラーになります。対処方法がわかりません。
https://--でアクセスすると、証明書が間違っているか不正なため
暗号化された接続を確立できないと怒られます。
証明書のエラーコード -8101
どなたかまじレスお願いします。

Certificate is to be certified until Jan 10 11:27:24 2006 GMT (365 days)
Sign the certificate? [y/n]:y

1 out of 1 certificate requests certified, commit? [y/n]y
Write out database with 1 new entries
Data Base Updated
CA verifying: server.crt <-> CA cert
server.crt: /C=JP/ST=Tokyo/L=Shibuya/O=rans corp./OU=admin/CN=rans.dip.jp/emailA ddress=admin@rans.dip.jp
error 18 at 0 depth lookup:self signed certificate
/C=JP/ST=Tokyo/L=Shibuya/O=rans corp./OU=admin/CN=rans.dip.jp/emailAddress=admin @rans.dip.jp
error 7 at 0 depth lookup:certificate signature failure

280 :login:Penguin:05/01/10 21:04:48 ID:b0I2kE0h
>>279
>>250-252

281 :login:Penguin:05/01/10 21:21:10 ID:u6xw+wPh
>>279
ttp://linux2ch.bbzone.net/

ttp://acorn.zive.net/~oyaji/www/certs_linux.htm

282 :login:Penguin:05/01/10 23:14:32 ID:rr8C/sU8
fedoraみたいに公式にwikiとbugzillaがあればどれだけいいか

283 :login:Penguin:05/01/11 01:10:09 ID:HPd2RmJq
8139too fast ethernet driver 0.9.26と表示されてインストールできねえ

284 :名無しさん@Vim%Chalice:05/01/11 02:02:35 ID:KRa/F2cx
3.0=>3.1 にアップデートして、kernelを2.4.27にしたら、 ipw2100が使えな
くなった。使おうとすると固まって入力受け付けなくなっちゃう。
とりあえずこれまで使ってた2.4.26を自分でビルドしたのまま使うから別にいいっちゃぁいいんだけど、
2.4.27で使えてる人いますか?

285 :login:Penguin:05/01/11 07:43:56 ID:A0ZDsAMI
>>282
非公式なwikiってどっかにある?


286 :login:Penguin:05/01/11 08:16:47 ID:qFoM4Pix
>>278
TestPkg の XOrg-6.8.0 は VineSeed に入れる前のテスト的なもの。
それを使うくらいなら、security fix を含んだ VineSeed の XOrg-6.8.1 を
使った方が良いと思う。

>>276
i915G もってないから、それに関しては分からないけど、
とりあえず VineSeed の XOrg は Vine 3.1 でも使える。

287 :login:Penguin:05/01/11 16:14:55 ID:07H0dxvG
/etc/sysconfig/pgsql/postgresqlのPGOPTSを書き換えても反映されない
/etc/rc.d/init.d/postgresqlでPGOPTSをpg_ctlに渡してない
メンテナさん直しておいて

288 :login:Penguin:05/01/11 17:21:49 ID:UX54ZKBZ
Vine3.1って、popper,imapper?って入ってます?
Vine2.6の時はqpopperとimap-2001aが標準で入っていて、
courier-imapに入れ替えて使ってたんですけど、
いまVine3.1入れてみたらpopper,imapperとも入ってないような気が。
まぁcourier-imapを使うんですけど、およよと思ったもので。
あとinetdも消えましたか。なんかうらしまな感じです。
どこかに、これがこう変わったよーという一覧はないでしょうか?

289 :login:Penguin:05/01/11 17:59:24 ID:Ja0jqKNg
>>288
色々変わるのは Vine に限らず時代の流れかと。


290 :login:Penguin:05/01/11 18:14:20 ID:dDGkVc0R
>>288
$ cat /etc/vine-release
Vine Linux 3.1 (Pichon Lalande)
$ rpm -qa |grep inetd
inetd-0.17-0vl1


291 :login:Penguin:05/01/11 19:36:50 ID:UX54ZKBZ
>>290
んー、うちのには入ってないですね。
パッケージの選択の問題ですか。
クライアントマシンではなくサーバー用途として、
カスタムで以下のグループを選択して入れたんですけどね。
もちろんクリーンインストールです。
・X Window
・日本語入力システム
・インターネットクライアント
・Emacsエディタ
・システム管理ツール
・インターネットサーバ
・基本開発ソフトウェア
・Rubyスクリプト言語
・全文検索エンジンNamazu
・ドキュメント

292 :login:Penguin:05/01/11 19:58:01 ID:sWq07sd+
>>291
とりあえず ttp://vinelinux.org/whatsnew.html でもよんでこいよ


293 :VineLinux3.1インストール初心者 :05/01/12 01:49:26 ID:3l5lcwDQ

本日、N経Linuxの添付CDのDisk1より
IBMノートR40eへインストールしました。
W2kと綺麗に同居でき、その簡単さにびっくり!!!

さて、Rootでログインしようと思い、
R40eのキーボード上にある赤いマウスポインタ
正式名トラックポイントの動きが不具合なのです!

左及び下への移動を認識しません。なぜか左下へ
いっきに飛びます。なぜでしょう?

IBM純正のUSBマウスを使うべきでしょうか?

>mouseの設定をしなおす。
と、発言をいただいたこともありますが、
マウスが効かないので、何もできません。

どのように対処すると良いのでしょうか?


294 :login:Penguin:05/01/12 03:10:23 ID:0/CF51jg
> IBM純正のUSBマウスを使うべきでしょうか?

はい。

295 :login:Penguin:05/01/12 05:57:18 ID:M2JGJgUU
ほとんど同様の質問を「くだらねえ」で行ない、アドバイスをいただいて既に解決しております。


296 :login:Penguin:05/01/12 06:14:36 ID:5s3mggzP
それは素晴らしいマルチですね

297 :login:Penguin:05/01/12 10:34:17 ID:AvNA3uoh
293さんと同様の問題ではまった。結論からいうと、初心者の293さんはUSBマウスを使ったほうがいいと思う。

自分は自己解決した。295さんのアドバイスで過去ログあさったけど探し方悪いのかみつからんっかたので書いときます。
ThinkPadX40とThinkPads30。VineLinux 3.0とVineLinux3.1で試しました。
トラックポインタの設定は、/etc/X11/xorg.confのSection "Input Device"で

Option "Protocol" "IMPS/2" を
Option "Protocol" "PS/2" にする。

そもそもXが上がってる場合には、boot時に linux -sでシングルユーザモードで起動して修正したらいいんじゃないか。

298 :login:Penguin:05/01/12 11:28:55 ID:0/CF51jg
GUI でしか修正できないと思ってる初心者に、LILO 等で渡すパラメータなんかの
話をしてもスルーされるだけかと。

299 :login:Penguin:05/01/12 12:00:34 ID:hBYJ3eMF
>>298
漏れなんか i、 q!、 w だけでvi使ってる(゚д゚)ウマー

300 :login:Penguin:05/01/12 13:20:07 ID:ku5vwuE4
「esc」と「wq」と「:」も使えや

301 :login:Penguin:05/01/12 13:58:22 ID:90RfTOwK
Emacsも使えや

302 :login:Penguin:05/01/12 14:15:33 ID:ecPpbsSb
>>299
さすがに x も使ってるだろ。おれも >>229のほか dd yy p P ZZ a くらいだか
>>229とレベルがかわらんな

303 :login:Penguin:05/01/12 15:04:32 ID:ku5vwuE4
>>229が謂れなき迫害を受けてる件について

304 :login:Penguin:05/01/12 15:10:34 ID:fO57n/2q
ぶっちゃけ、viは基礎の基礎しか知らんですたい

305 :login:Penguin:05/01/12 15:34:03 ID:8EEty6Tn
日頃 Emacs だと vi は、a,i,wq,q!,x,dd しか覚える機会がない。

306 :login:Penguin:05/01/12 16:00:20 ID:8SRCj2tx
vim 使うなら vimtutor は一度やっとくべきじゃないっすかね?
emacs なら M-x help-with-tutorial

ところで、セキュリティフィクスで XOrg-6.7.0-0vl6.1.src.rpm と
zip-2.3-14vl2.1.src.rpm が出てるんですが、これらはリリース番号に +1
せず +0.1 となってますよね。この辺りのVine的命名規則とかあるんですか?

307 :login:Penguin:05/01/12 16:10:08 ID:KBvNC1BY
>>306
基本的には ttp://vinelinux.org/packaging.html に従う。

308 :login:Penguin:05/01/12 17:48:02 ID:V+nm/lQW
文字が汚いといってる人を良く見るけど俺はあまり良く分からない。
最近のVINEの字は綺麗だと思うけどな
前のVINEはもじらをスクロールすると文字が消えたり潰れたりした。
それに比べて今はそんなことない。感動したけどな俺は。

309 :login:Penguin:05/01/12 18:17:32 ID:0/CF51jg
>>308
Windows を含めて比較すると汚いということじゃないの?

310 :login:Penguin:05/01/12 20:30:24 ID:PLq2LKYK
wineをrpmbuildやtar.gzから入れられない。
しょうがないからrpmで固められた奴をインスコしてる。

311 :login:Penguin:05/01/12 20:33:55 ID:PLq2LKYK
ごめんなさい、愚痴はチラシの裏にでも書きます。

312 :login:Penguin:05/01/12 20:51:25 ID:0/CF51jg
>>310
愚痴を書くんじゃなくて、どこで失敗したのか書いておけば、
同じ問題がおきて解決した人教えてくれる人がいるかもよ?

313 :login:Penguin:05/01/12 20:59:19 ID:PLq2LKYK
>>312
わかりました。
書いてみます。

314 :login:Penguin:05/01/12 21:26:41 ID:PLq2LKYK
当方はVine3.1を使っています。

Wine HQ http://www.winehq.com/
Wine-20050111.tar.gz http://prdownloads.sourceforge.net/wine/Wine-20050111.tar.gz?download

既にこれらのパッケージはapt-getにより入れてあります。
>apt-get install bison flex gpm-devel XFree86-gl-devel ncurses-devel
>apt-get install sgml-tools XFree86-devel sane-devel freetype2-devel arts-devel
>apt-get install autoconf docbook-utils docbook-dtd-sgml cups-devel ImageMagick

Wine-20050111.tar.gzを解凍後、一般ユーザで [wine-20050111] ディレクトリ直下の./configureをした結果。
ttp://dokuo-ha-hitori.dyndns.tv/~dokuo/cgi-bin/zuru/source/dokuo7215.txt

その後、スーパーユーザーに切り替えmake dependをした結果。
make depend ttp://dokuo-ha-hitori.dyndns.tv/~dokuo/cgi-bin/zuru/source/dokuo7219.txt
make -d depend ttp://dokuo-ha-hitori.dyndns.tv/~dokuo/cgi-bin/zuru/source/dokuo7220.txt

make -d dependの方は重いですがmakeの進行が細かく書かれてるのでこちらの方が参考になると思います。

よろしくお願いします。

315 :login:Penguin:05/01/12 21:33:51 ID:0/CF51jg
-lz で失敗してるので、zlib-devel が入ってないような気がする。

316 :login:Penguin:05/01/12 21:54:26 ID:PLq2LKYK
>>315
#apt-get install zlib-devel
したら指摘通り入っていませんでした。

すると、さっきまでできなかった make depend ができるようになり。
現在は make install 中です。

317 :login:Penguin:05/01/12 21:55:52 ID:PLq2LKYK
お礼を言い忘れてました。

ありがとうございました。

318 :login:Penguin:05/01/12 22:06:47 ID:0/CF51jg
>>316-317
オメ。うまくインスコできるといいね。

319 :login:Penguin:05/01/12 23:31:52 ID:WdAN2V7Q
うまくできました。

$./configure
#make depend
#make
だと上手く出来なかったのですが。

$./tools/wineinstall
だと最後まで出来て、
$wine
と入力すると反応しました。

ありがとうございます。

320 :login:Penguin:05/01/13 01:06:10 ID:SgboNdeF
>310,312
藻前ら良い椰子だな。GJ!

321 :login:Penguin:05/01/13 02:18:19 ID:FwswlXV+
2.6でproxy経由でapt-getとmailを見るため
検索してなんかのファイルを書き換えて成功したんですが
どうやって設定したか覚えてません。

現在の環境がproxyを使っていないため
apt-getとmailが利用できなくなりました。
どうすればproxyを解除できますか?

ちなみに
/etc/apt/sources.list
/etc/apt/apt.conf

は変更されてないみたいです。

よろしくお願いします。

322 :login:Penguin:05/01/13 02:23:54 ID:+fUcE9Zg
>>321
apt-get ができないとのことですが、そのマシンの Mozilla 等で Web ページは
見えます?

そのメールってのはどんなメールですか?
Yahoo とか Livedoor とか Hotmail とかの Web から見る奴?
それとも何らかのメールクライアントから読む奴?


323 :login:Penguin:05/01/13 02:39:09 ID:FwswlXV+
>>322
mozillaでwebページは見れてます。現在そのPCで書き込んでます。

メールはメールクライアントからのでsylpheedです。

324 :login:Penguin:05/01/13 02:48:03 ID:gldfWIjH
>>323
必要なデータをバックアップして3.1をクリーン・インストールってのはどうよ


325 :login:Penguin:05/01/13 02:58:02 ID:FwswlXV+
>>324
やっぱりそれが現実的ですよね。
もう少しあがいてみようと思います。

326 :login:Penguin:05/01/13 03:06:36 ID:Ub0Z8SrI
grep -r 設定されているproxy /etc/*

327 :login:Penguin:05/01/13 03:52:38 ID:FwswlXV+
>>326
今やってみましたが出てきませんでした。
grep -r proxy /etc/*
にしたり色々してみましたがそれらしきのが見つかりませんでした。
ありがとうございました。

328 :login:Penguin:05/01/13 03:57:25 ID:+fUcE9Zg
/sbin/iptables-save の結果きぼんぬ。(root 権限必要)


329 :login:Penguin:05/01/13 04:18:23 ID:FwswlXV+
>>328
どうすればいいのかわからないのですが、

/sbin/service iptables save
は保存中に失敗で

/sbin/iptables-save > /etc/sysconfig/iptables
はemacsで/etc/sysconfig/iptablesを開いても中身が空でした。

330 :login:Penguin:05/01/13 04:52:30 ID:FwswlXV+
>>328
再起動して
/sbin/iptables-save
できました。
結果です。

# Generated by iptables-save v1.2.7a on Thu Jan 13 04:50:00 2005
*filter
:INPUT ACCEPT [871:145839]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [911:72317]
COMMIT
# Completed on Thu Jan 13 04:50:00 2005

331 :login:Penguin:05/01/13 05:35:52 ID:rJDMkz9c
Vine2.6はkernel-2.6だと思っていた時期もありました

332 :login:Penguin:05/01/13 10:20:13 ID:xVm4m1n1
Vine 3.1 にKDockerをインストールしようと
していますが、qmake -> makeを実行すると
エラーが発生してインストールできません。
以下全文ではありませんがエラー文です。
--<以下エラー内容>-------
src/customtraylabel.cpp: member function 内の `bool
CustomTrayLabel::canDockWindow(long unsigned int)':
src/customtraylabel.cpp:258: error: incomplete type 'TrayLabelMgr' cannot be
used to name a scope
src/customtraylabel.cpp: member function 内の `void
CustomTrayLabel::dropEvent(QDropEvent*)':
src/customtraylabel.cpp:263: error: 文法エラー before `::' token
src/customtraylabel.cpp: トップレベル:
src/traylabelmgr.h:39: 警告: `QString options()' defined but not used
src/traylabelmgr.h:76: 警告: `const char*mOptionString' defined but not used
make: *** [tmp/customtraylabel.o] エラー 1
---------
どなたかVine3.1でKDockerをインストールされた
方はどのようにインストールされたかお教えいただけない
でしょうか。よろしくお願いいたします。

333 :login:Penguin:05/01/13 15:00:01 ID:NtvNcx1S
ちょとお尋ねします。
IDE の転送モードはデフォでDMA ですよね?

334 :login:Penguin:05/01/13 15:22:01 ID:kGWl9NqA
すみません。今日、サーバを立ち上げようと思い、vine linux3.0をインストールして、
PHPパッケージをインストールしようとしたら、次のようなメッセージが出て、全然駄目です。
ーーー
いくつかのパッケージをインストールすることができません。おそらく、
ありえない状況を要求したか、(必要なパッケージがまだそろっていなかっ
たり、まだIncomingから移動されていない)不安定なディストリビューション
を使用していないでしょうか。

単純な操作だけを行った時に、パッケージがインストール
できない場合は、バグリポートしてください。
以下の情報がこの問題を解決するために役立つかもしれません:

以下のパッケージは解決できない依存関係を持っています:
php: 依存: libdb-4.2.so それをインストールすることができません
E: 壊れたパッケE: 壊れたパッケージです
ーーー

もしかして、もっかい全部インストールしなおしでしょうか?

335 :login:Penguin:05/01/13 15:30:55 ID:BCUztqdU
>>334
PHPパッケージはどこから入手したの?

336 :login:Penguin:05/01/13 15:34:55 ID:NQYUIVBi
>>334
Vine3.1 にアップデートしる
そうすりゃdb4の新しいのが入る

337 :login:Penguin:05/01/13 15:41:25 ID:kGWl9NqA
>>335
とりあえず、私の手順が悪かったのかもしれないので、これまでの経過を書きます。

1、windows XPを一部のパーティションにインストール(110GB)

2、vine linux3.0を残りのパーティションにインストール(45GB)
3、[apt-get install MySQL-server MySQL-Max MySQL-client MySQL-shared]でMySQLをインストール
4、アップグレードを忘れているのに気づいて[apt-get upgrade]する。
5、[apt-get install php php-apache php-mysql]を実行するも、>>334のメッセージ。

今日から使いはじめたんで、いろいろとネットで調べながらやってたんですが、朝起きてからHPすらうpできていない俺はいったい。。。

338 :login:Penguin:05/01/13 15:44:30 ID:kGWl9NqA
>>336
分かりました。ありがとうございます。
一度、3.1にアップグレードしてきます。

339 :login:Penguin:05/01/13 15:54:44 ID:v6cPZkxG
>>337
で、PHPパッケージはどこから入手したの?

340 :login:Penguin:05/01/13 16:48:28 ID:NVZoyHCF
>>339
apt-getから手に入れたみたいよ。

341 :login:Penguin:05/01/13 17:13:56 ID:kGWl9NqA
できました!できました!!!!
とりあえずwebminを3.0でインストールしておいて、3.1にバージョンアップしたら普通にできました。
あとはPHPが正常に動いてくれることを祈るだけでつ。

>>340
コマンドで[# apt-get install php php-apache php-mysql]を使いましたよ。

342 :login:Penguin:05/01/13 17:44:30 ID:pcEh1SZ9
>>333
まあ、一応、
/etc/sysconfig/hartdisks

343 :login:Penguin:05/01/13 18:33:06 ID:/i8u3m+P
Vineがkernel 2.6採用するのっていつになるのか…

344 :login:Penguin:05/01/13 19:00:30 ID:F/plf3sL
ttp://vinelinux.org/roadmap.html

345 :343:05/01/13 19:41:29 ID:/i8u3m+P
ウホッ!半年後か!サンクス!

346 :login:Penguin:05/01/13 19:57:58 ID:NVZoyHCF
リモートコントロールのVNCについて質問があります。
既に
#apt-get install vnc-server
によりvncserverのインストールは成功しています。
また一般ユーザーでvncserverを起動しwindows機からのリモートにも成功しています。

Vineのバージョンはvine3.1です。
vncのバージョンはvnc-server (= 4.0-0.0.beta4.11vl1)です。
vncについてより詳細はコチラ(ttp://dokuo-ha-hitori.dyndns.tv/~dokuo/cgi-bin/zuru/source/dokuo7275.txt)

VNCをinetd経由で接続したいのですが、Session password(パスワードの要求)が起こってしまいます。
通常ならばもちろんパスワードの要求が起こるのですが、
inetd経由だとパスワードの要求が無くグラフィカルログイン画面に移るはずのようです。

こちらのサイトを参考に勧めました。
 ttp://www.atmarkit.co.jp/flinux/special/vnc02/vnc02b.html
 ttp://www.dream-seed.com/linux/vnc.html

以下がそれぞれの変更点と下の3つはどこが問題点なのかわからないので、一応ファイルごとをうpしました。
/etc/services に追加した文
 vncinetd 5950/tcp # Vertuan Network Computing
/etc/inetd.conf に追加した文
 vncinetd stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query 192.168.0.4 -once -geometry 1024x768 -depth 16 -alwaysshared
/etc/inittab の中身
 ttp://dokuo-ha-hitori.dyndns.tv/~dokuo/cgi-bin/zuru/source/dokuo7278.txt
/usr/bin/vncserver の中身
 ttp://dokuo-ha-hitori.dyndns.tv/~dokuo/cgi-bin/zuru/source/dokuo7276.txt
/etc/X11/gdm/gdm.conf の中身
 ttp://dokuo-ha-hitori.dyndns.tv/~dokuo/cgi-bin/zuru/source/dokuo7277.txt
です。

よろしくお願いします。

347 :login:Penguin:05/01/13 20:16:50 ID:NVZoyHCF
/usr/bin/vncserverは
>$defaultXStartup
>   = ("#!/bin/sh\n\n".
>    "# Uncomment the following two lines for normal desktop:\n".
>    "# unset SESSION_MANAGER\n".
>    "# exec /etc/X11/xinit/xinitrc\n\n".
>    "[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup\n".
>    "[ -r \$HOME/.Xresources ] && xrdb \$HOME/.Xresources\n".
>    "xsetroot -solid grey\n".
>    "vncconfig -iconic &\n".
>    "xterm -geometry 80x24+10+10 -ls -title \"\$VNCDESKTOP Desktop\" &\n".
>    "twm &\n");
から
>$defaultXStartup
>   = ("#!/bin/sh\n\n".
>    "# Uncomment the following two lines for normal desktop:\n".
>    "# unset SESSION_MANAGER\n".
>    "# exec /etc/X11/xinit/xinitrc\n\n".
>    "[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup\n".
>    "[ -r \$HOME/.Xresources ] && xrdb \$HOME/.Xresources\n".
>    "LANG=ja_JP.ujis\n".
>    "export LANG\n".
>    "xset +fp /usr/X11R6/lib/X11/fonts/japanese\n\n".
>    "kinput2 -canna -cannaserver localhost &".
>    "xsetroot -solid grey\n".
>    "vncconfig -iconic &\n".
>    "xterm -geometry 80x24+10+10 -ls -title \"\$VNCDESKTOP Desktop\" &\n".
>    "#twm &\n".
>    "exec gnome-session &\n");
と、GUIをtwmからgnomeが表示されるようにし、日本語入力できるようにしただけです。
なので /usr/bin/vncserver はあまり関係が無いかもしれません。

348 :login:Penguin:05/01/13 21:02:31 ID:gldfWIjH
>>346
ttp://www.atmarkit.co.jp/bbs/phpBB/viewtopic.php?forum=10&topic=16590
こんなの見付けたけどどうよ

inetd.conf の Xvnc のオプションに -securitytypes=none を加える
/etc/X11/xdm/xdm-config の DisplayManager.requestPort: 0をコメントアウト
!DisplayManager.requestPort: 0 とする

試したわけじゃないけどな


349 :login:Penguin:05/01/13 21:15:33 ID:NVZoyHCF
>>348
ありがとうございます。
上部の -securitytypes=none を加えてみたところ上手くできました。
inetd.confに加え、
>[root@localhost root]# service inet restart
>Stopping INET services:               [ OK ]
>Starting INET services:               [ OK ]
>[root@localhost root]#
とinetdを再起動したら、Windows側できちんとログイン画面が確認できました。
それとログインもできました。
本当にありがとうございました。

記念ですが、スクリーンショットを取ってみました。
こちらのアプロダの[dokuo7284.jpg]です。
ttp://dokuo-ha-hitori.dyndns.tv/~dokuo/cgi-bin/zuru/upload.cgi

本当にありがとうございました。

350 :login:Penguin:05/01/13 23:13:09 ID:TOW3K/FK
>>349
オメ

351 :login:Penguin:05/01/13 23:31:43 ID:+fUcE9Zg
dokuo7279.jpg がおもろい。

352 :login:Penguin:05/01/14 00:09:33 ID:IzzyewlP
flac-1.1.1-0vl4 がリビルドできなかったのでパチ。
--- flac.spec.orig 2005-01-13 23:57:25.000000000 +0900
+++ flac.spec 2005-01-13 23:59:05.000000000 +0900
@@ -84,7 +84,7 @@
XMMS で FLAC ファイル (*.flac) を再生するための入力プラグインです。
%endif

-%if %{build_xmms_plugin}
+%if %{build_bmp_plugin}
%package -n beepmp-flac
Summary: Beep Media Player plugin to play FLAC files
Summary(ja): FLAC ファイルを再生するための BMP プラグイン


353 :login:Penguin:05/01/14 01:30:27 ID:+/tCsZX6
via8237のSATAに接続したHDDにVine3.1インストールしたいんだけど,パーティションの設定から先に進めません.
インストール可能な領域が見つからないって怒られる.

そもそも無理なんでしょうか?

354 :1:05/01/14 01:56:37 ID:y4DqmOcV
2.6から3.1にアップしたのですが、
再起動後にgnomeが依存関係が解決できず立ち上がりません。
#apt-get -f install で解決できず・・・
同じようなかたいらっしゃいませんか?

355 :login:Penguin:05/01/14 02:16:09 ID:0f6bSoOR
>>353
BIOSいじる

356 :login:Penguin:05/01/14 04:03:00 ID:LlPrJy9V
>>354
# echo "/usr/X11R6/lib">> /etc/ld.so.conf
# ldconfig
# pango-querymodules > /etc/pango/pango.modules

3.0の時はこれで解決してたけど、試してみる?

357 :login:Penguin:05/01/14 04:09:27 ID:+/tCsZX6
>>355
ネットを調べてcombined modeにしたら良いということは分かったのですが,使っているマザー(K8T NEO2)のBIOSにはそのような項目はありませんでした.
FedoraCore3はインストールできそうなのでVineはあきらめます.
CPUもAthlon64だしね.

358 :初心者:05/01/14 05:44:54 ID:UuccPnE8
今日初めてVINEをインストールしたのですが
今までのLINUXのなかでは一番気に入りました。インストールが
スゲー楽だし、初期設定がちゃんとしてるし。なんでこれまで
使わなかったのか、少し後悔です。REDHATもまぁよかったけど。
他のLINUXは、初期設定が終わるころにぐったりする。

359 :login:Penguin:05/01/14 06:15:28 ID:sFUpaiwx
VineLinuxではWindowsXPの領域をマウントできないのでしょうか?
マウントしようとするとNTFSはサポートしていないと表示されます。
レッドハットは
http://linux-ntfs.sourceforge.net/rpm/downloads.html
このようなサイトもあり可能なようですが、Vine用のものは
どこかにありませんでしょうか?
ご教授おねがいします。

360 :185 :05/01/14 07:40:10 ID:qhh+p1Bw
>>359
俺のはkernel 2.4.27-0vl7.2ですが、
# cat /proc/filesystems
これでntfs表示されるしmountもできる。
# dmesg | grep -i ntfs
NTFS driver 2.1.6a [Flags: R/W MODULE]
NTFS volume version 3.1.

361 :login:Penguin:05/01/14 10:01:42 ID:eFF2wJrn
>>359
mount のマニュアルに目を通せば解決できると思います。
書き込みもできますので熟読しましょう

362 :login:Penguin:05/01/14 11:25:13 ID:xSyaDaBi
Vine3.1を使用しております。

マルチブートでlinuxとwinを設定しているのですが、
liloに登録すると両方が表示されて、選択できてしまいます(通常の動作)。

普段はwinの存在を知らせず、linuxのみを表示して
コマンドを入力するなり、何か指示をした時だけwinが起動するようにしたいのですが、
方法がありましたらご教授ください。

363 :login:Penguin:05/01/14 11:45:23 ID:AmMyJkyM
>>362
エロいな・・・

364 :login:Penguin:05/01/14 12:00:18 ID:gXlMSAfl
>>356
レスありがとうございます。
もうクリーンインストールしかないと思っていましたので、
是非、ためさせていただきます。
その後、結果を、報告させていただきます(^^;


365 :login:Penguin:05/01/14 12:19:45 ID:/tCNg3ll
grubでパスワードをかける


366 :login:Penguin:05/01/14 12:23:14 ID:cGmeVOO5
>>362
prompt, timeout を削除
詳しくは $ man lilo.conf


367 :login:Penguin:05/01/14 12:54:42 ID:NDQw1wQs
>>362
俺は lilo.conf の message=/boot/message をコメントアウトして、
install=/boot/boot-text.b を入れている。シンプルなのが好きなので。

368 :359:05/01/14 12:59:17 ID:sFUpaiwx
>>360,361ありがとうございます。
勉強しなおしてやってみます。


369 :login:Penguin:05/01/14 13:08:54 ID:eFF2wJrn
>>368
念のために書いておきますが、日本語マニュアルが読みたい場合は
jman コマンドを使ってください。

370 :359:05/01/14 13:12:52 ID:sFUpaiwx
いまcat /proc/filesystemsを見てみたのですが、
NTFSがありません。何か悪いことして消えてしまったのでしょうか。
カーネルは2.4.27-0vl7です。

nodev rootfs
nodev bdev
nodev proc
nodev sockfs
nodev tmpfs
nodev shm
nodev pipefs
ext3
ext2
cramfs
nodev ramfs
nodev nfs
reiserfs
nodev devpts
nodev usbdevfs
nodev usbfs
nodev supermount
nodev autofs

申し訳ありませんが、解決法があればご教授願います。

371 :login:Penguin:05/01/14 13:30:13 ID:j277HQUm
>>書き込みもできますので熟読しましょう
書き込みは保証されてない。
失敗してアボーンしても、泣かない、騒がない、スレに助けを求めない。

372 :login:Penguin:05/01/14 13:32:35 ID:HkQd326S
以下にカーネル2.6のNTFSwrite機能の説明を訳したものを載せます。
(直訳に近いので日本語としてはおかしな部分もあります。)

------------------------------------------------------------------------
NTFSドライバーの書き込みサポートは限定的(しかし安全)なものです。

唯一サポートされている操作は、
既に存在しているファイルの(ファイルの大きさを変更しない形の)上書きです。

ファイル及びディレクトリの新規作成はおこなえません。
削除と名前の変更は可能です。

注意:nonresident(NTFS用語です)なファイルのみ
書き込みがおこなえます。そのため、非常に小さなファイル(500バイト以下など)は
書き込みがおこなえません。

以下、略

373 :login:Penguin:05/01/14 13:43:03 ID:HkQd326S
>>362,366
余談になってしまうが、俺はVine3.1でgrubを使っている。
grubの場合はhiddenmenuで何かキーを押さない限りデフォルトだけを
表示する

374 :login:Penguin:05/01/14 13:56:54 ID:j277HQUm
>カーネル2.6


375 :login:Penguin:05/01/14 14:09:12 ID:HkQd326S
>>374
そうだよ。説明めんどくさいから省いたけど

2.6でも書き込みサポートはこの程度だ。と受け取ってくれてもいいし、
2.6でこの程度だから、2.4での書き込み機能はお話にならない程度だと受け取ってくれてもいいし、
Vineのカーネルはバックポートパッチがなされていて... みたいに話を拾ってくれてもいいし、

376 :login:Penguin:05/01/14 14:29:42 ID:xQyZNs5T
>>375
そういえば、Vine 3.1 までのカーネルは新しい NTFS ドライバが採用されてるけど、
VineSeed の kernel-2.4.28-0vl1 は古いドライバになってるね。

linux-2.4.26-ntfs-2.1.6b.patch を当てようとすると、一部のファイルで失敗するけど、
これらはファイルをまっさらにするだけだから、不要なファイルを消して、差分を
撮り直せば良いだけだと思うのだが、外した理由は他にあるのか?

377 :login:Penguin:05/01/14 16:57:41 ID:qC7OkN15
>>376
開発者が使ってなくて興味ないとか。

378 :362:05/01/14 17:29:27 ID:mvOMWZJj
>>365,366,367,373

ありがとうございます。
いろいろやってみます。

379 :login:Penguin:05/01/14 18:55:24 ID:evHaSxbw
Vine3.1 で linux-wlan-ng-0.2.1pre23 を make しようとしていますが、どうしてもエラーが
出てしまうので、もし make が成功した方がいらっしゃったらご教授いただきたく。
エラー発生時のログは以下のとおりです。

make[2]: ディレクトリ `/home/nitta/linux-wlan-ng-0.2.1pre23/src/p80211' に入ります
make -C /usr/src/linux SUBDIRS=/home/nitta/linux-wlan-ng-0.2.1pre23/src/p80211 WLAN_SRC=/home/nitta/linux-wlan-ng-0.2.1pre23/src/p80211/ \
modules
make[3]: ディレクトリ `/usr/src/linux-2.4.27' に入ります
scripts/split-include include/linux/autoconf.h include/config
find: *: そのようなファイルやディレクトリはありません
scripts/split-include: find: Success
make[3]: *** [include/config/MARKER] エラー 1
make[3]: ディレクトリ `/usr/src/linux-2.4.27' から出ます
make[2]: *** [default] エラー 2
make[2]: ディレクトリ `/home/nitta/linux-wlan-ng-0.2.1pre23/src/p80211' から出ます
make[1]: *** [all] エラー 2

試しにプロンプトにて /usr/src/linux-2.4.27 まで降りて scripts/split-include (〜以下略) と
実行させてみると、ちゃんとインクルードファイルを探してくれました。

380 :login:Penguin:05/01/14 21:15:40 ID:OajxL56H
make -d
ってやるとより詳細な情報が得られるよ。

381 :login:Penguin:05/01/14 21:31:57 ID:iXsCJ3Nn
先生〜ご教授願います。

Vine3.1を素のままフルインストールしました。
apachをinetd経由で起動させたいのですが、httpd.confをinetdに書き換えてて、
inetd.confをどのように記述したらちゃんと動くのかわかりません。

書き方教えてください

382 :login:Penguin:05/01/14 22:05:50 ID:OIhXEpd5
>>381
man inetd

383 :login:Penguin:05/01/14 22:11:17 ID:OajxL56H
>>381
inetdの設定ファイルは/etc/inetd.confです。
viなどで開いて自分で学んでください。

384 :login:Penguin:05/01/14 23:23:48 ID:7pl/QlKc
>>381
なんで inetd 経由にしたいの?

385 :login:Penguin:05/01/14 23:41:32 ID:OajxL56H
>>384
まぁそういうのは抜きにして、技術的な面で考えてみようぜ。
好奇心をひとつもぎ取るとそこから生える枝も無くなっちまうし。

って分けでまず/etc/inetd.confを自分で書き換えてみよう。
あんま難しくないし、他のを見て真似すれば上手くいくし。

386 :login:Penguin:05/01/14 23:44:32 ID:OquYw0j4
Apacheをtcpserverから起動しているのでinetdにしていたりします。

387 :381:05/01/14 23:56:46 ID:r84MPbXd
何とかでけました

proftpdの記述を参考に記述したのですが、うまくいかなくて悩んでいたんだけど
やっと無事にhttpdが起動でき、tcpwrapperが使えるようになりました。
inを抜けばよかったのか....

>384
tcpwrapperをhttpdアクセスでも使いたかっただけですよ。
規制かけるの楽だから。
そんなにアクセス多いわけじゃないので。

388 :login:Penguin:05/01/15 00:12:07 ID:irNLDF20
>>385
> 好奇心をひとつもぎ取ると
別にやめろとは言ってないが。

389 :352:05/01/15 00:22:22 ID:4bx5Zdw2
thx

390 :379:05/01/15 00:36:16 ID:ybPWy2Vq
>>380
アドバイスのおかげで原因が特定できました。split-include のバイナリがソースよりも古くて
おかしくなってたみたいでした。
強引に kernel-source の状態のみで make xconfig && make で解決させました。

これでやっと鯖用の php-4.3.10-0vl1 を rpm --rebuild できるわ…

391 :login:Penguin:05/01/15 01:25:40 ID:tOwWOcMx
>>386
tcpserverならinetdいらんだろ

392 :login:Penguin:05/01/15 06:59:07 ID:0rKgExiL
aptで取ってこれるSDL_imageを使ったところ、
png に対して、"Unsupported image format" と言われました。

試しに、libpng-develも入れて、
SDL_image-1.2.3-0vl3.src.rpm をrebuildしてみたところ、
shell$ ldd /usr/lib/libSDL_image-1.2.so.0
に対して、
libpng.so.3 => /usr/lib/libpng.so.3 (0x40054000)
も加わり、上のようなエラーは出なくなりました。

同症状の人、居ますか?

393 :login:Penguin:05/01/15 09:07:51 ID:tOwWOcMx
居ますかも何もaptでバイナリ持ってきてるんだからみんな同じだべ

394 :login:Penguin:05/01/15 11:07:06 ID:yJbAfJ3C
Vine3.1 + vnc-server-4.0-0.0.beta4.11vl1 での質問をさせてください。

vncserverをinetd経由で起動させたいと思い、
グラフィカルログインでは動作させられましたが、
サーバーはテキストログインで運用したいのです。
そこでXvncの引数から-queryをなくし、-PasswordFile
を指定してみましたが、認証はVNCのPasswordで通るものの
Sessionの中身を設定する方法が解らず、真っ暗な画面で
WMすら起動させられないでいます。
XDMCPを使用せず、テキストログインな環境のままで
WM等を指定するにはどうしたらよいのでしょうか。

とりあえず現状は下記のような設定 + hosts.deny, allowの記述のみです。

# cat /etc/services | grep vnc
vnc-inetd 5950/tcp # VNCServer

# cat /etc/inetd.conf | grep vnc
vnc-inetd stream tcp nowait nobody /usr/sbin/tcpd /usr/bin/Xvnc -inetd -once
-geometry 1024x768 -depth 16 -alwaysshared -PasswordFile=/etc/vnc_passwd

# ls -l /etc/vnc_passwd
-rw-r--r-- 1 root root 8 Jan 13 23:22 /etc/vnc_passwd

以上、よろしくお願いします。

395 :login:Penguin:05/01/15 11:14:15 ID:LVNG6ido
VineLinux3.1
VineLinux95
VineLinux98
VineLinux98SE
VineLinuxME
VineLinux2000
VineLinuxXP

396 :login:Penguin:05/01/15 11:22:48 ID:irNLDF20
>>391
ServerType を inetd にしてるってことでしょ。

397 :login:Penguin:05/01/15 12:11:10 ID:8AZ6MUpW
Wnn8 for Linux/BSD キタ━━━━(゚∀゚)━━━━!!!!

ttp://www.omronsoft.co.jp/SP/pcunix/wnn8/taiou.html

398 :login:Penguin:05/01/15 13:01:20 ID:vOXkPnrl
>>387
おめー

>>388
スマン、本当だよな。
俺の早とちりでした。

399 :login:Penguin:05/01/15 13:03:31 ID:Y99vpg4M
>>397
買ったらレビューよろ

400 :login:Penguin:05/01/15 13:45:42 ID:urptUr9p
>>397
Wnn6からでもバージョンアップできるのね。
5040円・・微妙な値段だなあ。

401 :login:Penguin:05/01/15 13:49:41 ID:8AZ6MUpW
Vine 4.1 に付属するんならそれを待った方が利口っすねぇ。
順番からするとAtokあたりになっちまうのかなあ。

402 :login:Penguin:05/01/15 14:05:09 ID:N05AekIB
VJEのままだったりして。

403 :login:Penguin:05/01/15 15:44:44 ID:vOXkPnrl
vineスレとは全然関係ないんだけどさ
何でLinux板なのにjmanプロジェクトスレが無いんだろう。

404 :login:Penguin:05/01/15 15:51:13 ID:IVmAmBtc
64bit開発しろや(゚Д゚)ゴルァ!

405 :login:Penguin:05/01/15 16:53:24 ID:+Q4r/glb
>>404
ヨロ

406 :login:Penguin:05/01/15 17:13:14 ID:Q3iMG+Rq
チーム戦シューティングの先駆け、TFCがついに「無料」化!?

クラス制スポーツ系チームプレイ旗取りゲームEnemy Territory Fortress (ETF)
2005年1月16日リリース予定
詳しくは本スレで

[無料]Enemy Territory Fortress 1[感無量]
http://game10.2ch.net/test/read.cgi/game/1105186532/

<基本ルール>
敵陣深く潜り込み敵チームの旗を奪って
自軍の陣地にあるキャプチャーポイントに持って帰れ!
数々のクラス(職業)を駆使し自軍を勝利に導くのだ!
<職業>
Recon <偵察兵> Sniper <狙撃兵> Soldier <兵士> Grenadier <手榴弾兵>
Paramedic <衛生兵> Minigunner <ミニガン射撃手> Flametrooper <火炎放射隊員>
Agent <諜報員> Engineer <工兵>  Civilian <一般人>

407 :login:Penguin:05/01/15 18:09:28 ID:eTAX2Iyy
Vine3.1 を i815 のノートPCにインストールしました。
起動時のVineロゴが出てこないようなのですがどうしたら出せますか?

あと、lilo.conf 内の
install=menu
というのが存在しないファイルを見ているような気がするのですが、これで正常なのでしょうか?


408 :login:Penguin:05/01/15 18:15:57 ID:S6dlHJGq
今はFEDORA COREを使ってる者なのですが
GNOME EDITERなんかはVINEのほうが日本語用途の設定とかしやすいでしょうか?
使い勝手の環境も含めて。

409 :login:Penguin:05/01/15 18:21:10 ID:VOIR+nfc
>>407
フレームバッファつかってるのなら Patch20010 を外してリビルド。

410 :login:Penguin:05/01/15 18:23:52 ID:yJbAfJ3C
>>407
FB絡み?
i81xはVESAFB未対応だから、とかそういうことかな?

>install=menu
jmanでなくて英語のman lilo.confを見ましょう。

# 何方か>>394にお助けを。随分流されてしもた・・・。

411 :login:Penguin:05/01/15 18:43:45 ID:kSczIQAX
>>410
いってる意味がよくわからない。
PuTTY+ssh ではだめなのかな?


412 :login:Penguin:05/01/15 18:54:18 ID:3p34JbbN
>>407
install=menu とかは lilo が典型例を知ってるから、
/boot 以下にファイルの実体が存在しなくてもいい。
>>367 の boot-text.b なんかも同じ。

413 :login:Penguin:05/01/15 18:57:28 ID:yJbAfJ3C
>>411
わかりにくくてすみません。

vncserverをinetd経由で動かしたい。
inittabをID:5にしてグラフィカルログインにすれば
XDMCP認証で設定できたが、inittabはテキストログイン設定のままで
vncserverをinetd経由起動できないか。

ということです。
今はsshでvncserverをいちいち手動で動かしていますが、
それが面倒なのとhosts.allow/denyでアクセス制限をしたいので。

414 :login:Penguin:05/01/15 19:55:39 ID:xDsvqzW2
>>413
crotabで自分は運用してますけど

415 :394:05/01/15 22:15:50 ID:yJbAfJ3C
>>414
ごめんなさい。crontabでしょうか?
ちょっと私の頭ではvncと繋がらないので、できれば少し説明していただけませんでしょうか。

416 :login:Penguin:05/01/15 22:36:14 ID:eTAX2Iyy
>>409-412
なんかとても感謝!!! すげー悩んでたんで
Patch20010 をはずしてリビルド?
src.rpm を rpm -ivh でインストールして
~/rpm/SOURCE/ あたりのファイルを消して(どっかに移動とかして)
~/rpm/SPECS/hoge.spec にたいして
rpmbuild -ba hoge.spec --target i686 なんかでよろしいでしょうか?

とにかくやってみます。


417 :login:Penguin:05/01/15 22:55:04 ID:eTAX2Iyy
どうやら Patch20010 というのは存在してないんですが・・・


418 :おせ〜てください。:05/01/15 23:15:30 ID:Xz73bZEJ
Pentium200 128MBのマシンを入手したので、Vine3.1を
インストールしましたが、動作が重くてストレスがたまります。
軽さを追求して、古いVineに入れかようとおもっとります。

同じようなマシンで、軽快に使えてるかた、Vineのバージョンを教えてくださいませ。

419 :login:Penguin:05/01/15 23:18:26 ID:eTAX2Iyy
>>418
GNOME をはずして軽いWMを使うとか

420 :418:05/01/15 23:21:23 ID:Xz73bZEJ
>419
そ〜か、そういう手がありましたね、すぐ、そこ、サンクス。

421 :login:Penguin:05/01/15 23:28:50 ID:T45DjiI/
ユーザー名にアンダーバーを入れたユーザーを作ったのですが、
ログイン画面でアンダーバーを入力する事ができません。
(ログイン画面以外では普通に入力できます)
入力する方法があれば教えていただけないでしょうか。

422 :login:Penguin:05/01/15 23:29:10 ID:eTAX2Iyy
>>420
ごめんはずさなくても良いのか
使わずに違うWMを使うということです。

>>409
#
# Patches 20000 and later are reserved for Vine patches
#
Patch20010: 2.4.6-fblogo-vine.diff

という行を ~/rpm/SPECS/hoge.spec にてみつけました。
これを外すとVIneのロゴマークが見れますか?
なんか逆に見えなくなりそうなんですが・・・

423 :login:Penguin:05/01/16 00:50:12 ID:s1+bYl/W
lilo.confにvga=789とか書けばいいんじゃないの?
そういうことではないの?

424 :394:05/01/16 01:08:13 ID:Y3btraAn
>>422
ttp://search.luky.org/vine-users.5/msg06565.html
[vine-users:056570] i810 マザーボードに付いて

このスレッドはお役に立ちませんか?
I81x系はVESAFBが使えない。vga16fbなどのmodule組み込みだと起動時のロゴには間に合わない。
だからKernel再構築してFBのmoduleを組み込んじゃおう。
って流れみたいです。

425 :login:Penguin:05/01/16 01:40:03 ID:Icc+AteC
>>424 サンクス
参考にしてみます。
実際 i81x系で起動時のロゴが見えてる人はいるのでしょうか。
/etc/modules.conf に以下の1行を追加。

options i810fb vram=12 xres=1024 yres=768 vyres=76 8 bpp=16 hsync1=48 hsync2=48 vsync1=60 vsync2=60 accel=1 mtrr=1

/etc/rc.d/rc.modules というファイルを新たに作り

#!/sbin/sh
modprobe i810fb

と書いて実行できるファイルに変更して、さらに /etc/rc.modules というリンクを作る。

# chmod +x rc.modules
# cd /etc/
# ln -s /etc/rc.d/rc.modules ./

これで起動の途中ぐらいからFBに切り替わるようになったのですが、ロゴの部分がどうしても見たいんです。

426 :394:05/01/16 02:19:27 ID:Y3btraAn
>>425
ですから、それだと起動直後は無理だからKernelに組み込んでおくんだと・・・。
実際私がやってみた訳ではないのですが。

427 :login:Penguin:05/01/16 09:34:56 ID:uASI8wWs
>>421
Vine じゃないけど,これでうまくいくんじゃないかな.
ttp://www.momonga-linux.org/archive/Momonga-devel.ja/msg02910.html

428 :login:Penguin:05/01/16 11:26:00 ID:JOaFn6B8
Vine 3.1 でインストールしました.
インストール時に「日本語キーボード」を
選択したはずなのに,*#%&() などの配置が
英語キーボードのものになってしまいました.

これを「日本語キーボード」にするには
どのように設定すればいいのでしょうか?

できれば GNOME からグラフィカルに設定したいです.


429 :login:Penguin:05/01/16 11:34:49 ID:cg4R30r1
>>428
xorg.conf

430 :login:Penguin:05/01/16 11:42:52 ID:3XI9lSyF
>>428
ぐのむのせっていにきーぼーどのせっていがあったようなきがします。

431 :428:05/01/16 12:20:27 ID:JOaFn6B8
>>430
たしかに GNOME のメニューには
「キーボード」がありますが,これには
日本語キーボードうんぬんの設定はありません

432 :login:Penguin:05/01/16 14:19:39 ID:30LSRuXt
vine3.1にsquidをいんすこして起動(#/etc/rc.d/init.d/squid start)させようとしたら、

init_cache_dir /var/spool/squid... /etc/rc.d/init.d/squid: line 147: 1749 Aborted $SQUID -z -F 2>/dev/null
Starting squid [ OK ]
/etc/rc.d/init.d/squid: line 148: 1750 Aborted $SQUID $SQUID_OPTS 2>/dev/null

とでてうまく起動してくれないのですが、起動できる人いますか?

433 :428:05/01/16 14:42:54 ID:IRf7wXnB
解決しました。
もういいです。

434 :login:Penguin:05/01/16 14:46:18 ID:+rxo7UC/
>>433
どうやって解決したの?

435 :login:Penguin:05/01/16 16:34:26 ID:pf6SuSQq
>>394
http://www.lares.dti.ne.jp/~yumi-n/lan/vnc.html

436 :login:Penguin:05/01/16 16:43:28 ID:kOvL6cXr
[VinePlus:02199]
リビルドしたものを、同じリリース番号のまま put しちゃまずいだろ。

437 :login:Penguin:05/01/16 17:08:22 ID:viBo1ppw
>>436
02199の本人です。
どーもすみません。

もうちょっとマイナーなパッケージで修行してきます...

438 :login:Penguin:05/01/16 17:17:20 ID:kDQDoN20
Xに加工したものをネットワークで配信するわけだし、
Xに加工してないものをVNCで配信できないんじゃないの?

439 :394:05/01/16 17:18:24 ID:Y3btraAn
>>435
レスありがとうございます。

そのページにも
>なお、この方法で接続を行う場合は、Linuxのログインモードをグラフィカルログインに変更しておく必要があります。
とあります。
この方法が一般的な方法のようですが、私の質問は>>413でも再度説明させていただいた通り
「Linuxのログインモードをテキストログインのままで同じことができないか」
ということなんです。

440 :394:05/01/16 17:41:03 ID:Y3btraAn
>>438
すみません。
「Xに加工」が良くわかりませんが、
セッションをgdmで開始するのではなく、他の方法で
(認証はVNC認証で構わない)行いたいだけです。

441 :login:Penguin:05/01/16 18:47:09 ID:N6c2X4nM
>>440
素直にvinoでも入れてみたらどうかね。

442 :login:Penguin:05/01/16 19:25:40 ID:A5tsvUrS
vine3.1 って ircd なくなっちまったのかな?

443 :login:Penguin:05/01/16 19:52:30 ID:U4fdMdD8
>>442
もともとない。2.5/2.6/3.0にだってない。
それより前って入ってた?

444 :login:Penguin:05/01/17 00:17:34 ID:mkpyjQ4m
>>442
うちは昔、ttp://yasundial.org/yasu/rpm/にあるircdのパッケージを
使わせてもらってたなぁ。2.6r1ぐらいまでは使ってた。
知り合いがMSNメッセンジャーに移っちゃったから再構築しなくなったけど。
Rebuildしてみてダメなら3.1向けに修正かけてみたら?

ローカルに置いてある自分用にいじったファイルの
タイムスタンプを見たら2002年1月だった…そんなに前か…

445 :ぁゃ (*゚ー゚)つ しぃプログラマー:05/01/17 00:23:23 ID:??? ?
>>443

ftp.kddlabs.co.jpのミラーを見る感じでは、無いような……
昔入れた記憶があったけど、どっかからsrc.rpm持ってきてリビルドしたんだっけか。

……と思って調べたら、↓から頂いてきてリビルドしたっぽいでつ。
ttp://yasundial.org/yasu/rpm/

んでこれはspecをちょっと手直ししないとダメみたいでつ。
手元のSeed環境でビルドできたとこまではやってみたけど。。。

446 :ぁゃ (*゚ー゚)つ しぃプログラマー:05/01/17 00:25:01 ID:??? ?
見事にかぶった……orz

えと、以下のように修正したらビルドまではいきまつ。

--- irc2.10.3+jp6.spec2000-07-12 22:17:06.000000000 +0900
+++ irc2.10.3+jp6-tk.spec2005-01-17 00:17:26.000000000 +0900
@@ -85,7 +85,7 @@
EOF

%define LDSOVER 2
-%define LIBCVER 2.1.3
+%define LIBCVER 2.3.3
%define LIBCRYPTVER 1
%define LIBNSLVER 1
%define LIBNSSVER 2
@@ -150,10 +150,10 @@

%attr(0755,root,root) %dir %{CHROOTDIR}

-/usr/man/man5/iauth.conf.5
-/usr/man/man8/iauth.8
-/usr/man/man8/ircd.8
-/usr/man/man8/ircdwatch.8
+/usr/man/man5/iauth.conf.5.gz
+/usr/man/man8/iauth.8.gz
+/usr/man/man8/ircd.8.gz
+/usr/man/man8/ircdwatch.8.gz
/usr/sbin/chkconf
/usr/sbin/iauth
/usr/sbin/ircd


447 :login:Penguin:05/01/17 01:00:54 ID:3k/zghYX
php-4.3.10-0vl2.0.2

ttp://morejams.no-ip.com/up/src/up0001.spec php.spec
ttp://morejams.no-ip.com/up/src/up0002.patch php-4.3.10-31106.patch

%changelog
* Mon Jan 17 2005 jax <jax@morejams.no-ip.com> 4.3.10-0vl2.0.2
- bug fix: #31106 4.3.10 - crashes with overloaded objects
http://bugs.php.net/bug.php?id=31106


448 :login:Penguin:05/01/17 01:02:15 ID:3k/zghYX
このスレで spec とか patch とかやりとりすることがあれば、
Uploader 使ってください。
(zip,lzh,spec,patch,diff,tgz,tbz,gz,bz2 以外のファイルは bin になります)

ttp://morejams.no-ip.com/up/


449 :login:Penguin:05/01/17 01:04:25 ID:lOxqt9WI
>>448
おぉ〜あり!乙!

450 :login:Penguin:05/01/17 03:21:20 ID:BoVf62CS
> [root@localhost root]# apt-get install arts-devel
> パッケージリストを読みこんでいます... 完了
> 依存情報ツリーを作成しています... 完了
> いくつかのパッケージをインストールすることができません。おそらく、
> ありえない状況を要求したか、(必要なパッケージがまだそろっていなかっ
> たり、まだIncomingから移動されていない)不安定なディストリビューション
> を使用していないでしょうか。
>
> 単純な操作だけを行った時に、パッケージがインストール
> できない場合は、バグリポートしてください。
> 以下の情報がこの問題を解決するために役立つかもしれません:
>
> 以下のパッケージは解決できない依存関係を持っています:
> arts-devel: 依存: arts (= 1.3.1-0vl1) しかし、1:1.3.2-0vl1 がインストールされ ています
> E: 壊れたパッケージです


Vine3.1でaptからarts-develをインストールしようとしたら、arts が 1.3.2-0vl1、
arts-devel が1.3.1-0vl1 のために(?)インストールができない形になってしまいました。
ミラーのラインナップを見てもバージョンが違っているみたいなのですが、何か解決策は
ありますでしょうか?

451 :login:Penguin:05/01/17 03:23:59 ID:3k/zghYX
>>450
Subject: Re: arts-develのインストール
Date: Sat, 15 Jan 2005 20:23:04 +0900

> arts-devel-1.3.2-0vl1.i386.rpm を incoming に put しました。
> そのうちミラーにも届くと思います。

ということらしいです。

452 :login:Penguin:05/01/17 06:55:50 ID:mvVVJi2e
>>436 , >>437
SeedPlusと同じリリース番号にすると何が問題になるんだっけ?


453 :login:Penguin:05/01/17 09:27:00 ID:1mq1YCU/
>>452
まったく同じパッケージであれば Plus/SeedPlus 同じで構わない。
リビルドしたものはダメ。

454 :login:Penguin:05/01/17 09:32:05 ID:1mq1YCU/
>>452
あ、何が問題に〜か。
同じバージョン、リリース番号で異なるパッケージが存在すると、どのパッケージか
特定できなるからじゃない?

455 :login:Penguin:05/01/17 11:44:21 ID:DCSc1LkW
>>441
vinoで394の望むことができるとは思えんが・・・。

456 :login:Penguin:05/01/17 11:50:28 ID:ckwxKHIF
telnet使うぐらいしか無いんじゃないかな。
あとは>438に続く。

457 :login:Penguin:05/01/17 12:07:03 ID:DCSc1LkW
>>456
いや>>438な説明も変だがな。
>>394のやりたいことはわかる。
俺もサーバーはコンソール待機させときたいので
ランレベル3のままでinetd起動できないか考えたことがあったが
無理っぽかった。
俺の場合vncの使用頻度は低いので
今はsshでその都度vncserver叩いてるが。

458 :Linux博士:05/01/17 23:23:24 ID:gIeaVtBN
>>421
Vineではユーザー名にアンダーバーは使えません。


459 :login:Penguin:05/01/18 00:08:15 ID:r7P8PYUQ
Vine2.6r4でOpenTypeフォント(Macのヒノラギフォント)を使うにはどうしたらいいのですか?

460 :login:Penguin:05/01/18 00:57:30 ID:dEdlQHY/
Think Pad T41 を使ってます
CPU は Intel Centrino です
スリープさせたいのですが、どうしたらいいのでしょうか?

461 :login:Penguin:05/01/18 01:18:19 ID:QO1NNH9g
3.1のbind9って/etc/rc.d/init.d/namedのstop関数が

 /usr/sbin/rndc stop
 killproc named

となっていて、二回殺そうとしてservice named stopとかが
失敗してしまうですよ。でもって、Vine的にはrndcの行を
コメントアウトすべきっすかね?(つまり2.6のbind8と同じ)

462 :login:Penguin:05/01/18 01:18:43 ID:HJGxTkLj
>>460
俺の手順
どこかからhibernate-1.02-1.src.rpmをダウンロードして
rebuildしてインストール
/etc/acpi/eventsにACPIのbutton.powerイベントに反応する為のファイルを作成し、
そちらか起動するファイルを/etc/acpi/actions/hibernateにしておく。
/etc/actions/hibernateにhibernateの為の設定を書く。(いきなり/usr/sbin/hibernate起動でも可)
/usr/share/hibernate/scriptlet.d/にresume時の動作を追加するscriptletを追加し、
そこに自分に合った内容を書く。

463 :login:Penguin:05/01/18 01:24:14 ID:ByAtjggI
>>462
apmdじゃダメな理由は?

464 :login:Penguin:05/01/18 01:26:53 ID:HJGxTkLj
>>463
acpiの方だと、電源ボタンだけじゃなく、様々なイベントに対応して
いてWindozと遜色なく使える。
てか、チンコ41だと普通ACPI使うだろ、

465 :login:Penguin:05/01/18 07:16:33 ID:mBpkatgA
>395
VineLinux3.11は無いのですか?

あ、Windows3.11のペットネーム忘れちゃったよ。


466 :login:Penguin:05/01/18 10:06:44 ID:bZEPULoD
再度の質問です.

Vine 3.1 でインストールしました.
インストール時に「日本語キーボード」を
選択したはずなのに,*#%&()… などの特殊記号の配置が
おかしくなっていました.
# 数字やアルファベットは正常

/usr/sbin/kbdconfig

というプログラムでキーボードの種類を選択できるのですが,
これを見ても,jp106 になっていました.
再度 jp106 を選択しなおしても同じだし,
他の us なんたらとか,いろいろのキーマップにしても
特殊記号のマップは変わりません.

とても不便です
解決方法を示唆ください


467 :login:Penguin:05/01/18 10:26:30 ID:iG/RdUpX
loadkeys jp106
で変えられる

/etc/sysconfig/keyboardに
KEYTABLE=jp106
とかいておけば起動時にjp106になる

468 :login:Penguin:05/01/18 10:35:36 ID:S7SQyDox
>>466

>>433
解決したんだろ?

469 :login:Penguin:05/01/18 11:15:19 ID:HJGxTkLj
>>466
どうしても直らなければ、
xevというコマンドを実行して、
特殊キーがどんなキーコードを発っているかを調べてくれ、

例えば、
[ろ]キー = 200
[む]キー = 159
みたいに調べて報告してくれ、

↑上の例の数値は出鱈目です。

そもそも、日本語キーボードなのか?

470 :466:05/01/18 11:19:25 ID:bZEPULoD
今,問題の PC にさわれないもんで
夜になったらためしてみます.


> そもそも、日本語キーボードなのか?

まちがいなく日本語キーボードです.


471 :login:Penguin:05/01/18 11:26:16 ID:7ujxPIM8
kbdconfigじゃなくて、Xの設定の話だと思われる

472 :login:Penguin:05/01/18 11:39:30 ID:8o68dmk1
/etc/X11/xorg.confのキーボード設定が
jp106、jpになっていないに1票

473 :login:Penguin:05/01/18 11:43:04 ID:HJGxTkLj
>>470
>>469>>471は最終的には同じことを意図してると思うよ。
実は>>429に既にサジェストがあったんだけど、対応したかな。

>>469は設定の修正の前にどんなキーボードかを確定するために書いた。

474 :login:Penguin:05/01/18 20:28:17 ID:s1DHhlEs
akia の DJ100 というノートに Vine3.1 インスコしました。
電源落とす時、最後の最後でフリーズします。(藁

LinuxWorld2月号の付録に付いてたのを入れたのです。
ところで、gtk+-devel glib-devel とかが VinePlus に見あたらないですが、
どこで、貰えるんでしょうか。

(aptを使うのもはじめてなので、これから勉強です。)

よろしくお願いします。

475 :login:Penguin:05/01/18 20:34:28 ID:HJGxTkLj
>>474
そのノート、古いんだろ、
カーネル再構築して、CONFIG_APM_REAL_MODE_POWER_OFFをyにしとけば
電源正しく切れるに一票

476 :474:05/01/18 21:32:51 ID:/dmGcdTo
>>475
はい、古いです。(3年位前のモデル?) と言っても
mobileCeleron700Mhz,メモリー256MB
なのでなんとかいけます。

>カーネル再構築して、
アドバイスありがとうございます。
でも、そこまでのスキルないです ・・・・・
マニュアル本見ながら恐る恐る make したりしてる程度のエンドユーザーなので。





477 :login:Penguin:05/01/18 23:32:42 ID:QZEv7Szq
教えて下さい。
Vine 3.1をCD imageからインストールしたんですが、
apt-getを行うと、セグメンテーションエラーが発生して、
apt-getが出来ません。

なにやら、データーベースが壊れているらしいのですが、
そんなことってあるんでしょうか?

ちなみに、これまでに行ったことは、
1.Vine 3.1をCDからインスト->インストできるが、apt失敗
2.Vine 3.0を雑誌付録のCDからインスト->同上
3.Vine 2.5をインスト->apt-get成功
Vine 3.1をCDからアップデート->apt-getには失敗する
4.Vine 3.1をインスト後、rpm --rebuilddb ->セグメンテーションエラー
rpm --initdbを行うが、やはりセグメンテーションエラー。
エラー内容は、データベースのベリファイに失敗しているとのこと。

以上です。何か解決策はありますでしょうか?

それにしても、CDインストを5回以上行ったのに、全て同様の
エラーがでるのが、理解不能です。
ちなみにCDのエラーかと思って、2を試してみましたが、結果は
同じだったので、CDのエラーではないと思います。



別のディストロに変えたほうが幸せでしょうか?

478 :474:05/01/18 23:34:20 ID:2YdgjN5U
自己レスです。
見つけました。
お騒がせしました。

479 :login:Penguin:05/01/18 23:34:56 ID:pBV40bjE
>>477
OSの問題じゃなくてハードウェアか作業手順の問題だと思う.
ハードウェア情報とかインスコ時の手順とかさらしてみ.

480 :477:05/01/18 23:43:56 ID:QZEv7Szq
>479
職場にあるマシンなんで、今は良く分からないんですが・・・

ハードウェアは、
Athlon 1G + 512M DIMM + ESC K5SA? (AmiBIOSの「サムライの息吹」だったと思います)
HDDは80G(うち、Vine用に50G、残りはWin用にとってあります) + CD-R Drive です

インストの手順は・・・グラフィカルな画面のインストで通常どおりに行ってます。

481 :login:Penguin:05/01/19 16:35:50 ID:3JDFPELw
3.1FTP使ってます。3.1CRを買ったんすけど、
vjeのrpmとfontのrpm2つをFTP版入れてる機械でrpm -Uvh すればいいんでしょーか。
インストーラからアップグレードインストール?
アプリのフォント設定とかが心配です。
こーゆー場合普通どうするの?

482 :login:Penguin:05/01/19 16:45:23 ID:JcAJ0TEG
VineLinux3.1(i386)を使用していて、PHP4をアンインストール(rpmで)してPHP5をインストールしようとしたら

#apt-get install php5-apache
パッケージリストを読みこんでいます... 完了
依存情報ツリーを作成しています... 完了
いくつかのパッケージをインストールすることができません。おそらく、
ありえない状況を要求したか、(必要なパッケージがまだそろっていなかっ
たり、まだIncomingから移動されていない)不安定なディストリビューション
を使用していないでしょうか。

単純な操作だけを行った時に、パッケージがインストール
できない場合は、バグリポートしてください。
以下の情報がこの問題を解決するために役立つかもしれません:

以下のパッケージは解決できない依存関係を持っています:
php5: 依存: libdb-4.2.so それをインストールすることができません
E: 壊れたパッケージです

というメッセージが出ました。

apt-get install libdb もパッケージがないと言われます。
それでlibdbを探して最新にしようと思ったのですが、VineのFTPのPRMSを探したのですがパッケージが見つかりません。

/lib/libdb-4.0.so
現在4.0がインストールされています。

なるべくならパッケージでインストールしたのですが、どのようにしたらよいでしょうか?

483 :login:Penguin:05/01/19 16:53:29 ID:USDPofNH
>>482
>>100-102
結論:メンテナがアフォ

484 :login:Penguin:05/01/19 16:55:59 ID:ezSuHJO+
>>482
apt-get install db4
少なくとも libdb-4.2.so は入るはず

485 :login:Penguin:05/01/19 17:09:01 ID:JcAJ0TEG
>>484
ありがとうございます、パッケージ名がdb4だったんですね。
お騒がせしました。

486 :login:Penguin:05/01/19 17:12:45 ID:2/y3Hp1E
そもそも apt、pam あたりが要求しているから、Vine 3.1 なら必ず db4-4.2 が
入っているはず。

487 :login:Penguin:05/01/19 18:20:49 ID:dKulX9aL
初導入でメインマシンに入れてみたが
デュアルブートの仕方がわからなかったから
サブマシンに入れ直したら激重ですorz
環境はK6 500Mhz 64MB

GNOMEがネックですか?


488 :login:Penguin:05/01/19 18:25:47 ID:aUu0AkjB
64MBでGNOMEなんて、マゾですかあんたは。

最低256あたりからだと思っていいですよ。


489 :login:Penguin:05/01/19 18:30:52 ID:dKulX9aL
>>488
やはりorz

490 :login:Penguin:05/01/19 18:44:35 ID:HOsIlptP
Vine3.1 でインストールしました.
GNOME をいれてしまって,
自動的に GNOME が起動するようになってるんですが,
CPU 366MHz, メモリ 192MB では
話にならないほど GNOME がにぶいため,
GNOME をやめて,fvwm などのウィンドウマネージャに
しようかと思うのですが,
どこをどういじっていいのかわかりませぬ


491 :login:Penguin:05/01/19 18:52:53 ID:jM+g0OFN
setwm

492 :login:Penguin:05/01/19 19:12:10 ID:UNlrkur0
>>487
PenII233、64MBノートで普通にVine3.1でGNOME使ってるけど
でもたまに機嫌悪い時に起動するとイライラするくらいだな

493 :login:Penguin:05/01/19 19:24:02 ID:tsSAuMTU
>>487
XFceの方が幸せになれる!(・∀・)イイ!!

494 :login:Penguin:05/01/19 19:52:47 ID:5Pn6EbN7
postfix-2.0.20-0vl5.src.rpm / SASLが有効になってなかったんでパッチ

--- postfix.spec.old 2004-10-28 18:10:50.000000000 +0900
+++ postfix.spec 2005-01-19 18:44:50.000000000 +0900
@@ -10,7 +10,7 @@
Summary(ja): Postfix メールトランスポートエージェント
Name: postfix
Version: %{origversion}
-Release: 0vl5
+Release: 0vl5.1
URL: http://www.postfix.org/
Copyright: Distributable - IBM PUBLIC LICENSE VERSION 1.0 - SECURE MAILER
Group: System Environment/Daemons
@@ -111,11 +111,12 @@
make tidy
make makefiles \
CCARGS="-DMAX_DYNAMIC_MAPS \
+ -DUSE_SASL_AUTH \
-DHAS_LDAP \
-DHAS_PCRE -I/usr/include/pcre \
-DHAS_MYSQL -I/usr/include/mysql \
-DHAS_PGSQL -I/usr/include/pgsql" \
- AUXLIBS=""
+ AUXLIBS="-L/usr/local/lib -lsasl"
make DEBUG="" OPT="$RPM_OPT_FLAGS"

for libs in master global util dns


495 :login:Penguin:05/01/19 20:18:32 ID:oNL7LKcz
"apt-get install task-kde" で入れた kdeを削除したいんですが、
ひとつひとつのパッケージを "apt-get remove hoge"するしかないんでしょうか?

496 :login:Penguin:05/01/19 21:03:40 ID:HHvDaAO/
>>494
パッチは、うpろーだ( >>448 )とかにあげといてもらえると、
コピペする手間が省けてうれしいのですが。

497 :login:Penguin:05/01/19 21:07:43 ID:ZXmkhYYW
>>490
まじレスすると、最初にグラフィカルログインする画面の右側にアイコンが
並んでいると思うが、ここでGNOMEの代わりにfvwmとかすきなものを選
べる(fvwmがインストールされていたら)。>>493の言うとおり、XFceが
おすすめ。


498 :495:05/01/19 21:46:59 ID:oNL7LKcz
つまらんこと聞いてすみませんでした。解決しました。

499 :login:Penguin:05/01/19 22:10:03 ID:HHvDaAO/
>>498
どうやって解決したのか、きぼんぬ。

500 :login:Penguin:05/01/19 22:27:00 ID:BBZBqTRi
>>497
前から疑問だったのだけど,BlackBoxをインストールしても
そこの選択肢に出てこないんだよな。
1.4の頃のgdmはちゃんと出てきたんだけど。

501 :login:Penguin:05/01/19 22:28:06 ID:NRPnOjwh
#apt-get remove task-kde
でおkだったんじゃね?

502 :login:Penguin:05/01/19 22:34:57 ID:qbX3vIya
オンボードのSATAデバイスの認識でいつも起動時に1分くらい無駄に時間がかかるのですが
コレを解消するためにSATAデバイスを探しに行かないようにする方法はあるのでしょうか?
BIOSで切るのが一番手っ取り早いと思うのですが、設定項目が見当たらなくて。

503 :495:05/01/19 22:41:54 ID:oNL7LKcz
>>499
解決っていうか、手作業でシコシコやりました。
最初に apt-get remove kde* とやって、後は前スレの誰かが貼ってくれた
リストを参考にしたり、apt-cache show や rpm -qi などで確認しながら、
apt-getでremoveとinstallをしました。

>>501
それやったら、task-kdeというパッケージひとつだけ削除されました。
で、困ってしまってここで聞いたわけです。

504 :login:Penguin:05/01/19 22:55:08 ID:NRPnOjwh
そういやそれぞれのコマンドにはそれぞれ情報を表示するオプションがあるし、
それだけは覚えられるようになるといいよな。

makeのオプション -d とか
aptなら apt-cache show とか
lspci とか uname とか

関係ないけど uname -a ってやってもディストリビュージョンが表示されないのって寂しいね。

505 :login:Penguin:05/01/19 23:43:38 ID:HHvDaAO/
>>503
トンクス。簡単な方法があるかと思ったけど、やっぱり手作業でつか。
こういう時 apt て役にたたねぇなぁ

506 :login:Penguin:05/01/20 00:17:38 ID:vFSj/wer
>>505
aptitude (apt のフロントエンド) を使えばできると思う。
# ただし aptitude を使ってインストールしたもののみ。

でも plus の aptitude はメンテされてない。

507 :login:Penguin:05/01/20 00:19:14 ID:cyWUw3tP
>>502
カーネル再構築

508 :login:Penguin:05/01/20 01:41:05 ID:xvo/CxGc
>>490
もう解決したかな?
# apt-get install fluxbox
# apt-get install xfce-4
で、自動的にgdmに登録されます。 ログイン画面でセッションで選んでGO!


509 :login:Penguin:05/01/20 01:54:15 ID:xvo/CxGc
きついスペックPCに
Rox (ファイルマネージャ) マンセー
http://add10.hp.infoseek.co.jp/rox/
i386 rpm
http://add10.hp.infoseek.co.jp/rox/rox-2.1.4-0.8.i386.rpm
ftp://ftp.ring.gr.jp/pub/linux/Vine/VineSeed/i386/Vine/RPMS/shared-mime-info-0.15-10vl1.i386.rpm
勝手にリンクごめん!

510 :login:Penguin:05/01/20 02:00:39 ID:JpTuj47k
藪から棒に…

511 :login:Penguin:05/01/20 02:11:42 ID:vFSj/wer
>>509
わざわざそんなの書かなくても、
# apt-get update && apt-get install rox
で良いのでは?

512 :login:Penguin:05/01/20 02:11:48 ID:KRq5uuSj
VineLinux2.6r4で鯖立ててたんですが、
aptで3.0→3.1とアップグレードしたところ
Postfixとphpがうまく動かなくなりました。

で、元に戻すってことは可能なんでしょうか?

513 :login:Penguin:05/01/20 02:11:59 ID:XUl3ELE2
山葡萄原人Linux

514 :login:Penguin:05/01/20 02:15:09 ID:VRUZzw51
>>512
可能

515 :login:Penguin:05/01/20 02:16:50 ID:KRq5uuSj
>>514
おーできますか。その方法は教えてもらえちゃったりします?
もしくは該当スレへ誘導してもらえませんか。

516 :login:Penguin:05/01/20 10:01:44 ID:0AYA6hHj
Vine3.1でカーネルを再構築したらフレームバッファに日本語が表示されなくなりました。
起動ログをみると

/lib/modules/2.4.27-0vl7.2xxxx/kernel/drivers/video/encode-eucjp.o: /lib/modules/2.4.27-0vl7.2xxxx/kernel/drivers/video/encode-eucjp.o: unresolved symbol doublebyte_default
/lib/modules/2.4.27-0vl7.2xxxx/kernel/drivers/video/encode-eucjp.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. Contact the module supplier for
assistance, only they can help you.

と出ています。
どうやら、encode-eucjpのモジュールを追加する際にGPLのライセンスの有無をチェックしているようですが、カーネルの再構築をしなければフレームバッファで問題なく日本語が使えます。
Vine3.1でカーネルを再構築してもフレームバッファ上で日本語を扱うにはどうしたらよいでしょうか?


517 :login:Penguin:05/01/20 10:06:03 ID:mPBHFg18
でさ、unresolved symbol doublebyte_default ってのは何?



518 :login:Penguin:05/01/20 10:11:53 ID:0AYA6hHj
>517
fb_doublebyte.hのことかと?
何でこれが出るのかはわかりませんが・・・


519 :login:Penguin:05/01/20 10:30:59 ID:mPBHFg18
>>518
ヘッダファイルがどうかしたのか?
ぼくもわかんないや・・・。[w

520 :login:Penguin:05/01/20 10:40:40 ID:k8E1Iuew
>>516
小学生?


521 :login:Penguin:05/01/20 10:50:20 ID:mPBHFg18
本当に困ってるなら、ML に投げればいいのにな。

522 :login:Penguin:05/01/20 10:51:43 ID:0AYA6hHj
なんかよくわかんないですけど、
unresolved symbol doublebyte_default
だから、doublebyte_defaultのモジュールも組み込めってことをおっしゃってます?
モジュールなのかどうかわかんないですけど。
insmod encode-eucjp
で、同じエラーが出るので
insmod doublebyte_default
したら
Can't locate・・・
ってなエラーが出たので/lib/modulesの下を見たらdoublebyte_defaultというモジュールがなかったので
どうしたもんかなと思ったんですけど。
コンパイルオプションにはDOUBLEBYTE_GBみたいな設定はあったけど、defaultは見当たらなかったので、
モジュールかどうか判断もできないんですけどね。

523 :login:Penguin:05/01/20 10:57:05 ID:mPBHFg18
なんかよくわかんないですけど、"unresolved symbol" が何を意味していて、
どういった場合に発生するのかを調べてみればいいんじゃないの?


524 :login:Penguin:05/01/20 11:09:52 ID:0AYA6hHj
>>523
バージョンの不一致などでモジュールが追加できないとかそういうことみたいです。
つまりカーネルアップデートしたりすると、組み込めないモジュールがあって使えないということなんでしょうかね?
モジュールのコンパイルのところでfailしてる部分もあったりするのでコンパイル自体が失敗しているだけなのかな・・・
フレームバッファのコンパイルオプションなんてたいした数ないから、コンパイルオプションを設定しまちがえるとも思えないんだけど
もう一回見直してみるかな・・・


525 :login:Penguin:05/01/20 11:45:58 ID:HEzh363+
まずこのスレをphpで検索すればいいのに

526 :login:Penguin:05/01/20 11:52:04 ID:T7Mro09V
>>524
− 基準になる.configを/usr/src/linux/config/から持ってきて必要な項目のみ再設定 −
これはやってます?

527 :login:Penguin:05/01/20 13:09:20 ID:0AYA6hHj
>>526
とりあえず、フレームバッファがONになってそうなので
kernel-2.4.27-i686.config
をそのまま使ってみました。
そしたら、コンパイルはうまく行ってるみたいなんですが、やっぱり起動時に
unresolved symbol doublebyte_default
がでてきて、GPLのライセンス云々がでてきますね。

/usr/src/linux/drivers/video/encode-eucjp.c
をみると
#include <linux/module.h>
#include <linux/fb_doublebyte.h>
#include "font_jis16.h"
となっていて、doublebyte_default 自体はモジュール名ではないような感じなんですよね。
fb_doublebyte.hをみると
extern struct double_byte * doublebyte_default;
でなにやら定義されているんだけど、この値をどっかで設定してやるんでしょうかね?



528 :login:Penguin:05/01/20 13:15:31 ID:0AYA6hHj
そうそうこのスレの最初のほうで話題になっていたI81x系のフレームバッファの話ではないと思います。
いちおうlspciの結果はっときます
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:02.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev 03)
00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:0d.0 Ethernet controller: VIA Technologies, Inc. VT86C100A [Rhine] (rev 06)
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC AGP (rev 7a)

繰り返しになってしまいますが、インストール直後はフレームバッファで日本語が使えていました。
再構築するとフレームバッファはつかえるけど日本語が文字化けするということです。
あんまりメジャーなトラブルじゃなさそうなのでやっぱりMLとかにたずねないとだめでしょうかね?
もうちょっとだけお邪魔させてくださいませ。


529 :login:Penguin:05/01/20 13:21:51 ID:T7Mro09V
よくわかりませんが、再構築の手順を書いてみてはいかがでしょう?
(mkkpkgを使ったのか makeか 等)
それから、lilo.confのkernel optionは、以前のkernelと同じでしょうか?

530 :login:Penguin:05/01/20 13:29:56 ID:0AYA6hHj
再構築の手順は
cd /usr/src/linux
make clean
cp configs/kernel-2.4.27-i686.config .configure
make menuconfig
make dep ;make bzImage
make modules
make modules_install
installkernel 2.4.27-0vl7.2-20050120 arch/i386/boot/bzImage System.map
grub-install /dev/hda
reboot
です。
grub使ってるんですがoptionは同じにしてます。
再起動後、新しいカーネルのほうで起動すると例のエラーがでて、古いカーネルだとフレームバッファで日本語が使えます。



531 :login:Penguin:05/01/20 13:40:19 ID:fctOsyO0
> cp configs/kernel-2.4.27-i686.config .configure


532 :login:Penguin:05/01/20 13:41:25 ID:T7Mro09V
多分レス書く時のtypoだとは思うのですが、
cp configs/kernel-2.4.27-i686.config .config
ですよね?

533 :login:Penguin:05/01/20 13:48:07 ID:0AYA6hHj
>>532
そです(^^;


534 :login:Penguin:05/01/20 14:54:05 ID:T7Mro09V
何かご自分でパッチあててませんか?
unresolved symbol だか GPLチェックだかわかりませんが、
もう一度ソースを展開しなおして、標準の.configで再構築でも同じでしょうか。
CONFIG_MODVERSIONS は設定していませんよね?

535 :login:Penguin:05/01/20 15:11:56 ID:0AYA6hHj
なんかググッても同じようなことしてる人いないので、おそらく単純ななにかを見落としているんだと思います。
再インストールしてやり直してみます。
親切にレスしてくれた皆さんありがとうございました。
うまくいったら・・・もとい、うまくいかなくてもまた来ると思います(^^;


536 :login:Penguin:05/01/20 15:21:06 ID:0AYA6hHj
>>534
レスつけていただいたのに申し訳ありません。
はじめからやり直してみます。
ところで
CONFIG_MODVERSIONS
をつけてはいけない理由ってなんでしょう?
コンフィグの説明にもよくわからなければnを選べって書いてあるんでnにしてあるんですが、
同一バージョンでコンパイルしてあればyでも問題ないと思っていたんですが違うんでしょうか?


537 :login:Penguin:05/01/20 15:41:06 ID:kW7000lx
[vine-users:069805] 以降のポストってある?
メール受信の方法というか流れを変えてみたんだけど、
[vine-users:069805] 以降、一通も届かないもんで。

538 :login:Penguin:05/01/20 15:47:51 ID:fctOsyO0
linux.or.jpが死んでるくさいからなあ。

539 :login:Penguin:05/01/20 15:48:16 ID:sLvKeuJP
lists.linux.or.jpが死んでるぽいのでどうしようもないかと

540 :login:Penguin:05/01/20 16:00:25 ID:kW7000lx
あぁそうなんだ。
全然知らなかった。
で、[vine-users:069805] で止まってる、っていうので正常?

541 :login:Penguin:05/01/20 16:27:17 ID:0AYA6hHj
先ほどフレームバッファで日本語が表示できないとのたまっていたものです。
再インストールして再構築したところ日本語が表示できました!
原因として考えられるのが、前回はインストール後 apt-get install でカーネルをインストールしたんですが、
そのときはカーネルヘッダ、カーネルドック(?)、カーネルソース全てをインストールしました。
しかし、今回はカーネルヘッダしか要求されなかったので apt-get install でカーネルヘッダだけを
インストールしたらうまくいきました。
やはりコンパイルオプションとかカーネルのソースが合わなかったということなんでしょうかね?
お騒がせいたしました。



542 :login:Penguin:05/01/20 20:35:20 ID:T7Mro09V
kernel-sourceとkernel-hedersが合っていなかった に一票。

お疲れ。

543 :login:Penguin:05/01/21 10:55:42 ID:g2/nxUUM
atokのインストール完了。
/opt/atokx2/sample/client.patchにvine3.0のパッチがあった。
自分の環境は3.1だったので実行すると一部失敗とメッセージが出たので手で修正、再起動。
かんなでは無理だった自分の名前が一発変換できた!

現在 kita + atokで書き込み中。


544 :login:Penguin:05/01/21 12:37:22 ID:hFlwicSI
>>543
もしよければ、修正した方法を教えてくれませんか?
私も近日中にVine3.1にATOK for Linux をインストールする予定なので。

545 :login:Penguin:05/01/21 12:40:02 ID:VakLzt2t
>>543
タイミング的にATOK for Linuxの話かな〜

546 :login:Penguin:05/01/21 18:28:14 ID:rNNnvxBl
>>543
漏れはSeedのvutilsを試してみる予定。

* 土 1月 15 2005 xxxxxxxxxxxxxxxxxxxx 1.22.3-0vl1
- fixed atok17 setting in imelib


547 :login:Penguin:05/01/21 20:29:13 ID:nqSbOyLf
さっきkernel-smp#2.4.27-0vl7 → 2.4.27-0vl7.2に上げたら
どーした訳か24bit colorだとframe buffer表示でけんようになった。
で、vga=0x317(16bit)にしたら表示した。
どうせコンソールしか使わんからそれでも一向に構わんのだが、意味が分からん。

ちなみにビデオカードはSiS315e 64MB RAMのやつ。

548 :login:Penguin:05/01/21 23:49:46 ID:zcPCvNgJ
すんません。質問っす。

Thinkpad T21にVineの3.1をインスコしたんだけど、
頻繁にハングしてしまいます。(1時間に1回くらい)

Vineを入れる前はRed Hat 9.0入れてたんだけど、
同じ症状でした。
これって何が悪いんでしょうか?
とりあえずmemtestではエラーなしだったし、diskも新品に変えてみたんだけど。

549 :login:Penguin:05/01/21 23:57:02 ID:XM9dP/Fa
>>548
熱暴走の可能性は?CPUの温度をモニターしながら様子を見たらどうでしょう。

550 :login:Penguin:05/01/22 00:05:51 ID:Xt/X9D0d
>>548
とりあえず、Windows でもそうなるのか確かめてほすぃ。

551 :login:Penguin:05/01/22 00:08:28 ID:3oY9ZJlM
>>548
Xwindowってか、GUIでなくてもハングする?

552 :login:Penguin:05/01/22 00:14:45 ID:OBwPaN/5
レスどうも!
>>549
熱は結構すごいですね。
pen3 850MHzですが、最近のPenMでは考えられないくらい熱い感じです。
温度モニターのやり方を知らないので、数値は未測定です。

>>550
windowsでは固まらなかったです。

>>551
GUIなしだったらハングしないです。


553 :login:Penguin:05/01/22 00:32:39 ID:jJiEX0Lq
>>552
> pen3 850MHzですが、最近のPenMでは考えられないくらい熱い感じです。

比較する意味あるの?

554 :login:Penguin:05/01/22 01:32:35 ID:6V7ICEc4
>>552
CPUの温度はlm_sensorsをインストールする。
ACPIの関係でCPUファンがLinuxでは動かない(WinはOK)という現象がたまにある。

555 :login:Penguin:05/01/22 01:44:40 ID:q/evjMDD
Vineのカーネルにはlm_sensorsパッチがあたっているよ


556 :login:Penguin:05/01/22 01:53:42 ID:Fa6lpuSO
インテル、Sonoma版CentrinoでLinuxを正式サポート
ttp://japan.cnet.com/news/ent/story/0,2000047623,20080174,00.htm

Vine 3.1 はセントリーノ用のバックポートパッチあたってるのかい?対応してるんなら
アルビソママン買いたいのだが…

557 :login:Penguin:05/01/22 02:05:44 ID:6V7ICEc4
>>555
詳細希望

558 :login:Penguin:05/01/22 02:39:29 ID:9tk4Bxvr
>>555
まぁカーネルモジュールはあってもユーザスペースユーティリティが無いわけだが。
気になって調べてみたら、lm_sensorsの公式サイトのダウンロードページに
Warning: IBM Thinkpad users should not install LM Sensors.
とあるから、ティンコパッド使ってる香具師は逆にHardware sensorsを全て切ってみるのが手ではないか?
少なくとも推奨はされていないようだ。

559 :login:Penguin:05/01/22 12:35:17 ID:nT6bk7+3
正直kernel-2.4のACPI周りで悩むくらいなら、他のkernel-2.6系ディストリビューションに乗り換えた方が楽だと思うが。
もうVineのメリットってCD一枚で入る、くらいしかないし。 pen3 850MHzあれば十分だろ。

560 :login:Penguin:05/01/22 15:22:36 ID:ncQd/6iy
kernel 2.6 もまだ地雷だらけですよ。

561 :login:Penguin:05/01/22 19:59:15 ID:/32y2qMw
すいません。 Vine3.1 を ノートと デスクトップに入れたのですが、両方で、
I-O DATA の i connect の IEEE1394接続の外付けHDDが認識出来ません。
どなたか、使えてるかたいますか?

バックアップはこのHDD にしているので 、困ってます。


562 :login:Penguin:05/01/22 20:00:58 ID:tNoGYVt9
>>561
IEEE1394のIO自体は認識しているのか?

563 :login:Penguin:05/01/22 20:11:47 ID:Fa6lpuSO
>>560
もすかして大ちゃんでつか?

564 :login:Penguin:05/01/22 20:27:09 ID:igrNDekt
>>562
ごめんなさい。大ボケこいてました。
/lvar/lo/gmessages で ieee1394 device added となってたので、
自動でモジュールをロードしてるのかと勘違いで。

# modprobe ieee1394
# modprobe ohci1394
# modprobe sbp2
# echo "scsi add-single-device 0 0 0 0 " > /proc/scsi/scsi

として、無事認識しました。

実は、Suse の LiveDVD では 、この HDD だけ 認識してくれなかったので、
早とちりで、Vine もかぁ? となってしまって。
お騒がせしました。



565 :login:Penguin:05/01/22 21:07:12 ID:euKp6YVD
Vine は他のディストリビューションと比較して,
日本語環境がよくできてますよね.
何も設定せずとも,コンソールのメッセージが
日本語でてくれたりしてありがたいです.

Windows の cygwin の telnet なり ssh なりで
Vine に接続すると,日本語が文字化けします.
これはたぶん Vine 側が EUC のためかと思うのですが,
ちゃんと表示するには cygwin を
どう設定すればいいのでしょうか?


566 :login:Penguin:05/01/22 21:10:45 ID:AFljtfVa
日本語対応のターミナル使え。

567 :login:Penguin:05/01/22 21:21:40 ID:X4iDoJpc
つーかcygwinはさまなくてもWindowsから普通に
telnet なり ssh なりでVine に接続すればいいんじゃないのか?

568 :login:Penguin:05/01/22 21:33:41 ID:U84A6mHd
ターミナルなら日本語パッチを当てたPuTTYがおすすめ。
cygwinも使っているけど、sshのときだけPuTTYを立ち上げてる。

569 :login:Penguin:05/01/22 21:34:00 ID:tNoGYVt9
>>565
いまどきコンソールのメッセージが化けるディス鳥なんてあるのか?

570 :login:Penguin:05/01/22 23:10:39 ID:cpt5YwHy
vine3.1でLPC-CB-CLGT(多分Realtek8169)のCardBusキチンと動いてる香具師いる?
一応自動で認識されてしばらく動いてるんだけど。
ちょっと大きなファイル通信したりするとLinuxごと固まるんだけど、、、

571 :login:Penguin:05/01/22 23:54:04 ID:c5hwkO3z
Flash player 7 の質問です。
ttp://blog.drecom.jp/FFF/category_7/
Vine2.6 の時にはこのページの設定で
ttp://www.melcoinc.co.jp/
このページのようなFlashのメニューのテキストが見れましたが、Vine3.1 Flashplayer 7 では同じ様に見ることができません。
どうしたら見ることができますか?

572 :login:Penguin:05/01/22 23:58:56 ID:c5hwkO3z
>>570
ttp://buffalo.melcoinc.co.jp/taiou/os/linux/
このページにLinuxの対応状況がありますよ。

573 :login:Penguin:05/01/23 00:15:06 ID:B4R49DUn
>>570
そのカード自体は使っていないので分からないけれど、PCIボード版のLGY-PCI-GTでは、
自動認識で入るものやBuffaloオフィシャルのドライバでは、同様の症状が起きた。

結局、Realtekのサイトに置いてあるRTL8169のドライバ(要#define書き換え)を入れて、
今は安定している。

574 :login:Penguin:05/01/23 02:17:49 ID:id6Q1m9q
>>571
なにもしなくても表示できてるよ
Vine3.1+mozilla-1.7.5
そのページはJavaScriptをonにしないと表示されないよ


575 :login:Penguin:05/01/23 05:37:52 ID:ZfMfbPsI
日経LINUXはもうやめるんでしょうかね
もっと反映してほしいがWINDOWSみたいにブームにはなってない
サーバーやマニア向けだね
互換性のある無料ワープロや表計算がでないとね

576 :login:Penguin:05/01/23 06:18:18 ID:Dr7p5EZv
>>565
ttssh使ってます。

>>571
FlashPlayerでFlashのテキストが表示できないんだけど、表示できてます?
今のところ家で表示できてるのはFedoraCore3だけなんですが。

577 :login:Penguin:05/01/23 06:23:28 ID:bzw9U6Hx
>>576
> FlashPlayerでFlashのテキストが表示できないんだけど、表示できてます?
いけださんのページ
http://www013.upp.so-net.ne.jp/ikeda/linux/misc.html#flashplayer

578 :login:Penguin:05/01/23 06:47:55 ID:AS/r3PHJ
>>575
日経Linuxって営業職向けじゃないの?
LinuxWorldの方が鯖缶向けなような気がする。

579 :login:Penguin:05/01/23 18:20:48 ID:gbyjKoIf
>>569
cygwin

って話だろ。

まぁWindowsからなら普通はttssh使うよな。
楽チン。

580 :login:Penguin:05/01/23 18:27:40 ID:e9Khc12H
teraterm なんてふつーつかわないんじゃ?
今はputtyjp だろ。

581 :login:Penguin:05/01/23 18:32:10 ID:7wrls8UJ
普通、なんて決め付けるなよ。
teraでもputtyでも本人が不自由してなきゃどうでも良かろ。
俺はWinでは何となくVara使ってる。理由はない。

無駄レススマネ。

582 :login:Penguin:05/01/23 18:39:10 ID:e9Khc12H
やっぱり、ふつー puttyjp だろう。
困ってないことにする香具師って、単に知らなかったことを隠したいんじゃ?

583 :login:Penguin:05/01/23 18:44:14 ID:o0ovt5aW
>>579
今時、SSH2.0もサポートしてないttsshなんて使ってるやついるか?
teratermは、もう過去のソフトだぞw

やっぱ標準はputtyじゃないか?

584 :login:Penguin:05/01/23 18:47:16 ID:9jZhPBOz
なんか今日はいろんなところで毒電波が発生してるな・・・
空気が乾燥しているせいか?

585 :login:Penguin:05/01/23 18:48:16 ID:e9Khc12H
>>584
お前のせい。

586 :login:Penguin:05/01/23 18:53:33 ID:9jZhPBOz
あっそ。
わかったからとりあえず○○○はするなよ。

587 :login:Penguin:05/01/23 18:55:40 ID:e9Khc12H
なんだ、あることはあるじゃねーか。teraterm は糞だけど。
http://www.vector.co.jp/soft/winnt/net/se337560.html

588 :login:Penguin:05/01/23 19:09:59 ID:Te5P+Dnk
>>583
UTF-8 TeraTerm Pro - 2.08 / SSH2対応TTSSH
http://sourceforge.jp/frs/index.php?group_id=1412

もう過去の話。

こんなことも有るので、どっちもどっちかと。
http://slashdot.jp/article.pl?sid=04/08/04/0852231&topic=28
(チョッと、比較が古いか。)

589 :login:Penguin:05/01/23 19:10:25 ID:u7qql/62
ルータの設定をシリアル経由で行うので、TeraTermはまだ現役。
hdkさんのPuTTY日本語パッチ出てから、SSHクライアントとしては引退したけど。

590 :login:Penguin:05/01/23 19:42:09 ID:4p+QxdtM
良く分からないが、TeraTerm Pro を使っていると、
どんなデメリットが生じるんだ?
漏れは昔から不自由無く使っているが。
SSH2.0がどうとかと言われても、実際に使っている上で
不満に感じた事は無いしさ。

591 :login:Penguin:05/01/23 19:55:22 ID:0Q5ItIMb
MacSSH って便利だったんだけどねぇ。。。

592 :login:Penguin:05/01/23 20:07:57 ID:u7qql/62
>>590
SSH Protocol Ver.1 に穴が見つかったまま
放置されてるのが問題なんじゃない?

穴っつっても通信内容が読める、とかの程度で、
すぐに外部からクラックされるようなものじゃないから、
不満じゃなければそのままでいいのかも。

593 :login:Penguin:05/01/23 20:10:57 ID:fRrcBZZd
Xプロトコルによるリモート表示について質問があります。

環境:
 Vine3.0→Vine3.1にアップデートしたもの ランレベル3
実行した手順:
0. startx
1. クライント側で、xhost +AAAAA (AAAAAは、サーバのホスト名)
 2. ssh AAAAA
 3. setenv DISPLAY 172.**.**.**:0.0 (BBBBBは、クライアント名)
 4. ./xclock
 5. ここで、表示されずしばらくのち
  Can't open display の表示される。

となり、リモート表示ができません。
何か解決策がわかりましたら、ご教示ください。

ML過去ログを検索した所、似たような現象の方がいたので
確かめてみたのですが、だめでした。
参考)ttp://search.luky.org/vine-users.6/msg09309.html
試した事
1 /etc/X11/gdb/gdm.confにDisallowTCP=false
結果 ×(そもそもランレベル5の時の解決策?)
2 /etc/ssh/ssh_config にForwardX11Trusted yes
結果 ×(ssh経由でのXのふるまいの解決策?)

というか、
netstat -an |grep 6000
Xサーバがlistenされていません。。

594 :login:Penguin:05/01/23 20:13:23 ID:u7qql/62
sshがX enableでビルドされていたら、
1.のxhostと3.のsetenv DISPLAYはイラネ。
あとは-Yオプションかな。

595 :login:Penguin:05/01/23 20:13:57 ID:z6IzASSZ
>>588
ソフト紹介ありがとうございます。
早速インスコしました。

596 :login:Penguin:05/01/23 20:33:31 ID:fRrcBZZd
何度もすみません。
もしやと思い、違うsshサーバに接続した所ちゃんと表示できました。
できるサーバとできないサーバの設定を比較した所
/etc/ssh/sshd_configの
# X11 tunneling options
X11Forwarding yes
の設定の所でした。

ただ、サーバ側の管理者権限がないため/etc/ssh/sshd_configの
設定を変更する事ができません。
今までどおり、ssh経由でない(勉強不足ですみません)方法でもリモート表示を行いたいのです。
どうすればよろしいのでしょうか。

597 :570:05/01/23 21:49:02 ID:Z13i+6xI
CardBusでのギガビットについて質問した者です。

http://www.tadachi-net.com/desktop_pc/asus_terminator/gigabit_nic1.html

の部分を参照してドライバ突っ込んでみました、

見事安定で感謝感謝です。
が、ルータ越しでのFTPで送信すると速度が激遅、、、
LAN内だとある程度速度がでるのに、、なんででしょうかね?
ちなみにルータはOPT90です。




598 :login:Penguin:05/01/23 22:06:59 ID:+K7vZuWV
c-kermit

599 :login:Penguin:05/01/24 00:15:54 ID:fcqfUVoy
tgif で入力した日本語を print to PS,pdf とすると
文字化け。。。

600 :login:Penguin:05/01/24 00:52:30 ID:TkJwwroc
Vine3.1インスコ完了。増設して20Mbyteメモリのマシンに。
そこから書き込み中。

Gnome動かすと洒落にならんけど、twmとかfbだと問題ないな。


601 :login:Penguin:05/01/24 01:09:05 ID:BafQFzDZ
カーネル2.6インす子

602 :login:Penguin:05/01/24 03:22:00 ID:odoXytmb
>>577
ありがトン!
やってみるヽ(´ー`)ノ

603 :login:Penguin:05/01/24 05:08:46 ID:2tAng64M
環境 VineSeed (2.5〜)
apt-0.5.15.cnc.6-0vl9
rpm-4.0.5-1vl8
apt-get dist-upgradeすると、kernel-headerのバージョンと異なる
kernel(2.4系)を削除しようとします。
(kernel22は削除対象になっていない)

kernelのHOLD指定が削除されたようですが、既に入っているパッケージ
を削除するのは問題がある気がします。(lilo.confにも書かれているので)
この挙動で正しいのでしょうか。


604 :login:Penguin:05/01/24 05:12:56 ID:313+AxP5
>>603
VineSeed ML で議論されているわけだが、何かわからんことがあれば ML で聞けば?

605 :login:Penguin:05/01/24 05:13:20 ID:mRam8K6S
vine 3.1にfirefoxインストールしたんですが、インストール時に聞かれる
インストール先フォルダの一がよくわからなかったので、
/usr/bin/firefox-install
に入れたのですが、どのディレクトリにインストするのが一般的でしょうか?。



606 :login:Penguin:05/01/24 05:27:07 ID:zjaQQZgU
>>605
% man hier

管理ができるならどこでも良いんじゃね?
私は $HOME/.firefox に入れてる
ふつうは /usr/local か /opt に専用のディレクトリを掘って入れる


607 :login:Penguin:05/01/24 05:41:14 ID:2tAng64M
>>604
SeedのMLは敷居が高い気がして躊躇していました。
帰ったらsubscribeしてみます。

608 :login:Penguin:05/01/24 11:39:10 ID:BBg18BN5
MegaRaidのようなRAID cardへinstallするときはどうすれば
いいのでしょうか?

やったことexpert installをしたが、megaraidのmodulesを読み込むとの
表示がでるも、megaraidの論理diskをinstallerが認識できない。

しょうがないのでいつものIDEのHDDにinstallしてkernelを再構築して
Megaraidをkernel組み込みにしてtar でIDE diskの中身を全部
Megaraid diskへ転送。その後liloを再設定してMegaraidから
起動するようにしました。

いつもいつもこのやり方はつかれます。なんとか簡単にやれる方法は
ないのでしょうか?

609 :571:05/01/24 13:17:43 ID:s+HWuC3F
>>576-577
レスありがとうございます。
自己解決しました。

TrueType-kochi-subst

が入ってないというオチでした。orz
# apt-get install TrueType-kochi-subst

あとは
$ su
# cd /usr/X11R6/lib/X11/fonts/TrueType
# ln -s kochi-gothic-subst.ttf kochi-gothic.ttf
# ln -s kochi-mincho-subst.ttf kochi-mincho.ttf
# ftdumpxlfd kochi-gothic.ttf >> fonts.dir
# ftdumpxlfd kochi-mincho.ttf >> fonts.dir
# xset fp rehash

ttp://www.dawgsdk.org/typingmona/
Vine3.1 は標準で入っているのは
TrueType-sazanami
TrueType-base


610 :login:Penguin:05/01/24 14:02:51 ID:UxqcdgJO
>>596
ttp://www2.yukawa.kyoto-u.ac.jp/~hosokawa/biblo.html
>>594と同じだけど

611 :login:Penguin:05/01/24 14:26:52 ID:JxbxZ+kD
ところで、今の Seed って gtk2 のテキストボックスがおかしい?
記号とか入れ続けてる限り右から左に書かれるんだが。

612 :login:Penguin:05/01/24 15:07:38 ID:UxqcdgJO
>>611
俺もビックリした。atokで日本語モードにすると左から右になる

613 :login:Penguin:05/01/24 15:17:43 ID:mMpKBISJ
>>611
gtk2 が 2.6 になってからおかしいね。

614 :login:Penguin:05/01/24 16:45:40 ID:KoOl8hR9
>>596
/usr/X11R6/bin/startxをみると
serverargs ="-dpi 96 -nolisten tcp"
となっているので、
-nolisten tcp
を消してやると他のマシンのXクライアントも
表示できるようになると思います。


615 :593,596:05/01/24 17:10:27 ID:aMhIHEyf
皆様ありがとうございます。
>>614さんの設定でうまく表示することができました。
startxがスクリプトだってことしらなかった・・・
man startx
man xinit
すべきでした。


616 :login:Penguin:05/01/24 17:57:13 ID:yUWNM48i
セキュリティを強化したいので、tripwireやsnortを
入れたいのですが、vine3.1にポンと入ってくれるrpm
ってないのでしょうか?一応ソースからやってみたり
したのですが、良い解説サイトもなく、失敗しました。

ルーターのFW(SPI)やIPTABLEだけではなんとなく不安です。

617 :login:Penguin:05/01/24 18:00:48 ID:yUWNM48i
デフォルトでのセキュリティ設定が強固と名高い
OpenBSDは、インストールがしんどそうだし。
(でも、これも標準でsnoteとか入ってないんですよね)

618 :login:Penguin:05/01/24 18:30:43 ID:yUWNM48i
というか、セキュリティ云々に振り回されるのがいやなので
windows用のdriveshieldみたいな、再起動で完全に設定が元に戻る
システムにしたい。設定変更の時だけ、オフラインにして設定変更するとか。
そういうソフトないのかな。

619 :login:Penguin:05/01/24 18:58:44 ID:313+AxP5
>>618
VMware の中とか、uml の中とか、qemu の中で飼っておけ。

620 :613:05/01/24 19:32:03 ID:mMpKBISJ
少なくとも gdm のユーザー名・パスワードを入力するテキストボックスは
XkbDisable をコメントアウトしたら直った。
訳分からん。

621 :login:Penguin:05/01/24 20:03:09 ID:UxqcdgJO
>>618
そういうあなたには書き込み不可能なone CD Linuxの類をどうぞ。
KNOPPIXを環境に合わせてリマスタリングして、使ってくれ。

622 :618:05/01/24 20:54:00 ID:yUWNM48i
>619,621
できるだけ安全にWEB鯖を立てたいのです。
(今はWin98で立ててるけど、どことなく糞っぽいので
Linuxに移行したい)

UML for KNOPPIX が良いのかもしれませんね。

623 :login:Penguin:05/01/24 21:41:07 ID:YHeLs2Zm
subversionがapache2をrequireするようになってる。

パッケージ方針に烈しく疑問を抱いてみる。

624 :login:Penguin:05/01/24 22:33:57 ID:313+AxP5
>>623
同意。

625 :login:Penguin:05/01/24 22:55:10 ID:mMpKBISJ
現状だと、checkout するために使いという場合でも apache2 が要求されるしな。

626 :login:Penguin:05/01/24 23:41:59 ID:OwpEg9jw
以下のパッケージは解決できない依存関係を持っています:
task-xfce: 依存: xfce4-session-engines それをインストールすることができません
E: 壊れたパッケージです


627 :login:Penguin:05/01/24 23:56:39 ID:BGUfDMlu
>>626
繋ぐ鯖変えてaptしてみろ
話はそれからだ

628 :login:Penguin:05/01/25 00:24:56 ID:FCi27p6/
>>626
## Vine Linux 3.1
## 標準では extras カテゴリは除外されています。extras カテゴリ内のパッケージ
## が必要な場合はコンポーネントリストに "extras" を追加してください。



629 :login:Penguin:05/01/25 01:16:50 ID:vV1y5FGh
> 29 名前:マンセー名無しさん :05/01/24(月)02:16:53 ID:qUuDuVDm
> >>26
> ちなみに韓国のHancom社と日本のVine Linuxは仲良しだ。
> 
> http://www.hancom.co.jp/
> 
> Vineのスケジュールが順調に遅れるのは法則発動のせい(w

> 30 名前:はぽねす ◆BBx90lwzdU :05/01/24(月)02:28:30 ID:5V+fbQkA
> うちがVineから手を引いた最大の要因なんですよね(笑)。

ハン板の連中キモイな・・・

630 :login:Penguin:05/01/25 02:04:00 ID:Y9mlJqm6
Linax magazine THE DVD 2005 購入して、vine linux 入れたのはいいけど、特にサーバーとか興味なし。
アプリもWindowsのほうが多いし・・・・。こんな香具師はLinux From Scratch くらいしかやる意味ないでしょうかね・・・?

631 :login:Penguin:05/01/25 04:07:21 ID:PUJ+lO2D
>>630
Windows 使うといいと思うよ。

632 :login:Penguin:05/01/25 07:29:23 ID:9q92UEEA
つかなぜ今更 3.0 …

633 :login:Penguin:05/01/25 07:43:51 ID:fjyl1l1Z
DVDのマスター作成までに3.1リリースが間に合わなかったんじゃないの。
しかし、普段Windows使ってる人のLinux入門の定番的Distroが
揃いも揃ってGNOMEを標準のDEに採用ってのはどうなんだろう。
今となってはQtのライセンス問題とかないしKDEを敬遠する理由は無いはず。
(LGPLやBSDLじゃないから嫌なのか?)

KDEの方が圧倒的に馴染みやすいのは明らかでしょうに・・・

634 :login:Penguin:05/01/25 10:27:09 ID:Gxtt78U3
KDE、GNOMEより重くない

635 :login:Penguin:05/01/25 15:09:29 ID:OL/qvcwa
>>634
XFceって軽々〜

636 :login:Penguin:05/01/25 17:55:38 ID:mL76g+IC
wmxは軽いぞ

637 :login:Penguin:05/01/25 19:38:59 ID:+BlAEA1A
Vine3.1をフルインストールして、何にもいじってない状態で
# apt-get updateしたらエラーがでてできなかったもんで、
2.6→3.0にアップグレードするときにやるっていうsources.listの[vine]を消すってのを試してみたらできました。
これってなんででしょ?

638 :login:Penguin:05/01/25 19:53:59 ID:GTPyg7eU
>>637
日付が狂っていて、gpg keyring のインポートに失敗してるんじゃね?
ls -l /usr/lib/rpm/gnupg/pubring.gpg

639 :637:05/01/26 01:09:44 ID:c5YTtbaN
>>638
aptでvine-keyringをreinstallしたら、もとのsources.listでもupdateできました。
正直その辺のことがよくわからないので、なにがダメだったかってのがいまいちわからないんですが、
とにかくサンクスです。

640 :login:Penguin:05/01/26 03:24:46 ID:mggE6bSF
ppxp ログの logrotate の話とか見てると禿しく
BTS 設置をキボーンしたくなる。

641 :login:Penguin:05/01/26 03:42:38 ID:EkRw5eYV
>>640
家鯖で unofficial bts 作って、手あたり次第バグを報告してやれば
いいじゃないか。

642 :login:Penguin:05/01/26 04:04:57 ID:mggE6bSF
> 手あたり次第バグを報告してやれば
いや、logrotate の話は以前にも報告されているわけで
また何カ月かすると誰かが同じ報告するかもしれないわけで……
そして、また何カ月かすると誰かが同じ報告するかもしれないわけで……
for (;;)

643 :login:Penguin:05/01/26 04:12:07 ID:VKLJ01gk
ちょっと前に VinePlus-ML で gettext の話が出てたけど、
多くの(国際化された)パッケージがビルド時に必要とするだろうし、
build-essential 扱いでも良いんじゃない?

644 :login:Penguin:05/01/26 06:51:02 ID:EkRw5eYV
for (;;) {
わけで……
}

645 :login:Penguin:05/01/26 08:50:01 ID:1v5kDujm
>>640
開発者になって設置しちゃえばいいじゃない。

646 :login:Penguin:05/01/26 09:40:04 ID:7Z9gc/Yn
vinelinux.orgの「VineSeed更新情報」止まってませんか?

647 :login:Penguin:05/01/26 10:51:01 ID:ZM0bFsPU
SEED DESTINYがはじまるんだ

648 :login:Penguin:05/01/26 13:30:49 ID:fRjDbhKE
vineスレとは全然関係ないんだけどさ
何でLinux板なのにファイラーに関するスレが無いんだろう。

649 :login:Penguin:05/01/26 13:36:38 ID:D68PFYcM
ファイラーってファイル操作をするソフトのことですか?

ファイラ、何使おうか?
http://pc5.2ch.net/test/read.cgi/linux/1017002577/


650 :login:Penguin:05/01/26 13:41:13 ID:1v5kDujm
>>648
> vineスレとは全然関係ないんだけどさ
なら↓へ。

くだらねえ質問はここに書き込め! Part 95
http://pc5.2ch.net/test/read.cgi/linux/1106304664/

651 :login:Penguin:05/01/26 14:20:17 ID:k+EXuQXK
>>283

はじめてLINUXを導入しました。
2.6は何のトラブルもなくインストールできたのですが、
283さんと同じ現象でインストールできません。
283さんはインストールできたのでしょうか?
もしくは、283の現象を回避する方法はありませんか?


652 :login:Penguin:05/01/26 14:57:26 ID:Zk5vL9p0
vineスレとは全然関係ないんだけどさ
何でLinux板なのにエスパー募集スレが無いんだろう。

653 :login:Penguin:05/01/26 17:23:39 ID:a4Ho7lup
FAQのような気がしますが見つかりません

ノートとかによくあるワイドディスプレイに解像度を合わせるにはどうしたらいいでしょう?
インストール時に 1280x768 と指定したのに、表示は 1024x768 になって、ワイドテレビで表示したような
横に間延びした画面になってしまいます
ちゃんと横幅を 1280 ピクセルで使いたいのに・・・

654 :login:Penguin:05/01/26 17:54:09 ID:znOwRZXr
>>653
ノートスレにいったほうがいいかも。

655 :login:Penguin:05/01/26 17:57:01 ID:c5YTtbaN
>>653
# Xconfigurator --monitor --help
とかで設定し直してみたら?

656 :login:Penguin:05/01/26 18:02:35 ID:Oora30nT
>>653
ほんとにぐぐった?
ttp://www.google.co.jp/search?q=XOrg+1280x768&meta=lr=lang_ja&hl=ja&sourceid=mozilla-search&num=30&start=0&start=0
Modeline "1280x768" 80.14 1280 1344 1480 1680 768 769 772 795
↑こんなのがざくざく出てくるけど

657 :login:Penguin:05/01/26 18:40:02 ID:a4Ho7lup
>>654-656
ありがとうございました
ノートスレで>>656さんの指摘と同じ 1280patch-845g-855gm-865g パッチの存在を知り、
設定することができました

658 :login:Penguin:05/01/26 23:37:35 ID:TDB4PeZJ
すみません便乗で質問です
ノートで解像度ではなくて画面がちらつくんです。
リフレッシュレートを65、70、75とかえてやってもだめでした。


659 :login:Penguin:05/01/27 04:00:42 ID:RyEfThpf
>>658
>>654
液晶は大抵60Hzだがな。

660 :login:Penguin:05/01/27 11:46:31 ID:kfBgf1Fe
ATOK for Linuxの話題あまり出ませんが
みなさん>>543の方法でできてるんでしょうか?

661 :login:Penguin:05/01/27 13:09:54 ID:zLB00q5k
rox の
不適切な UTF-8 のファイル名です。
っての、なんとかならないのかな。

662 :login:Penguin:05/01/27 13:13:48 ID:q8CVirXn
>>660
[vine-users:069847] ATOK for Linux インストール報告
これで動いた。

[vine-users:069941] Re: ATOK for Linux インストール報告
こっちは試してないけど動いた報告複数あり。

663 :login:Penguin:05/01/27 13:56:16 ID:Hx+ejyLo
Vine LinuxでNTFSのファイルシステム使えるようにしてください

664 :login:Penguin:05/01/27 14:00:02 ID:nO+HbKiN
カーネル作り直せば?

665 :login:Penguin:05/01/27 14:17:52 ID:dXfJFSwS
xfs 使うのはどうすればいいんでしょう?
module は標準で入ってるようなのですが、
mkfs.xfs は「んなもんねーよ」と怒られてしまいます。

vine3.1です。

666 :login:Penguin:05/01/27 14:42:01 ID:yjuuChCu
>>665

おいらは、

ftp://oss.sgi.com/projects/xfs/download/cmd_rpms/SRPMS/

からSRPMをもってきて、rpmbuild --rebuildでビルドし直して使ってます。

依存関係があるので、

attr
acl
xfsprogs
dmapi
xfsdump

の順かな。

667 :login:Penguin:05/01/27 15:00:44 ID:+i6sBrJr
>>663
読み込みならカーネル再構築しなくても可能

NTFSファイルシステムのドライバは2.6のがバックポートされてる筈だけど、
2.6でもNTFS書き込みは所詮>>372,374-375程度

やっぱりWindowsのファイルシステムに直接書き込みしたいのなら、vfat(FAT32,FAT16)
を使うのがベター

どうしてもNTFSパーティションに書き込みたいならCaptive導入だな。劇遅だし、
DLLのバージョンに敏感すぎるけど、

言っておくけど、
標準カーネル内のドライバでNTFSに自由に書き込み可能になる可能性は将来的にも先ずないよ。
NTFSの仕様は高額のNDAを結ばないと得られないから、

668 :login:Penguin:05/01/27 16:17:44 ID:H+ryH4pu
>>662
VineUsers-ML 全文検索システム
http://vine.ic.sci.yamaguchi-u.ac.jp/

すみません。こちら↑を探したのですが新しいものはまだ載っていないようです。
MLに入っていない人は参照できないのでしょうか。
方法がありましたらご教授ください。

669 :login:Penguin:05/01/27 16:33:18 ID:3vQI5vKk
>>668
>>2 にある http://search.luky.org/ を使おう。


670 :login:Penguin:05/01/27 16:34:09 ID:49/B/oIE
>>668

>>1
> 質問をする前に http://linux2ch.bbzone.net/

知識の泉 -> メーリングリスト
http://linux2ch.bbzone.net/index.php?MailingListArchives#content_1_13

671 :login:Penguin:05/01/27 17:42:08 ID:7quPzciA
Vine3.1を使ってます。
emacsの標準のエンコードってJISみたいです。
EUCに変更するにはどうしたら良いですか。

672 :login:Penguin:05/01/27 17:56:21 ID:nO+HbKiN
Emacs part13
http://pc5.2ch.net/test/read.cgi/unix/1096186227/

673 :login:Penguin:05/01/27 18:53:31 ID:1E6KB51M
ちょっとお尋ねします。
VINE3.1でtelnetで接続出来ないです。

・inetd.confのtelnetの#は消しました。
・hosts.allowには all : all を設定、hosts.deny には何も設定してません。
・再起動した上で telnet localhost でも login: が表示されず
 10秒ほどで自動的に切断されます。

原因はなんですか??

674 :login:Penguin:05/01/27 19:12:39 ID:mqfVitH+
rootでアクセスするからです。と、適当に言っておく

675 :login:Penguin:05/01/27 19:27:37 ID:q4Jdtxzd
>>670
ありがとうございました。
ひとつ利口になりました。

676 :login:Penguin:05/01/27 19:53:28 ID:fmPh5b8C
VINE3.1はNTFS Filesystemに対応しているのでしょうか?

677 :login:Penguin:05/01/27 20:02:01 ID:q4Jdtxzd
>>676
やったことないけど
http://yamajazz.way-nifty.com/jazz/2004/12/linuxwindows.html

678 :login:Penguin:05/01/27 20:11:21 ID:fmPh5b8C
>>677
有難うございます。やってみます。

679 :login:Penguin:05/01/27 20:44:59 ID:N0IlsfnS
>すでに入っているパッケージの開発用サブパッケージを全てインストールする
> # apt-get script install-devel.lua

>>224でも指摘されてたけど、3.1をクリーンインスコして試してみたけど未だ直ってないね。
updateかける前でも後でも試したけど、ヤッパ駄目。

680 :login:Penguin:05/01/27 20:53:30 ID:+i6sBrJr
>>676,678
すぐ上にこれがあるよ>>663,667

681 :login:Penguin:05/01/27 21:21:36 ID:SPsanApM
>>671
HTMLモード以外は、EUCのような気がするけど。。。

682 :login:Penguin:05/01/27 21:28:18 ID:7XaxlVfI
>>649
ラーって伸ばしたらダメなんですね。
恥ずかしい失敗。

683 :login:Penguin:05/01/27 21:45:58 ID:SPsanApM
>>682
取りあえず
ttp://www.amy.hi-ho.ne.jp/~lepton/program/p3/prog311.html
とか
ttp://nagoya.cool.ne.jp/infinite/column/prolonged_sign.html
を嫁

684 :login:Penguin:05/01/27 21:56:56 ID:1SyDb2cr
>>682
IQ300のゴリも「ラー」と伸ばしていたから、問題ないかと

685 :login:Penguin:05/01/27 22:15:40 ID:VjdcLbtQ
>>683
つまり、略しているからどちらでもおkなんだ

686 :login:Penguin:05/01/27 22:18:25 ID:lzQneqdd
>>673
apt-get install telnet-server

687 :login:Penguin:05/01/27 22:26:28 ID:sM9jojzi
>>679
extras をぬけば開発用サブパッケージをapt-getできる。
ただし、ちょっとまえから art, art-devel の依存関係がおかしくなっている。
両方の 1.2.3-0vl1 を手動でいれればどうにかなると思う。
試してみてそ。

688 :login:Penguin:05/01/27 23:29:09 ID:bXL9/WR7
>>679
また駄目になったの?
3.1をリリースしてしばらくは大丈夫だったのにね。

689 :login:Penguin:05/01/27 23:48:56 ID:ntUsGF0G
extras はメンテされてないパッケージが含まれてるから、うまくいかないんだろうな。

arts-devel は再度 put されたけど、またもやマージされなかったみたい。
同一パッケージのようだから、Project の人が VineSeedPlus のものをコピーすれば
良いんじゃない?

690 :login:Penguin:05/01/27 23:55:09 ID:sM9jojzi
>>687
あ…artsね…

691 :673:05/01/28 00:16:49 ID:t8m6lsza
>>686
有り難うございました。
telnetでloginできるようになりました。

telnetサーバーが無かった訳ですね  orz

692 :login:Penguin:05/01/28 00:21:30 ID:X/KwO8f0
xfce関係、task-xfceだけがextrasに入ってるみたいなんだけど、そういうもん?
4.0から4.2に上がったとき、upgradeでtask-xfceだけが取り残されて、
xfce関係全部removeしてapt-get installしようとしたら無理だった。
extras追加して無事入ったけど・・・。

693 :login:Penguin:05/01/28 00:29:08 ID:X/KwO8f0
>>692
ゴメン。今見たらちゃんと入ってた。
その時だけだったのか、何かの勘違いだったか寝ぼけてたのか・・・orz

694 :login:Penguin:05/01/28 00:37:57 ID:sAWentEo
>>683
ありり。
3音以上なんですね。
2音以上だと例文の「カバー」が「カバ」、情けないですね。

695 :login:Penguin:05/01/28 00:43:16 ID:v1jSfbDg
>>684
ゴリ自身に問題があるような……
http://wagesa.cool.ne.jp/music/anime/uchuenjingori.html

696 :login:Penguin:05/01/28 00:48:34 ID:ly+uH1NR
>>692
xfce-4.2 で xfce4-appfinder,icon-theme,session,session-engine が増えたけど、
カテゴリを plus にする前に put しちゃったから、extras に放り込まれてしまった。
put する前に申請しておけば問題は起きなかったと思う。

697 :login:Penguin:05/01/28 01:44:13 ID:X/KwO8f0
>>696
あ、そうでした。記憶違い。
session-engineが無いって蹴られたからextrasにあるのを確認して
extras足したんでした。納得。
ありがとうでした。

>カテゴリを plus にする前に put しちゃったから、extras に放り込まれてしまった。
メンテナさんでしょうか?お疲れ様でございます。

698 :login:Penguin:05/01/28 02:34:17 ID:QL5q0VfS
すいません、質問なんですが
リナックスワールド2月号についていたvine3.1をIBM netvistaA20にインストール
しようとしたんですけどインストール元の指定の所でローカルCDに指定すると
イメージファイルがありませんとエラーが出て前に進みません、ハードディスクインストールも
試みたのですが結果は同じでした。
CD自体は傷もなく他のPCには問題なくインストール出来たので異常はないと思います。
また、CDドライブも正常です。PCの構成はストックのままです。
いろいろ検索して調べたのですが未だ解決方法を見つけれずにいます。
どなたかご教授願えませんでしょうか? 


699 :login:Penguin:05/01/28 11:26:04 ID:zA6O3lyO
ring鯖なんだけど
apt-cache showpkg phpで
Versions:
4.3.9-0vl1
となる。4.3.10になってない?

700 :login:Penguin:05/01/28 11:30:58 ID:zA6O3lyO
Vine/apt/3.1/i386/base
以下の更新が止ってた
別のring鯖しますた

701 :login:Penguin:05/01/28 13:22:15 ID:BxYSWBzd
週末にカーネルサンダースしないといかんな

702 :671:05/01/28 14:46:28 ID:A0xZDGsx
>>681
$ emacs test.txt &
なんてすると、モードライン?のところに
-かんな-J:-- test.txt
というふうになります。

C-x [ENTER] f euc-jp
すると -かんな-E:** test.txt
のようになるのでこれはデフォルトがJISだと思うんですが違いますか?

emacs.el と見てもちゃんと euc-jp に設定されています。
;;; 言語環境の指定

(set-language-environment "Japanese")

;;; 漢字コードの設定

(set-default-coding-systems 'euc-jp)
(set-buffer-file-coding-system 'euc-jp-unix)
(set-terminal-coding-system 'euc-jp)
(set-keyboard-coding-system 'euc-jp)


703 :login:Penguin:05/01/28 15:38:00 ID:pL0JdDLN
vine3.1 のCourier-IMAPのパッケージがインストールできないのですが、
自分の環境が悪いのか確認死体ので、インストールに成功した方は、
いますでしょうか?

704 :login:Penguin:05/01/28 15:38:53 ID:Ivu76Xua
ここはVineスレなんですが。


705 :login:Penguin:05/01/28 15:50:42 ID:hLcnqyW0
>>704
>>702はVine3.1のemacsのデフォルト設定の話だから、このスレでいいんじゃない?
で、$ emacs -q test.txt &
をやってみて、EUCになるのなら、どこかで自分でJISに設定している。

706 :login:Penguin:05/01/28 16:02:36 ID:YiG+IvEA
test.txtというファイルがJISなのかも

707 :login:Penguin:05/01/28 16:05:35 ID:HKKva/rI
>>705
そういう事じゃなくって、デフォルトは何ですか?
と聞かれてeucですと答えてる人にレスしてるでしょ。

デフォルトはeucですと答えてるのはここがVineスレだからですよ、と教えてあげてるの。

質問するのは構わないけど、こういう事もあるから、やっぱりemacsスレでやる方が事が
スムーズに運ぶんじゃないかな、とふと思ったよ。

708 :login:Penguin:05/01/28 16:07:45 ID:8ySKxrcj
>>703
普通にインストールできてます。
別に苦労した記憶もない。

709 :703:05/01/28 16:31:41 ID:pL0JdDLN
>>708
それは、Courier-IMAPのバージョンが4でしょうか?


710 :login:Penguin:05/01/28 16:40:37 ID:hqRRiThR
ってか、何をどうやったらどうなったか書いた方が解決に近いんじゃないか?

711 :703:05/01/28 16:52:14 ID:pL0JdDLN
>>710
ごめんなさい。

しばらく前から、 apt-get dist-upgrade をすると、「courier-imap」が、保留に
なっていたので昨夜、試しに「courier-imap」をアンインストールして再インストールをしたら、失敗下のです。
# apt-get install courier-imap
パッケージリストを読みこんでいます... 完了
依存情報ツリーを作成しています... 完了
いくつかのパッケージをインストールすることができません。おそらく、
ありえない状況を要求したか、(必要なパッケージがまだそろっていなかっ
たり、まだIncomingから移動されていない)不安定なディストリビューション
を使用していないでしょうか。

単純な操作だけを行った時に、パッケージがインストール
できない場合は、バグリポートしてください。
以下の情報がこの問題を解決するために役立つかもしれません:

以下のパッケージは解決できない依存関係を持っています:
courier-imap: 依存: courier-authlib それをインストールすることができません
依存: libcourierauth.so.0 それをインストールすることができません
依存: libcourierauthsasl.so.0 それをインストールすることができません
E: 壊れたパッケージです


さらに依存関係に関係ありそうなパッケージをインストールしようとしてもエラーになってしまいました。
# apt-get install courier-authlib


712 :login:Penguin:05/01/28 16:55:58 ID:hqRRiThR
何からインスコしようとしてるのかな?
rpm コマンドでパッケージを直接入れてみたらどうでしょう。

713 :login:Penguin:05/01/28 16:57:22 ID:LEIcHcDZ
>>702 >>671
>emacs.el と見てもちゃんと euc-jp に設定されています。
. がないけど、~/.emacs.el を見てますよね?

Vine3.1 使ってないから確認できないけど。標準の動作を確認するならこんな感じで。
$rpm -qf /etc/skel/.emacs /etc/skel/.emacs.el
etcskel-2.6-1vl1
etcskel-2.6-1vl1
$rpm -V etcskel

root で
#useradd new-user
#passwd new-user

new-user でログイン。
$touch empty.txt
$file empty.txt
empty.txt: empty

$emacs empty.txt
何か日本語で書いて保存。
$file empty.txt
確認。

714 :671:05/01/28 17:12:47 ID:A0xZDGsx
>>705
>>713
レスすみません

$ emacs -q test3.txt ←新規ファイル

したら E: なりました。 ただしCannaが少し変?
C-\ で起動でした。
自分の .emacs.el がおかしいのかな。
何もいじってないのですが。いじるスキルもないのですが。
新しくユーザ作って試してみます。


715 :703:05/01/28 17:25:30 ID:pL0JdDLN
>>712

ごめんなさい。
rpm でインストールを行ったら、「expect」がたりなかっただけでした。

# rpm -ivh courier-authlib-0.53-0vl2.i386.rpm
エラー: 依存性の欠如:
/usr/bin/expect は courier-authlib-0.53-0vl2 に必要とされています

「expect」をインストールすることで、うまくいきました。


716 :671:05/01/28 18:00:25 ID:A0xZDGsx
>>714
解決しました。 >>713 ありがとう。感謝!!

# useradd hoge
# passwd hoge
してログインして emacs 開いたら E: でした。
.emacs.el コピーして解決しました。

違っていた所は以下でした。
-------------------------------------------------------
(set-selection-coding-system 'euc-jp)

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
(custom-set-variables
;; custom-set-variables was added by Custom -- don't edit or cut/paste it!
;; Your init file should contain only one such instance.
'(auto-compression-mode t nil (jka-compr))
'(case-fold-search t)
'(current-language-environment "Japanese")
'(default-input-method "japanese")
'(global-font-lock-mode t nil (font-lock))
'(server-switch-hook (quote (raise-frame))))
(custom-set-faces
;; custom-set-faces was added by Custom -- don't edit or cut/paste it!
;; Your init file should contain only one such instance.
)


717 :login:Penguin:05/01/28 18:52:54 ID:bVX97ROs
あら?
kernel-2.4.27-0vl7.3 ってまだ行き渡ってない?
apt(本家+KDDI)で入れようとしたけど出てこないや
アナウンスから2日も経ってるのに

718 :login:Penguin:05/01/28 19:17:33 ID:bVX97ROs
うはwwwwwいつの間にかオンラインマニュアル新しくなってたwwwwwwwwww
もうinit Sしなくていいのねwwwwwww普通にランレベル3でapt-getできたwwwっうぇ

前回(昨年末)は前のやり方ですんなりアップデートできたのにな(´・ω・`)

719 :login:Penguin:05/01/28 19:34:53 ID:0C34ZNNp
カーネルうpだてしたので再起動してほかってたらfsck走っててずぅーっと止まったまんまに
なってしまいます。

原因も何もわかんないしいい機会なので2.6 -> 3.1にしてみます。

720 :login:Penguin:05/01/28 19:49:54 ID:E/WVBKw1
今日の昼過ぎ(だと思う)に、「apt-get update」をやったら、
ハッシュ値が一致していなかったかなんだか忘れたのですが、
とにかく何かが一致しないという事でエラーになりました。
その時に数回繰り返したら正常にアップデート出来たのですが、
これはサーバ上のデータが改変されたということなのでしょうか?
このまま、「apt-get upgrade」を行っても大丈夫か教えて下さい。

721 :login:Penguin:05/01/28 20:03:00 ID:ly+uH1NR
>>720
apt データベースを更新している時にミラーリングされてると、
ハッシュファイルの MD5SUM と、リリースファイルに書かれた MD5SUM が
一致しなくなる可能性はあるだろうね。

>>718
2.5 の頃から apt でカーネルの更新してたけど。

722 :720:05/01/28 20:12:05 ID:E/WVBKw1
>>721
なるほど。
偶然更新時のタイミングに「apt-get update」をやってしまったのですか。

 | 以下のパッケージがアップグレードされます:
 |   glibc glibc-common glibc-devel nscd
 | 以下のパッケージは保留されます:
 |   kernel-headers
 | アップグレード: 4 個, 新規インストール: 0 個, 削除: 0 個, 保留: 1 個
 | 37.2MB のアーカイブを取得する必要があります。
 | 展開後に 591kB が解放されます。

現在は、次のようにアップグレードが実行できそうなので、
勇気を出してパッケージのアップグレードを行おうと思います。

教えて頂きありがとうございました。

723 :login:Penguin:05/01/28 21:02:49 ID:V290XCOM
apt-get updateしたら次のメッセージが表示されたんですが、
Pingやtracerouteは通ります。これってどういう現象なのですか?

エラー http://updates.vinelinux.org 3.1/i386 release
Cannot initiate the connection to updates.vinelinux.org:80 (219.117.217.214). - connect (101 Network is unreachable) [IP: 219.117.217.214 80]
以下の取得に失敗しました: http://updates.vinelinux.org/apt/3.1/i386/base/release Cannot initiate the connection to updates.vinelinux.org:80 (219.117.217.214). - connect (101 Network is unreachable) [IP: 219.117.217.214 80]
パッケージリストを読みこんでいます... 完了
依存情報ツリーを作成しています... 完了
W: いくつかのリポジトリのリリースファイルが取得できませんでした。取得できなかったリポジトリは無視されます。
W: この問題を解決するためには 'apt-get update' を実行する必要があるかもしれません。
E: いくつかのインデックスファイルのダウンロードに失敗、無視、あるいは古いものが使用されました。

724 :login:Penguin:05/01/28 21:49:58 ID:LniwbYth
サーバ更新中

725 :login:Penguin:05/01/28 21:52:27 ID:V290XCOM
>>724
つまり更新が終わるまでまで待てということでしょうか?

726 :login:Penguin:05/01/28 23:01:40 ID:vO7e+4Xe
>>723
1回目は、俺も同じメッセージが出る。2回目やると成功するぞ。
もじらでHPみれないなら、何回も出る。(DNSサーバが見つからない)

727 :login:Penguin:05/01/28 23:09:00 ID:vO7e+4Xe
vine3.1でWEB鯖を運用してる人。セキュリティ対策にどんなことしてますか?
(またはどんなツール使ってます?)

今のところ、ルータのファイアウォールとiptablesと
不要なサービスを止める、しかやってないので、公開できずにいます。
完璧ってのは無理でも、これやっとけば、狙われない限りOKという技は
ありますか?なんか詳しいHPがあるとうれしいんですが。

728 :login:Penguin:05/01/28 23:17:57 ID:kDjuzRll
SeedPlusの、postgresql8 は、今回のは没だそうな。
南無・・・。

729 :未承諾広告※ ◆TWARamEjuA :05/01/28 23:54:58 ID:LpUBUO5K
>>727
> ありますか?
ありません。

730 :727:05/01/29 00:34:12 ID:sUTBp3sW
>>729
どうもありがとう、「無い」ということがわかったよ。サンクス。

731 :login:Penguin:05/01/29 01:13:41 ID:DE+veGmV
>>623-625

SeedPlus でのパッケージャですよ、と。

 Subversion の各コマンドが libapr を link しているので、
回避するには libapr を外出しするように apache2 パッケージを
いじらないといかんのよ。

 その前に db4 の変更が accept されないとダメなんだけどね。

732 :login:Penguin:05/01/29 01:25:08 ID:JW4Q2rOg
>>731
libapr に関してはは apahce2-apr に入ってるんでない?

733 :login:Penguin:05/01/29 01:56:44 ID:LHgvUx46
vineのSRPMのglibcをリビルドしてるのですが、どうしてもうまくいきません。
最後の部分は以下の様なのですが、アドバイスいただけないでしょうか?

/var/tmp/glibc-2.3.3-root/usr/share/man/man3/sigwait.3thr: 0.0% -- replac
ed with /var/tmp/glibc-2.3.3-root/usr/share/man/man3/sigwait.3thr.gz
+ '[' -d /var/tmp/glibc-2.3.3-root/usr/info -a /usr/share/info '!=' /usr/info ']
'
+ gzip -9nvf '/var/tmp/glibc-2.3.3-root/usr/share/info/libc*'
gzip: /var/tmp/glibc-2.3.3-root/usr/share/info/libc*: No such file or directory
エラー: /var/tmp/rpm-tmp.56791 の不正な終了ステータス (%install)


RPM ビルドエラー:
/var/tmp/rpm-tmp.56791 の不正な終了ステータス (%install)



734 :login:Penguin:05/01/29 02:12:05 ID:2EB8m59Q
先に日本語を習ってこい

735 :732:05/01/29 02:14:58 ID:JW4Q2rOg
よく見たら typo が。
それはともかく、db4 は accept されたようだね。

736 :login:Penguin:05/01/29 02:31:12 ID:TgWecloK
頭の悪そうなメンテナだらけですね。

737 :login:Penguin:05/01/29 05:24:30 ID:YEQ6FmzD
>>732
多分>>736>>732へのコメントだろう
specファイルが修正しきれていない
usr/share/info/libc*部分


738 :login:Penguin:05/01/29 05:31:41 ID:TgWecloK
php および postgresql8 の人のアホっぷりと、
dicey な人の脳内っぷりもたまらんところですな。

739 :login:Penguin:05/01/29 09:01:41 ID:TgWecloK
[VineSeed-Plus:02883] [VineSeed-Plus:02887]

なんなんだ?そこまでして笑いものになりたいのだろうか。


740 :login:Penguin:05/01/29 12:59:28 ID:/aDammnT
>>739
まあ問題のポイントはみんな packaging.html に書いてあったことのような。

741 :731:05/01/29 15:07:16 ID:DE+veGmV
>>732

 先に Vine3.1 上でいじってたので、VineSeedPlus の apache2 を見て
 なかったよ(コラ)。大感謝。後で直しておきませう。


742 :login:Penguin:05/01/29 17:00:40 ID:k/TNZEKG
nslookup が command not found になってしまいます。
apt-cache search nslookup としても見つかりません。

IPアドレス <-> ホスト名の名前解決はどのようにおこなえばよいのでしょうか。

743 :login:Penguin:05/01/29 17:02:57 ID:mLLTQsGv
dig

744 :742:05/01/29 17:40:49 ID:k/TNZEKG
apt-get install bind-utils

で解決しました。

745 :login:Penguin:05/01/29 22:16:54 ID:hvhVStbS
ちょっとお尋ねしたいのですが、Vine3のGnome2.4について、スタートメニューに
入っているランチャ類は、どのようにすれば思い通りに編集できるのでしょうか?
ランチャのメニュー上から直接編集すると~/gnome2/vfolders/applicationsに
ファイルが格納されてしまい、本来のファイルがどこぞへ消えてしまいます。

もととなるファイルがどこにあり、どのように設定ファイルを編集すればよいのか
ご存知の方がおられましたら、ご教示願えないでしょうか。

746 :login:Penguin:05/01/29 22:34:09 ID:YEQ6FmzD
>>745
findとgrepの使い方に習熟すれば、人に聞かなくたって
自分で答えがわかるぞ


747 :login:Penguin:05/01/29 22:50:47 ID:/1iE8dNU
>>745
それでいいのでは?

全ユーザ分を書き換えたいのなら、
/usr/share/applications/hoge.desktop
とかを探すべし。

748 :login:Penguin:05/01/29 22:51:52 ID:/1iE8dNU
nautilus で、HTMLをレンダリングして欲しいんだけど、
どこで設定するんでしょうか。

749 :login:Penguin:05/01/30 00:30:16 ID:mRQKNExc
>>746-747
ファイルを編集しながら内容を追っていくうちに編集の方法がわかりました。
どうもありがとうございました。もうおまえらに用はありません。

750 :login:Penguin:05/01/30 00:38:10 ID:/SRmGpyO
超初歩的な質問ですみません。
ネットランナーに入ってたVINE LINUXをインストールしたんですが、
日本語入力ができません・・・。
RED HAT LINUXでは確かshift+spaceで日本語に移行できたと思うんですが、
何かぜんぜん違うやり方なんでしょうか?
日本語が使えると思われるツール(ありさんマークのワープロじゃなくて)で
試しても駄目でした。
インストール時のミスか何かでしょうか。

751 :login:Penguin:05/01/30 00:42:20 ID:GIkQrmTI
ネットランナーに入ってたVINE LINUX
ネットランナーに入ってたVINE LINUX
ネットランナーに入ってたVINE LINUX
ネットランナーに入ってたVINE LINUX
ネットランナーに入ってたVINE LINUX
ネットランナーに入ってたVINE LINUX

マジ?


752 :750:05/01/30 00:45:42 ID:/SRmGpyO
久々に買ったらどさくさに紛れて入ってた…。
多分今月号か先月号のやつだと思う。
すごく小さな扱いだったが…。
俺もびびった。

しっかりDVDにちゃんとした形式で入ってたよ。
BIOSいじってからCD-ROMから起動するとインストール画面に移行。
ぶどうの画面が出てきます。

753 :login:Penguin:05/01/30 01:19:40 ID:GIkQrmTI
あ、そーなん、まぁ、情報少ないから適当に言うが
kinput2ならばshift+spaceで起動するんじゃなかった?
ctrl+spaceか?kinput2とかcannaが動いてるか確認汁
google使ってね〜

754 :750:05/01/30 01:24:14 ID:/SRmGpyO
一通り確認してみます。
それで駄目だったらもうどうしようもないんで、アンインストールして
前使ってた赤いやつに戻します。

755 :login:Penguin:05/01/30 01:48:05 ID:7Tc0ZIBG
ってかネットで検索ぐらいしないのかよ。

756 :login:Penguin:05/01/30 02:46:03 ID:CIOiPJ1u
ttp://vinelinux.org/documentations.html

757 :login:Penguin:05/01/30 06:33:02 ID:kmHEqkTe
窓を食い荒らし尽くして、こんどはVineですか。
まるでイナゴの大群ですね。

758 :login:Penguin:05/01/30 09:46:52 ID:vODdrIMU
PC JAPANの間違いじゃないのか?

759 :login:Penguin:05/01/30 10:36:31 ID:C03xJuPX
>>758
PC JAPAN弟子

760 :login:Penguin:05/01/30 10:49:44 ID:kJtLGbd1
>>750
ありさんマークのワープロって何?

761 :login:Penguin:05/01/30 15:26:30 ID:y/JJiv6n
3.0 から 3.1 へのアップグレードについて
/etc/apt/sources.list 内の 3.0 の記述を 3.1 に変更し、 以下を実行することで 3.1 へアップグレードすることができます。
[参考: Vine Linux 3.1 用 sources.list]
# apt-get update
# apt-get dist-upgrade
これってどうやるんでつかあ。

762 :login:Penguin:05/01/30 15:30:14 ID:9d1Nitvk
釣り?

763 :login:Penguin:05/01/30 15:52:57 ID:CHd1hyVy
>>761
どうやるって・・・
あなたが書き写してる通りにやるしかないでつ

764 :login:Penguin:05/01/30 17:01:52 ID:48TTbYeO
>>761
どうって…
vi /etc/apt/sources.listで参考: Vine Linux 3.1 用 sources.listの内容のテキストをコピペ
そしてテキストをesc :wqで保存終了。
もしくはwget でVine Linux 3.1 用 sources.listをダウソして取り替える。

それからルートになってapt-get updateて打ったあとapt-get dist-upgradeを打つ…だよ?

765 :login:Penguin:05/01/30 17:23:45 ID:5KYb6c4U
1.まず、viでコピペのやりかたを訊かれ必死に説明するも届かず、wgetを薦めるも
 「/etc/apt/に上書きすると 権限がない って怒られます」 と質問される。

2.「apt-get dist-upgradeとやったら変な文字がたくさん流れて終わったみたいなんだけど
  本当に正常に終わったの?カーネルは変わってないみたいだけど?」と訊かれる。

3.「苦労してやっとできたみたいだけど、これやる意味ってあるの?起動後毎回しなきゃいけないの?
  何でそんなに必死になって教えるの?」と逆切れされる。

4.>>754の最後の行と同じ文が出てくる。

766 :login:Penguin:05/01/30 17:25:18 ID:C03xJuPX
たぶん >>761 さんはviを知らない人では?

767 :login:Penguin:05/01/30 17:31:18 ID:IR/zzJPT
emacsでも編集できるっしょ。(rootでemacsはあまりおすすめしなけど)
emacsの使い方も知らないなら、黙ってWindows使ってなさい。

768 :login:Penguin:05/01/30 17:34:40 ID:apGiLsDK
viも知らずにアップグレードとは片腹痛い
3.1CR買うか、窓でも使っとけ

769 :login:Penguin:05/01/30 17:55:41 ID:24VVXB8T
>>761
情報ありがとう。早速作業しました。

770 :从*・ 。.・) ◆SayuminPM. :05/01/30 17:57:39 ID:UBByXFeV
これを思い出した
http://sodan.org/~knagano/misc/ed.msg.txt


771 :login:Penguin:05/01/30 19:36:37 ID:IxWqmRXg
漏れはインストールしたら真っ先にFDから
uemacsを/usr/binにコピーしちゃうんで
vi は一切使わんけど。

軟弱ですまん。
だって楽なんだも〜ん

772 :login:Penguin:05/01/30 20:52:12 ID:9GRnQYLz
漏れは逆にviしか知らなかったので初めてemacsを
立ち上げた時、終了方法が分からずkillした記憶がある

773 :login:Penguin:05/01/30 21:52:24 ID:gJEmuZkD
>>772
俺は今でもkill以外の終了方法がわからん・・・

774 :login:Penguin:05/01/30 22:03:03 ID:0I0QwCQy
>>773
電源OFFすればいいやん。

775 :login:Penguin:05/01/31 00:33:35 ID:LSunLZjr
俺はaee入れちゃうヘタレですが

776 :login:Penguin:05/01/31 00:42:54 ID:INVxNf53
2ちゃんねるブラウざーfor linuxがありますか?

777 :login:Penguin:05/01/31 00:52:05 ID:omKnceW9
Kita - 2ch client for KDE part2
http://pc5.2ch.net/test/read.cgi/linux/1089905503/

778 :login:Penguin:05/01/31 00:58:10 ID:IJ21kSmX
>>776
http://linux2ch.bbzone.net/index.php?FAQ%2FApplication#c5638092

779 :login:Penguin:05/01/31 00:59:14 ID:1DdzGqwn
素人が玄箱買っちゃだめだって。

780 :login:Penguin:05/01/31 01:13:08 ID:co2LL9f4
ここは良いくだ質スレですね

781 :login:Penguin:05/01/31 07:52:49 ID:TbfF7CQe
>>738
どこがアホなのか分からん...orz

782 :login:Penguin:05/01/31 09:15:43 ID:N48kH7SU
3.1CRをSeedにupgradeして使っている方はいますか?
塩梅はどうでしょう?

783 :login:Penguin:05/01/31 09:21:43 ID:0D2e++6b
塩梅 て何?

784 :login:Penguin:05/01/31 09:49:04 ID:wQGER0z3
アリさんマークのワープロって何?

>>783
あんばい ではなかろうかと

785 :login:Penguin:05/01/31 10:22:08 ID:1DdzGqwn
Seedは自己責任、バグフィックス・改良の為の開発版、塩梅もへったくりもなかろう。
問題が有れば、意見やパッケージングをしてくのが筋。

786 :login:Penguin:05/01/31 11:24:05 ID:TbfF7CQe
今ごろ、xpdfとlibtiffが直るとは。

787 :login:Penguin:05/01/31 11:39:07 ID:hNhAH9EM
>>786
GNOME標準のワープロのことではないか。OOoがある今では、使う気がせんが。
詳しくはGNOME Officeで検索してけろ。

788 :748:05/01/31 15:49:54 ID:TbfF7CQe
nautilus-gtkhtml を入れれば良いのか。

それでは、「日記は広告の(ry」AAをどうぞ。↓

789 :login:Penguin:05/01/31 15:55:34 ID:Jl5apOjj
日記には、定評のある博文館を
http://www.hakubunkan.co.jp/2005.html

790 :login:Penguin:05/01/31 16:58:35 ID:HUKJJoF/
nautilus-mozillaって昔あったよね
レシートの裏


791 :login:Penguin:05/01/31 17:15:33 ID:/6sVwuwr
Seedの開発以前に、安定版のセキュリティホールをなんとか汁。BTSはやく作れ。

792 :login:Penguin:05/01/31 17:43:37 ID:gs3y21k4
3.0/3.1のErattaから判断して穴が残っていそうなSeedのパッケージ
xpdf,libtiff,shadow-utils,openssl,namazu,cyrus-sasl

番外
XOrg(自身ない)
squid(よくわからん)
apache(htpasswd/同一名で中身が違う)
indexhtml

間違い、勘違い、抜けがあっても怒らないでね♥

793 :login:Penguin:05/01/31 21:04:08 ID:EZ/ZlCaJ
あとkernelも

794 :login:Penguin:05/01/31 21:58:41 ID:0cL4Bjsd
2.4r4でapt-get updateすると、apt-get upgradeでglibcが出てくるんだけど、
やっちゃって大丈夫なんかな?

glibc入れ替えるとややこしいことになるという先入観があって、心配で踏み止まってるんだが


795 :login:Penguin:05/01/31 22:14:31 ID:fhkmVGtY
knoppix使ってみたらきれいだったんでKDE入れたけど
実際入れてみたけどあんま楽しくなかった。

796 :login:Penguin:05/02/01 00:20:11 ID:hMHNo0zk
>>794
セキュリティアップデートだよ。
オフィシャルなパケジはテスト済みだから。
心配ならsrpmの中身を見てみよう。

797 :login:Penguin:05/02/01 06:22:41 ID:X3onSxUJ
2000年度ログに載っていた質問。

「自前で、フォームデータのデコードを行いsendできるようにしたいのですが
参考になる、またはお勧めのWebページがありましたらURLをお教え下さい。」

それに付いていたレス。

「この様な Vine Linux には直接関係のなさそうな話題はあまり
この ML には適さないと思いますが、フォームのデコードに関しては
CGI 関連の書籍やウェブページを当たられるとよろしいかと思います。」

質問者は1996年にPostScript言語の理解があるという看板を出して
事業を展開しておりました。
思い当たる質問者は腹を立てるかも知れないけど、
ご自身の性質(性格じゃないよ)に関し、胸に手を当てて
よく考えてみて下さいな。
性格は変わる可能性があるけど、性質は終生変わらないと思われ。
5年前の話題を出されるほど敵を作ってるってことを忘れるな。

798 :login:Penguin:05/02/01 09:19:44 ID:MnBJn39/
mod_limitipconn.spec <URL:http://morejams.no-ip.com/up/src/up0003.spec>

%changelog
* Tue Feb 1 2005 jax <jax@morejams.no-ip.com> 0.22-1vl0.1
- Initial release.
spec based on <http://dominia.org/djao/limit/mod_limitipconn-0.22-1.src.rpm>
with no changelog


799 :login:Penguin:05/02/01 18:15:04 ID:9LSH5vt/
>>797
昔の話を持ちだして何が言いたいのか。擦れ違い。

800 :login:Penguin:05/02/01 20:14:51 ID:JQWBobF7
>>792
xpdfとshadow-utils更新来てますね。
subversionのApache2依存の件も解消してるみたい。
中の方々、お疲れさまです。


801 :login:Penguin:05/02/01 23:51:28 ID:c+J8MlJL
昨日から「apt-get update」が失敗するんだけど、なんでだろう?
Vine-3.1にしたらこのザマだ_| ̄|●

802 :login:Penguin:05/02/01 23:54:12 ID:Pdjz2R/D
>>801
もっと具体的に書けよ。
それともただの愚痴か?

803 :login:Penguin:05/02/01 23:59:38 ID:Xx8wV0B7
無恥で〜す

804 :login:Penguin:05/02/02 00:00:00 ID:c3kOtHpH
1行目で質問するのかなぁ?って思ってみたら
2行目で愚痴か。

やる気無いならそもそも愚痴すら書くな。
やる気あるならエラーぐらい書け。

805 :login:Penguin:05/02/02 00:23:20 ID:p5trtM26
今やってみたら うちのVine3.1では
updates.vinelinux.org、extrasで「サイズが適合しません」になるわ。

806 :login:Penguin:05/02/02 00:34:44 ID:a0CDC7ur

>>805
何度か続けて試して見なさいよ

807 :login:Penguin:05/02/02 00:42:06 ID:p5trtM26
>>806
さっきから何度も試してるんだけど、変わらずです。
まあ、時間が経てば通るようになるかな。

808 :login:Penguin:05/02/02 00:48:05 ID:XIyGr2X6
今日初めてLinuxをインストールした超初心者なのですが、
ノートの内蔵無線LANを認識させようと思い、
ipw2100-1.0.2.tgzをダウンロードしてipw2100-1.0.2-set_security.patchを適用させたのですが
*** ターゲット `modules' を make するルールがありません。中止。
と出てしまいmakeできませんでした。
過去ログ漁ってみたりググったりしてみたのですがやはりできませんでした。
どなたかご教授お願いします。

809 :login:Penguin:05/02/02 00:48:44 ID:SyXp8Vwe
サーバ変えてみりゃいいじゃん

810 :login:Penguin:05/02/02 00:51:24 ID:p5trtM26
>>809
>>801を見て気になったから、さっきやってみただけよん。
Errata見て必要そうだったらそうする。

811 :login:Penguin:05/02/02 03:59:44 ID:Ehp6DFEU
glibc-common-2.2.4-14vl15.1 インストールしたら
パッケージ LC_TIME は file index 中に見つかりません
とかいったメッセージが大量に出てきた。
なんか気持ち悪い。

812 :login:Penguin:05/02/02 04:53:39 ID:2FEaF3kb
Linuxを覚えようとインストールしてみました

なんとかKDEなどの導入までできたんですが、
aptで保留パッケージが1件出てしまいます。

直接指定してinstallしようと思うんですが、
どのパッケージが保留されているか知るには、
どうすればよいのでしょうか?

どうか教えてください。

813 :login:Penguin:05/02/02 05:41:25 ID:2LtK8dCK
>>812
apt-get upgradeすると「以下のパッケージは保留されます」ってでてない?

814 :812:05/02/02 08:42:58 ID:IYituDbc
なにやら、おかしくなってしまい、
再インストールするはめに… orz

見逃してたのかもしれません。
再インストール後にもう一度たしかめてみます。

ありがとうございました。

815 :login:Penguin:05/02/02 11:25:17 ID:HJfHsKF0
Mac mini買ったんだけどVine3って動きますか?


816 :login:Penguin:05/02/02 11:30:27 ID:IleYGWNT
>>815
うごきません

817 :login:Penguin:05/02/02 11:39:02 ID:iopQkl2p
>>816
そうなの?

818 :login:Penguin:05/02/02 11:55:03 ID:IleYGWNT
すまそ
「PPC 搭載 Macintosh」 なんだね Mac mini って
動くかもね
買って試した人に訊いて

819 :login:Penguin:05/02/02 12:01:30 ID:HJfHsKF0
動く可能性はあるんですね
ところで外付けHDD(Firewire)にVineをインストールして
起動できますか?

820 :login:Penguin:05/02/02 12:35:41 ID:45I/CR6H
(´-`).。oO(Dejavu...かな)

821 :login:Penguin:05/02/02 13:25:37 ID:DkgvP9BW
とりあえずPPCスレに行ったほうがいいと思うがねえ

822 :login:Penguin:05/02/02 14:43:35 ID:9MpHkjBg
てーか、この手のは自分でやってみれば判る事。
いちいち訊くようなスキルのヤツは何をやっても駄目。


823 :login:Penguin:05/02/02 17:17:01 ID:sWbVhy8O
すみません
DOSVのLILOのフロッピー版どっかにありませんか
いまhda1 にはある別のlinux hda3 にvineいれているんですが
vine 選択できないんです

824 :login:Penguin:05/02/02 17:21:37 ID:EXkhf13E
>>823
grub汁!

...でいいのかな。>>823の日本語分かんないし。

825 :login:Penguin:05/02/02 17:25:22 ID:IleYGWNT
つーか、LILOって他所から持ってきてもそのまま使えない予感
別のLinux立ち上がるのなら、それのLILOいじればいいじゃん

826 :login:Penguin:05/02/02 17:41:56 ID:upt1I3x7
だね

827 :login:Penguin:05/02/02 18:24:01 ID:1NuwvjZW
WINDOWSキーとAltとoとfを同時に押すと
オープンファームウェアに入るので
そこで、
boot-deviceとboot-fileを適切にsetenvしてboot
(たぶんhfs(boot)パーティションとそこにあるyabootを指定)
だけど外付けHDDがどうなるか、しらん。
あと、
オープンファームウェアが壊れてもしらん。
(たぶん、set defaults -> reset all でなおる)


lilo.confをいじって
/dev/fd0にliloすると
DOSVのLILOのフロッピー版
だけど、ふつうにMBRに入れるといいとおもう。

828 :login:Penguin:05/02/02 19:24:34 ID:45I/CR6H
PPCとPC/AT夢のコラボレーション.

829 :login:Penguin:05/02/02 23:18:58 ID:vntfjzPh
Vine Linux 3.1を使っている方に聞きたいのですが
私の環境では24時間以上使い続けているとゾンビプロセスが発生します。
調べてみますと親のプロセスがcronで子のプロセスがsendmailでした。

rpm -q sendmail
と売ってみたところインストールされていないと表示されました。

しかし/usr/sbin/に実行形式でsendmailが入っていました。
ゾンビプロセスの所有者がrootでしたので、cronの設定に記述されていると思い
crontabでrootのリストをみてみましたら何も記述されていませんでした。

ゾンビプロセスを発生させたくないため、何とか設定を書き換えたいのですが
どのようなことをすればよろしいでしょうか?


830 :login:Penguin:05/02/02 23:24:13 ID:/kaYv722
>>829
/etc/cron.daily
/etc/cron.hourly
/etc/cron.weeklyも

831 :login:Penguin:05/02/02 23:39:49 ID:3WvJNMg2
> rpm -q sendmail
> と売ってみたところインストールされていないと表示されました。
>
> しかし/usr/sbin/に実行形式でsendmailが入っていました。

$ rpm -qf /usr/sbin/sendmail

832 :login:Penguin:05/02/02 23:42:03 ID:a0CDC7ur
>>824
自信ないならわざわざ書くなよ
しかも最後にゃ訳分からん言い訳。
この手の書き込み最近目にするけど
お前か?

833 :829:05/02/02 23:43:14 ID:vntfjzPh
>>830
ご指定のディレクトリをみましたが、実行形式でいくつかファイルがありました。
その中身をみていましたが、sendmailの記述はみられませんでした。

anacronの仕組みはまだ理解しておりません。
anacronの設定ファイルの記述をみてみましたが、ご指定のディレクトリに対して
実行頻度と時刻が明記されているだけでした。

大変気になるのは/usr/sbinにsendmailが入っていることです。
インストール時にデフォルトで入っているものでしょうか?

ハックされている気もするのですが。

834 :login:Penguin:05/02/02 23:49:36 ID:/kaYv722
>>833
俺の中のVineの常識では、
最初から、そして、どのrpmにも属せずに入っているものだよ。

anacronはcronを補完するものだね。ノートとか電源を切っていることが
多いマシンではcronが何かしようと思っても電源が切られていて出来ないことがある。
anacronは必要な仕事がおこなわれていなければ、その仕事を実行し、
既にその仕事が終わっていれば何もしない、という仕様を実現してくれる。


835 :login:Penguin:05/02/02 23:52:56 ID:p5trtM26
>>833
>>831を何故無視する・・・

836 :login:Penguin:05/02/02 23:58:48 ID:/kaYv722
>>835
>>831の人、スマン、俺嘘書いたよ。>>834は何か他のディストリのことだな。


837 :829:05/02/02 23:59:50 ID:vntfjzPh
>>831

どうもコマンド実行が間違っていたようです。
実行しましたら、postfix-2.0.20-0vl5ということが判明しました。
ありがとうございます。

postfixは停止してありますので

>>830
でご指摘がありました、/etc/cron.daily/の中にpostfixというファイル名が
あるのでそれが原因かもしれません。

>>832
anacronのご説明ありがとうございます。
参考になります。
自分で詳しく調べてみたいと思います。

>>833
送信後に返信に気づいた次第です。
無視しているわけではないです。


838 :829:05/02/03 00:03:55 ID:NGXRmRPV
途中で送信してしまいました。

色々情報をいただきありがとうございます。
どうもまだまだ、覚えることが多そうです。

自分で調査してみて、がんばってみようと思います。
ありがとうございました。


839 :812:05/02/03 00:05:04 ID:IYituDbc
Vine の前にFedoraをインストールしてみたら、起動せず…
丸一日かけて3回もインストールするも、なぜか動かず…

Vineは少し古いようですが、やっぱりVineにしようと思います orz
Knoppixっていいのかな。。。

Linux初心者です。DOSの知識はあるので、コマンドはすぐなじめそうですが。。。

840 :login:Penguin:05/02/03 00:17:17 ID:Hpnl4O5P
>>839
まだカーネル2.6はガタガタしてるので
Fedoraが起動しないマシンにVineを選択するのは最適だと思います。

841 :login:Penguin:05/02/03 00:23:53 ID:1X8CAnDi
DOSの知識というと
copy con autoexec.bat
とか?

842 :login:Penguin:05/02/03 00:28:45 ID:D6RuAOvu
vine3.1ですが、キャプションのフォントって項目は何で変更できないのでしょう?

843 :812:05/02/03 00:35:41 ID:SEiofb6d
>>840

入門にはVineはおすすめらしいので、Vineで覚えていこうと思います。

>>841

そうです。
パイプとかリダイレクトとか、grep とかもそうですね。

Linuxは、ものによってコマンドがいろいろある(?)ので少し戸惑ってます。

ネットワーク関係の使い方を覚えたいと思ってます。

けど、windowシステム(?)を使うとウィンドウとあまり変わりないので、
できればコマンドのほうを。。

844 :login:Penguin:05/02/03 00:47:54 ID:AMD34OdW
postfixは少し敷居が高い気がするなぁ。
ネットでも参考資料があんまし見つからないし全然わかんね。

設定弄っててなぜか送信できたりなぜか送信できなくなったり。
明日本を立ち読みしてくる。
とにかくコレが出来ればレベルアップできそうだってのが嬉しかったりする。

845 :login:Penguin:05/02/03 01:59:04 ID:tT3oLhvm
>>844
AMDおめ

846 :login:Penguin:05/02/03 07:49:58 ID:XeK0m+tq
日記帳書いてるヤツ、初心者版かくだ質へいけよ。

847 :login:Penguin:05/02/03 07:54:53 ID:geRfUiLr
> postfixは少し敷居が高い気がするなぁ。
> ネットでも参考資料があんまし見つからないし全然わかんね。

嘘はいかんと思う。

848 :login:Penguin:05/02/03 08:31:02 ID:r5qKLm45
>>844
Postfixで敷居が高いなんていったら、Sendmail使ったら脳がシェイクされちゃいますよ。

849 :login:Penguin:05/02/03 12:10:00 ID:CoWZXsfh
同意。sendmail.cfは古代言語のノリだと思った。

850 :login:Penguin:05/02/03 12:37:50 ID:TZIj1hMt
こうもり本(゜д゜)<あらやだ!

851 :login:Penguin:05/02/03 13:28:57 ID:DV2EejXJ
Vine Linux 3.1 (kernel#2.4.27-0vl7.3) を使っています。
「apt-get dist-upgrade」を実行すると、下のように表示されます。
これはアップグレードしても問題無いのでしょうか?
よろしくおながいします。

 | [root@dhcppc0 root]# apt-get dist-upgrade
 | パッケージリストを読みこんでいます... 完了
 | 依存情報ツリーを作成しています... 完了
 | アップグレードパッケージを検出しています... 完了
 | 以下のパッケージがリプレースされます:
 |   php (by php5-apache)
 | 以下のパッケージが削除されます:
 |   php-apache php-pear
 | 以下のパッケージが新たにインストールされます:
 |   php5 php5-apache php5-pear
 | アップグレード: 0 個, 新規インストール: 3 個, リプレース: 1 個, 削除: 2 個, 保留
 | : 0 個
 | 4941kB のアーカイブを取得する必要があります。
 | 展開後に 2180kB のディスク容量が追加消費されます。
 | 続行しますか? [Y/n]


852 :login:Penguin:05/02/03 13:39:48 ID:EPCJUSUq
>>851
何がわからんの?

853 :851:05/02/03 13:41:02 ID:DV2EejXJ
>>852
「dist-upgrade」ですので他のアプリケーションとの競合や現在のバージョンで
正常に動かないなどのトラブルが発生しないかを教えて頂きたいのです。


854 :login:Penguin:05/02/03 13:43:36 ID:r5qKLm45
>>853
アホかw 久々にワロタ

そんなの人によってインスコしてるパッケージが違うのにトラブルが起きるかどうかなんてわかるかよw

855 :login:Penguin:05/02/03 13:45:47 ID:r5qKLm45
ところで、現在Solaris10をインスコ中。
インストーラの日本語化は完璧。GeForce5700で何も設定せずにGUIモードでインスコできた。

856 :login:Penguin:05/02/03 14:19:56 ID:ebJJceD4
つ [ちらし]

857 :login:Penguin:05/02/03 14:41:51 ID:p2sWgtLm
>>856
最近のちらしは両面印刷だからな〜
その影響がこんなところにもでているとは

858 :login:Penguin:05/02/03 15:09:27 ID:XeK0m+tq
つ [トイレットペーパー]

859 :login:Penguin:05/02/03 16:46:29 ID:rcn6R2IH
VineLinux3.1 i386版を使ってます。
http://debian.fam.cx/index.php?Tips#content_1_3
のページにあるような、全く同じパッケージ構成で
別のマシンにインストールするコマンドとかありませんか?

860 :login:Penguin:05/02/03 16:49:16 ID:1X8CAnDi
rpm -qa でパッケージを吐き出して、
apt-get install で突っ込むとか?
バージョンナンバーまわりで加工が必要かな。

861 :login:Penguin:05/02/03 16:53:47 ID:w1EL1Jkb
Desktopマシンとしての日本語環境に期待して入れてみた@3.1

メーラーがだめだめ、、>Sylpheed1.0.0-0vl0.beta1
beta1ってなんなんですか?
こりゃ、サンダバにかえるっきゃないか

おまいら何使ってる?

862 :login:Penguin:05/02/03 16:56:12 ID:Hpnl4O5P
>>859
簡単なスクリプトで出来る


マシンAでrpm -qa > rpmlist.txt
マシンBのrpmの置き場所で
for i in `cat rpmlist.txt`; do
rpm -q "${i}">/dev/null
if [ $? -ne 0 ]; then
rpm -Uvh "${i}*" --nodeps
fi
done

同じrpm名でi386とかi586とかnoarchとか複数ある場合があるから
本当に実行する場合はその辺考慮して下さい。

863 :login:Penguin:05/02/03 16:57:53 ID:xb2M03HD
>>861
1.0.0以降にしろ or sylpheedダメ過ぎ ?


864 :859:05/02/03 16:59:27 ID:rcn6R2IH
>>860さん862さんありがとうございました。
今別マシンをインストール中なので、完了したら
是非試してみます。本当にありがとうございました。

865 :login:Penguin:05/02/03 17:01:32 ID:Hpnl4O5P
>>861
3.1がリリースされた時点ではまだsylpheed1.0.0は出てなかったんだから
仕方がないでしょ。

自分は1.0.0に入れ替えて使ってますよ。

866 :login:Penguin:05/02/03 17:15:46 ID:+dhwlEQE
>>855
個人的に大変興味がある話だが
いかんせん板違い

867 :login:Penguin:05/02/03 17:18:47 ID:xb2M03HD
>>865
aptで拾えるように3.1のupdateに置いて欲しい...


868 :login:Penguin:05/02/03 17:31:28 ID:nk/Yz52i
OOoでちゃんとdocが読めるぞ、すげーなー
と感動


869 :login:Penguin:05/02/03 17:37:06 ID:prJNnVEa
>>867
[VineSeed:09706] 予告: sylpheed-1.9.0, gpgme-1.0.2

>sylpheed-1.9.0 がリリースされたら、gpgme-1.0.2 と一緒に put したいと思
>います。
>
>sylpheed の変更点は、
> - GTK2 版
> - 依存関係の修正
> - ソースに含まれる desktop ファイルを使用
> - htmlview を標準の Web ブラウザとして使用
>です。

870 :login:Penguin:05/02/03 17:38:28 ID:1X8CAnDi
>>869
それ、次の開発版じゃないの?
バージョン 1.9.0 だし。

871 :login:Penguin:05/02/03 17:46:08 ID:Hpnl4O5P
>>870
もちろんそうですよ。
From: Hiroyuki Yamamoto <hiro-y@kcn.ne.jp>
To: sylpheed-jp@good-day.net
Reply-To: sylpheed-jp@good-day.net
Subject: [sylpheed-jp:02806] Sylpheed 1.9.0 (development) released
Date: Tue, 1 Feb 2005 18:51:56 +0900
X-Mailer: Sylpheed version 1.9.0 (GTK+ 2.4.14; i686-pc-linux-gnu)

山本です。

Sylpheed 1.9.0 (development) をリリースしました。

まだあくまで開発版という位置づけなので、それを踏まえた上で使用してください。

変更点:

* 最初の開発版リリース。
* GTK2 へ移行:
- 多言語(m17n)に対応。
- キャッシュや設定ファイルを含めて、内部エンコーディングを全て
UTF-8 で処理するようにした。
- フォントのアンチエイリアス表示に対応。
- フォント管理に関わる多くの問題を解決。
- 多くの点でユーザインタフェースを改善。
* gpgme-1.0 に対応(Toshio Kuratomi さん thanks)。
- 暗号化用の鍵が信用されていない場合は警告を表示するようにした。
- 署名の正当性をより詳しく表示するようにした。
- ネストされたマルチパート中の署名を認識するようにした。

--
Hiroyuki Yamamoto <hiro-y@kcn.ne.jp>

872 :login:Penguin:05/02/03 17:50:19 ID:1X8CAnDi
>>871
Seedはともかく、3.1に必要なのは安定版でしょ。

873 :login:Penguin:05/02/03 17:53:13 ID:1X8CAnDi
補足すると、>>867 は 3.1 に 1.0.0 が欲しい、と言っているのに、
>>869 が Seed の 1.9.0 を引き合いに出すのがよく分からんのだが。

874 :login:Penguin:05/02/03 18:05:52 ID:Hpnl4O5P
ちなみに1.0.1が出ました。

Subject: [sylpheed-jp:02807] Sylpheed 1.0.1 (stable) released
Date: Tue, 1 Feb 2005 18:55:24 +0900
X-Mailer: Sylpheed version 1.9.0 (GTK+ 2.4.14; i686-pc-linux-gnu)

山本です。

Sylpheed 1.0.1 (stable) をリリースしました。

変更点:

* gpgme-1.0 に対応(Toshio Kuratomi さん thanks)。
- 暗号化用の鍵が信用されていない場合は警告を表示するようにした。
- 署名の正当性をより詳しく表示するようにした。
- ネストされたマルチパート中の署名を認識するようにした。
* POP3 セッションが中断した後メッセージを重複して取得しないようにした。
* その他バグ修正。

875 :login:Penguin:05/02/03 18:08:18 ID:g66vG38j
>>867 >>872-873 補足というよりも蛇足かもしれないけど。

Sylpheed は Plus じゃなくて main のパッケージだから
Bug とか セキュリティホールとか見つかるまでは、
バージョンアップされないはず。

3.2 のリリースとかみたいな Vine 自体のバージョンアップがあれば
いろいろまとめてあがるかもしれないけど。

876 :861:05/02/03 18:11:21 ID:w1EL1Jkb
サンダーバードいれちゃったよ、、
POP/SMTP over SSL, APOP, SMTP AUTH、全部対応してるし
しばらく使ってみる


877 :login:Penguin:05/02/03 18:20:55 ID:jog96lle
スクリプト で --nodeps 使うなんて壊杉、、、

878 :login:Penguin:05/02/03 18:56:36 ID:Y68p3mPF
>>876
Thunderbird完成度高いと思うよ。
慣れちゃったからどうしてもSylpheedじゃなきゃっていう人でないなら
Thunderbirdおすすめ。

879 :login:Penguin:05/02/03 19:32:52 ID:68Kpp1M5
>>878
スレ違いな質問なんだけど、Sylpheedに比べてThunderbirdが
優れている点て何がありますか。Sylpheedじゃなきゃっていう人では
ないけど、Sylpheedに乗り換える程の不満がないので教えて頂け
ませんか。

880 :login:Penguin:05/02/03 19:49:10 ID:RZKbMlJo
仕事場のマシンでMRTG動かしているのです、やたらとメモリ食ってしまってます。

RHL8.0で動いているMRTG2.10.15は
18 0 10280 8844 1856 S 0.0 1.7 4:35 mrtg

このようにあまりメモリ食ってないんですが

Vine3.1で動いているMRTG(2.10.15 2.11.0 .2.11.1 3つ試しました)
10 0 12300 12M 1824 S 0 0.0 3.1 0:12 mrtg
とやたらメモリ食ってます、その上5分間隔でグラフ作ってるのですが、そのたびにメモリ
が大きくなってきて、半日でメモリ300MB位食いつぶしてしまいます。

daemonで動かさなければ問題なのですが、daemonだと結構CPUに負担がかかってできれば
daemonで動かしたいと思ってます。

同じ経験された方いますでしょうか?

インストールはソースからコンパイル

881 :880:05/02/03 19:57:58 ID:RZKbMlJo
途中で書き込んでしまいました。

インストールはソースmakeして特にエラーもでません。

もちろんmrtg実行時にも特にエラーでてません。

882 :login:Penguin:05/02/03 20:08:35 ID:Hpnl4O5P
>>877
他のマシンの構成のコピー、しかも、新規インストール直後
におこなうのなら
怖いという表現にはあたらないと思います。

ここで--nodepsを付ける意味は、正しくない構成にする為ではなく、
スクリプトの中でrpm一個ずつインストール可能とする為です。
そこんとこ誤解なきように

883 :login:Penguin:05/02/03 20:09:54 ID:XeK0m+tq
>daemonで動かさなければ問題なのですが

日本語を先に勉強なおした方が、良さそうな気がするが・・
Vineのパッケージの問題ではないし、先にMRTGのスレに逝くべきだとも思うが、

とりあえず、手元で動いてるVine3.1では、mrtg-2.11.1+rrdtoolが入ってるけど
リソースリークは起きてないな。

そもそもCPUに負荷って、何のCPUでどれだけプロービングしてるんだ?
値を取得しているSNMPなりシェルスクリプト側の問題とちゃんと切り離してから
mrtgが問題と認識して書き込んでるの?


884 :login:Penguin:05/02/03 20:15:19 ID:Hpnl4O5P
>>882
くどいけど念を押しておきます。

当然ながら、コピー元のマシンから正しいrpmパッケージ構成を
持ってくることが前提です。言うまでもないことですが

885 :login:Penguin:05/02/03 20:21:53 ID:J7Zay9Wb
>>884
rpm パッケージの構成が正しくても、--nodeps なんて使ったら PreReq が無視されて、
インストール前後に実行されるスクリプトが正しく実行されないよ。

886 :login:Penguin:05/02/03 20:37:06 ID:Hpnl4O5P
>>885
ここは難しいところだな。

実際のところPostのスクリプトが他のパッケージのファイルに影響を受ける例は
殆どない。今回は基幹パッケージ自体は普通にインストールする予定だし

でもrpmのリストをsortした上で、--nodepsなしで実行するのが安全だろうな。

基幹パッケージはインストール済みなんだから--nodepsなしでもインストールできない
ものは殆どないだろう。

>>859さん、訂正です。




887 :login:Penguin:05/02/03 20:38:39 ID:RZKbMlJo
>>883
すみませんタイプミスです。
「問題ないのですが」です。

CPUの負荷は5分ごとに一瞬80%程度まで上がります、問題ないと言われれば、そうなんですが
daemonでは目立ったCPUの負荷はないので。

MRTGスレの方がよかったかもしれませんね

RHL側とVineマシンがわでsnmpともにnet-snmpでcfgファイルもほぼ同じ内容です。

888 :login:Penguin:05/02/03 20:55:42 ID:RZKbMlJo
>>887
CPUはPen3(Katmai)500Mhz
メモリ 384MB
5分間の平均で1%上がる程度です。
(RunAsDaemonと比較すると)

889 :login:Penguin:05/02/03 22:23:19 ID:AMD34OdW
>>848
たぶん煙出てきますよ。
Postfixスレでも読んでくるよ。
ノシ

890 :login:Penguin:05/02/04 01:05:24 ID:hCMzDkWP
結局よく分からずとりあえず設定をリフレッシュしようと思い
#apt-get remove postfix
#rm -fr /etc/postfix/
#apt-get install postfix
と入れなおして
ほぼここの通りにやってみました。
ttp://acorn.zive.net/~oyaji/mail2/postfix.htm
一応変更部分を抜き出して書いてみます。

>myhostname = jtoku.dip.jp
>mydomain = dip.jp
>myorigin = $mydomain
>inet_interfaces = all
>mydestination = $myhostname, localhost.$mydomain, $mydomain
>mynetworks_style = class (とりあえずsubnetもやってみた)
>alias_maps = hash:/etc/postfix/aliases
>alias_database = hash:/etc/postfix/aliases
>mail_spool_directory = /var/spool/mail

です。
ちなみにルータ介してますが、これが曲者で「自IPを参照しても参照出来ない」とのこと。
http://pc5.2ch.net/test/read.cgi/hard/1104138424/6
お手上げです。

891 :login:Penguin:05/02/04 01:06:44 ID:hCMzDkWP
失礼しました。
当方の環境は
Vine Linux 3.1です。

892 :login:Penguin:05/02/04 01:19:02 ID:hCMzDkWP
メールクライアントの方で
アカウントの設定でメールアドレスをuser@192.168.0.10とやっていたのがダメだったようで、
user@jtoku.dip.jpにしたら上手くいきました。

ほんっとバカでした。
失礼しました。

893 :login:Penguin:05/02/04 02:15:34 ID:z6YjcWR0
みんなどうせGnomeとかKDE使ってるんでしょ

コンソールでほかにテキストエディタとかないのかなぁ
viとかemacs以外で。

ソフトはDOS以下だね。。。

894 :login:Penguin:05/02/04 02:19:20 ID:Ezs2fBm5
>>893
http://www.vector.co.jp/vpack/filearea/unix/writing/edit/index.html

895 :login:Penguin:05/02/04 02:21:32 ID:z6YjcWR0
いや、探したんだけど、
結局、viとemacsの2系統しかないよね…

コンソール用ほとんどないし


896 :login:Penguin:05/02/04 02:21:37 ID:s/cWZ+bC
Vz党にはneがおすすめだよもん

897 :login:Penguin:05/02/04 02:23:56 ID:z6YjcWR0
そっか、ありがとう

ためしてみるよ

898 :login:Penguin:05/02/04 02:26:08 ID:5NH5muzR
>>893
テキストエディタ何使ってますか?
http://pc5.2ch.net/test/read.cgi/linux/1017675477/1-100

899 :login:Penguin:05/02/04 02:44:19 ID:BrsopYai
>myhostname = jtoku.dip.jp
>mydomain = dip.jp

これはおかしい。dip.jp を持ってるのかと。

900 :login:Penguin:05/02/04 06:19:37 ID:I2SQdKqZ
>>875
セキュリティーホールはともかく、
bugは見付かってるんじゃない?

901 :not 890:05/02/04 06:22:28 ID:I2SQdKqZ
>>899
mydomain = jtoku.dip.jp
myorigin = dip.jp
でいいのかな。

902 :login:Penguin:05/02/04 11:27:51 ID:TO5pHIm7
>>895
jed

903 :login:Penguin:05/02/04 12:55:38 ID:Dx61F4ni
jedも操作系はemacs的だけどね

904 :login:Penguin:05/02/04 13:00:31 ID:XbjxpaUV
二台のVine3.1が入ったPCで、あるディレクトリの中身をメインのマシンからサブのマシンへ
ftpでコピーさせるスクリプトをcronで実行させたところ、何故か途中で止ってしまいます。

同じスクリプトをコンソールから手動で動かすと何の問題もなく最後まで実行されるのですが、
cronでは何度やっても数個〜100個前後のファイルを転送したところで中断してしまうのです。

全く実行されないということならば、cronまたはスクリプトの設定ミスということも考えられるのですが、
「途中で止る」というのがどうにも理解できません。
前述の通り、コンソールからの実行では数万個(数100GB)レベルのファイルでも問題なく転送されるため、
NIC等のハードウェア面でのトラブルとも考えにくいところです。
どのような原因が考えられますでしょうか?

また、恐らく中断時に何らかのエラーメッセージが出ているのではないかと思うのですが、
/var/logの各ファイルを見てもそれらしいものは見当たりません。
cron(root権限)実行時のエラーメッセージはどこに保存されるのでしょうか?

905 :login:Penguin:05/02/04 13:02:28 ID:P0Ntf7o1
>>904
root宛てのmailにエラーが送信されてるはず。

906 :902:05/02/04 13:24:01 ID:TO5pHIm7
>>903
設定を弄ればWordStar風に変えられるょ

907 :login:Penguin:05/02/04 17:08:54 ID:mb/pMEcj
PPC版のisoイメージってどこにあるの?

908 :login:Penguin:05/02/04 17:49:25 ID:PCf3QCAY
>>906
WordStar風っておぃ、同年代か。

909 :login:Penguin:05/02/04 18:11:41 ID:+WNC9Gxf
MIFESなんてのもあったな

910 :login:Penguin:05/02/04 18:33:50 ID:u6TTPtPI
red とか WordMaster とか・・・
古すぎ。
Mifes はまだ使ってたりする。
for Win V6 w

911 :login:Penguin:05/02/04 19:11:14 ID:YjJn8XI+
>>904
ftpが15分でタイムアウトしているとか?

912 :904:05/02/04 19:48:49 ID:XbjxpaUV
早速のご返答どうもです。

>>905
ファイルサーバ用途で、samba と proftpd 以外ほとんど何も使ってないんで、MUAは何も入れてません。
メールは /var/spool/mail に入るのでしたっけ?
一応見ましたが、ここには何も入ってません。
メール以外には何も痕跡は残らないものでしょうか?

>>911
同じスクリプトが手動起動ならば、何時間かかってもきちんと転送してくれるので、
それはありえないと思います。

ちなみに中断されたあと、手動でスクリプトを実行すると、大抵最後のファイルの restart から
はじまるので、やはり何らかの理由で転送中に遮断されているようです。

二台のPCはeth1に1mのクロスケーブルで直結されています。
NICは両方 Intel Pro 1000MT。
CPUはメインが P4-530(prescott) とサブが Xenon 2.0GHz。
マシンパワー的にも特に問題が出るとも思えない状況です。

913 :login:Penguin:05/02/04 19:58:41 ID:+WNC9Gxf
とりあえず、logをdebugレベルまであげてみたら?

914 :login:Penguin:05/02/04 19:59:45 ID:UyDDsSwM
>>912
mailx はデフォで入ってるはずなので、
su - して mail って打ってみたらどんな感じ?

915 :904:05/02/04 20:48:50 ID:XbjxpaUV
>>913
というのは、dmesg -n 7 を実行すればよろしいのでしょうか?
(ほとんど初心者なので、すみません)

>>914
No mail for root でした。


916 :login:Penguin:05/02/04 20:49:03 ID:PCf3QCAY
$ sudo apt-get install libgnomemm
パッケージリストを読みこんでいます... 完了
依存情報ツリーを作成しています... 完了
いくつかのパッケージをインストールすることができません。おそらく、
ありえない状況を要求したか、(必要なパッケージがまだそろっていなかっ
たり、まだIncomingから移動されていない)不安定なディストリビューション
を使用していないでしょうか。

単純な操作だけを行った時に、パッケージがインストール
できない場合は、バグリポートしてください。
以下の情報がこの問題を解決するために役立つかもしれません:

以下のパッケージは解決できない依存関係を持っています:
libgnomemm: 依存: libatkmm-1.0.so.1 それをインストールすることができません
依存: libgdkmm-2.0.so.1 それをインストールすることができません
依存: libglibmm-2.0.so.1 それをインストールすることができません
依存: libgtkmm-2.0.so.1 それをインストールすることができません
依存: libpangomm-1.0.so.1 それをインストールすることができません
E: 壊れたパッケージです

Vine3.1な人、俺だけじゃないよね?

917 :904:05/02/04 20:49:22 ID:XbjxpaUV
先ほど、cronで件のスクリプトが、この一週間で初めて最後まで動作しました。
特に何も設定を変えてないんですが。
(睨みつけてれば働くのか? 藻前は……)

今後のこともあるので、原因はちゃんと解明しておきたいところですので、
引き続きご教示頂ければ幸いです。

# 再発してくれないと原因究明は難しいかもしれない…

918 :login:Penguin:05/02/05 00:12:04 ID:3w0McSJL
Sylpheed1.9.1が来た。Gtk+2のエディタウィンドウの問題(>>611)のせいでメール
が無茶苦茶書きにくくなった。Seedってなんだかんだいって問題ない(自己解決で
きる範囲)だったけど、今回は、情報なさすぎて、どうしたらいいんだー。

919 :login:Penguin:05/02/05 01:07:04 ID:tKHDZYfW
>>879
Thunderbirの優れている点。
 ・Windows上でも走る。
Thunderbirdの欠点
 ・Inbox形式である。

Sylpheedの優れている点
 ・Mailbox 形式である。
Thunderbirdの欠点
 ・Windows用バイナリの開発が頓挫している。

できれば統一したいだけに、悩ましいところだ。

920 :login:Penguin:05/02/05 01:09:54 ID:izvIvE0Z
>>919
sylpheedはMHも使えるし、
IMAPにも対応している(まだまだ発展途上だが)

921 :login:Penguin:05/02/05 01:14:32 ID:ktbv4fva
>>919
Sylpheedは欠点が無いのか

922 :login:Penguin:05/02/05 01:16:11 ID:pP7cGSac
firefoxがsudoしないと起動しないんですけが
/usr/local/firefoxにインストールしているんですが

923 :login:Penguin:05/02/05 01:23:14 ID:3cV2do9B
>>904
ftpじゃないとだめ?
rsyncで代用できない?

924 :login:Penguin:05/02/05 01:39:54 ID:LD14uPgX
>>918
sylpheed-1.9.1でCanna使ってカナ変換をするのに、
Ctrl+nだと変換しないよね?まさかうちだけ?

925 :919:05/02/05 02:13:20 ID:tKHDZYfW
>>921 汗。なんか支離滅裂、意味不明になってますね。

Thunderbirdの優れている点。
 ・Windows上でも走る。
Thunderbirdの欠点
 ・Mailbox形式(Inbox形式)である。

Sylpheedの優れている点
 ・Maildir形式(MH形式)である。
Sylpheedの欠点
 ・Windows用バイナリの開発が頓挫している。

これであってますか? (w

とにかく、私としては、メールは、個別にファイルとして保存して欲しいわけですが、
WinとLinuxの双方で、同じMUAを使いたいのです。

926 :login:Penguin:05/02/05 02:27:18 ID:40zV7Z3w
>>925
ありがとうございます。参考になりました。たしかに、
WinとLinで共通に使えるのは大きいですね。
自分の環境では、Windowsではメールは読まない
のですが、親のサポートを考えるとその辺も大事に
なってきますね。

927 :login:Penguin:05/02/05 02:47:52 ID:mQF/g8YQ
>>918
これは XkbDisable を無効にすればなんとかなるだろ。
GNOME 2.8 だと XKB がなんとかって言われるけど、
デスクトップの設定→キーボードで、正しいレイアウトを選択(デフォルト値にリセット)
した後、ログインし直したら、言われなくなった。

XkbDisable のままが良いと言うならお手上げ。

928 :login:Penguin:05/02/05 03:33:08 ID:87/j6Zk8
>>927
ウホッ
あっさり直った。

929 :login:Penguin:05/02/05 14:01:23 ID:wjtQlovs
3.1インスコしようと思ったら、クロシコのATA133カードが認識しねぇ
2.6r4にもどすか...λ.....

930 :login:Penguin:05/02/05 18:22:49 ID:jlHayjix
3.1にWebminをインストールするのが面倒なのって直った?

931 :login:Penguin:05/02/05 18:33:07 ID:mQF/g8YQ
>>929
・kernel-2.4.27-0vl7 のソース取ってくる
・i386-BOOT.config を編集して、その ATA カードのドライバを組み込みにする。
・リビルド。
・CD-ROM の /isolinux/vmlinuz を、新しく作り直した kernel-BOOT の
vmlinuz-2.4.27-0vl7BOOT と入れ替える。
・mkisofs で CD イメージを作り直す。
で良いんじゃないか?
Vine 3.0 のβ版で PDC20269 に対応してなかった時は、このやり方でできた。
モジュールの入れ替えが面倒なので、バージョン・リリース番号はそのまま。

932 :login:Penguin:05/02/05 23:34:45 ID:izvIvE0Z
>>931
インスコ後の再起動以降のカーネルも
そのハードに対応していない場合はどうする?
CD内の該当カーネルrpmを入れ替えておく?


933 :login:Penguin:05/02/06 00:21:35 ID:F2ebrtDq
>>932
i586,i686,athlon UP 用の config では、CONFIG_BLK_DEV_SIIMAGE=y になってるけど、
これと違う?
# 他の config は見てない。

934 :login:Penguin:05/02/06 00:23:14 ID:LNXv3pET
とりあえず通常のM/BのATAにつないで、
作業終わってからATA133につなげばいいんじゃねーの?

935 :login:Penguin:05/02/06 00:32:45 ID:ydOugNPC
>>933
>>932は個別の場合について聞いているんじゃないよ。

>インスコ後の再起動以降のカーネルも
>そのハードに対応していない場合はどうする?
そういうハードウェアの場合はどうする?という意味の質問

>>934
それも出来ない場合の質問
そもそも、そんなことが出来るなら>>931自体必要ないだろ

936 :login:Penguin:05/02/06 00:39:55 ID:F2ebrtDq
>>935
やはりそうだったか。
その場合は、
・kernel パッケージも入れ替えて CD を作る。
・インストール後にレスキューモードや KNOPPIX などを使って入れ替える。
・諦める
かな?

937 :login:Penguin:05/02/06 00:41:34 ID:ydOugNPC
>>935
ていうか、>>932が質問すること自体がおかしいよなあ
>>932の4行目が質問の答えであることは間違いないんだから

>>932は質問形式じゃなくて>>931の補足として書くべきだったな。

938 :login:Penguin:05/02/06 04:40:16 ID:vrKMR1lz
3.xってEmacsの設定がバグだらけだけどなんかあったのか?

939 :login:Penguin:05/02/06 07:03:44 ID:fAfasYTB
>>938
例えば?

940 :login:Penguin:05/02/06 09:24:59 ID:wmEui9fo
>939
C-lが効かなくなるとか突然コントロールキー自体を受け付けなくなるとか
起動時にエラーが出るとか(setq yahtml-fill-column nil)がデフォルトで無視されるとか

そんで.emacs.elの命令を大量にコメントアウトしたらエラーが出なくなるとか

941 :名無しさん@Vim%Chalice:05/02/06 12:37:29 ID:ZbA8NEY2
なんかvfatをrwでmountしてあるはずなんだが、書き込み作業を
行おうとすると、それまで書き込めていたのに突然
書き込み許可の無いパーティションだ
# しょっちゅうじゃないので再現出来ず正しいエラーメッセージ
# は分からんm(__)m
とかえらーメッセージが出て書き込めなくなる時がある。
皆さんそんなことないですか?
kernelはaptで取ってきた最新の2.4.27を使っていますが。

942 :login:Penguin:05/02/06 12:45:48 ID:lM/Yyn4R
>>941
/var/log/messages に何か出てると思う。
過去分も少し rotate で残ってると思うので、確認きぼん。

943 :login:Penguin:05/02/06 14:11:11 ID:6t9mMOJ+
Vine Linux と WindowsXP SP2 を両方入れようかと思うのだが
どっちを先に入れるほうがいいのかな??

944 :login:Penguin:05/02/06 14:21:07 ID:LoEPud5S
>>943
ブートローダに LILO が使いたいなら Windows → Linux
NTLDR が使いたいなら Linux → Windows が良いかな。

ちなみに、Windows インストーラのパーティショニングには少々難があって、
漏れは第1パーティションのすぐ後ろに拡張パーティションを作られるのが嫌だから
まず最初に Linux のインストーラでパーティションだけ切って、それから
Windows → Linux の順で入れる。
# そしてその直後 grub に走る

945 :login:Penguin:05/02/06 15:10:31 ID:ydOugNPC
>>944
あまりそのレスは誉められないな。

NTLoaderでマルチブートするのはWindowsの提灯ライターしか勧めない
糞な方法だし、liloをMBRにインストールすると、Windows(9x,XP,2003)の
インストーラとかに上書きされたときの復旧が大変(事前に準備しとかないと)

勧められるのはMBRにインストールするローダーとして
MBM(http://elm-chan.org/fsw/mbm/mbm.html)を使う方法

●Linuxのインストール時にブートローダー(grubでもliloでも)は、/とか/bootパーティション
 インストールする。(どのディス鳥でも高度な設定とかでそのようなことが可能)
●NTLoaderをマルチブートには使用しない。Windows系OS(9x系、NT,2000,XP,2003)のマルチブート
 にもMBMを使用する。

そしてMBMをいつでも再インストール可能なようにCDとかFDとかを用意しておく。

そうしておけば、いつMBRを何かの拍子に上書きされても、MBMを再インストールするだけで
回復する。(MBMのインストールは一瞬で済む)
再設定とかは不要←これが一番大事

ここも参考に
http://pc5.2ch.net/test/read.cgi/linux/1106304664/475
http://pc5.2ch.net/test/read.cgi/linux/1096733379/550,552

946 :login:Penguin:05/02/06 15:12:54 ID:ydOugNPC
>>945
MBMをいつでもインストールする手段を確保しておくと、
Windows、Linuxどちらを先にインストールしても良い

順番が縛られるなんてそんな馬鹿な方法を勧めるライターがいることが不思議!

947 :login:Penguin:05/02/06 15:30:01 ID:6t9mMOJ+
MBM?

948 :login:Penguin:05/02/06 15:31:04 ID:lM/Yyn4R
MBM なんて不思議なものを使う人がいるのも問題かな。


949 :login:Penguin:05/02/06 15:36:05 ID:mxJ4tTMN
MBM をインスコした FD を常に一枚は用意しておくよ漏れは。

950 :login:Penguin:05/02/06 15:43:10 ID:/6QRHUGq
MBMはクソオタがブート画面にオタ絵を表示するために使う代物。
こんなものを他人に薦める時点で、手段と目的を履き違えてるよ。


951 :login:Penguin:05/02/06 15:44:17 ID:LoEPud5S
grub FD なら用意してるよ漏れは。

952 :login:Penguin:05/02/06 15:47:05 ID:ydOugNPC
MBMじゃないといけないと言うわけじゃないよ。
MBMと同等の機能、仕様を持ったブートローダーは他にもあるよ。
まあMBMを優秀なブートローダーの代表として扱っているわけ

grubとMBMは一長一短だよ。
ただMBRにインストールするブートローダーとしてはMBMのほうが適任だよ。
選択したパーティションをアクティブにし、そのパーティションのPBRの
プログラムをコールするという仕事を設定なしにおこなえるという面でね。

grubはそんな簡単なことをおこなわせるだけで、設定ファイルが必要だし、
どこかのパーティションを利用する必要がある。

NTLoaderはお話にならない。まず第一にMBRにインストールする物じゃないし、
選択したパーティションをアクティブにすることさえできないし、
PBRのプログラムをコールすることもできないから事前にPBRのイメージを
吸い出しておかないとならない。全くWindowsの提灯記事にのみ出現する代物

953 :login:Penguin:05/02/06 15:51:07 ID:ydOugNPC
>>950
なんでそんなにねじ曲がった説明するのかな
殆どのMBMユーザはただの優秀なブートローダーとして使ってるよ。

954 :login:Penguin:05/02/06 15:56:04 ID:lM/Yyn4R
>>953
> 殆どのMBMユーザ

統計でもとった?

> 優秀なブートローダー

優秀であるか優秀でないかの評価基準きぼん。

ねじまがってるのはお前じゃないの?

955 :login:Penguin:05/02/06 16:00:12 ID:oOb8pbvN
MBMの賛成派と反対派がいるのはわかった。
反対派はMBMではなく具体的に何を押すのか明記した方が良くないか?

956 :login:Penguin:05/02/06 16:00:41 ID:ydOugNPC
>>954
マジレスする価値のない釣り師を相手にしても仕方がないのだが
そこを敢えて反論する。

じゃあ、
MBRにインストールするブートローダーとしてMBMより優秀なものをご存じなら
???が???の面で優秀です。っていう感じで説明してみせて下さい。

957 :login:Penguin:05/02/06 16:01:38 ID:lM/Yyn4R
NG ID:ydOugNPC

958 :login:Penguin:05/02/06 16:03:21 ID:LR8qLhqn
>>945のリンク先に行ってみたけど
アニメキャラに萎えるのは事実だな・・・
テキストメニューならなんとか使えそう


959 :login:Penguin:05/02/06 16:04:03 ID:ydOugNPC
>>957
ほら、やっぱり君、反論できないじゃないか

どうせ言わなくても君以外はlM/Yyn4RをNGにするよ。

960 :login:Penguin:05/02/06 16:06:08 ID:f7ySalVa
Vineスレらしくていいね♪

961 :login:Penguin:05/02/06 16:08:48 ID:uQmo0sZt
ID:ydOugNPCのようなキモヲタは出てくるなよ・・・

962 :login:Penguin:05/02/06 16:10:23 ID:eQuhzn2v
>>959
かわいそうなヤツだなw

963 :login:Penguin:05/02/06 16:10:48 ID:lM/Yyn4R
LILO なり GRUB なりが多く使われていて、マルチブートの方法として定番な
わけだよね。ハウツーなりノウハウも定着している。
また、LILO や GRUB はオープンソースで開発されていて、
何か問題があった場合に安全に対策できるという利点がある。

ところで一方、MBM は、ごく一部のユーザにしか使われておらず、
最終更新も 2002. 11. 5。作者が消えたり、何か問題があった場合は、
どうなるんだろうという不安がある。

ブートローダのことを良く理解していない人間に、いきなりマイナーな
ものを勧めるのはふさわしくないんじゃないかな?

ID:ydOugNPC は、MBM を勧める理由って何だろう?

964 :login:Penguin:05/02/06 16:12:57 ID:LR8qLhqn
趣味は人それぞれだよ
俺はアニメキャラには興味ないけど、
機能説明読んで、MBM自体には興味持ったよ
今は市販のブートマネージャ使ってるけど、
ちょっと試してみたくなったよ

965 :login:Penguin:05/02/06 16:13:38 ID:ydOugNPC
>>961
早速ID変えてきたか
uQmo0sZtもNGだな

MBMの画面をわざわざ変える暇人がそんなにいるわけがないだろう
殆どの人はブートローダーとして使うのみだよ。

966 :login:Penguin:05/02/06 16:15:21 ID:lM/Yyn4R
>>965
> 殆どの人は

「殆ど」と言うのなら根拠を示せと。
嘘健康食品の広告と同等ですよ?

967 :login:Penguin:05/02/06 16:16:02 ID:uQmo0sZt
>>965
MBM信者っているんだな・・・

968 :login:Penguin:05/02/06 16:18:41 ID:eQuhzn2v
>>965が必死な件について

969 :login:Penguin:05/02/06 16:19:14 ID:LoEPud5S
まぁ、grub は Linux の boot を PBR なしに行うことができるわな。
 grub → 起動

MBM は PBR への橋渡ししかできないよな。使ってないから分からんがおそらく。
 MBM → PBRのLILO → 起動

970 :login:Penguin:05/02/06 16:20:07 ID:ydOugNPC
>>963
ブートローダーが頻繁にアップデートされると逆に不安になるよ

勧める理由は先に書いたとおり、MBRにインストールするブートローダとしての
機能を様々吟味した結果だよ。といっても俺は長年使っているうちに良さを
確認できたという形だ。grubやliloも人一倍使っているよ。それらを比べた上で
書いている。MBMはMBRに、grubやliloはPBRにインストールして使い分けるのが
適当だよ。

971 :login:Penguin:05/02/06 16:22:34 ID:lM/Yyn4R
>>970
> ブートローダーが頻繁にアップデートされると逆に不安になるよ

ぼくもカーネルが頻繁にアップデートされると逆に不安になるよ。

> MBRにインストールするブートローダとしての機能を様々吟味した結果だよ。

どのような点を吟味したのか列挙してよ。

> 長年使っているうちに良さを確認できたという形だ。

そもそも良さとは何だろう?良いか悪いかの評価基準は?

> grubやliloも人一倍使っているよ。

人一倍とは?人一倍使ったことになる具備要件きぼん。

972 :login:Penguin:05/02/06 16:24:56 ID:ydOugNPC
>>967
信者じゃない
他のも使っているし、MBM、grub、lilo、NTLoaderの欠点も皆自分で体験して
知った上で書いている。

973 :login:Penguin:05/02/06 16:28:09 ID:x90dIDJR
Vine 3.1

グラフィカルにログインする設定にしました

事情があって,設定を変えずに
一時的にテキストでログインしたいんですが
どうすればいいのでしょう?

974 :login:Penguin:05/02/06 16:28:34 ID:yQqZ8xZK
結局みんな、自分の主観が基準、、

でもそれでいーんじゃない?

975 :login:Penguin:05/02/06 16:30:01 ID:LR8qLhqn
そそ
スレ違いだからもうやめてね

976 :login:Penguin:05/02/06 16:30:05 ID:mxJ4tTMN
>>973
/sbin/init 3


977 :login:Penguin:05/02/06 16:31:48 ID:LoEPud5S
>>973
Ctrl+Alt+F1〜F6のどれか

978 :973:05/02/06 16:37:18 ID:x90dIDJR
>>976 >>977

どのタイミングで??


979 :login:Penguin:05/02/06 16:38:40 ID:lM/Yyn4R
>>978
>>976 は、どこかのターミナルから。
>>977 は、X の画面から。

>>977 が安全かな。戻る時は、Alt+F7 くらいだったはず。

980 :login:Penguin:05/02/06 16:41:15 ID:HRN+475A
>>973
「設定を変えずに」といえるかどうかわからないが、
/etc/inittab の20行目くらいにある id:5:initdefaulte: の5を3に書き換える。

981 :973:05/02/06 16:43:34 ID:x90dIDJR
X 自体が画面にうつらないんです

1600 x 1200

で設定されていて,モニタはその解像度はダメなんです

それで,テキストではいって,設定を変えたいというわけです.

lilo の画面から,テキストログインを強制する方法はありませんか?

982 :login:Penguin:05/02/06 16:44:21 ID:lM/Yyn4R
lilo の画面だと、linux 3

983 :login:Penguin:05/02/06 16:44:49 ID:LR8qLhqn
>>981
その状態で Ctrl+Alt+F1 効かないの?

984 :973:05/02/06 16:45:07 ID:x90dIDJR
>>982

OK です

それがつかえそうです

985 :login:Penguin:05/02/06 16:48:26 ID:HRN+475A
>>981
LILOの起動画面で、「linux 1」と入力すると、シングルユーザーモードで起動する。
起動したら、mount -a を実行。
viで、>>980のヶ所を変更する。
一回再起動。
今度はテキストモードで起動するので、マターリxorg.confを修正。

986 :login:Penguin:05/02/06 16:50:00 ID:lM/Yyn4R
>>985
それって、モロ「設定を変え」てるじゃん。
シングルユーザモードて最近使ってないな。

987 :ヴァイン:05/02/06 21:27:54 ID:CUsJ/uRT
質問をする前に http://linux2ch.bbzone.net/ を読み
>>2 で調べ、スレの検索も忘れずに。

●前スレ
Vine Linux Thread 其の28
http://pc5.2ch.net/test/read.cgi/linux/1103908631/

●過去ログ検索 (Vine Linux Thread 其の13 75さん提供)
http://2chlinux.dtdns.net/2ch-linux-vine/

●VineLinux ホームページ
http://vinelinux.org/

●FTPサイト
http://vinelinux.org/getvine.html#ViaFTP


988 :login:Penguin:05/02/06 23:28:10 ID:87quySev
わっしょい

989 :login:Penguin:05/02/06 23:37:34 ID:ydOugNPC
>>963
俺が日頃お客さんのマシンでMBMを使っているLinuxerの為じゃないよ。
MBMはWindowsのマルチブート用として使ってる。
NTLoaderでは決して真似のできない機能があるから重宝しているんだよ。
マイナーなツールであろうと説明すれば問題なくお客さんは了承してくれます。

Linuxerは現在でもgrubやliloを使っていて、それが便利か不便かも気づかないくらい
当たり前として使っている。
俺の場合は昔からブート関係の知識があって、MBMはVectorで98年頃自ら見つけて使い始めた。
この類のツールを誰かの推薦もなしに使い始めるのはかなり技術寄りの人間でないと無理だと思う。
でも、推薦を受けて使ってくれる人は多いですよ。そんなもんですよ。
このスレの上では俺はここの住人に信頼されている筈もないから、好き勝手叩かれるけどね。




990 :login:Penguin:05/02/07 00:17:26 ID:XcotueuT
>>989
ブート関係の知識があるようには思えないが。
MBMならSmart Boot Managerの方が幾分マシだと思う。

Linuxを使う分にはgrubが一番重宝すると思うがね。
MBMはFSを読めないし。

991 :login:Penguin:05/02/07 00:47:47 ID:QniWgtv5
>>989
君がMBMを好きなのはよく分かったし
多分なにがしかのメリットもあるんだろうけど、
その調子で熱弁奮い続けられると
はっきり言って引くよ。
ちょっと時間置いてから書いてくれないか?

992 :login:Penguin:05/02/07 00:49:16 ID:PVQkDelE
次スレを立ててみました。
このスレッドが終了しだい移行をお願いします。>ALL

Vine Linux Thread 其の29
http://pc5.2ch.net/test/read.cgi/linux/1107704438/


993 :login:Penguin:05/02/07 01:33:23 ID:4G5FvGgL
>>989
NTLoader, lilo, grub, MBMの欠点や利点を比較して簡潔にまとめて
くれれば、みんなの参考になると思います。逆にそれを書いてくれないといくら
MBMを勧められてもわざわざ使おうとは思いません。ブートローダーに
詳しいようですので、分かりやすく説明して頂けると助かります。

994 :login:Penguin:05/02/07 01:45:21 ID:Ba6d2i5G


995 :login:Penguin:05/02/07 01:55:55 ID:/Vgkyur3


996 :login:Penguin:05/02/07 01:59:11 ID:uFEcR0wC

>>945
> liloをMBRにインストールすると、Windows(9x,XP,2003)の
> インストーラとかに上書きされたときの復旧が大変(事前に準備しとかないと)

> そしてMBMをいつでも再インストール可能なようにCDとかFDとかを用意しておく。
矛盾してねーか?

grubもFD作っときゃ
> そうしておけば、いつMBRを何かの拍子に上書きされても、MBMを再インストールするだけで
> 回復する。(MBMのインストールは一瞬で済む)
> 再設定とかは不要←これが一番大事
これは可能だろう

まぁ,ブートローダで苦労するのは他系列のOSの存在を無視して
パーティション切りもブートローダも融通の利かないWindowsが悪いだが

997 :login:Penguin:05/02/07 02:31:57 ID:D3QoNgT8
ふと思ったんだが、

ひょっとしてMBM関係者だったんでは?


まぁ、ブートローダーなんか原理自体は単純だし、
あとはどういう機能を実装させるかだろう。

MBMは何も考えずに放り込めるのがウリのようなことを言っていたが、
これは逆にいえば、誤認識等が起きた時に対応できないことに等しい。
そして、様々なドライブ・メディア・OSが出てきている今日現在、
未来に出てくる物まで保証できるかと考えれば、そんな筈も無い。
メンテナンスがされているかどうかというのは、非常に重要な要素だろう。

もちろん、MBMのようなアプローチがあること自体は悪くない。
が、だからと言って、他のブートローダーより優れているかといえば、
メンテナンスがされていない状態では絶対にありえない。

そして、そんなものを顧客に勧め、将来において問題が発生した時に、
誰がどのように面倒を見るのか・・・・
自分で問題解決した改良版作るのか?

一般的なものを使うことにより、他人がメンテナンスを引き継ぐことができる
というメリットもある。
客のためになることとはどういうことなのか、一度考えてみることを勧める。


998 :login:Penguin:05/02/07 02:41:14 ID:Ba6d2i5G
新スレではブートローダ話はやめような

999 :login:Penguin:05/02/07 02:45:00 ID:Ba6d2i5G
999

1000 :login:Penguin:05/02/07 02:45:26 ID:W2Skhr38
>>997
一見いいこと書いてるようだけど、
後半争点がずれてるし、言いがかりっぽいな。
今の使い方がノントラブルなら将来云々は排除できるだろ。
NGな使い方が必要になったら他探せば。
まあメンテの件は同意だけどさ。
何だかMBM推薦の彼が可哀想になってきた。

で、1000

1001 :1001:Over 1000 Thread
このスレッドは1000を超えました。
もう書けないので、新しいスレッドを立ててくださいです。。。

288 KB
★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.04.00 2017/10/04 Walang Kapalit ★
FOX ★ DSO(Dynamic Shared Object)