5ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

Gentoo Linux 10

1 :login:Penguin:04/06/30 05:20 ID:5V/QxKlt
Gentoo Linux
http://www.gentoo.org/

Gentoo Linux Users Group Japan (GentooJP)
http://www.gentoo.gr.jp/
・はじめに
GentooJPの歩き方
http://www.gentoo.gr.jp/jpmain/arukikata.xml
Gentoo Linux 1.4 インストール手引書
http://www.gentoo.org/doc/ja/gentoo-x86-install.xml

・もうちょっと先
Gentoo Linux Frequently Asked Questions
http://www.gentoo.org/doc/ja/faq.xml
Gentoo Linux tips 集
http://www.gentoo.gr.jp/jpmain/tips.xml
Portage ユーザガイド
http://www.gentoo.org/doc/ja/portage-user.xml
Gentoo-Portage.com
http://www.gentoo-portage.com/
Gentoo-Wiki.com
http://gentoo-wiki.com/Main_Page
前スレ (Gentoo Linux 9)
http://pc5.2ch.net/test/read.cgi/linux/1084107269/

2 :login:Penguin:04/06/30 05:25 ID:VxTrWu/Q
過去スレ
8 http://pc5.2ch.net/test/read.cgi/linux/1080398777/
7 http://pc3.2ch.net/test/read.cgi/linux/1076059699/
6 http://pc.2ch.net/test/read.cgi/linux/1071138693/
5 http://pc.2ch.net/test/read.cgi/linux/1065520318/
4 http://pc.2ch.net/test/read.cgi/linux/1047823838/
3 http://pc.2ch.net/test/read.cgi/linux/1049981814/
2 http://pc.2ch.net/test/read.cgi/linux/1041348878/
1 http://pc.2ch.net/linux/kako/1024/10244/1024483126.html

3 :login:Penguin:04/06/30 05:25 ID:VxTrWu/Q
Gentoo Linuxディストリビューションの誕生
http://www-6.ibm.com/jp/developerworks/linux/010223/j_l-dist1.html

Enoch発Gentoo行き (「若干の"つまずき"と"いさかい"」経由)
http://www-6.ibm.com/jp/developerworks/linux/010413/j_l-dist2.html

Linuxからの離脱と復帰
http://www-6.ibm.com/jp/developerworks/linux/010511/j_l-dist3.html

ebuild システムの探訪
http://www-6.ibm.com/jp/developerworks/linux/000714/j_bash3.html

4 :login:Penguin:04/06/30 05:26 ID:VxTrWu/Q
・コミュニティ
ebuildJP
http://ebuild.gentoo.gr.jp/
Wiki
http://wiki.gentoo.gr.jp/
航海日誌
http://diary.gentoo.gr.jp/
Bugzilla
http://bugs.gentoo.gr.jp/

5 :login:Penguin:04/06/30 12:16 ID:YcCtaP05
>>1
厳冬っていれろよバカ

6 :login:Penguin:04/06/30 12:17 ID:nl3SgxVi
>>5
バカはお前だ

7 :login:Penguin:04/06/30 12:38 ID:OLq3cZUh
FreeBSDのpkg_infoみたいなコマンドってないのでしょうか?

8 :login:Penguin:04/06/30 12:50 ID:nl3SgxVi
>>7
qpkg じゃだめか?

9 :login:Penguin:04/06/30 14:00 ID:385a00qQ
こっちが本スレか。

10 :login:Penguin:04/06/30 20:20 ID:LfTWzW61
KDEを導入する予定ですが、音は鳴らしたくないので、
nosound -alsa -arts
とやったのですが、

なぜか、artsをemergeされてしまいます。
何かいい方法はないでしょうか..


11 :login:Penguin:04/06/30 20:40 ID:LfTWzW61
やっぱり、kde-baseに依存しているから、音無環境の構築はムリでしょうか。

12 :login:Penguin:04/06/30 20:43 ID:146A87Iz
artsをマスクしてなんて言われるかやってみればええんでないの?

13 :login:Penguin:04/06/30 20:51 ID:LfTWzW61
>>12
> artsをマスクしてなんて言われるかやってみればええんでないの?

あー
やっぱり、kde-baseに依存しているから、ムリですね。
う〜ん。音無環境を作りたかったのに。
あきらめました。

14 :login:Penguin:04/06/30 21:15 ID:XnX1qBkK
無音にしたいだけならKDE側からarts無効にすりゃいいだけの話じゃん
arts入れないで少しでもHDDを節約したいとかいう話ならわからんでもないけどさ


15 :login:Penguin:04/06/30 21:32 ID:zaBO7Xe2
カーネル構築時に音鳴らさないようにすれば?
完全に音を鳴らしたくないのか
KDEに関係する音が聴きたくないのかどっち?

16 :login:Penguin:04/06/30 21:38 ID:LfTWzW61
>>15
> カーネル構築時に音鳴らさないようにすれば?
> 完全に音を鳴らしたくないのか
> KDEに関係する音が聴きたくないのかどっち?

完全に音を鳴らしたくないのです。
kernelではsoundを無効にしています。

なおかつ、無駄なプログラムをいれたくないなぁと思って試行錯誤していたのです。
依存関係のプログラムならしかたないので、あきらめることにします。

17 :login:Penguin:04/06/30 22:04 ID:nl3SgxVi
>>14-15
kdebase の configure には --without-arts があるみたいだけど、
なくてもビルドできるなら USE フラグでインストールするかしないか決められるんじゃないの?

net-dialup/ppp も 2.4.2 から強制的に net-libs/libpcap を入れられるんだけど、
なくてもビルドできるんだから USE フラグ見て決めろよって思う。

18 :login:Penguin:04/06/30 22:07 ID:nl3SgxVi
もしかして Gentoo のポリシーでデフォルトの機能は殺さないってのがある?

19 :login:Penguin:04/06/30 22:09 ID:n+EWMrPw
bugsにはarts依存をUSEフラグで調節できるようにするパッチが先日投稿されていたけど、まだコミットされていないのね。

さらにはやく入れろとコメントつけたりとか、Ccに自分のアドレスつけてアピールしたりすると効果的。

20 :login:Penguin:04/06/30 22:36 ID:LfTWzW61
>>19
ほーほーほー
KDEの導入は少し延期することにします。
とりあえず、2ちゃんでアピールすることにします...



21 :login:Penguin:04/07/01 06:16 ID:niJyh8fb
なんか、誰もやっとらんので、
>>1-4に乙。


22 :login:Penguin:04/07/01 13:41 ID:qcuHEelM
2004.1で/etc/portage/package.unmaskが効いてないような気がするというか
少なくとも自分のとこではさっぱり効かないんですが、パスとか変わったんでしょうか・・・?
package.keywordsとかは効くんだけど。

23 :login:Penguin:04/07/01 13:46 ID:2qCxzNAS
>>22
具体的に何をやって効かないって言ってる?

24 :login:Penguin:04/07/01 13:54 ID:qcuHEelM
>>23
package.unmaskにパッケージ名、
たとえば今日入れようとしてるlm-sensors-2.8.6の場合だと
sys-apps/lm-sensors
と1行書いて終わりです。
Webで調べてもこれで失敗してる人はいないようなんですが
どうやってもunmask状態にならずインストールできません・・・。

25 :login:Penguin:04/07/01 14:01 ID:2qCxzNAS
>>24
package.unmask を間違って理解してる。

package.unmask
Just like package.mask above except here you list pack-
ages you want to unmask. Useful for overriding the
global profile.mask file (see below). Note that this
does not override packages that are masked via KEYWORDS.

26 :login:Penguin:04/07/01 14:08 ID:0UjuDtND
そういえば、package.unmaskでもlinux-headersとかunmaskできないよね
仕様なのかしら

27 :login:Penguin:04/07/01 14:11 ID:qcuHEelM
>>25
要するにあくまで/usr/portage/profiles/package.maskのオーバーライドでしかないから
そこに書いてないような最新パッケージのunmaskなんかできねえってことです・・・かね?

だとして、改めてlm-sensors-2.8.6を入れるにはどうしたらいいか
もしわかれば教えてもらえないでしょうか。
/etc/portage/package.keywordsにも
sys-apps/lm-sensors ~x86
と書いて、その上で
emerge -k =lm-sensors-2.8.6
と実行してもマスクされててインストールできないです。

28 :login:Penguin:04/07/01 14:12 ID:bH3aSxVk
>>26
ACCEPT_KEYWORDS="-*"になってるからebuildいじるか直接指定しないと無理。

29 :login:Penguin:04/07/01 14:16 ID:2qCxzNAS
>>26-27
package.keywords にこれを書く
sys-kernel/linux-headers -*
sys-apps/lm-sensors -x86

30 :login:Penguin:04/07/01 14:19 ID:0UjuDtND
おぉ感動

31 :27:04/07/01 14:32 ID:qcuHEelM
同じく感動。

>>29
ありがとうございました。
できたけど意味わからんので調べてみたいと思います。

32 :login:Penguin:04/07/01 14:58 ID:1yPYvn7I
>>29
俺も知らなかった。

ところでsys-kernel/linux-headers -*とすると
意図しないアップデートを誘発しちゃうから危ないよ。
バージョンも指定しておいた無難だろうね。

>>31
ARCHはstable、~ARCHはunstable、-ARCHは対象外、
-*はチョー実験的といったところかな。

33 :login:Penguin:04/07/01 16:35 ID:2jTCtzxi
>>32
> ところでsys-kernel/linux-headers -*とすると
こう書いたら、そう意図した事になるんだよ。


34 :login:Penguin:04/07/01 17:35 ID:kgxNaor2
warata

35 :login:Penguin:04/07/01 17:44 ID:Toq3qDC2
>>33が正論だ

36 :login:Penguin:04/07/01 17:49 ID:60oheozP
ところで今の lm_sensor って kernel とかち合って変なことにならないのかね

37 :login:Penguin:04/07/01 18:03 ID:Rn31Y4lI
-* を指定するのは man に書いてあるよ。
日本語の portage-manpags-ja も(最新版は)追従している。
ちなみに自分も訳すまでは知らなかった(ぁ

38 :27:04/07/01 18:08 ID:qcuHEelM
>>32
なるほどー。ありがとございます。

>>36
kernel2.6.7にlm-sensors-2.8.6で、これまでのところ普通に動いてます。

39 :32:04/07/01 19:44 ID:1yPYvn7I
>>33
>こう書いたら、そう意図した事になるんだよ。

ちょっと言い方を間違えたかな。言いたかったのは、
マスクを外して普通にアップデートの対象になることを
意図しているかどうか、ということではないよ。

カーネルヘッダをアップデートしたらいっしょに
glibcのリビルドも必要になるけど、emergeは
そこまで自動化してくれていないよね。だから、
カーネルヘッダを自動でアップデートさせるような
マスクの無効化はむしろうれしくないわけです。
要するにカーネルの自動アップグレードは個人的には
意図しないアップグレードなわけです。

というわけでやっぱり俺の言い方が間違っていたわけです。

40 :login:Penguin:04/07/01 19:50 ID:2jTCtzxi
>>39
頓珍漢な言い方したって解ってるならグダグダ言うな。

41 :login:Penguin:04/07/01 20:22 ID:1yPYvn7I
>>40
すまんねぇ、そっちは本当はわかっちゃいねえのよ。

42 :login:Penguin:04/07/01 20:50 ID:HWgk5Jxl
kdeをインストールしたら、

gconvert.c:47:2:#error GNU libiconv not in use but included iconv.h is from libconv
中略
!!! ERROR: dev-libs/glib-2.4.1 failed.
でemerge失敗。

samga-jaをemergeする際に
/usr/portage/profiles/package.maskの
libiconvのマスクをはずしたのがわるかったのでしょうか?

結構いろいろいじってから、KDEを導入しようと試みたもので...
やっぱり、KDEはgentooインストールの際に入れないとダメでしょうか?


43 :login:Penguin:04/07/01 21:03 ID:HWgk5Jxl
kdeというか、単にglibのコンパイルに失敗するという現象でした...
gccが悪いのか.....

44 :login:Penguin:04/07/01 23:27 ID:aZlAvefk
linux-headersを2.4系から2.6系にしたんだけど、そういう場合って最初(stage1くらい)からインストールしなおした方が問題が少ないとかある?

45 :login:Penguin:04/07/01 23:34 ID:h7uGWlit
>>44
とりあえず自分は、glibcをemergeし直して
binutilsとgccとglibcを再emerge。後はemerge -e world。
途中でこけたらemerge --resume --skipfirstやってる。

46 :login:Penguin:04/07/01 23:40 ID:aZlAvefk
>>45
うっわ〜結構自分用の環境作っちゃった後だとemerge -e worldはきついなぁ。。。
情報ありがとうございます。

47 :login:Penguin:04/07/02 01:02 ID:y1RhBcj+
pthreadに依存してる奴だけ作り直せば?
それだけで十分だべ 普通。

48 :login:Penguin:04/07/02 17:12 ID:bp6Z7Yio
gentooをインストールしたいのですがネットワークカードを認識してくれません。
M/Bはp4p800 deluxe でオンボードの3COM 3C940を使用し、CATV接続です。

ls /lib/modules/*/kernel/drivers/net/*
とタイプして利用可能なネットワークカードモジュールの一覧をみても見当たりません。

どなたか良い対処方法ご存知でしたら、教えてください。
お願いします。

49 :login:Penguin:04/07/02 17:20 ID:bAv2Fs/A
>>48
sk98lin
ちがったらごめんな。

50 :login:Penguin:04/07/02 17:31 ID:Lrkn+KeK
>>48
>>49でアタリみたいだけど、
↓いろいろ見て回ってもいいと思うよ。

P4P800 3C940 Linux driver の検索結果 約 659 件中 1 - 100 件目 (0.29 秒)

51 :login:Penguin:04/07/02 17:52 ID:ubW9W1By
ここは、検索エンジンが使えない奴に
検索エンジンの使用をお勧めするスレなんですか?

52 :login:Penguin:04/07/02 19:22 ID:DWiBQmZ+
自ら助ける人を助けるスレです

53 :login:Penguin:04/07/02 19:41 ID:WF1u+TD4
ここは慈悲深いインターネットですね。

54 :login:Penguin:04/07/02 20:15 ID:tfpZxcjI
USE="static"って案外ヤバイね。

55 :login:Penguin:04/07/02 20:25 ID:ubW9W1By
>>52
検索エンジンも使わないでこんなところで
くだ質している奴が自らを助けているとは、
恐れ入りますなぁ。南無。

56 :login:Penguin:04/07/02 21:08 ID:buyAsAQL
>>54
どうヤバイの?

57 :login:Penguin:04/07/02 21:59 ID:3kfy4c5d
>>52
> 自ら助ける人を助けるスレです

アメリカニズムですか。
gentooの精神とは相容れません。

58 :login:Penguin:04/07/02 22:24 ID:Ifb6LfIw
>>56
USE="static"でサクっとemerge --newuse worldやって
rebootしたらファイルシステムのマウントでコケた。
ライブライが読み込めないとかなんだとかで。
LiveCDからchrootしてUSE="-static" emerge --newuse worldをやり
とりあえず元の状態に戻せたから良かったけど。
kernel2.6を使ってた場合にはsmpのkernelでbootしないと
chroot段階でFATAL : kernel too oldと言われてしまうのな。
危うくそこではまりそうになった。

59 :login:Penguin:04/07/02 23:22 ID:ubW9W1By
>>58
>USE="static"でサクっとemerge --newuse worldやって

これまたなぜに?


60 :login:Penguin:04/07/02 23:26 ID:Ifb6LfIw
static link だと早くなるとどっかで見た事があるから。

61 :login:Penguin:04/07/02 23:52 ID:wbBjzJR8
emerge gnuplot できなくなってる.


62 :login:Penguin:04/07/02 23:54 ID:ubW9W1By
USE=staticはbootstrap用だっから、
想定外のことが起きたんでしょう。
ライブラリのロードを短くしたいのだったら
prelinkでも試してみたら?

63 :44:04/07/03 14:49 ID:C/SV0Mys
(>>47)
くだらない質問にも書いたんだけど、pthreadに依存するやつだけコンパイルしなおすのって
# revdep-rebuild --soname libpthread.so.0
とするだけでいいの?
libpthread.so.0のタイムスタンプが2.6のヘッダーにした時より前なんだけど。。。

64 :login:Penguin:04/07/03 14:51 ID:g2OjooE4
>>63
UNIX板に書いたり、くだスレに書いたりわけわからん奴だな。
nptl使わないなら何もしなくていいよ。

65 :44:04/07/03 15:02 ID:C/SV0Mys
>>64
いや〜すいません、pthreadってPOSIXがなんたらかんたらだからUNIX板の方いいのかなぁとか思っちゃったり(汗)
nptl使わないならとくにいいんですか?ありがとうございます。
お言葉通り何もしませんw

66 :login:Penguin:04/07/03 21:09 ID:Ddp80Tny
>>37
いつも御世話になっています。あんた本当に偉いよ。

67 :login:Penguin:04/07/04 00:49 ID:n1zT5a3k
>>60
>>62
> USE=staticはbootstrap用だから
俺もそうだと思う。static link下手にすると、ライブラリのセキュリティホール
見つかった時とか、結構更新が大変だし。
個人的には、Apacheなどをchroot jailで動かすのに一部のパッケージだけ
USE=static使おうとしてたところ。


68 :login:Penguin:04/07/04 05:51 ID:SkqeKV0k
>>64
逆にnptl使うなら、
# revdep-rebuild --soname libpthread.so.0
見たいな事しないとまずい?
とりあえず普通に動いてるから、あまり気にしてなかったんだけど、
Javaだけ明らかに、なんか動きがおかしいんだよね…
JBossが動かなかったり。

69 :login:Penguin:04/07/04 06:36 ID:g7336d9l
>>68
ほとんどのバイナリは大丈夫だけど、まずいものもある。

Red Hat Linux 9 リリースノート
http://install.linux.duke.edu/pub/linux/base/9/i386/RELEASE-NOTES-ja.html

70 :login:Penguin:04/07/04 19:27 ID:/Aawvhc7
お聞きしたのですが
emerge -o ufed
とすると
These are the packages that I would merge, in order:
Calculationg dependencies ...done!
[ebuild R ] app-portage/ufed-0.34
とでます
Rとはどういう意味なのでしょうか??
すいませんが よろしくお願いします

71 :login:Penguin:04/07/04 19:53 ID:4LpAbaIj
不敗神話のR

72 :login:Penguin:04/07/04 21:56 ID:2otwtGFI
R指定のR

73 :login:Penguin:04/07/04 22:02 ID:UGKY3CP4
マジレスすると置換(replace)のR
manにも書いてある。

74 :login:Penguin:04/07/04 22:44 ID:g7336d9l
>>68
新たに libpthread に依存するようになるようなものがあったりする(sys-libs/db だけかも)ので、
それだけじゃ駄目みたい。万全を期すなら revdep-rebuild --soname libc.so.6 か。

75 :login:Penguin:04/07/04 22:51 ID:90KwoVE5
proxyをはさんでemergeする設定はどのようにすればいいのでしょうか

76 :login:Penguin:04/07/04 22:55 ID:FTlQqxJD
gentooは知らんけどwgetとかのダウンロードツールって
環境変数http_proxyとかftp_proxyを使うよね。

77 :login:Penguin:04/07/05 07:12 ID:YKgDI8fo
>>75
>>51-53

78 :login:Penguin:04/07/05 17:17 ID:2mkBUo0g
>>74
それだと、結局emerge -eみたいなもんですかね?

79 :login:Penguin:04/07/05 18:43 ID:q/FAoCaU
>>78
思想が違う

80 :login:Penguin:04/07/05 21:40 ID:bDzqf4sf
>>78
歯槽が違う

81 :login:Penguin:04/07/05 22:24 ID:bDzqf4sf
pam-0.77-r1 をemergeしようとすると /usr/lib/libcrack.a が
見つからないと言われるぞ(゚Д゚)ゴルァ

libcrack.soは/lib以下にあるぞ(゚Д゚)ゴルァ

手直ししたぞ(゚Д゚)ゴルァ

82 :login:Penguin:04/07/06 01:37 ID:e8sPvzqq
>>81
cracklib を merge する時に USE=-pam したからだ

83 :login:Penguin:04/07/06 04:34 ID:R/HkkHGp
gentooを業務に使っている日問いますか


84 :login:Penguin:04/07/06 13:37 ID:TJo334JY
emerge -s 等で関連しそうなパケジを探しますが、最近メンテされて
いるのかよくわからないモノも沢山ヒットする場合あります。
これは、/usr/potage/ 以下の各ebuildのタイムスタンプを確認すれば
よいのでしょうか?
emerge -s で最新ver.の ebuild の更新日時を表示してくれると一番
ありがたいんですが...

85 :login:Penguin:04/07/06 13:57 ID:Lm9XUzNV
更新日時ではアクティブかどうかは分からないような……。
たとえば数週間前全 ebuild のヘッダが変わったので、どの ebuild も
その意味では更新日時は1月以内。emerge に -l (--changelog) 渡して
ChangeLog を見るしかないんじゃなかろうか。(アップグレードの
ときしか効果ないけど) ChangeLog からエントリ抽出するような機能
が emerge -s/-S か esearch くらいにはあるとよいかもね。

86 :login:Penguin:04/07/06 22:33 ID:jE85bhKg
初心者な質問ですいません。

現在、パーティションを hdc1(boot),hdc2(swap),hdc3(root)と区切ってます。
Grubを実行し、root (hd2,0) としたところ、そんなディスクはないと怒られました。
hda->hd0, hdb->hd1, hdc->hd2 だと思ってたのですが、調べてみると、BIOSが認識している順番で
決まると書いてあったので、root (hd0,0), setup (hd0) としました。

/boot/grub/grub.conf の設定を
splashimae=(hd0,0)/boot/grub.splash.xpm.gz
root (hd0,0)
kernel (hd0,0)/boot/kernel-2.4.26-gentoo-r3 root=/dev/hdc3
initrd (hd0,0)/boot/initrd-2.4.26-gentoo-r3
としてリブートしたところ
 VFS: Cannot open root device "hdc3" or 03:01
 Please append a correct "root=" boot option.
 Kernel panic: VFS: Unable to mount root fs on 03:01
とのことでブートしてくれません。

grub.conf の root=の個所をhda3, hdc1, hda1 等にしてみたのですが
状況が全く変わりません。

何か根本的に間違ってるところがあるのでしょうか。


87 :login:Penguin:04/07/06 23:18 ID:e8sPvzqq
>>86
ハードディスク見えてないならカーネルの問題かな

88 :login:Penguin:04/07/06 23:28 ID:2R4pg82w
>>86
マザーボードのIDE接続は、どういうジャンパ設定でどう接続されてるの?


89 :login:Penguin:04/07/06 23:56 ID:jE85bhKg
現在の接続は、
Pri:Mst:CD-ROMドライブ,Pri:Slv:none
Sec:Mst:HDD(S-ATA160G),Sec:Slv:none

HDDは、LiveCDからブートした際には問題なく認識できています。
全スレのキャッシュに全く同じ質問があったのを発見したのですが、
その方も色々試した結果、断念されたみたいです。

とりあえず暫くあがいてみます。


90 :login:Penguin:04/07/07 00:15 ID:gFn6A/xt
>>89
S-ATAがSCSI デバイスとして認識されていると思われます。
/dev/sda? で試されるとよいかと。

#私も同じ問題で悩みました。

91 :login:Penguin:04/07/07 00:18 ID:8ytOD+8O
>>89
とりあえずHDD とCD-ROM を入れ替えて
ごく普通の接続にしてみたら?

92 :login:Penguin:04/07/07 02:34 ID:2YlGEACC
LiveCD では認識するということは、LiveCD と同じカーネルを使えば
動くはず。gentoo-dev-sources を使って genkernel で(オプション
なにもいじらずに)コンパイルすれば同じになるかと。(完全に同じに
したければ、LiveCD に入っている config ファイルを探してやれば
同じになるはず)

93 :login:Penguin:04/07/07 03:59 ID:ACb7CJss
もしかしたらtypoな質問かもしれませんが、liveCD2004.1でブートして、インストール作業をしている途中
(厳密にはハードウェアの自動認識が終わって、ネットワークの設定をする時)
フロッピーを読む事は出来ないのでしょうか?
実行したコマンドは
mkdir /mnt/floppy でfloppyディレクトリを作成した後
mount -t msdos /dev/fd0 /mnt/floppy  を実行しました。
そうすると
mount : fs type msdos not supportet by kernel
と言われてしまいます。
ううむ、bootCDでこんな事ってあるのでしょうか…
カーネル再構築しないといけないのかな…

当方Abit製AN7(nForce2チップセット)というマザボを使っているので、
フロッピー経由でオンボードNICのドライバを運びたいと思っているのです。

94 :login:Penguin:04/07/07 04:30 ID:uM3ukej5
>>86
2004.1のデフォルトのカーネルの設定ではext3が「モジュールとして入っている」
いってしまえば、ext3と言う金庫をあける鍵がext3と言う金庫の中には行ってる状況。
genkernel --menuconfigでext3を、カーネル内蔵に変更してカーネル作るか、
ext2でフォーマットしてインストールするかだけど、せっかくgentoo使うなら前者がお勧め

、、、、、と言う一ヵ月ぐらい前に3日程俺がはまった状況と同じ事で悩んでるとか?

95 :login:Penguin:04/07/07 04:32 ID:uM3ukej5
全然違うか。root=の所が間違ってると言うということは、、、。

96 :93:04/07/07 07:13 ID:ACb7CJss
>>89さん
(hd0,0)という記述方法は(hd「ハードディスク番号」,「パーティション番号」)っていう事です。
ですから、
89さんの環境になおすと
(hd0,0) = boot(/dev/hdc1)
(hd0,1) = swap(/dev/hdc2)
(hd0,2) = root(/dev/hdc3)
になると思われます。

>/boot/grub/grub.conf の設定を
>splashimae=(hd0,0)/boot/grub.splash.xpm.gz
細かい所ですが、「splashimage」ですね。

>root (hd0,0)
ここではルートディレクトリを指定しなければいけませんね。

>kernel (hd0,0)/boot/kernel-2.4.26-gentoo-r3 root=/dev/hdc3
>initrd (hd0,0)/boot/initrd-2.4.26-gentoo-r3
ここもそうですね。
この記述法だとgenkernelを使ってらっしゃるのかな?

ちなみに日本語のインストールマニュアルは結構情報が古いので、
まだでしたら英語のインストールマニュアルを読んでみるといいかもしれません。
参考になれば幸いです。頑張ってください( ´∀`)b

#俺のSATAな環境では何故か中途半端な/dev/hdeでした

97 :login:Penguin:04/07/07 07:24 ID:lzRKqY7w
>>96
> >root (hd0,0)
> ここではルートディレクトリを指定しなければいけませんね。
違う。
grubの言うrootはブートパーティション。
つーか、起動はちゃんとしてるから、あとはカーネルでハードディスクをどう認識してるかの問題。

98 :login:Penguin:04/07/07 07:37 ID:xQeAh3Gb
ずーっとgentoo-sourcesのstable環境で使ってるんだが、思い立って
#emerge -p gentoo-dev-sourcesしてみたら2.6.7-r8で
マスクかからずの状態なのね。
今後、stableは、
2.4.* -> gentoo-sources
2.6.* -> gentoo-dev-sources
というかたちでいくのかしらん?

ati-drivers使ってるマシンだけxfreeのアップデートがかからないのは
やっぱati-driversのせいなんだろうねえ。
もう半年以上Xはアップデートされてない。
~x86の人はみんなxorg-x11にいっちゃったのかい?

99 :login:Penguin:04/07/07 08:22 ID:2YlGEACC
>>93
いま手元で LiveCD ブートできないので分からないけど、
msdos じゃなくて vfat はあった気がする。

100 :login:Penguin:04/07/07 10:11 ID:N/9zCc8K
>93
liveCD-2004.0でNF7-Sにインストールしたが、nvnetを自動認識したが?
(BIOSでAPICをOFFにしないといろいろ不具合があった)
その後はカーネルを作る度に emerge nforce-net でいいです。

101 :login:Penguin:04/07/07 12:02 ID:WLs6dMZG
>>45
glibcの再ビルドってホントに必要か?glibcは/lib/modules/`uname -r`の下から
カーネル用ヘッダを優先的に辿ってますよ?

102 :login:Penguin:04/07/07 15:42 ID:fXIH8PMD
SCSIとして試す。接続を入れかえる。gentoo-dev-sourcesでコンパイルし直す。
どれも全部だめでした。
FSとか変更して2度ほど再インストールしてみたけど結果はX。
カーネルがvupするまで待とう・・・
答えてくれた方々、色々有難うございました。


103 :login:Penguin:04/07/07 15:48 ID:lzRKqY7w
>>102
>>86か?
>>92はやったのか?
環境も何も晒さずにできなかったって報告されてもうざいだけだ

104 :login:Penguin:04/07/07 21:51 ID:gg29TfAJ
普段使ってるマシンの portage tree を tar でかため,
しばらく触っていなかった別のマシンで展開し emerge -p system したら
更新するパッケージが何もないと言われるようになってしまいました.
emerge -p portage とかだとちゃんとインストールできるんですが,
どうしてしまったんでしょう?


105 :login:Penguin:04/07/07 22:27 ID:lzRKqY7w
>>104
emerge regen

106 :93:04/07/07 23:40 ID:ACb7CJss
無事NICを認識させる事に成功しました。
100氏の意見を参考に、CDbootオプションにnoapicをつけるだけでOKでした。BIOSのapicはONで今のところ問題なしです。
また、99氏に意見をもらったフロッピーの件なのですが -t vfat でやってみても結果は同じでした。

>>105
うお、間違ってましたか。
うちのでは実際のrootパーティションを指定しないとダメだったので、
てっきりrealrootパーティションを指定するものだと思ってました。
というか、実際の問題はそれではないし…
もうちょい文章を良く読めよ俺って感じですよね。
精進します(;´Д`)

>>102
まだ見てるか解らないけど、カーネルコンフィギュレーションの部分で
自分の使っているfile systemの項目をチェックしてみました?


107 :login:Penguin:04/07/08 06:07 ID:ggCd4mXs
なんだよGentooって海外じゃモロ小馬鹿にされてるディストリなんだな
ツーぶって使っていたのが恥しくなったよ。。。他に移項シマス....

108 :login:Penguin:04/07/08 06:14 ID:t/YCL8Ot
最近、ネタになるような出来事ってあったっけ?

109 :login:Penguin:04/07/08 07:46 ID:c0I4KqOS
2004.2そろそろ?

110 :login:Penguin:04/07/08 09:53 ID:aGmUAOXQ
>>107
ディス鳥とかgentooとか言う以前にダメ人間な匂いがぷんぷんする。

111 :login:Penguin:04/07/08 09:59 ID:IQwmPzIb
>>107
海外って、南朝鮮とか?

112 :login:Penguin:04/07/08 10:12 ID:78pAkTng
>>105
ありがとうございます.
emerge regen して cache は更新されましたが,
状況は変わりませんでした.


113 :login:Penguin:04/07/08 10:50 ID:apgCquOl
他人の評価を気にするようならLinuxもVMwareも使わん方がええて。

114 :login:Penguin:04/07/08 14:23 ID:wbZ+Ix5O
>86

私もほぼ同様な環境で動作させています。
ちなみに私のgrub.confは
title=Gentoo Linux
root (hd0,3)
kernel (hd0,1)/boot/kernel-2.4.26-gentoo-r3 root=/dev/ram0 real_root=/dev/sda4 init=/linuxrc vga=0x317
initrd (hd0,1)/boot/initrd-2.4.26-gentoo-r3
となっております。
また、fstabは
/dev/sda2 /boot ext2 noatime 1 1
/dev/sda4 / xfs noatime 0 0
/dev/sda3 none swap sw 0 0
となっています。
ちなみにkernelはgenkernelで構築しました。
kernel2.4だと私の環境では、sataはscsiとしてのみ認識されます。
live cdでbootした際に、dfで確認してみてはいかがでしょうか?
お役にたてたら幸いです。

115 :login:Penguin:04/07/08 14:50 ID:pSfA/UUN
横レスですいませんが、使えているSATAってチップはIntelなんでしょうか?
kernel-2.4.24のころにSii3112チップのマシンに一回入れてみたんですが、
チップは正常に認識はするものの、dmesgにエラーを吐きまくってて、
パフォーマンスも悪すぎました。
最近のkernelでは問題ないのかな?

116 :115:04/07/08 14:52 ID:pSfA/UUN
ちなみに、Sii3112の認識は hde, hdg だったような...

117 :114:04/07/08 16:18 ID:wbZ+Ix5O
>115
私のマシンはiDEQ200Aというキューブ型のマシンです。
sataのチップはVIAのVT6420です。
私のマシンもlive cdでブートするとhdはhdeと認識されましたが、
ブート時にhdを認識しない事が多発しましたのでfstabを書き直し
ました。
kernel2.6では不明ですが、kernel2.4ではsataはSCSIとして扱った
方が無難なようです。
というよりも、sata自体、LinuxではBOOT CDから認識しないものの
方が多いので、苦労したい人以外は避けた方が無難なような気がし
ます。

118 :115:04/07/08 16:27 ID:pSfA/UUN
なるほど参考になります。今後、機会があったらまたチャレンジしてみようと
思います。どうもありがとうございました。

119 :login:Penguin:04/07/08 20:09 ID:hQU4baiI
>>115
2004.1のLiveCDで起動するとhdaで認識されるけど,
gentoo-dev-source(2.6.7-r8)だとsdaで認識されてます.

チップはIntel. dmesgはこんな感じ.
libata version 1.02 loaded.
ata_piix version 1.02
ata_piix: combined mode detected
ata: 0x170 IDE port busy
PCI: Setting latency timer of device 0000:00:1f.2 to 64
ata1: SATA max UDMA/133 cmd 0x1F0 ctl 0x3F6 bmdma 0xF000 irq 14
ata1: dev 0 cfg 49:2f00 82:74eb 83:7fea 84:4023 85:74e8 86:3c02 87:4023 88:203f
ata1: dev 0 ATA, max UDMA/100, 160836480 sectors: lba48
ata1: dev 0 configured for UDMA/100
scsi0 : ata_piix
Vendor: ATA Model: HDS722580VLSA80 Rev: V32O
Type: Direct-Access ANSI SCSI revision: 05
st: Version 20040403, fixed bufsize 32768, s/g segs 256
SCSI device sda: 160836480 512-byte hdwr sectors (82348 MB)
SCSI device sda: drive cache: write back
/dev/scsi/host0/bus0/target0/lun0: p1 p2 p3 p4
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 0

参考になれば.

120 :login:Penguin:04/07/08 20:16 ID:Fg2i1y9c
特定のパッケージのみ特定の最適化フラグを設定するとかできますか?

121 :login:Penguin:04/07/08 20:22 ID:ve1+dmNx
>>120
USE="<設定したいフラグ>" emerge <特定のパッケージ>ではだめか?


122 :login:Penguin:04/07/08 20:25 ID:Fg2i1y9c
>>121
いえ、CFLAGS="最適化フラグ" CXXFLAGS="最適化フラグ" emerge 特定のパッケージ
を簡単にやりたいんです。
特定のパッケージに対してmask外したりUSEフラグを外す時に
/etc/portage以下にファイル作って書き込んでいますよね。そんな感じで。

123 :login:Penguin:04/07/08 22:05 ID:y76OCJSc
ebuild を編集した後でも install の部分だけを実行することは可能でしょうか?
install でこけたので、src_install を編集して ebuild hogehoge.ebuild install とかやると、
ebuild が変わってるから WORKDIR を作り直しますみたいなことを言って、
一からやり直そうとしてしまいます。

124 :login:Penguin:04/07/09 00:24 ID:QkkRmtPz
nvuのebuildはまだ出てないみたいですね

125 :login:Penguin:04/07/09 02:51 ID:iKfsvSWT
>>123
--resume はダメ?(ダメっぽい気もする)

126 :123:04/07/09 21:34 ID:wyf2tQE7
>>125
emerge の話じゃないので…

ebuild 作ってる人はこの辺どうやってるのですか?
間違い見つけるたびに全部最初からやり直しなんてやってられないです。

127 :login:Penguin:04/07/09 22:12 ID:22iiKhnA
>>126
FEATURES="noauto" ebuild hoge

もちろん、make.confに設定してもよし。


128 :login:Penguin:04/07/10 00:02 ID:2gQsBraC
基本的に全部最初からやり直しています。
直したつもりが直ってないと困るので……
ebuild 作る人は、他の人が emerge で楽するために
労力を割くわけで、全部最初からやり直しという、
いわば「やってられない」ことをやる必要があるんじゃ
ないか、とは思っています。

129 :login:Penguin:04/07/10 00:33 ID:92fhrqtt
genkernel + grub
よりも、
make config + lilo

のほうが筋が通ってて
分かりやすいことに今気付いた。

130 :login:Penguin:04/07/10 00:38 ID:U3dUwqTE
bootloaderはどっちでもいいやん

131 :login:Penguin:04/07/10 01:15 ID:SBNe+v64
俺も make config は genkernel より好きだけど
lilo と grub では grub 以外考えられん感じ。
パラメータ指定しくってても
boot 時に指定し直してどうにか出来るのはとても助かる。

132 :login:Penguin:04/07/10 11:36 ID:71u01XMu
linux-headers-2.6.99ってなにもの?

133 :login:Penguin:04/07/10 11:48 ID:gs5SMHYB
>>132
ChangeLog とか中身とか見れ

134 :login:Penguin:04/07/10 11:57 ID:71u01XMu
>>133
おっ、ありがとう。

135 :login:Penguin:04/07/10 17:10 ID:9BSvAlSy
gaming-sourcesって無くなっちゃったんですかね
ck-sourcesに統合されちゃったのかな

136 :login:Penguin:04/07/10 18:04 ID:ABN+aSmb
>>135
gaming-sourrces自体がckベースだったんだが
そのckが2.6になってから方針すっかり変ちゃったんで
gaming-sourrcesの維持が難しくなっただけ。

137 :123:04/07/10 18:06 ID:1eM7eOea
>>127
ありがとうございます。期待どおりの振る舞いでした。

>>128
最終チェックで一通り最初からやるのはいいのですが、
何時間もかかるビルドを何度もやるのは時間の無駄でしかないと思います。

138 :login:Penguin:04/07/10 21:37 ID:2gQsBraC
まあ何時間もかかるビルドなんてそうそうないんだから、最初からやっても
いいんではないのかな、と思ったりも(だいたいビルド中ずっとコンソール
ながめているわけでもなし)。Pentium III 700MHz だけど、1時間以上
かかるのってKDE/Qtがらみだけなので…… (逆に言うと KDE/Qt 関係
のパッチなんかだとビルドしたくないのでまず試さない)

139 :login:Penguin:04/07/10 23:33 ID:A6NYwEkL
Pentium3 700MHzってそんなに早かったんだ。
知らなかった………

140 :135:04/07/11 00:07 ID:5wk0lsQy
>>136
なるほど、どうもです。
どういう風に方針が変わっちゃったんだろう…
うーむ、ちょっとドキュメント漁ってみます

141 :名無しさん@そうだ選挙に行こう:04/07/11 08:39 ID:eTceIYbs
>>139
4つぐらい乗ってるんじゃない?;-)

142 :名無しさん@そうだ選挙に行こう:04/07/11 09:00 ID:JIIYwIAs
なんで、「そうだ占拠に行こう」なんだ?
デフォルト名が変になってる?
#雲丹板でも同じ現象が起ってる

143 :名無しさん@そうだ選挙に行こう:04/07/11 09:11 ID:UDAQD7+2
>>142
Gentoo と関係ないでしょ。

スレ立てるまでもない雑談スレ
http://pc5.2ch.net/test/read.cgi/linux/1063594836/

144 :名無しさん@そうだ選挙に行こう:04/07/11 09:16 ID:JIIYwIAs
>>143
スマソ

145 :名無しさん@そうだ選挙に行こう:04/07/11 13:32 ID:p1E4UXU0
印刷の設定について質問させてください
cupsdを駆動させている状態でgeditやemacsやlprからは印刷できるのですが
acroreadやfirefoxからだとプリンタにjobがいきません
/etc/cups/printers.confでは
  <DefaultPrinter dj938c>
  Info dj938c


/etc/printcap では
  dj938c|dj938c:rm=phobos:rp=dj938c:

となっているので印刷のプロパティで「lpr -P dj938c」としてもダメでした
どのあたりが原因で印刷されないのでしょうか

146 :名無しさん@そうだ選挙に行こう:04/07/11 17:08 ID:O9U/050V
最近、xfreeをemergeでアップデートしたらXが起ち上がらなくなりました。
ここのアップローダー
http://tool-ya.ddo.jp/2ch/trash-box/
20040711165641010.txt が /usr/bin/X11/X とした時のログです。
Googleで検索をしてもエラー報告のレポートばかりで、何が原因でどう対処したら良いのか
解りませんでしたので、どなたかご存知でしたら教えてください。
FMV6566SL5c(i810e chipset) セレロン566MHzで使用しています。

147 :名無しさん@そうだ選挙に行こう:04/07/11 17:12 ID:JIIYwIAs
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
Duplicate symbol __i686.get_pc_thunk.bx in /usr/X11R6/lib/modules/fonts/libbitmap.a:bitmapmod.o
Also defined in /usr/X11R6/lib/modules/fonts/libbitmap.a

って出てるから、シンボル情報がおかしくなってんでないのかね?
ためしにモジュールからbitmap消してみ。

原因は最適化のかけすぎか、binutilsかgccに妙なバグがあるか
それは藻前の書き込みからじゃわからんので、詳細を書いてください

148 :名無しさん@そうだ選挙に行こう:04/07/11 17:15 ID:zHereUUs
portage 最新にしたら、
inherit eutils
書いてない ebuild で epatch が使えなくなってる。

149 :名無しさん@そうだ選挙に行こう:04/07/11 17:39 ID:zHereUUs
inherit eutils がないのに epatch 使ってるダメな ebuild 達

app-games/xscorch-0.1.16_rc2.ebuild
app-text/ghostscript-7.05.6.ebuild
dev-libs/judy-20020627-r1.ebuild
dev-lisp/cl-prevalence-20040709.ebuild
kde-base/kdenetwork-3.2.3-r1.ebuild
mail-client/cone-0.57-r1.ebuild
media-gfx/freewrl-1.06.ebuild
media-gfx/surf-1.0.4-r1.ebuild
net-dialup/slmodem-2.9.8.ebuild
net-im/gyach-0.9.7-r1.ebuild
net-libs/openhbci-0.9.16.ebuild
net-wireless/kismet-2004.04.1.ebuild
sys-apps/hwdata-knoppix-0.107.ebuild
sys-fs/convertfs-20020318-r1.ebuild
sys-kernel/hppa-dev-sources-2.6.7_p1-r2.ebuild
sys-kernel/openmosix-sources-2.4.26-r2.ebuild
sys-kernel/openmosix-sources-2.4.26-r3.ebuild
x11-misc/bblaunch-0.0.3.ebuild
x11-plugins/allin1-0.4.7.ebuild

150 :名無しさん@そうだ選挙に行こう:04/07/11 18:20 ID:O9U/050V
>>147
レスを返してくれてありがとう。

gcc バージョン 3.3.3 20040412 (Gentoo Hardened Linux 3.3.3-r6, ssp-3.3.2-2, pie-8.7.6)
CFLAGS="-O3 -march=pentium3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
こんなもので足りますか?-->詳細
bitmapmod.oというファイルはどこにも無かったのですが、(locate bitmapmod.o)
libbitmap.aを別な名前に変えてstartxしてみました。
しかしモジュールが足りないと言って、やはり起動してくれませんでした。

151 :名無しさん@そうだ選挙に行こう:04/07/11 18:44 ID:O9U/050V
emerge でアップデートされたファイルは以下です。

sys-libs/zlib-1.2.1-r2
app-arch/gzip-1.3.3-r4
sys-apps/sed-4.0.9
dev-libs/openssl-0.9.7d-r1
net-www/apache-2.0.49-r4
sys-kernel/gentoo-sources-2.4.26-r3
sys-apps/shadow-4.0.4.1-r3
net-misc/openssh-3.8.1_p1-r1
sys-fs/reiserfsprogs-3.6.17
media-libs/fontconfig-2.2.2
x11-base/opengl-update-1.7.2
x11-base/xfree-4.3.0-r6
app-arch/tar-1.14
x11-terms/aterm-0.4.2-r9
app-editors/nano-1.3.2-r1
sys-fs/e2fsprogs-1.35
dev-libs/glib-2.4.1
x11-themes/hicolor-icon-theme-0.4
x11-themes/gnome-icon-theme-1.2.1
x11-misc/shared-mime-info-0.14
dev-libs/atk-1.6.1
x11-libs/gtk+-2.4.1
net-www/ochusha-0.5.5
media-fonts/mplus-fonts-2.2.1
sys-devel/m4-1.4.1
sys-apps/coreutils-5.2.1
net-misc/iputils-021109-r3
app-misc/screen-4.0.2
合計28

152 :名無しさん@そうだ選挙に行こう:04/07/11 18:57 ID:zHereUUs
>>146
Bugzilla の #43177 か bug #51342 を見てみたら?

153 :名無しさん@そうだ選挙に行こう:04/07/11 19:14 ID:y8pVIxQq
自分の環境とmake.confを公開してくれる太っ腹な人はいませんでしょうか?

Gentooがより普及して.emacsみたいにmake.conf専門スレッドが出来るようになることを期待しています。

154 :login:Penguin:04/07/11 19:43 ID:1QhvnVqO
インストール時 bootstrap-2.6.sh でlinux26-headersを使う方法ってないかな。
正しいかわからないけど、 /etc/make.profile/virtual を s/linux-headers/linux26-headrs/
してみた。様子見

155 :login:Penguin:04/07/11 20:36 ID:UDAQD7+2
>>153
そんなにいじる必要あるか?

156 :login:Penguin:04/07/11 21:06 ID:AHE4LGZm
>>146
俺もちょっと前に同じエラーになった。
BugzillaにUSE="static"するといいって書いてあったので、
/etc/portage/package.useに
=x11-base/xfree-4.3.0-r6 static
って書いてemerge仕直したらXが起動できるようになった。

これが最善な方法かは分からないが、一応起動はできるようになると思う。
ちなみにCFLAGSは俺と全く同じだw

157 :login:Penguin:04/07/12 01:14 ID:uIldaU0n
>>156
ありがとう!
早速試してみます。
とは言っても、コンパイルに時間が掛かるから結果は明日になると思います。

158 :login:Penguin:04/07/12 12:17 ID:d3UVignX
選挙もサボってgentoo-sources-2.4.26-r3から
gentoo-dev-sources-2.6.7-r9に。
xfree-4.3.0-r5からxorg-x11-6.7.0-r1に移行したんですが、
PS/2ホイールマウスが使えなくなってしまいました。

/etc/X11/XF86Config-4のマウスんとこは
Identifier "Mouse1"
Driver "mouse"
Option "Buttons" "5"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/psaux"
にしてあります。Option "Buttons"をコメントアウトしたり
/dev/psauxを/dev/mouseにしてもダメでした。

移行の手順は、gentoo-dev-sourcesで起動してから
#emerge -C xfree
#emerge xorg-x11
#etc-update
#opengl-update xorg-x11
で、etc-updateは全部-5です。

カーネルはoldconfigかけたので、モジュールが入ってないことはないと思います。
なんか違うとこあったら教えてくださーい!!

159 :login:Penguin:04/07/12 12:19 ID:vwBA7H+H
>>158
> カーネルはoldconfigかけたので、モジュールが入ってないことはないと思います。
思うだけじゃなくちゃんと確かめてください

160 :login:Penguin:04/07/12 12:20 ID:d3UVignX
追記。マウスのホイール以外はちゃんと使えてます。
中ボタンのペーストもできる。

161 :login:Penguin:04/07/12 12:25 ID:d3UVignX
>>159
あ、早速どうもっす。
.configのInput Device Driversから。

CONFIG_INPUT_KEYBOARD=y
CONFIG_KEYBOARD_ATKBD=y
# CONFIG_KEYBOARD_SUNKBD is not set
# CONFIG_KEYBOARD_LKKBD is not set
# CONFIG_KEYBOARD_XTKBD is not set
# CONFIG_KEYBOARD_NEWTON is not set
CONFIG_INPUT_MOUSE=y
CONFIG_MOUSE_PS2=y
# CONFIG_MOUSE_SERIAL is not set
# CONFIG_MOUSE_INPORT is not set
# CONFIG_MOUSE_LOGIBM is not set
# CONFIG_MOUSE_PC110PAD is not set
# CONFIG_MOUSE_VSXXXAA is not set
# CONFIG_INPUT_JOYSTICK is not set
# CONFIG_INPUT_TOUCHSCREEN is not set
# CONFIG_INPUT_MISC is not set

いいんですよ、ねえ?

162 :login:Penguin:04/07/12 14:51 ID:OjZYU3fi
>>158
/etc/X11/XF86Config-4ってちゃんと読み込まれてる?
/etc/X11/XF86Configとか/etc/X11/xorg.confの方が
使われてたりしない?

163 :login:Penguin:04/07/12 16:32 ID:s+Kqhu+T
自分もxorgに移行したけど/etc/X11/XF86Configが
そのまま使われてるよ。

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

164 :login:Penguin:04/07/12 17:14 ID:A04x5c79
xorg+kdeが最近の流れなのですか

165 :login:Penguin:04/07/12 17:40 ID:d3UVignX
あれこれどうもです。
Emulate3Buttons "no"を足してみたりやってみたけどそろそろアカン。
xorg.confはなかったです。まあちゃんと起動したからいいかな。
kernel2.6のalsadriverと2.4の時emergeしてきたalsa-driverがどうなってるかとか
xfreeの時入れたati-driversは入れ直さなくていいのか、とか
結構まだ謎が多いので、次の休日にでも、またいろいろ試してみます。
最後に>>164
おら、どーしてもKDEだけは入れる気になんねーだ。

166 :login:Penguin:04/07/12 18:15 ID:bcBwl4R9
あ、あのね...

167 :login:Penguin:04/07/12 19:56 ID:0+VhwUxV
KDE使ってるけどメニューにあるアプリは殆ど使ってない罠。
gnomeよりKDEが好きだけど、qtアプリよりgtkアプリが好き。

168 :login:Penguin:04/07/12 20:04 ID:Cr0+r92i
>>167
KDEとかgnomeとか言ってるうちはお子様、はやく卒業しろ。

169 :login:Penguin:04/07/12 21:17 ID:UAIBxO9R
>>165
今のところはxorg.confが無ければ、
XF86Config-4が使われる。

漏れもなんの問題もなく乗り換えられたけどな。
ものはUSBのトラックボールだけど。

170 :login:Penguin:04/07/12 21:23 ID:v7paxnke
>>168
食わず嫌いな餓鬼はイッテヨシ

171 :login:Penguin:04/07/12 22:17 ID:DIR9LDES
うぎゃああ、glibcのバージョンウプしたじゃねぇか...
昨日やっとgnomeのコムパイルが終わったばかりなのに...orz


172 :login:Penguin:04/07/12 22:21 ID:OoeWf4q+
>>171
>>168

173 :login:Penguin:04/07/12 22:40 ID:r6kAc6Uk
glibc2.3.3はいつになったら正式リリースになるんだろう

174 :login:Penguin:04/07/12 23:02 ID:MLYwtoYI
emacs でコピーしたテキストを firefox 0.9.1 にペーストできますか?
firefox でコピーしたものは emacs や mlterm にペーストできるんですが,
逆ができません.


175 :login:Penguin:04/07/12 23:13 ID:Tg/oh3bj
kde-3.2.3は非常によくできてると思うが何か?

176 :login:Penguin:04/07/12 23:20 ID:OoeWf4q+
>>175
KDEはどうみてもUNIX互換のOSには見えないのがヤダ
あっ、デファの話ね


177 :login:Penguin:04/07/12 23:27 ID:Tg/oh3bj
そのカッコから入るところが理解できん。OSなんて使えればよし

178 :login:Penguin:04/07/13 05:26 ID:Pn9rqDHC
165です。おはようさんです。
やっぱり荒れてるし(^^;

KDE差別もいい加減にせんといかんですか。
なにかって言や「KDEスバラシイ」言い出すヒト見て始めたんだけど。
スバラシイのは分かったから。

>>174
普通にできますが。マウスの真ん中がWindowsでいうペーストだと知らない人?

179 :login:Penguin:04/07/13 06:07 ID:WXuTuIAZ
xorg+kdeが最近の流行みたいですね

180 :login:Penguin:04/07/13 07:02 ID:bt6wKzmm
Debianユーザなんですが初めてGentooをインスコしています。
噂には散々聞いてましたけど、いやーすごいっすね、これ。
mkswapなんて始めて使った。
勉強になります。

で、現在emerge -u systemの27 of 80ぐらいなんですが、
そろそろ出社の時間が(;´Д`)
放置してくかなあ。

土日にやっときゃ良かった…。

181 :login:Penguin:04/07/13 07:42 ID:nX89ap9H
nforce-netのemergeが通らない(;´д`)
なんでじゃーー

182 :174:04/07/13 12:20 ID:gMIXY+ka
>>178
> >>174
> 普通にできますが。マウスの真ん中がWindowsでいうペーストだと知らない人?

Ctrl+V や Shift-Insert ではできませんか?
今, 中ボタンで試そうとしたんですけど,
マウスポインタが -0-0 の位置に飛んでしまって,
ペーストできませんでした.
xfce4 でも openbox でも同じなので
X か VMware にイベントを奪われているように思いますが,
マウス使わずにペーストしたいです.


183 :login:Penguin:04/07/13 13:42 ID:jsoNGE73
gentooと関係あんのか

184 :login:Penguin:04/07/13 14:02 ID:hnkWCGaM
>>182
ポインタが飛ぶのはXの設定じゃねーの?

わからんけど、firefoxにコピーできないのは、
gtkのクリップボードとXのクリップボードが違うからじゃない?
GTKはgtk用のクリップボードとXのクリップボードにコピーするけど、
emacsとかは、Xのクリップボードにしかコピーしないとか。

漏れはKDE使ってるから、GTK方面あまり知らないけど、
確かGTKでもctrl-vでいけたと思うけど。
とりあえずGTK同士で試してみたら?

というか、スレ違い。

185 :login:Penguin:04/07/13 14:04 ID:3kLuAWrq
>>184
スレ違い。

186 :login:Penguin:04/07/13 21:09 ID:lFFI6M4Q
>>181
Reverse Engineered nForce Ethernet supportはどうよ。kernel 2.6になってちょっとしてから組み込まれたと思うんだけど。

187 :login:Penguin:04/07/13 21:17 ID:OWYvSjTo
>>181&186
通りすがりですが、それずっと使ってます。
今までまったく無問題です。
Gentoo以外ではSuSEもこれ使ってFTPインスコOKでした。


188 :login:Penguin:04/07/13 23:03 ID:n0gXy97m
Gentoo 1.4のuniversal版LiveCDでインスコしたいのですが、bootの途中でkernel panicになります。
rootfsがマウントできないようです。
なにかコツがあれば教えてください。
minimalじゃないとうまくいかないとか・・・。

x86は無問題だったんですが。
sparc64で、マシンはUltra10です。
よろしくおながいします。


189 :login:Penguin:04/07/14 00:01 ID:kdgt6B36
emerge -uD world したら mplayer とかいろんなモンが
cannot set up thread-local storage: kernel too old for
thread-local storage support
とか出て動かなくなっちゃったんですが、同様の方いませんか?

190 :189:04/07/14 00:03 ID:kdgt6B36
ちなみに gentoo-sources-2.4.25-r5 で最近カーネルはいじってないんですが...

191 :174:04/07/14 00:12 ID:xYaYXKqC
>>184
すみません. Gentoo 固有の問題ではないんですね.
Fedra ではできるとかいう情報もあったんですが,
非 GTK アプリが GTK のクリップボードを弄りにいくようにしないと
原理的に無理ってことですね.
gedit と firefox ではコピペできましたが,
emacs とできないとなると不便すぎます.
私の使い方が変なんでしょうか.


192 :login:Penguin:04/07/14 00:24 ID:NzRRtrtn
/releases/x86/2004.1/livecd/install-x86-universal-2004.1.iso
ってブータブルなCDイメージですよね?焼いてもCDブートできないんですが
焼きミスかな。

193 :login:Penguin:04/07/14 01:01 ID:khRRXo/y
ふつうに焼きミスだと思います。

194 :login:Penguin:04/07/14 01:23 ID:NzRRtrtn
>>193
どうもです。再チャレンジしてみます。

195 :189:04/07/14 01:50 ID:xwcrnTrS
>189の件ですがどうも glibc-2.3.4.20040619 が悪かったみたいですが...
2.3.3.20040420に落としてみようかとやってみたら、emerge に glibc を落と
すのはよくないんじゃない?と脅されて断念しました。

196 :login:Penguin:04/07/14 02:28 ID:bH7ITua0
>>191
何が変て中ボタンでポインタが飛ぶ方が変だなあ。
Ctrl+vとかはうちも確かにできんかったが。
つか、GTK+(Gnome?)に、こういうコピペ法あると知らなかった。
失礼した。


197 :189:04/07/14 02:58 ID:xwcrnTrS
度々すいません。カーネルを2.4.26-gentoo-r6に上げてみたりしたけどダメでした。
glibc-2.3.4.20040619 と nvidia-glx がダメみたいです。(うちだけなのかなぁ)

一人でアフォみたいなので、もう黙ります。すいませんでした。

198 :login:Penguin:04/07/14 03:22 ID:GiUR3c0Z
>>191
Mozilla と Emacs の間では相互にコピペできました。
(mozilla-1.7, emacs-cvs-21.3.50-r1, emacs-21.3-r4)
Firefox じゃ無理ですか。ちょっとインストールしてみます。

199 :login:Penguin:04/07/14 09:51 ID:i3RoeGLt
>>197
まだ解決してないがForumに同じ症状の人がいる

次の>>1には~arch使ってておかしなことがあったら、まずBugzillaとForumを見るよう書いて欲しい

200 :login:Penguin:04/07/14 11:42 ID:DS6rJ9sG
200ゲッチュ!

201 :198:04/07/14 12:59 ID:GiUR3c0Z
firefox-bin-0.9.1 入れてみたのですが問題ないですね。
emerge info の結果を貼ってもらえますか? >>191

202 :login:Penguin:04/07/14 15:16 ID:mvq0rvYK
SELinuxに興味ある人いる?

203 :login:Penguin:04/07/14 17:06 ID:gSCSXohk
いる。

204 :login:Penguin:04/07/14 18:53 ID:bH7ITua0
くだ質スマ。
ふと気づいた。/lib/modules以下にずらずらとkernelversionのディレクトリが並んでますが、
いいんだよね?余計なのは消しちゃって。
いいとは思うんだけど、なにやら怖いのだ。
だれかいいっていってくれー。


205 :login:Penguin:04/07/14 18:59 ID:BlFRHl7x
いい.
もう古いカーネル使わないならいらない.

206 :login:Penguin:04/07/14 19:49 ID:7nr9MJfY
直接関係ない話題なんだけど・・・

7/5のGentooニュースに載ってたMETISSEってのを何気なく見てびっくり。
こういうのを作ってみたいなあ、なんて思ってたWMが既に存在してたよ。
興味ある人はここでスクリーンショット見てみて。
http://insitu.lri.fr/~chapuis/metisse/index.html


207 :login:Penguin:04/07/14 19:58 ID:jZzALPvn
>204
たぶん消しちゃっていいんだけど、まあ modules は大した大きさじゃないよね。
それより、/usr/src 以下が1バージョンあたり200MB以上あるんで、
一応 unmerge してから /lib/modules 以下とともに消すようにしてる。

208 :174:04/07/14 21:20 ID:wf9cttJw
>>201
テストしていただきありがとうございます.
emerge info の結果です.
firefox-0.9.1 を入れたときから変えてなかったと思います.
関係あるかわかりませんが VMware の中にいます.

$ emerge info
Portage 2.0.50-r8 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r9, 2.4.26-gentoo-r3)
=================================================================
System uname: 2.4.26-gentoo-r3 i686 Mobile Intel(R) Pentium(R) 4 - M CPU 1.80GHz
Gentoo Base System version 1.4.10
distcc 2.9 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.8.3
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium4 -O3 -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config
/usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"


209 :174:04/07/14 21:21 ID:wf9cttJw
>>208
つづき

CXXFLAGS="-march=pentium4 -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache digest sandbox"
GENTOO_MIRRORS="http://gentoo.oregonstate.edu http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portagejp /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X apm arts avi berkdb cdr cjk crypt cups encode esd foomaticdb gdbm gif
gnome gpm gtk gtk2 guile imlib jpeg kde libg++ libwww mad mikmod motif mozilla
mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png python qt quicktime
readline ruby sasl sdl slang socks5 spell ssl svga tcltk tcpd truetype
x86 xml2 xmms xv zlib"


210 :login:Penguin:04/07/14 21:31 ID:i3RoeGLt
>>208
それGentooの問題なのか?

211 :login:Penguin:04/07/14 21:42 ID:REAA3BNP
ThinkPad X31にGentooを入れてる方はいますか?
どんな感じでしょうか?

212 :login:Penguin:04/07/14 21:50 ID:6Oik6+p4
>>211
入れてます。いい感じです。
KDE も快適に使えています。

213 :login:Penguin:04/07/14 22:06 ID:bH7ITua0
>>205 >>207
あんがと。消した。なんにもない。ヨカッタ。
HDD使用1.8G弱(~/を除く)まで落ちた。うほー。

>>211
Thinkpad 560ZでWin98とマルチブートで使ってるおいらにゃ羨ましい限り。
入れちゃえ入れちゃえ。

>>201
中ボタンじゃなくて「Ctrl+VもしくはShift+insertで」できたの?
208はそれで騒いでたわけなんだが。

214 :login:Penguin:04/07/14 22:18 ID:Ed9jcdfF
2004.1をクリーンインストールしてるんですが、
dev-java/blackdown-jreの所で固まってしまいます。

バグジラにも、(55639など)何件か上ってるようなのですが、
解決方法が分りません、、orz

何かヒントを頂けませんでしょうか?

215 :login:Penguin:04/07/14 22:21 ID:i3RoeGLt
>>214
glibc 上げればいいんでないの

216 :login:Penguin:04/07/14 22:24 ID:4TbbjtgZ
186&187氏
なんと!こんなものがあったとは…。
いやー快調です。情報Thxです(´∀` )
ちょっと前にSiI3112なSATAの話題があったので報告を。
M/B : AN7(SiI3112チップ)
HDD : Seagate ST3160023AS ×2
その他ドライブ : DVR-ABN4 (プライマリマスタで接続)
使用kernel : gentoo-dev-sources-2.6.7-r10

LiveCD2004.0にてブート、その時は/dev/hde及びhdgで認識されていました。
が、install作業終え、再起動して実際にGentooを起動して
dmesgによるとhda及びhdcと認識されるという現象が(;´Д`)

dmesgはこうなってます。
eth0: forcedeth.c: subsystem: 0147b:1c06 bound to 0000:00:04.0
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
SiI3112 Serial ATA: IDE controller at PCI slot 0000:01:0b.0
SiI3112 Serial ATA: chipset revision 2
SiI3112 Serial ATA: 100% native mode on irq 11
ide0: MMIO-DMA , BIOS settings: hda:DMA, hdb:DMA
ide1: MMIO-DMA , BIOS settings: hdc:DMA, hdd:DMA
hda: ST3160023AS, ATA DISK drive
ide0 at 0xf8852080-0xf8852087,0xf885208a on irq 11
hdc: ST3160023AS, ATA DISK drive
ide1 at 0xf88520c0-0xf88520c7,0xf88520ca on irq 11
hda: max request size: 64KiB
hda: 312581808 sectors (160041 MB) w/8192KiB Cache, CHS=19457/255/63
/dev/ide/host0/bus0/target0/lun0: p1
hdc: max request size: 64KiB
hdc: 312581808 sectors (160041 MB) w/8192KiB Cache, CHS=19457/255/63
/dev/ide/host0/bus1/target0/lun0: p1 p2

217 :198:04/07/14 22:33 ID:GiUR3c0Z
>>210
USE フラグの組み合わせによってうまくいったりいかなかったりする
可能性があるので、とりあえず Gentoo の問題でいいんじゃないかと
思いましたが、過去に遡って投稿を読んでみると、症状が理解できました。
つまり、

* マウスは使いたくない。キーボード操作だけでペーストしたい。
* Emacs からコピーしたものを Firefox にペーストしたい。

ということでしたか。マウスの中ボタンでペーストできるのは確認していた
のですが、単にキーボード操作ではできませんね。ただし、emacs-cvsを
gtk USE フラグをオンにして emerge し、メニューから「Edit→Copy」
でクリップボードに入れると、Firefox に Ctrl-v もしくは「右クリック→Paste」
でペーストできます(Emacs から GTK+ 側のクリップボード経由で渡す)。
中ボタンでペーストするのがいちばん楽な気もしますが、VMware では
うまくいかないんですね。

218 :login:Penguin:04/07/14 22:46 ID:Ex/vFHL6
Acrobat Readerで、日本語のPDFファイルで見れないファイルがあります。
エラーメッセージは
Unable to find or create the font
"hogehoge" Some characters
may not display or print correctly.
というものです。"hogehoge"の部分はフォント名でMS-GothicとかHeiseiKakuGothic-W5などです。

app-text/acroread
media-fonts/acroread-asianfonts
をemergeするだけじゃダメなのでしょうか?
解決法をご存知の方いらっしゃいましたらどうかご教示ください

219 :login:Penguin:04/07/15 00:37 ID:qT7fX2Yb
いつのまにかprofilesにdefault-x86-obsd-2004なんてのが出来てら。

220 :login:Penguin:04/07/15 00:44 ID:eh9d/+Ey
PCMCIAのCD-ROMでしかブートできないノートをもらいました。CDドライブ付きで。
OSは何も入ってなく、USBのフロッピーも持っていません。
Gentooのインストールディスクでブートすると、ブートはするものの
ブート後にCD-ROMにアクセスできないらしく、BusyBoxが立ち上がってしまい
基本的なコマンドしか使用できません。

 こんな環境でGentooインストールできますか?

221 :login:Penguin:04/07/15 01:21 ID:Cu0U7vNz
何が言いたいのか良くわからん
フロッピーなんかハナから要らんわけだが

222 :login:Penguin:04/07/15 01:44 ID:T1LzBrbu
>>220
ブートオプションdopcmciaは試した?

223 :login:Penguin:04/07/15 01:56 ID:e+GtsM+T
>>218
5.x用の日本語フォントには、ゴシックが入ってないのよ。
4.x用の奴持ってくればいい。
少し検索すれば見つかるはず。奥村先生の所とか。

224 :login:Penguin:04/07/15 02:25 ID:ZvKOx5XJ
以前gnomeの最新版を追っかけるのにgarnomeを使用していたのですが
それを削除した後にemergeでgnomeをアップデートしようとすると
libtool: link: cannot find the library `/usr/local/garnome/lib/libgmodule-2.0.la'
と言うエラーを吐いて停止してしまいます(現在/usr/local/garnomeは消去済み)
/etc/ld.so.confには上記のパスは入っていませんし
$PATH,$LD_LIBRARY_PATHにも入っていません
現状のファイル構成に合った設定に戻してコンパイルを通したいのですが
どこを修正すれば直るのでしょうか?よろしくお願いいたします

225 :login:Penguin:04/07/15 02:27 ID:ew5hUPbL
GentooのインスコってKNOPPIXからやるのが一番ラクチンかなぁ。漏れ的には。
容赦なくFTPインスコするからGentoo LiveCDって1.4以降では使ったことない。

226 :login:Penguin:04/07/15 09:42 ID:d7W1h5zQ
LiveCDから起動せずにインストールする方法ってどこかにマニュアルがありますか?
仕事しながら空きハードディスクにインスコしたいので。

227 :login:Penguin:04/07/15 09:49 ID:n7nnhlde
proc とか大丈夫なん?

228 :login:Penguin:04/07/15 09:53 ID:Lj7NaWwM
>>226
LiveCDからインストールするときと一緒。普通にできるよ

仕事しながらインストールするなら/etc/make.confに、
PORTAGE_NICENESS=5とか書いてコンパイルの優先度を下げてやると吉。

229 :login:Penguin:04/07/15 09:55 ID:Qrap2lho
>>226
FDインスコの方法ならgentoo.jpに日本語のが有ったような希ガス。

230 :login:Penguin:04/07/15 10:23 ID:d7W1h5zQ
>>228
ありがとうございます。
以下のサイトを見つけたんですが、こいつを参考にするといけそうです。
ttp://www.gentoo.org/doc/en/altinstall.xml

231 :login:Penguin:04/07/15 14:04 ID:FwR9RBKY
apache2をSSL enableでインスコして、apache2ctl startsslでは動くようになったんですが
自動起動はどうやったらいいんでしょうか。
何もしないと80番で普通に起動するだけでsslが動きません。
/etc/init.d/apache2を覗いてもstartセクションはよくわからないし。
たぶん何か、gentoo的に正式な手順みたいのがあるんだろうけど
調べてもわかりませんでした・・・。ご存知の方教えてください。

232 :login:Penguin:04/07/15 14:06 ID:RnHyqxOk
>>231
/etc/conf.d/apache2 は?

233 :login:Penguin:04/07/15 14:07 ID:FwR9RBKY
と書いたそばから調べついた・・・。
/etc/init.d/apache2 に
APACHE2_OPTS="-D SSL"
と書く、が正解でした。

234 :login:Penguin:04/07/15 14:09 ID:FwR9RBKY
>>232
あ、そっちの方がより正しいっぽいですね。それでやることにしました。
ありがとうございます。

235 :login:Penguin:04/07/15 14:18 ID:FwR9RBKY
何度も連書きで申し訳ないです。
/etc/conf.d/apache2にAPACHE2_OPTSを書いても反映されないようです。
というか初めから書いてありましたが、やっぱりSSLは有効になっていません。
最初にやったように、/etc/init.d/apache2に無理矢理書くと有効になっています。
何か見落としがあるんでしょうか?

236 :login:Penguin:04/07/15 16:30 ID:MP8aoyc1
xorg-x11-6.7.0-r1でlibbitmap.aのシンボルがどーたらで起動できない件だけど、
-fstack-protector外すと大丈夫みたい。このフラグALLOWD_FLAGSでいいの?
当方 athlon-xp x86 環境

237 :214:04/07/15 20:54 ID:FgZwHs9T
>>215
解決しました。ありがとう。

238 :login:Penguin:04/07/15 23:08 ID:qOALqPu9
GLSA 200407-12を和訳してみました、、こういうのは
初めてなので、かなり意訳、誤訳を含んでいまつ、、ごめんなちい
(分かりにくいんで、敢えて原文に無い言葉を入れている部分もあります)

対象のカーネルソースのVerや、原文を読んで確認したい方は
ttp://www.gentoo.org/security/en/glsa/glsa-200407-12.xml
こちらまで。

239 :238:04/07/15 23:08 ID:qOALqPu9
Advisory Reference GLSA 200407-12 / Kernel
Release Date July 14, 2004
Latest Revision July 14, 2004: 01
重要度 高
リモート脆弱性

これに関するバグレポート #55694

概要
2.6系のLinux カーネルに、『攻撃者が特殊なTCPパケットを送信することによって、
カーネルで無限ループが発生し、対象のマシンをハングアップさせることが出来る』
という脆弱性が発見されました。

2. 脆弱性の対象について

背景
Linuxカーネルは、GNU/Linuxシステムの管理における中心的機能であり、
データ構造やアクセス手段など、システムが動作するために必要不可欠な
ハードウェアへのアクセス方法を提供しています。

解説
攻撃者はIPTables内のTCPオプションを制御するコードのイテレータに対して、
不正なデータを使用することが出来ます。127バイトより大きなヘッダを持った
TCPパケットを作成する事で、このイテレータに、負の数を入力出来るだろうと思われます。

影響範囲
不正なパケットを一つ送信することでカーネルはループに陥り、
CPUリソースとマシンの処理能力の全てを使い果たし、サービス拒否(DoS)状態になります。
この脆弱性は、ローカルアクセスを必要としません。


240 :238:04/07/15 23:09 ID:qOALqPu9
3. 解決に関する情報

代替策(カーネルアップグレードが出来ないときの)
Netfilter 機能、もしくは (IPtablesにおいて)``--tcp-option'' ルールを
使用しないならば、このexploitコードによる脆弱性は存在しません。
netfilter 機能をカーネルから外すか、``--tcp-option'' を使用している全てのルールを
削除すれば良いでしょう。
しかし、パッチのあたったカーネルにアップグレードする事を強く推奨します。

解決方法
最新のカーネルソースにアップグレードすることを推奨します。
-----------------------------------------------------------------------


241 :218:04/07/16 00:17 ID:vKAjWgrZ
>>223
レスどうもです。
HeiseiKakuGothic-W5に関しては、4.xに入っていたHeiseiKakuGo-W5-Acroを
Resource/Fontに突っ込めば見ることができました。
しかしMS-Gothicの方はそれでも見ることが出来ませんでした。
色々調べてみたところ、どうもms*.ttcが諸悪の根源だったようです。
これを削除したらMS-Gothicも見ることが出来ました。

さらに~/.adobe/Adobe云々とかいうファイルを見てみたところ、
acroreadは/usr/X11R6/lib/X11/fontsを見てるぽかったので
ms*.ttcの場所を/usr/X11R6/lib/X11/fonts/truetype/から
/usr/local/share/fonts/truetype/に移しました。
これで万事解決いたしました。

242 :login:Penguin:04/07/16 00:31 ID:cjnI55Qs
>>238
乙でつ。
もう英語表記になれたから今更ってとこもあるけど、
GLSA-JPみたいなのもあってもいいかも。

243 :login:Penguin:04/07/16 07:59 ID:gfOCsZeM
昨日apache+sslで質問してた人ではないんですが、
apacheの動作確認しています。
USE=apache2で入ったapache-2.0.50とperl-5.8.2で、
YuKi-WiKiからそこらで配ってる掲示板まで
出来合のperl製CGIがまるっきり動かないのです。
バージョンが上過ぎるってことなんでしょか。
自分で簡単なやつを組んでみたりするとちゃんと動くんですが。
あと、tDiaryやHiKiなど、rubyのやつはしっかり動くんですが。
mod_perl入れようとするとapache-1.x入れようとするし。
スレちがいだばスミマセン。
rubyのまわしもんでもありません。

244 :login:Penguin:04/07/16 08:59 ID:deCt+2dT
>>243
改行がCRLFなだけと予想する。
つーか、「まるっきり動かない」じゃなくてエラーメッセージちゃんと書け。

apache2 用の mod_perl は ~x86 指定しないと入らない。

245 :243:04/07/16 10:27 ID:gfOCsZeM
があん。動きました。。。おお恥。
ありがとうございます。スレ汚しすみません。


246 :login:Penguin:04/07/17 00:44 ID:eB51Q+Xc
KDEのKonquerorやKMaiといったKDEの一部だけをインストールするには
emergeを使わずに自分でダウンロード→コンパイル→インストール
するしかないんでしょうか?
emerge -s Konqueror
emerge -s KMail
とかやっても見つからないので。

247 :login:Penguin:04/07/17 01:40 ID:a1leOMx3
KDEはデスクトップの基本的なものはkdebaseまでで構築される。
けどKMailとかはどうだかは知らない。
まずkdebaseまで入れてから、足りないものはどれか
調べてみるのが吉。
使いもしないもんまでemerge kdeで全部入れるのはアホです。

と書いた俺は
「KDEだけは入れたくない」と言い張った>>165だったりするのだが...

248 :login:Penguin:04/07/17 01:52 ID:+G9ArAqB
kdeのパッケージ構成は本家kde.gr.jpに当たってみる方が吉

249 :login:Penguin:04/07/17 03:00 ID:b5e4VcpX
>>246
kdepimだと思った。

250 :248:04/07/17 03:05 ID:b5e4VcpX
>>246
あ、kmailだけ入れたいのね。それは分からん。
(あと、emerge -S も試すべし。)

251 :249:04/07/17 03:06 ID:b5e4VcpX
>>250 の名前間違えた。すまぬ。


252 :238:04/07/17 06:42 ID:xy6WWug9
238でGLSAを投げたものです。なんの前触れも無く
一方的にやってしまってすみませんでした。

これからもGLSAを和訳して(もっとましな訳を)、公開
していければと思ってるんですが、適切な場所ってどこでしょうか。
Gentoo.gr.jp のWikiとかでしょうか。
2chはさすがにまずいでしょうか、、

253 :login:Penguin:04/07/17 07:14 ID:BDAiDNtV
デフォルトでkde.eclassの85行目に--enable-final追加されてれば楽なんだけどなぁ。

254 :login:Penguin:04/07/17 09:35 ID:UOuoX8+x
>>252
gentoojp-docs@ml.gentoo.gr.jpに参加してみない?

255 :login:Penguin:04/07/17 10:32 ID:myuJ/heL
もう半年くらいは Gentoo 一本ですが、はじめてフロッピーディスクを
使う必要が出てきた。カーネルは gentoo 提供じゃない、
ftp.kernel.org からもらってきた 2.6.7 で、なんの気なしに

mount -t vfat /dev/fd0 /mnt/fd

みたいにしたんだが、「そんなデバイスはない」と怒られる。ああ、これは
devfsd が導入されているせいだと思い、/dev/ide/以下などをの検索してみたが、
fd / floppy らしきデバイスが見つからない。カーネルには、FDの
サポートは入れてあるんですけどね。devfsd のドキュメントを読んでみたけれど、
デバイスファイルが missing のとき、どうやったらFDにアクセスできるかわからない。

どなたか、アドバイスいただけませんか?

256 :login:Penguin:04/07/17 10:48 ID:oN1/+i5u
>>255
modprobe floppy

257 :246:04/07/17 12:26 ID:eB51Q+Xc
レスサンクス。

emerge -S Konqueror
emerge -S KMail
をやってみたところ結構な数のパッケージ入れないといけないみたいです。
そのなかにkdepimもkdebaseも含まれてました。
あきらめて素直にemerge kdebaseします。

258 :login:Penguin:04/07/17 14:05 ID:q0CD4oO4
2004.1でインストールしたんだけど、
/etc/passwdにgameやらpostgresやらqmailやら余計なユーザが
デフォで追加されてるのね。そういうものなの?
いや、消せばいいだけなんだけど、なんか感じ悪くて。
stage3からやったからこうなるのかな?

259 :login:Penguin:04/07/17 14:06 ID:0GWf5TLB
>>258
そだよ。>そういうもの
その通り、貴方にとって余計なら消せば良いと思います。

260 :258:04/07/17 14:15 ID:q0CD4oO4
>>259
レスthx:-)
gentooのパッケージングシステムの仕組みが分かってないんだけど、
たとえば、PostgreSQLをパッケージでインストールする時って、
debやrpmみたいに、裏で勝手にユーザpostgres作ったりしないのかしら?
作ってくれるならいくらでも消すんだけど。どんなもんでしょ?

261 :login:Penguin:04/07/17 14:32 ID:3F4GnXLj
>>255
/dev/sdaと言う可能性

262 :login:Penguin:04/07/17 15:29 ID:oN1/+i5u
>>260
作られるものもあるし作られないものもある。

263 :260:04/07/17 15:40 ID:q0CD4oO4
>>262
じゃ、デフォのユーザが存在してることを前提にパッケージングするような人が
いないことを願っておこうかな。
こころおきなく消しまくろっと:-)
レスどもでした。

264 :login:Penguin:04/07/17 15:47 ID:oN1/+i5u
>>263
多分 game も postgres も qmail も作られない。

265 :263:04/07/17 16:12 ID:q0CD4oO4
>>264
えぇーー、、、まぁgameはともかくとして、アプリケーション固有のユーザくらいは
作ってほしかったのよね、、、この分だとapacheやpostfixとかも怪しいっぽいし。
面倒だからいじるのやめよっ( ´Д`)

266 :login:Penguin:04/07/17 16:18 ID:6oM1/Io/
Gentoo起動したらブート画面で「QM_MODULES hogehoge...」ってエラーが
いっぱい出てきちゃった。どうもmodule-init-toolsがらみらしいのはわかったけど、
こんなエラー出てきた人いる?module-init-toolsを前のバージョンに戻してみると
いいのかな?ちなみにカーネルはgentoo-dev-sources-2.6.7-r9。

267 :login:Penguin:04/07/17 16:21 ID:UkwwNgUc
ntpとかはユーザがいないとemergeのときにntpがいないぞゴルァって
いってくれたりする。
好きなようにすれば?としかいえないな。

268 :login:Penguin:04/07/17 16:42 ID:oN1/+i5u
>>266
Bugzilla とか Forum にいる。

269 :login:Penguin:04/07/17 16:50 ID:S8sIn6Ng
>>266
むっちゃくちゃな最適化してるとかそういう事はないん?

270 :login:Penguin:04/07/17 17:26 ID:5ENZxD9h
>>266
なりました
module-init-toolsを入れたのにmodutilsを消してなかった為
emerge system -u やった時にmodutlsのバージョンが上がっていて
インストールされてしまった
Live CDで起動してmodule-init-toolsを入れ直したら無事に起動した


271 :login:Penguin:04/07/17 17:58 ID:6oM1/Io/
>>268
>>270
ダンケスコ
とりあえず
# emerge module-init-tools
とやってインストールし直したら直りました.ただ,ネットワークカードのモジュールが
当然ロードされてなかったので別のマシンでダウンロードしたファイルをCDに焼いて
/usr/portage/distfile に移さなきゃなりませんでした.カーネル新しくしたときは
module-init-tools を emerge し直した方が無難だね.

272 :login:Penguin:04/07/17 18:18 ID:x45Ojq+0
livecd-2004.1 に
/usr/portage/scripts/bootstrap-2.6.sh
ってのがあるけどこれって何?
これ使ってインストール作業をすれば
kernel-2.6 の Gentoo がお手軽に出来上がったりする
素敵な物なんでしょうか。

273 :名無し募集中。。。:04/07/17 18:31 ID:LerRzzcP
>>272
それ使うとstage1からインストールするんじゃないの?

274 :login:Penguin:04/07/17 18:51 ID:x45Ojq+0
>>272
/usr/portage/scripts/bootstrap.sh
ってのもあって、インストールドキュメントには stage1 から
インストールする時はこれを使えって書いてあります。
bootstrap-2.6.sh に関しては何も触れられてません。

275 :login:Penguin:04/07/17 20:42 ID:myuJ/heL
FDが使えない件について、レスサンクス。でも、

>>256
フロッピーは module にしておかないと駄目なのかな。組み込んだら
×でしょうか。スペシャルデバイスは何かの仕組みが自動的に
作ってくれないのですかね。

>>261
少なくとも /dev/sda ではなかったです(sdb 以下でもないみたいね)。

もうちっと頑張ってみるわ。


276 :login:Penguin:04/07/17 21:05 ID:yMiQDJY/
BIOSでFDコントローラ無効にしてるとか、
USBFDなのに、
SCSIエミュレーション有効にしていないとか、
そういう落ちじゃねぇだろうな。

277 :login:Penguin:04/07/17 21:48 ID:myuJ/heL
>>276
そんな馬鹿なことは、と思いつつ一応チェックしたけれど、FDコントローラは
有効だったし、USBFD でもないからSCSIエミュレーションは関係ないと思う
(USBメモリを使っている関係で、エミュレーションはONにしてますが)。

それより、>>255 さんが指摘した方法(#modprobe floppy)でチェックしたら

FATAL: Error inserting floppy (/lib/modules/2.6.7/kernel/drivers/block/floppy.ko): Invalid module format

ときたのだ。こっちのほうが重大みたい。
実は、alsa もちゃんと動いていなくて、via82xx などを始めとするドライバが読み込めず、
起動時に山ほど同じエラー(Invalid module format)が出ているんですよね
(ALSA ドライバ側の問題だと思って、そのうちバージョンアップしたら直るだろ、
と気楽に構えていた)。

先日、ディスクをフッ飛ばして、1から再インストールしたので、環境は比較的きれいだと
思っていたのだが、なにかわたし、まずいことをしてるんでしょうね。
ヒントをくださるかた、いらっしゃいませんか?

278 :login:Penguin:04/07/17 21:50 ID:myuJ/heL
ごめんなさい、modprobe floppy を試せというのは >>256 さんの指摘だったよ。

279 :login:Penguin:04/07/17 21:55 ID:myuJ/heL
>>277
おっと、dmesg をチェックしたら、floppy や alsa 関係のモジュールで

floppy: version magic '2.6.7 K7 gcc-3.3' should be '2.6.7 K7 gcc-3.2'

などと出ているね。この magic を正すにはどうしたらいいんだろうか。

280 :login:Penguin:04/07/17 22:17 ID:qrA8hryM
Gentooのカーネルって Linuxの最新カーネルから
どれくらい遅れて更新されますか?

281 :login:Penguin:04/07/17 22:33 ID:+ZSr9ox7
>>280
gentooのkernelってどれよ


282 :login:Penguin:04/07/17 22:41 ID:qrA8hryM
狭義の意味のkernelです。



283 :login:Penguin:04/07/17 22:49 ID:WcLLayCG
>>282
で、どれよ?

284 :login:Penguin:04/07/17 22:59 ID:+ZSr9ox7
>>282はもしかして、gentooでのkernelの扱いについて知らないのかな?
gentooは、ユーザーがいくつかあるkernelの中から好きなもんを選ぶのよ。

↓ここに(古い)リストと各々の解説がある。
ttp://www.gentoo.org/doc/ja/gentoo-kernel.xml

最新のkernelへの対応状況はそれぞれ違うよ。
ttp://www.gentoo-portage.com/browse-portage.php?category=73
ここ参照ね。

285 :login:Penguin:04/07/17 23:02 ID:+ZSr9ox7
ついでに質問

「狭義の意味のkernel」ってどういう意味?
逆に「広義の意味のkernel」って何なの?

kernelの意味合いに広いも狭いもないじゃねーの?

286 :名無しさん@Emacs:04/07/17 23:29 ID:mKLioGLL
狭義のkernel=vanilla
広義のkernel=その他
ってこなんじゃね?

287 :login:Penguin:04/07/17 23:34 ID:yMiQDJY/
...夏だな。

288 :login:Penguin:04/07/18 01:18 ID:MF7PibIF
新しいデバイスを追加したときにそれがどのデバイスファイルに関連づけられているかを
調べるにはどうすればいいのでしょうか?

現在USBのモデムでダイアルアップ接続してるけどこれのデバイスファイルがカーネルを
upgradeする度に、動く動く
/dev/input/hoge だの(忘れた)
/dev/ttyACM0 だの
/dev/usb/acm/0 だの...


289 :login:Penguin:04/07/18 01:26 ID:IjogPgAi
>>288

dmesg |less

290 :login:Penguin:04/07/18 02:05 ID:3KZMe9l4
dmesgしても出てこないみたいですが
ちなみに今回usbプリンタを接続したときのメッセージがこれ

-----
usb 1-2: new full speed USB device using address 3
cdc_acm 1-2:1.0: ttyACM0: USB ACM device
usbcore: registered new driver cdc_acm
drivers/usb/class/cdc-acm.c: v0.23:USB Abstract Control Model driver for USB mod ems and ISDN adapters
-----
でデバイスファイルが
/dev/usb/acm/0

291 :login:Penguin:04/07/18 13:12 ID:vrQkydP6
>>288
lspci見たいなコマンドでlsdevってあったような。
でも、君の要求を満たさない可能性もある。

292 :login:Penguin:04/07/18 14:35 ID:mYa+MxDC
>>282
ちゃんとemerge syncしてればほぼその日に手に入るけど。。。

293 :login:Penguin:04/07/18 15:20 ID:3wS2sUVZ
mule-ucs
をemergeしたらやたらemacsが重くなった。
高速化パッチとやらがあるらしいけど、どうすれば良いんだ?

294 :login:Penguin:04/07/18 19:06 ID:R9YNRvDe
>>293
mule-ucsでインストールされるelispファイルをコンパイルすれば
解決するかも。

295 :login:Penguin:04/07/18 21:32 ID:3MxFUDbd
livecdからインストールしたんですが、初ブートで失敗しました。
gentoo-dev-sources を取得して make menuconfig で設定後に
手動でコンパイル。ブート時のエラーメッセージは

296 :login:Penguin:04/07/18 21:33 ID:3MxFUDbd
livecdからインストールしたんですが、初ブートで失敗しました。
gentoo-dev-sources を取得して make menuconfig で設定後に
手動でコンパイル。ブート時のエラーメッセージは

297 :login:Penguin:04/07/18 22:38 ID:GjRl3G34
>>296
死んだのか?

298 :login:Penguin:04/07/18 23:52 ID:mP9gKACo
真っ白に燃え尽きたらしい。

299 :login:Penguin:04/07/18 23:52 ID:3MxFUDbd
>>297 遅くなりました。。続きです。
ReiserFS: hda3: found reiserfs format "3.6" with standard journal
ReiserFS: hda3: using ordered data mode
ReiserFS: hda3: journal params: device hda3, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda3: checking transaction log (hda3)
ReiserFS: hda3: Using r5 bash to sort names
VFS: Mounted root (reiserfs filesystem) readonly.
Freeing unused kernel memory: 196k freed
INIT: version 2.84 booting
INIT: PANIC: segmentation violation at 0x804d6cf! sleeping for 30 seconds.
Losing too many ticks!
TSC cannot be used as a timesorce.
Possible reasons for this are:
You're running with Speedstep,
You don't have DMA enabled for your hard disk (see hdparms),
Incorrect TSC synchronization on an SMP system (see dmesg).
Falling back to a sane timesource now.

300 :login:Penguin:04/07/19 00:01 ID:/sIiCF9g
windows上のvmware上にgentooをインストールしてるんで
そこらへんに問題があるのかもしれません。/etc/fstab は
/dev/hda1 /boot ext3
/dev/hda2 swap
/dev/hda3 / reiserfs
こんな感じ。かなり省略してますが。devfs,ext3,reiserfsは
カーネルに組み込みました。とりあえず、DMAを有効にしたい
んですが、hdparamを使うんじゃなくてカーネルのコンパイルで
設定できましたっけ?

301 :login:Penguin:04/07/19 00:05 ID:rCQdwkNM
正直 VMWare 上でどうとか言ってるのうざい。
Gentoo の問題かどうか切り分けしてからここに書けよ。

302 :login:Penguin:04/07/19 00:10 ID:M4a/t+5F
すいません。移動します。

303 :login:Penguin:04/07/19 00:34 ID:523RC/ZC
切り分けられねーレベルだからここに書いてるんだろ

304 :login:Penguin:04/07/19 19:39 ID:rOou6twG
2004.2まだ?

305 :login:Penguin:04/07/19 20:02 ID:YzbN1iue
portageの2.0.51がstableになってからじゃないの?

306 :login:Penguin:04/07/19 22:12 ID:6n1FYA4O
emacs の ebuild(Makefile)って /etc/make.conf で設定してる CFLAGSを
採用してくれないんだけど。emacsのebuildファイルに
CFLAGS=${CFLAGS} eonf ...と書いてもでもだめで、
# CFLAGS='-O3 -march=pentium3' emerge emacs
とかならいけるみたい。果して効果はあるのか。

307 :login:Penguin:04/07/20 00:13 ID:3vCeKbBZ
>>306
どういうこと?
うちじゃ make.conf の CFLAGS を使っているようだが

308 :login:Penguin:04/07/20 03:09 ID:iWP6RXUN
xorg-x11-6.7.0-r2にあたるパッチのうち

9385_all_6.7.0-motif-allow-fhs-and-default-off.patch

って何か間違ってねーか?



309 :login:Penguin:04/07/20 03:23 ID:af5bcolq
てかその前にopengl-updateがおかしかったりしない?
includeファイルをチェックしてる所、修整しちゃったよ

310 :login:Penguin:04/07/20 03:33 ID:iWP6RXUN
>>308のレスは済まない。漏れが悪い。

57271で議論されてた。


311 :login:Penguin:04/07/20 03:58 ID:iWP6RXUN
>>309
うんにゃ。漏れんところだとopengl-update-1.8.1は問題出てない。

312 :login:Penguin:04/07/20 06:29 ID:af5bcolq
漏れの所は
xfreeの残骸とxorgのと両方インクルードが残ってて
ebuildで指示されたように mv やっても同じ警告が出て先へ進まなかったよ
xfreeのインクルードを消しても同じだった
条件文を 逆 にしたらようやく通ったw

313 :login:Penguin:04/07/20 10:08 ID:fVm/Vl6C
emerge unmerge xfree はやった?

314 :306:04/07/20 12:54 ID:u02ymhcC
>>307
うそー。マジかよ。俺だけかよ。
configureの頭で
checking whether the C compiler (gcc -O2 -mcpu=i686 -pipe -fno-stack-protector ) works... yes
だし、コンパイルも
make - --jobserver-fds=3,5 -j bootstrap; \
fi
cd lib-src; make all - --jobserver-fds=3,5 -j \
CC='gcc' CFLAGS='-O2 -mcpu=i686 -pipe -fno-stack-protector' CPPFLAGS='-D_BSD_SOURCE ' \
LDFLAGS='-L/usr/X11R6/lib' MAKE='make'
make[1]: Entering directory `/var/tmp/portage/emacs-21.3-r4/work/emacs-21.3/lib-src'
んな感じだな。CFLAGS='-O3 -march=pentium3'
に設定してるのに。 kernel 2.6 で nptl 使ってるのとか関係ないよね


315 :login:Penguin:04/07/20 15:19 ID:7FCOt91W
漏れもxorgに移行しようかと思ってるんだけど、USE='X"にしてる時に
何かのXクライアントをemergeした場合、勝手にxfree-x11がインストール
されたりはしませんか?ちょっと心配です。

316 :login:Penguin:04/07/20 16:02 ID:3vCeKbBZ
>>314
emerge info した時の CFLAGS は?

>>315
/var/cache/edb/virtuals に xfree が残ってたらされるよ。

317 :306:04/07/20 16:08 ID:u02ymhcC
_| ̄|○
emerge info と make.confのCFLAGSが違う
なんで?


318 :306:04/07/20 16:11 ID:u02ymhcC
連アタスマソ
構文ミスがありました。お騒がせスマソ
今日は、emerge -e world寝

319 :login:Penguin:04/07/20 21:37 ID:eFbc1xpp
stage1* のファイルだけをダウンロードする事なんてできるのでしょうか?

320 :login:Penguin:04/07/20 21:47 ID:Ir/Sk1kn
Gentoo MacOS
http://gentoo-wiki.com/Gentoo_MacOS
http://www.gentoo.org/news/en/gwn/20040719-newsletter.xml

インストールしてみますた。
/usr/portage/profiles/default-macos-10.3/packages.build
が間違ってるくさいんだけど、詳細不明。
IRCもMLも参加してないし、Alphaなんでマターリ、マターリ現実逃避しつつ...。
(金曜までに二つレポートがorz)

321 :320:04/07/20 21:49 ID:Ir/Sk1kn
肝心なurl忘れた。
ダウンロードはコチラから↓
http://www.metadistribution.org/macos/

322 :login:Penguin:04/07/20 22:07 ID:/9x/45bj
>>319
できるよ

323 :login:Penguin:04/07/20 22:36 ID:VvqRCE7M
>>317
環境変数で CFLAGS を設定してない?
make.conf の設定よりもそっちが優先されるよ。

324 :login:Penguin:04/07/21 20:30 ID:teJl9mVR
emerge syncの
Number of files:
9万突破記念age

325 :login:Penguin:04/07/21 22:30 ID:i8CfEdnW
emerge -f mplayer のように複数ファイルをダウンロードするとき,
失敗しても無視して次のファイルを落としにいくようにできる?


326 :login:Penguin:04/07/22 00:56 ID:8lTcgjE2
skkserv(multiskkserv)をLAN内の別のPCから
利用したいのですがうまくいきません

skkservそのものは正常に起動していて、
そのPCでは辞書変換もでき、
nmap localhost を実行すると
1178/tcp skkserv
と表示されます。

しかし同じパソコンで
nmap 192.168.xxx.xxx(そのPCのLAN内部IP) とすると表示されません。
(sshやnfsなどは表示されます)
他のPCからこのPCのIPを指定した場合も同じで
このPCのskkservを使用できません。

/etc/hosts.allowを設定してみたり、xinetdを試して
みたけれども駄目なようです。

この場合何を設定したら良いのでしょうか。

327 :login:Penguin:04/07/22 02:14 ID:dxcV8bC9
どうしてGentooだけ、時代の流れから取り残されているんですか?

328 :login:Penguin:04/07/22 02:45 ID:j3kUun6S
どのへんが取り残されてるんですか?

329 :login:Penguin:04/07/22 02:48 ID:8qyFU+mf
>>326
使ったことも入れたこともないけど、
ソース見る限りじゃ -s オプションでサーバネーム指定するように思う。
-h で usage 出してみ。
Gentoo 関係ないやん。

330 :login:Penguin:04/07/22 04:01 ID:KvPiyzlV
>>328
いつものバカだから、相手にせず捨て置け

331 :login:Penguin:04/07/22 05:34 ID:ykVXSdTW
~x86なおまいら、alsa-libをインスコすると、
ハングうぷが散々愉しめますよ。

332 :login:Penguin:04/07/22 06:00 ID:ykVXSdTW
とっととsys-apps/texinfo-4.7でgroffをビルドできる様にしやがれ。

333 :login:Penguin:04/07/22 09:52 ID:VzQdStI/
夏休みっていうのはひどいもんですな

334 :login:Penguin:04/07/22 11:03 ID:EEPLapt8
さっき久しぶりにemerge syncしてemerge -u systemってしたら
groff1.9とかいうソフトのとこで「エラーが多すぎて諦めます」みたいなエラー出して
終了しちゃいますた。

なにも悪い事はしてないつもりなんですが・・・
だれか助けてください。

335 :login:Penguin:04/07/22 12:04 ID:VzQdStI/
夏休みは2つ前のレスも読めなくなりますか?
バージョンまで錯乱しますか?

336 :login:Penguin:04/07/22 12:11 ID:/lu98ep/
>>334
groff-1.19って日本語が正常に扱えなかったような気がする。
だから俺はgroff-1.18系をそのまま利用してる。

つーわけで、groff-1.19でエラーになるならマスクしちゃっえば。


337 :login:Penguin:04/07/22 14:58 ID:tF/ubTNx
すいません、これってどういうことですか?

# emerge -up kde

These are the packages that I would merge, in order:

Calculating dependencies \
!!! all ebuilds that could satisfy "~kde-base/kdeaddons-3.2.3" have been masked.
!!! possible candidates are:
- kde-base/kdeaddons-3.2.3 (masked by: ~keyword)
!!! (dependency required by "kde-base/kde-3.2.3" [ebuild])

!!! Error calculating dependencies. Please correct.


338 :login:Penguin:04/07/22 15:07 ID:fuL28s0u
>>337
エラー文くらい読めよ…
ACCEPT_KEYWORDS

339 :login:Penguin:04/07/22 15:10 ID:gMkZzuJ/
>>337
おかしな話だな。
kde-3.2.3 は x86 なのに、それに必要な kdeaddon-3.2.3 が ~x86 つーのは。

340 :login:Penguin:04/07/22 15:35 ID:tF/ubTNx
kde-3.2.3はkdeaddon-3.2.3を入れたいけど、それが~x86だから入れられないよってことですね。
ちょっと考えてみればわかったものを失礼しました。

341 :login:Penguin:04/07/22 16:24 ID:hxjC7A8M
kde-base/kde ってインストールしたら何かいいことあるんでしょうか?
自分は必要なkde-base/kdeXXXだけをemergeしてますが。

342 :login:Penguin:04/07/22 16:38 ID:drTtrZXe
kdeeduとkdeaccessibilityとkdegamesは入れてもあまり意味無いね。

343 :login:Penguin:04/07/22 16:47 ID:gMkZzuJ/
>341
kdeXXXを全部入れるためにあるんじゃないの 

344 :login:Penguin:04/07/22 22:41 ID:himeZe8H
ふっふっふっ、いよいよGentooをインストールすることにしました。
本も買ってきたし・・・今はなき、コンパックのプレサリオを使います。
セレロン533MHz
HD8.4G
チップセットは確かi810
うまくいくかどうか・・・

345 :326:04/07/22 23:11 ID:8lTcgjE2
>>329
教えていただいたとおり
usageを出してみたところ
Specify which ip to listen.
と説明がありました。
試したけれどどうも駄目みたいです。
LANカードを二枚さしたり複数のIPアドレスがある場合に使うのかな。

とりあえずdbskkd-cdbを使用して
/etc/hosts.deny /etc/hosts.allow で設定したところうまくいったので
しばらくはこれを使っていきたいと思います。
ありがとうございました。




346 :login:Penguin:04/07/22 23:17 ID:Y5BoPtas
母板やチップセットはともかく
ソースを展開&コンパイルしまくるわけだから、HDDとメモリは
でかくて早いに越したことは無い

347 :344:04/07/23 00:08 ID:S9CGBZqw
えっ、
セレロン533Hz
HD8.4G
メモリ128+64
じゃあこころもとないかな?んーもちょっと調べて検討してみよう

348 :login:Penguin:04/07/23 00:26 ID:cEnSjq/E
Gentoo で何がしたいのかにもよる。>スペック

stage3 や GRP 使うんだったら十分だろうし、
stage1 からじゃなきゃヤダってんなら考え直した方が良さそう。
いずれにせよ、HDDは安いからでっかいのにしといた方が吉。

349 :login:Penguin:04/07/23 00:52 ID:HrvfEwla
gentooとWinXPのデュアルブート環境で使用しているのですが
起動の度に時計の時刻が後ろにずれていきます。
いちおう WinXPの設定は「東京」 で
Linux側は
/etc/localtime -> /usr/share/zoneinfo/Asia/Tokyo
/etc/rc.conf : CLOCK="local"
にしています。どれか設定がおかしいのでしょうか?


350 :login:Penguin:04/07/23 01:09 ID:+iXwHw95
gentoo.orgがつながらないですね。

351 :login:Penguin:04/07/23 01:17 ID:sAYp8d1+
>>347
C3-533でStage1からビルドしたことはあるぞ。
めちゃくちゃ時間かかったけどな。
coLinuxとか使えるなら、Windowsマシンも使ってdistccとかを使うといいぞ。

352 :login:Penguin:04/07/23 01:36 ID:kRACVFQf
>>350
ふつーに繋がるでそ。(ip: 64.5.62.17)

それともこれかな? (でもこれは確かpackages.g.oの場合だしなぁ)
echo 0 > /proc/sys/net/ipv4/tcp_default_win_scale
echo 0 > /proc/sys/net/ipv4/tcp_moderate_rcvbuf

353 :login:Penguin:04/07/23 09:27 ID:tReOvGwr
なんかKDEでデスクトップのホームとかクリックすると
デスクトップのアイコン全部が消えるんだが・・・
(んでまた現れる・・・以上エンドレス)
漏れだけ?
KDE3.2.2はGentooがはじめてだけど、他のディストリのKDEの時は
そんなことなかったんだがなぁ。
他にも同じようになった人いる?


354 :login:Penguin:04/07/23 09:31 ID:81aQTZTd
>>353
グラフィック周りの設定が悪くて、表示がトロくなってるとか。
他のディストリでも同じ事が起こっているが一瞬で気づかないだけとか。


355 :353:04/07/23 09:44 ID:tReOvGwr
>>354
書いてなくてスマンかった。
Geforce FX 5200以上のGeforce FX系マシン2台にインスコして同じ症状なんだよ。
(片っ方はNvidiaのカーネルモジュールとか入れてるが同じ症状なんでその辺ではないと思う)
CPUクロックも2G以上、メモリも1G以上あるからその辺が問題とは思えんし・・・

つーかクリックしたらデスクトップのアイコンが全部消えて(ホームアイコンクリックしただけでもね)
もっかい現れる。
もちろんホームは開かないから、表示がトロいだけではないと思うんだが・・
ググってもでないし、ここに同じ症状の人いないかと思ってね。


356 :243:04/07/23 10:21 ID:vjSm/J64
>>244
もしかしてxfreeからx11-xorg移行?
emerge --unmerge xfreeしてからxorg入れても、たまに変になったりするよ。
こっちはRadeon9200でGnomeと、環境はまるっきりちがうけど。


357 :login:Penguin:04/07/23 10:24 ID:vjSm/J64
ありゃりゃ、ごめん、>>355っす。


358 :353:04/07/23 10:46 ID:tReOvGwr
>>356
いや、xfreeだけだよ。xorgとかは入れてない。
ログ見ても(XFreeログとか、~/.xsession-errorとか)それらしいエラーは見つからないし・・
やたらkonkuererがシグナル11で落ちるんで、konkuererの問題ぢゃないか?とは思うんだが、
これも漏れではググっても情報見つからなかったのよ・・・・
こんな現象初めてなんで、どこが問題なんだかまったく検討がつけられん・・・

359 :login:Penguin:04/07/23 12:09 ID:FfOMKWPm
>>181 kernel2.6?
gentoo forumsで見つけたんだけど
kernel2.6 emerge /usr/portage/net-misc/nforce-net/nforce-netxxx.ebuild
とりあえず逝けた。

360 :login:Penguin:04/07/23 12:50 ID:aBLngNSK
>355
同じような環境だけど全然問題なし。4台ぐらいあるがすべて問題なし。

361 :login:Penguin:04/07/23 16:39 ID:E0gUKrQR
gentoo-dev-sources な環境で,skkfep を使おうとしているのですが,
デバイスファイル(?)が下記の様なパーミッションになっていて,
root ユーザ以外では途中で止まってしまいます.
(Cannot get /dev/tty と表示される)

lr-xr-xr-x 1 root root 6 7月 22 14:52 /dev/ptyp0 -> pty/m0
lr-xr-xr-x 1 root root 6 7月 22 14:52 /dev/ptyp1 -> pty/m1
(中略)
lr-xr-xr-x 1 root root 7 7月 22 14:52 /dev/ptypf -> pty/m15

crw-rw---- 1 root root 2, 0 7月 23 16:17 /dev/pty/m0
crw------- 1 root root 2, 1 1月 1 1970 /dev/pty/m1
(以下略)


これらのファイルのパーミションを変えようとしても,何故か変更されません.
どこがまずいんでしょうか?

なお,udev は使っていません.

362 :login:Penguin:04/07/23 17:21 ID:tReOvGwr
>>361
変える事がいーかどうかは別として、
シンボリックリンクになってるからでは?
だからリンク先(たとえばpty/m0)の方のパーミッション変えないと
変わらないんじゃないの?


363 :login:Penguin:04/07/23 22:10 ID:ju6KrTpe
安定版のipw2100(0.44)使えてる人いますか?
うちでは、

# modprobe ipw2100
unresolved symbol 'hostap_get_crypt_ops'

になってしまい、
http://ipw2100.sourceforge.net/faq.php#qa_1_0
にある通り、先にhostapをロードしたのですが、結果は変わりません
でした。

# ACCEPT_KEYWORDS="~x86" emerge ipw2100
で、0.49を入れたらあっさり解決しました。

364 :login:Penguin:04/07/24 01:59 ID:bW6v2/pv
Mozilla が 1.7 になっていたので emerge -u mozilla したら
以下の様にエラーに成るのですが、これはどう対処すれば良いのでしょう。

Calculating dependencies ...done!
>>> emerge (1 of 1) net-www/mozilla-1.7 to /
>>> Downloading http://mirror.gentoo.gr.jp/distfiles/!moznomail?
--01:59:17-- http://mirror.gentoo.gr.jp/distfiles/!moznomail?
=> `/usr/portage/distfiles/!moznomail'
mirror.gentoo.gr.jp をDNSに問いあわせています... 211.14.6.124
mirror.gentoo.gr.jp[211.14.6.124]:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 404 Not Found
01:59:17 エラー 404: Not Found。



365 :login:Penguin:04/07/24 02:02 ID:fYu6Ii3v
404って出てるじゃん

366 :login:Penguin:04/07/24 02:05 ID:vJm9S/a7
afterstepのebuildだけど、dependしてるx11-wm/gnustep-envがgnustep-base/に移動してるのに、それを修正してないからエラーでるね。
最近こういうの多いなー、portageを管理しきれてない感がする。
#気づいた自分がやるべきなんだろうけど。

367 :361:04/07/24 02:36 ID:6vFmiGwV
>>361
リンク先のファイルもパーミッションが変わらないです.

というか,kernel-2.6 でskkfep 使っていらっしゃる方々は
どうやっていらっしゃるんでしょうか?

368 :login:Penguin:04/07/24 03:57 ID:EtNXoXuB
>>364
使っている portage のバージョンが古いような気が……。
DEPEND の USE フラグがネストすると扱えないというバグがあって、
opera でよくそのエラー見かけたのだけど、最近の portage では直って
いるはず。FEATURES に cvs が入っているとそうなったんじゃないかと。

>>366
報告してくだされ。gnustep は人で足りない。

>>367
もう uim-fep のほうを使っているので……。

369 :login:Penguin:04/07/24 11:42 ID:tvg7Cgl8
kde(3.2.3)のうぷ kita-

370 :login:Penguin:04/07/24 17:16 ID:bW6v2/pv

>>368
portage のバージョンは 2.0.50-r9 です。
/etc/make.conf の FEATURES から cvs を外したら、うまく行きました。
有難う御座いました。


371 :login:Penguin:04/07/24 22:44 ID:cGKW5w7q
Qtを上げられないまま来たけど
ついにQt DEPEND のKDEがキタ

372 :login:Penguin:04/07/25 13:21 ID:6lv4fs8Y
gentoo 初心者です。

chkconfigに慣れているのですが、
gentooでのrunlevelコントロールがまったくわかりません。

文書などがありましたら教えてください。

373 :login:Penguin:04/07/25 14:11 ID:Zg9mzwho
>>372
rc-updateのことですか?

374 :login:Penguin:04/07/25 14:11 ID:HahfwA0O
>>372
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2&chap=5

375 :名無しさん@Vim%Chalice:04/07/26 00:32 ID:hRaPB+46
Opera staticってないの?

376 :login:Penguin:04/07/26 00:51 ID:QgrCIidQ
USE="static" emerge opera -vD しろよ.


最近,餓鬼多す(ry

377 :login:Penguin:04/07/26 02:14 ID:UyFxp/yO
夏だし、週末(だった)し

378 :login:Penguin:04/07/26 09:00 ID:ivIQbhze
timidity++が2.13.0-r1に上がったとき、MIDIがまともに再生できない
という状態になりました。(CPU使用率がMaxでリアルタイム処理できない状態)
同時にアップデートしたartsが怪しかったのでUSE=-artsしたら直ったのですが、
同じ状態になった人はほかにいますでしょうか?

379 :353:04/07/26 09:10 ID:ttg7lTP8
KDEでアイコン表示が変な件解決しました。

1・emerge sync で最新に更新
2・コンパイルオプションから、"O3","pipe","marchj=pentium4"を削除

これでKDEを全消去して再度 emerge KDE で直りました。
まぁ、1は問題が出てるときもバージョンが古いのか?と思って何度もやってたしこれが原因ではなさそう。
となると多分問題は2なんだけど、影響ありそうなオプションに見えないんだけどなぁ・・・

ともあれ、うまく動くようになったんでいろいろアドバイスくれた方々、ありがとでした。

380 :353:04/07/26 10:32 ID:ttg7lTP8
"marchj=pentium4”
ぢゃなくて、
"march=pentium4”
だな。

TYPOスマソ・・・・・○| ̄|_

381 :login:Penguin:04/07/26 19:13 ID:87ly569r
2004.2リリース!
あれっ、夏休みでここいないのか(無念)

382 :login:Penguin:04/07/26 19:23 ID:psEXPcWw
>>381
既に使ってる人には関係ないからなあ

383 :login:Penguin:04/07/26 19:29 ID:4lTS641u
BitTorrentも用意されてる↓
http://www.tlm-project.org/torrents/gentoo/x86/2004.2/

384 :login:Penguin:04/07/26 21:10 ID:HmcrjOrK
2004.2といっても、入れたバージョンが何だろうがemerge syncをやってればそれ相当になるんだもんね。。。

385 :login:Penguin:04/07/26 21:30 ID:EqLVx8F1
>>384
その通り

相当っていうか、それすら通り越してる香具師もいれば(unstable)
自己流環境のまま、遥か明後日の方向に突っ走ってる香具師もいるだろ(混在かつ自己流選定)

まあ、使い方は色々ってこったな

386 :login:Penguin:04/07/26 22:16 ID:0JbMW2iB

# emerge w3m

Invaild package name: w3m-0.5.1-r1/w3m-0.5.1-r1


(w

387 :login:Penguin:04/07/26 22:31 ID:izrPpnYG
で?

388 :login:Penguin:04/07/26 22:55 ID:EqLVx8F1
>>386
再現しませんが?

389 :login:Penguin:04/07/26 23:39 ID:0JbMW2iB
sorry

#echo '>=net-www/w3m-0.5.1-r1 -gtk imlib' >>/etc/portage/package.use
~~~~
just a typo




390 :login:Penguin:04/07/27 10:09 ID:VwDt5haV
>>384
微妙に違うのでは?
/etc/make.profileのリンク先だけかもしれないがorz

391 :login:Penguin:04/07/27 12:37 ID:cbUDV+xn
etc-updateの -3。
mv: overwrite XXX ? で no が効かないんのはなんで?y は効く。

392 :391 :04/07/27 14:50 ID:cbUDV+xn
すんません。etc-updateの使い方を知らなかったようです。
ファイル名の番号を入力すれば、さらにメニューが表示されるんですね。

でも-3でnoできないなら-5との違いは何でしょう?
個人的には-3は必要ないです。

393 :login:Penguin:04/07/27 16:52 ID:RKam3hco
emerge kde してから丸一日。まだ終わらん。
いまは kde-graphic とかいうのをコンパイルしてる模様。
終わりは近いですか?

394 :login:Penguin:04/07/27 16:54 ID:c1rED/sn
>>393
漏れはAthlonXP2500+で12hくらいだったかな。

395 :login:Penguin:04/07/27 19:06 ID:9dkD3bbJ
>>393
別の窓でemerge -p kde してみるとか。

396 :login:Penguin:04/07/27 21:51 ID:RKam3hco
>>394
うちも同じCPUだ。でもまだ終わらない。メモリがしょぼいのかなー。
>>395
kdeartwork
kdeaccessibility
kdenetwork
kdepim
kdeaddons
kdeadmin
kdegames
kde
がまだ残ってる模様。ねこそぎインストールしてるみたい。kdegames なんて
いらないのに… ちゃんと調査してから始めるべきでした。コンパイルしてる
間に新しいQtがあがってるし。

397 :login:Penguin:04/07/28 02:01 ID:Yk+qs3QU
>>396
>コンパイルしてる間に新しいQtがあがってるし。

わろた

398 :login:Penguin:04/07/28 05:10 ID:2ZLtqa3E
XF86で、フォントのアンチエイリアシング止めたいですけど
何処を書き換えたらよかとですか?

399 :login:Penguin:04/07/28 15:40 ID:0wvM6YEw
>>398
くだ質へゆけ。
なお。使ってるWM書かないと
向こうでもスルーされる恐れあり


400 :名無しさん@Emacs:04/07/28 15:58 ID:YB7K3nUR
$HOME/.fonts.conf に

<match target="font">
<edit name="antialias" mode="assign">
<bool>false</bool>
</edit>
</match>

を追加すればいい.WM は関係ないでしょ.


401 :login:Penguin:04/07/28 16:11 ID:1PLjr9SY
遊びで2004.1入れてたので、インストールマニュアル修正がてら
2004.2を最初から入れなおしてみる。
いままでLiveCDで認識してくれなかったNICをすんなり認識した。
細かいことだけれど、けっこう嬉しい。

402 :login:Penguin:04/07/28 18:42 ID:nLTWJam8
KDEとかのバイナリって無いの?
古いPCで、KDE使うなって事ですかね。
もれのCeleron500MHzではどうにも。。。

あと、なんかGentooって昔のFreeBSDみたいな感じですよね。
きっとバイナリパッチやGentoo RELEASEも出来るんだろうなぁ〜

403 :login:Penguin:04/07/28 19:09 ID:QQI73kIa
>>402
俺のCeleron1000MHzだとKDEに丸一日以上かかったので、
500MHzだと丸二日ぐらいでは?
まぁ五十歩百歩。

でも500MHzだとKDEの動作自体が重杉な悪寒。
俺もいまはFluxboxに乗り換えた

404 :login:Penguin:04/07/28 19:49 ID:OMNFNHWo
KDEが無くてもQtは入れなきゃいけないし…

405 :login:Penguin:04/07/28 19:57 ID:b2qGpHvs
>>404
なぜ?

406 :login:Penguin:04/07/28 20:33 ID:XioiUOS+
例えばBlackBoxのプラグインの中にはQTライブラリを使うものがあるし。
QtやKDEを入れたくなくてBlackBoxにしたのに、すっごくいやな気分になるのさ。

407 :login:Penguin:04/07/28 20:36 ID:b2qGpHvs
>>406
ならそんなWMを使わなければいいだけの話

408 :login:Penguin:04/07/28 20:55 ID:+x5AFhZV
>>407
それをいっちゃぁお締めぇよ。QTのお陰でいろんなもんが出来てるんだから
QTのバイナリは欲しいところだねぇ。

409 :login:Penguin:04/07/28 21:02 ID:DpGBeBOY
Qt だけなら、2時間/1GHz ぐらいでコンパイル出来ない?

410 :login:Penguin:04/07/28 21:41 ID:rcKX2IfE
Qtはすぐ終わる。KDEコンパイルしたけどいらねーやこれ。
せっかく丸2日かけたのに。

411 :login:Penguin:04/07/28 22:32 ID:0wvM6YEw
てかQtが必要なBlackboxプラグインを406が使うの?
使わないならUSE=-qtで何の問題もないわけだが。

412 :login:Penguin:04/07/28 23:04 ID:5Yl7NGkz
KDE一式、20パッケージ
4時間半ぐらいだったかな?
AMD64 3200
やっぱ早いね。

413 :login:Penguin:04/07/28 23:31 ID:jicVQfc/
>4時間半ぐらいだったかな?
>AMD64 3200
自慢だな?自慢してるんだなコンチクショー
くそぉ、うらやましいぜっ

414 :login:Penguin:04/07/28 23:34 ID:DpGBeBOY
>411
調べてみたら bbconf が無条件で使うようになってるね。
今ならふつー fluxbox なんだろうけど。

415 :login:Penguin:04/07/29 00:00 ID:B3gqKCSn
>>412
CFLAGSはどの様に書いてますか?
教えてください
~amd64ではありません

416 :412:04/07/29 00:24 ID:0/jBwmZd
CFLAGS="-O2"
こんだけ。。。

417 :login:Penguin:04/07/29 00:25 ID:IxeeRoxP
別の窓で・・・とか話でてるし、なんかWMの上でコンパイルしてるのか?
そーだとすると若干遅くなる気がする。
GUIの上に窓開いてその上で、状況の表示とコンパイルとしてるんだから。
表示だけでもX系の処理の呼び出しやX系からカーネル(?)あたりの呼び出しも発生して、遅くなる気がするんだが。
その上でコンパイルも走るわけだからね。
コンソールでやってみると若干早いのかもしれん。

・・・・・・最も漏れの気のせいかもしれんが。


418 :login:Penguin:04/07/29 01:05 ID:vWctNnWy
>>417
俺もなんとなくコンソールのほうが早いんじゃないかと思うけど、
コンパイル中に何もしないならともかく、ふつーに使ってて
その裏でコンパイルしてることが多いから、Xの上でやってる。

419 :login:Penguin:04/07/29 01:13 ID:0xymCM5a
PORT_LOGDIR 設定して標準出力&エラーは /dev/null に。

420 :login:Penguin:04/07/29 03:38 ID:38+0F+C+
>>418
俺はフレームバッファコンソールすら許せんかったよ。
CUIでログイン、emerge hogeとおっぱじめたら
Ctrl+Alt+F2で別画面ログイン、んでstartx。
PenIIノートだったりするとX動かす気にもなれんからほっとく。

421 :login:Penguin:04/07/29 03:46 ID:38+0F+C+
そういえば1.4が出る以前、$LANGをja_JP.eucJPにしてると
ビルドできないパッケージがあるちゅう話があった気がするが、
あれはもうよくなったんでっか?
あれあったから
1)CUIでビルド
2).xinitrcでLANG設定してstartx
ちゅう癖がついてたんだけど。


422 :login:Penguin:04/07/29 07:43 ID:ImlUMnGs
!!! ERROR: kde-base/kdemultimedia-3.2.3 failed.
!!! Function kde_src_compile, Line 130, Exitcode 2
!!! died running emake, kde_src_compile:make


423 :login:Penguin:04/07/29 09:48 ID:2odzuAtV
http://bugs.gentoo.org/show_bug.cgi?id=58559

424 :login:Penguin:04/07/29 12:42 ID:KEQEz2ur
firefoxを0.9.1に上げたらフレームの調子が悪い。
http://www2.2ch.net/2ch.html
の左側のリンクをクリックしても板が表示されない orz

425 :login:Penguin:04/07/29 12:54 ID:sqs+O7/j
手元のセレ366、めもり 64M なノートで splat qt すると
9時間半と出た。

そんなもんなんだろうか。

426 :login:Penguin:04/07/29 13:48 ID:UvVc4Q7O
>>424
0.9 からセキュリティ上の理由とかで
別ドメインへのフレームのリンクがデフォルトで制限されてる。
それ解除すれば問題なかったような。。。


427 :login:Penguin:04/07/29 18:12 ID:KEQEz2ur
>>426
docshell.frameloadcheck.disabledをtrueにしたら解決しました。
さんくす


Firefoxまとめサイト
ttp://software.s48.xrea.com/mozilla/index.php?FAQ#content_1_1

428 :login:Penguin:04/07/29 18:26 ID:38+0F+C+
KDEビルド二日かけて完了。
勇んで起動。無駄にはしゃぎつついろいろ設定。動作確認。
よしよしとmozillaを立ち上げ、日本語入れようとしたら
Wnn7(XWNMO)が動かない....。






あほだ。

429 :login:Penguin:04/07/29 18:47 ID:rChg+z58
Firefoxとかすぐバージョンアップされるとむかつく。
時間を返せーと思うんだが、全部コンパイルしなくても良いんだよね?
もう少しスキルがあれば・・・

430 :login:Penguin:04/07/29 21:01 ID:QQ0I+8e3
>>429
ccache

431 :login:Penguin:04/07/29 21:08 ID:kJ1NEFj2
lintool が見当たらないのですが、どこかのパッケージに吸収されましたか?


432 :415:04/07/29 21:15 ID:B3gqKCSn
>>412
同じですか…
レス サンクス

433 :login:Penguin:04/07/29 21:46 ID:S1/6UYc5
てか、ATOKX使いは誰も居ないので束?
QTが上げられないのでKDEも更新できず・・・OTL

434 :login:Penguin:04/07/29 22:09 ID:8C/KSOxl
QtっていくつならATOKまともに動くの?

435 :login:Penguin:04/07/30 01:48 ID:EuCFUzod
>>434
よくわからないけど、JPに上がっているのが最新みたい。
その後更新がないのでみんなどうしてるんだか?
いちおう自分はそこで止めてるけど、
いつのまにか候補ウインドウが文字化けするようになって直らない。
あそこはGTKのはずだけど。。

436 :login:Penguin:04/07/30 01:57 ID:VMismTQD
ああ、パッチの問題か。ATOKパッチが最新Qtに追いついてないんだね。

437 :login:Penguin:04/07/30 02:15 ID:p2u5AjAB
ん?atokxは~x86環境最新のkdeで何の問題もないが?

438 :login:Penguin:04/07/30 04:18 ID:VMismTQD
>>437
マジで? 改行後とかカーソル位置おかしくならない?

439 :login:Penguin:04/07/30 08:04 ID:ysgPyxuq
>>437
バージョンは?
さっきも使ってたら、ON/OFFの切り替え時に行の最初の字が削れてしまったり、
いきなりキー入力が行えなくなったり(マウスは桶)、
挙げ句の果てはKDEアプリ巻き込んでお亡くなりになったり・・・
候補文字化けは相変わらずだし。

これでもATOKXとQtとも一度はunmergeしてremergeしたんだけどなぁ。

>>438
その症状は今のところ出てない。

440 :437:04/07/30 10:20 ID:h/Ewa4y3
しまった。Qtアプリで文章を書いてなかったんで気が付かんかった。スマン。
kedit, kateとかでやってみたら、うちでは改行後に入力キーの累計?が重複して
出ちゃうね。"QTextCursor::gotoParagraph Index: 11 out of range"とか出てるから
上書きすべきカーソル位置を見失っちゃってるようだね。

rxvt+vi, gtkアプリでは問題なし。

441 :login:Penguin:04/07/30 13:40 ID:VMismTQD
>>440
でしょ? 現象としては、Qtが思っているカーソル位置と実際のカーソル位置
がずれている現象と、そうなってしまうとキーを一つ打つたびに連打されたよう
な結果になる現象。改行やカーソル移動の前にIMをOFF/ONすればカーソル位置が
リセットされるので毎回そうやって入力してます。

442 :login:Penguin:04/07/30 14:34 ID:IiC2fEdb
javac やjava を実行すると、強制終了って出るんだけど、
皆の環境では動いてますか?
sun-jdk-1.4.2.05 です。

443 :login:Penguin:04/07/30 21:22 ID:LGlWf/Gz
Gnome+Atokだと問題なし


444 :login:Penguin:04/07/30 22:36 ID:GW1fEudO
>>442
JBoss以外は問題なく動いてるけど。

445 :442:04/07/30 23:32 ID:IiC2fEdb
>>444
サンクスです。
もうちょっと調べて原因探してみます。

446 :login:Penguin:04/07/31 01:39 ID:HpZmmt+S
>>443
そんなことはわかってる。Qtの問題。

447 :login:Penguin:04/07/31 02:30 ID:M3Fup6Ls
atokxはqt-3.2.3-r1 + kde-3.2.2で一応使えています。
http://www.pc-souko.jp/deskbbs/linux/bbs/imgf/0073-1091207552.png
候補ウィンドウの文字化けや改行が変になることはありません。
ただ、候補にある語を選択しても反映されないことはありますが、
もう一度変換することで確定できます。
atokxは最初に1.0-r4をemergeしてから、1.0-r2をemergeすることで、
パレットも使用可能です。
XIM Input Styleはover the spotにしています。
qtのバージョンは3.3.2でもatokxは使えますが、フォントの関係で3.2.3を使っています。


448 :login:Penguin:04/07/31 02:56 ID:HpZmmt+S
>>447
>>441の現象は出てない? うちではパレットも変換も無問題なんだが>>441
現象だけはどうにもならない。XIM Input Styleはover the spotというのは何?
もしかしてそれが鍵?

449 :login:Penguin:04/07/31 03:34 ID:M3Fup6Ls
>>448
kate、kwrite、kita、kmail、で確認しましたが、>>441の様な現象は
出ていないと思います。XIM Input Styleはqtconfigで変更できます。
XIM Input Styleをon the spotにすると、候補ウィンドウに表示される
語も一発で変換でき、kate等のQtアプリでは何も問題は無いのですが、
Operaでスペースを入れることができないので、over the spotにして
います。

450 :login:Penguin:04/07/31 03:37 ID:SRbx/EB7
スレ違いだけど

over the spot
変換作業が入力箇所で行われるもの。あるいは入力箇所で逐次入力できるもの。
別窓になるのは変換候補だけ。他全てカーソルのある位置で行なえる。
MS IMEと同じような感じ。

root
入力&変換用の小窓が日本語入力モードになると自動で出てきて
そこに文字を入力する事になる、それも逐次 挿入すべき箇所に転送(&挿入)される。
変換作業はその専用の窓内で行なう。
例えるなら、日本語入力のためにemacsで入力、対象にコピペする作業のうち
コピペだけを自動化したような感じ。

まだ他にも入力スタイルはいくつかある。
skkinput2あたりが色々試せると思われ。

入力スタイルがアプリに及ぼす影響のうち
もっとも多いのが、ウィジェット側での対処。
gtk2はキャレットの描画も担当してる。
入力処理も体系的に管理してる。

Qtは入力アプリのものをそのまま利用してる。
gtk2のimの扱いのような汎用性のある構造はまだQtにないので
Xと上手く折合いをつけていかなきゃいけない。
個々の入力アプリで対応状況が大きく異なるのもそのため。
これは多言語化、国際化とは別次元のドロ臭い部分なので
早急なim用のフレームワークの実装が望まれる。
#ただatokはちょっと特殊だよなぁ


451 :login:Penguin:04/07/31 03:38 ID:SRbx/EB7
ついでにQt側とim側での入力スタイルの設定が一致してないと
かなりアレな事になると思われ。

452 :login:Penguin:04/07/31 08:39 ID:TxymwzFF
>>422
おれも同一の症状でKdeのemerge できず。
423をみて、USE="arts" も試したけど解決せず。
そちらは解決しましたか?

453 :login:Penguin:04/07/31 18:52 ID:4y8BewZh
なんかいっぱいアップデートきた

454 :login:Penguin:04/07/31 22:22 ID:FFhQoTB2
>>453
うん。ビビッたね。

455 :login:Penguin:04/07/31 22:26 ID:U34Kt20r
やべーな
この前のKDEすっ飛ばしてるから
今ごろは大変な量になってるな


456 :422:04/08/01 01:16 ID:BODt8Hhe
>>452
未解決っす。。

>>423
返答、あったの452のレスを見るまで気づかなかった。
Thanks.
今からチャレンジします。

457 :login:Penguin:04/08/01 02:00 ID:WebgoY5Y
いろいろ調べたのですが分からない事があるので質問します.

kterm 上で,less とか nano でファイルを開いていると,PageUp と PageDown が効きません.
xterm では起こらなかったので,kterm 固有の問題だと思います.

それと,Tgif のフォントが非常に汚いです.(下のような感じ)
http://penguin.s4.xrea.com/imgboard/img-box/img20040801015507.png

両方とも,/etc/X11/app-defaults/ の中を見てみたのですが,よく分からんかったです.

458 :login:Penguin:04/08/01 04:05 ID:YwFqq3Bt
>>447
つまりだ、~x86環境で使ってる漏れが悪いということだな・・・

qt-3.3.0-r2, kde-3.2.3だとダメなのか。orz

459 :login:Penguin:04/08/01 05:57 ID:7hZtPsQF
あの、portage に Tgif がないようなんですが…

460 :login:Penguin:04/08/01 06:00 ID:j+s1gcfs
>>459
portagejpにある。
何故か本家には無い。

461 :458=439:04/08/01 06:46 ID:YwFqq3Bt
>>441の現象確認。
当方ただいま、qt-3.3.2,atokx-1.0-r2。
ところで、/etc/init.d/のスクリプトはIIimを使えばいいのか、iiimを使うのか?どっちなんだろ?
今までIIimだと思って使ってたのが、iiimも起動していて気持ち悪かったので、両方の中身をみて
IIimを消してiiimにしてみた。atokxの方を書き換える必要があったが、とくに問題はなさそう。
パレットが文字化けするのは相変わらず。これはGTK,Qt問わず。困ったもんです。これってGTKに
依存してるんじゃなかったっけ?文字コードの設定が悪いのかな?LANGのUTFとかEUCとかその辺?




462 :458=439:04/08/01 06:54 ID:YwFqq3Bt
いちおうスクリーンショット。
ATOKXでパレットが文字化け(つーか見えん)してるの図↓
http://penguin.s4.xrea.com/imgboard/img-box/img20040801065331.png


463 :login:Penguin:04/08/01 07:04 ID:YwFqq3Bt
状況としてはこちらの方と全く一緒。設定画面もダメダメ。
悲しいかな、3年前の情報で、fj.osに投稿した内容らしいのだけど、スレッドが残ってない。

http://216.239.57.104/search?q=cache:NMLi5e7DOu4J:www.nishimoto-site.net/archiver/fj/os/linux/200111/msg00162.html+atokx+%E3%83%91%E3%83%AC%E3%83%83%E3%83%88+%E6%96%87%E5%AD%97%E5%8C%96%E3%81%91&hl=ja
カスタマイズを施そうと思ったところ文字パレットにマウスカーソル
を重ねて見たところ通常なら「カスタマイザ」や「単語登録」
と日本語で表示されるはずが全て「Pallete」と表示され
カスタマイザをクリックして起動させてみたところ日本語で
表示されるはずの部分が空白もしくは文字化けで全く日本語が
見れない状態になっていました。


464 :login:Penguin:04/08/01 07:42 ID:YwFqq3Bt
むしろ、GTKの問題のような予感・・・

slocateで調べて atok がパスに入っているファイルを片っ端から削除して
カスタマイズファイルに至るまで、portageツリー以外のファイルを全削除。
これで再度インストールしたけれど、パレットは文字化けしたまま。
カスタマイズしようにもタブに文字が表示されないので、もうだめぽ OTL

同じATOKXで正常動作しているユーザがいるわけだから、あとはGTKとその設定ファイル
くらいしか差は思いつかない。当方、gtk+-2.4.4でつ。



465 :login:Penguin:04/08/01 08:06 ID:YwFqq3Bt
おまいら、謎が解け松田。
http://www.a-yu.com/pub/faq03.html

/usr/lib/im/locale/ja/atokserver/atokx_client
の修正が必要だった。

つーか、これ以前に参照して治していたはずなんだがなぁ・・・
少なくとも漏れの情報wikiページにはこのページを参照して治した形跡が・・・。
何はともあれこれで快適に入力できる・・・はず。

あー、なんかQt絡みのはだめっぽい。>>441の現象は残って今津。
Qt戻す鹿。

466 :login:Penguin:04/08/01 08:15 ID:7hZtPsQF
>>460
サンクス。結構メジャーなツールなのになんでだろうね。

467 :login:Penguin:04/08/01 08:27 ID:TyzDFjER
Ngraphもいれてほしい

468 :login:Penguin:04/08/01 08:51 ID:9vseptjV
gcc-3.4.1-r1からsys-libs/libstdc++-v3がPDEPEND(マージ後にインストール必須)に
含まれるようになったけど、これってgcc-3.3.xがあれば要らないことないですか?
gcc-3.3.xを外すための準備段階みたいなものなんでしょうか?

469 :login:Penguin:04/08/01 15:30 ID:D6m/fji8
本やサイトを見ながらgentoo2004.2をインストールしてます。
ステージファイルを展開して、procのマウント、resolv.confのコピー
chrootの実行と進んできたのですが、環境変数の更新で注意らしきものが
出ます。これはエラーでしょうか?

#env-update
!!! Invaild token (not '=') is
!!! ParseError: Invaild token (not '='): etc/make.conf: line6
!!! Incorrect multiline literals can cause this. Do not use them.

make.confファイルになにか誤った記述があるのでしょうか?

470 :エスパー名無しさん:04/08/01 15:59 ID:Q9+B54UP
6行目までの文法がおかしい
foo = bar
見たいになってないといけないのに
foo bar
と(=ではないもの)が続いている。

>>469
その誤った記述を晒さないと常人には答えられないぞ

471 :login:Penguin:04/08/01 16:02 ID:7hZtPsQF
/etc/make.conf の 6行目が変だって書いてあるじゃん。

472 :login:Penguin:04/08/01 16:03 ID:7hZtPsQF
エスパーさんが答えてましたね。ごめんなさい。

473 :login:Penguin:04/08/01 16:09 ID:m1fgtamr
>>469
前スレに全く同じ症状の人がいた。

Gentoo Linux 9
http://pc5.2ch.net/test/read.cgi/linux/1084107269/451
> 451 名前:432[sage] 投稿日:04/06/03 00:08 ID:vhI6QVmG
> 解決しました。
> これは、明らかにバグじゃないですか?
>
> なんか/etc/make.confに勝手にipv6がどうのこうのという文章がコメントアウトされずに直に書き込まれていたのが原因でした。
> それをコメントアウトしたらとおりました。
>
> なんだこりゃ・・・

結局なんでこんなことになったのかは、夜中に急用で出て行ったきり帰ってこなかったので不明。

474 :login:Penguin:04/08/01 16:58 ID:eMTfPIAU
thinkpad X31を使用しています。
この度、カーネルを2.6にバージョンアップしようと、カーネルのコンフィグを行っていたところ
CPUの種類のところでつまづきました。
X31のCPUは、「pentium M」 と 「pentium-4 M」
のどちらなのでしょうか?アドバイスお願いします。

475 :469:04/08/01 17:11 ID:EEbrSdYg
>>470-473
ありがとうございます。/etc/make.confを見たら確かに
ipv6がどうのこうのが書き込まれていました。よく見るとWebページのような・・。
もしかするとサイトに書いてあったとおりにmirrorselectコマンドをやって
しまったのが原因かもしれません。
とりあえず最初からやり直してmirrorselectをしなかったらうまくいきました。
お手数おかけしました。

476 :login:Penguin:04/08/01 17:21 ID:m1fgtamr
>>475
よく見れば前スレでも mirroselect が原因だって出てた。

477 :login:Penguin:04/08/01 18:45 ID:Y2HdHFaH
glib-2.4.4のアップデート中にエラーになるよぉ。
Function src_compile, Line 35, Exitcode 2
ってどゆこと?

478 :login:Penguin:04/08/01 18:56 ID:UsLUCR5H
そんな部分晒されても対処のしようがない

479 :login:Penguin:04/08/01 19:05 ID:zxsSUTPB
>>474
Pentium-4 M (not Pentium M) chipsなんで、Pentium Mに一票
ここで聞くより、くだ質へ行った方がいいよ。

480 :login:Penguin:04/08/02 19:03 ID:fwUpx+BY
# rm -rf /var/tmp/portage/*
って実行してもOK?

481 :login:Penguin:04/08/02 19:05 ID:YFS0UePm
>>480
OK

482 :login:Penguin:04/08/02 19:40 ID:SYvcCCTD
Gentoo じゃ -f なんて無くても同じじゃね?

483 :login:Penguin:04/08/02 21:15 ID:fwUpx+BY
>>481>>482
ありがとう。大分すっきりした。-fつけなくても問い合わせはされないのかな。
さて、次は tmpreaper でもインスコするか…

484 :login:Penguin:04/08/02 22:30 ID:+habQ1Ui
昨日はあわてふためいていろいろ書き込んでしまいスマンかった。
冷静に考え直してみると、肝は
/usr/lib/im/locale/ja/atokserver/atokx_client
への変更だったわけで、これって、ebuildではJUSTSYSTEM配布のものへ修正パッチ当たってないんだよね?
てことは、>>447>>448さんなんかは自分で修正したってこと?
それとも修正無しで使えてるのかな?

漏れは当初そのままで使えてたんだけど、GTKかXOrgへの更新時に使えなくなって以来、
あわてふためいてしまって、いったんは修正の情報を見つけてなおしたんだけど、
カーソルの動きがおかしい件でQtといっしょにATOKXのremergeとかし出して、
それからずっと修正の件を忘れてしまった。それで、パレットが文字化けしてる原因は
ATOKXではなくてGTKとかにあるものとばかり思い込んでた。

もしかしてebuildの修正 r2→r6 とかした方が良いのかな?

485 :login:Penguin:04/08/03 03:21 ID:cG2THx99
genkernel 3.0.2c で gentoo-source-2.4.26-r6 を
コンパイルした kernel で起動すると
/lib/modules/2.4.26-gentoo-r6/kernel/drivers/net/8139.cp.o
は存在するにもかかわらず, 起動メッセージで,

... can't load module 8139cp
missing kernel or user mode driver 8139cp

と 10 回言われてしまいます。

genkernel は正常終了しているようですが,
genkernel.log を見ると以下のような行があります.

depmod: *** Unresolved symbols in /lib/modules/2.4.26-gentoo-r6/kernel/drivers/scsi/sata_sil.o
depmod: *** Unresolved symbols in /lib/modules/2.4.26-gentoo-r6/kernel/drivers/scsi/sata_svw.o
depmod: *** Unresolved symbols in /lib/modules/2.4.26-gentoo-r6/kernel/drivers/scsi/sata_via.o

正常に module をロードできないのはなぜでしょうか?


486 :login:Penguin:04/08/03 06:15 ID:5iQZcLQZ
出来上がったカーネルを/bootにコピーしてないとか?

487 :login:Penguin:04/08/03 07:01 ID:rbHcrbSU
  ∧||∧     \    │   蟹 警報! ! |  /
 (  ⌒ ヽ      \   └―――──―――┘ /“corega FEther PCI-TXC Plus
  ∪  ノ        \     ヽ(´ー`)ノ    / 】“ELECOM LD-10100S
   U U        \    ∧∧∧∧∧ / 易】“ GreenHouse GH-ET100RT
 オンボードが蟹だった \<     カ  >【安易】“駄メルコ LGY-PCI-TXD
v(・ω・)v v(・ω・)v v(・ω・)v<      二 .>【安易】“プラネッ糞 FW-110TX
v(・ω・)v v(・ω・)v v(・ω・)v< 悪   チ  >【安易】“哀王 ET100-PCI-L2
―――――――――――‐< 感  ッ  >―――――――――――――――――――‐
 蟹チップ___マンセー`ヾヽ< !!!!!  プ  > 蟹は蟹であると見抜ける人でないと  |\
    ,r''´  ,ォく ̄^       〉、<     の >(ハイエンドなLAN環境を実現するのは)難しい
 /     / ノ !        / { } ∨∨∨∨∨ \     / |/|           __ \  /
./       し' ノ、   , -、 {  `′ /         \   \ 丿 __     '"ゞ'-'  | |
{ ヾ;、.   _,.ィ「! }-ィ゙ /〉}、ヽ,  ‐/              \  | | '"-ゞ'-'____| | __//
ヽ、 ~ ,r'ソ  ト-'′ `┬'^い, }  /  ∧∧   ミ ドスッ \\\| | ̄ ̄ ::::::::   ̄ ̄\/
.( 'ー')j/  ヾj   jツ   i / ,ゝ/  (   ,,)┌―─┴┴─‐`く      ( ,-、 ,:‐、    |/\
. [`〔」ノ     `'ー'゙    {  `7  /   つ   RealTek   \              |/\
  `'y′            [ニ7 〜′ /´ └―─┬┬─―─ \  __,-'ニニニヽ .   |/\
   〉             } /   ∪ ∪         ││ ε3     \ ヾニ二ン"     |/\
  (  蟹. REALTEK ノ/             ゛゛'゛'゛        \_____/


488 :login:Penguin:04/08/03 10:10 ID:ix3zAAy3
手動で emerge したいとき(例えばソースをちょっといじりたいとき)って,この手順であってますか?

ebuild /path/to/.ebuild unpack
/var/temp/portage 以下にあるソースをいじる
ebuild /path/to/.ebuild compile
ebuild /path/to/.ebuild install
ebuild /path/to/.ebuild qmerge
ebuild /path/to/.ebuild merge
ebuild /path/to/.ebuild clean

kmess をインストールするときにこの手順でソースを少しいじったのですが,
emerge -p kmess とかすると,ちゃんとインストールできたのが確認できるのですが,
genlop kmess とかすると,そんなモンインストールされてないと怒られます.

489 :login:Penguin:04/08/03 11:48 ID:aWCi5myV
>>486
自動的に kernel と initrd がコピーされ,
タイムスタンプを確認して grub.conf を書き換えていますので,
そんなことはないと思います.


490 :login:Penguin:04/08/03 12:04 ID:ix3zAAy3
>>485
genkernal のオプションは何?

491 :login:Penguin:04/08/03 17:08 ID:kB+LUChL
ちょっと疑問があるので教えてください
emergeしたらパッケージの依存関係とか満たしていろんなものインストールしますよね
それで、たとえばAってプログラムがBのバージョン1が必要なのに、CっていうのをインストールしてBのバージョンが2になって
Aが動かなくなったりってことはあるんですか?不安でしょうがないので教えてください

492 :login:Penguin:04/08/03 18:11 ID:5/+aIwbW
march=athlon-xpを指定していますが、
これによっってgccに-m3dnowや-msseなどのオプションが自動的に伝えられるとどこかで見たような気がするのですが
その場合、USEフラグの3dnow等は意味を成すのでしょうか?

493 :login:Penguin:04/08/03 20:10 ID:r3WuHk/b
>>492
#ifdefとかで違うコード(インラインアセンブラなど)
がコンパイルされたりされなかったりする可能性があるでしょ

494 :login:Penguin:04/08/03 20:16 ID:hFBDFC3x
>490
sudo sh -c 'PATH=/sbin:$PATH genkernel all'
です。
関係ないですが, /sbin を PATH に入れとかないと,
mke2fs がなくて initrd がつくれません.


495 :login:Penguin:04/08/03 20:47 ID:l0h0Ua2E
>>492
http://pc5.2ch.net/test/read.cgi/linux/1078274648/155

CFLAGSでは意味無いかも知れんけど
USEでは使われたりするかもね

496 :login:Penguin:04/08/03 23:54 ID:84f93FBH
>485
その状態でネットには繋げられてるの?
だとしたら他のドライバがロードされているから
8139cpがロードされないだけだと思う。

genkernelって、使わないモジュールもコンパイルする
みたいだから、気になるならmenuconfigすればいい。

497 :login:Penguin:04/08/04 00:15 ID:WI6aRC9e
オンボードSCSI接続のHDDがshellからgrub立ち上げて(root,[TAB]って打つと
hd1で認識されてるのにブート時だとhd0で認識されるんだけど。。。
そーゆーものなの?小一時間ハマったんけど

498 :login:Penguin:04/08/04 00:36 ID:bgHM2aWA
>>491
そういうときはどっちかがどっちかをブロックする(つまりAを
入れていればCが入らないし、Cを入れていればAが入らない)か、
もしくはそのBのバージョンがemerge -uD worldのたびに上下する。
(本来上下しないで全部ブロックしないとだめだと思うんだけど。)
結論からいうと、そういうこともある。で、見つけた人が報告して
くれないとずっとそのまま放置。これは仕方ないよね?

499 :469:04/08/04 00:50 ID:OEm/Ch1Q
インストール後のreboot時にまともに立ち上がりません。

/bin/sh:can't access tty;job control turned off
attempt to access beyond end of device
01:00: rw=0, want=4397, limit=4096

このメッセージが画面に出て/#プロンプトが出ます。
環境はcpu:AthlonXP2500+ M/B:MSI-KM4M HDD80GBに
Gentoo2004.2をインストールしています。
FSはext2です。


500 :login:Penguin:04/08/04 01:06 ID:9rWeIyor
>>498>>491
SLOT使ってるのだったら複数バージョン混在できるよ。
知ってると思うけど。

501 :login:Penguin:04/08/04 01:50 ID:cRpTwtsw
>>496
ネットに繋げてないので確かめていませんが,
ノートに内蔵されている LAN のドライバは 8139cp
でよかったと思います.

genkernel --menuconfig all でスリムにしたカーネルを
つくろうとしていたのですが, XFS あたりで Error になるので,
試しに標準のオプションでやってみているところです.

2004.2 でも入れなおした方が早いかな.


502 :>>485:04/08/04 07:14 ID:3oKgr+qH
俺のノートも蟹だけどドライバは8139tooだ

503 :login:Penguin:04/08/04 12:06 ID:v3iZvD+s
助けてください
時々、gentoo再起動させたときに/etc/fstabとかmodules.dとかの設定したもの全部消えてるんです
どうしてこんな症状でるのでしょうか
ヒントでもいいので下さい、お願いします

504 :login:Penguin:04/08/04 12:10 ID:VITR82EO
>>503
etc-updateしたんじゃないの?

505 :login:Penguin:04/08/04 12:15 ID:v3iZvD+s
>>504
返答ありがとうございます
etc-updateしたら全部消えてしまうときがあるんですか
どういった状態でupdateしたら消えてしまうのですか?
あと、どうやったら消えないでupdateすることができるのですか?

506 :login:Penguin:04/08/04 12:18 ID:qpm3VBCV
>>503
実際のファイルシステムとfstabの内容が微妙に違うとか?
オプションとか、ext2とext3の間違いとかだな。

次回からもう少し詳しい情報を書くようにするとお望みの回答が出やすいと思うよ。

507 :504:04/08/04 12:37 ID:VITR82EO
>>505
質問する前にetc-updateというのが何なのかを調べた方が良いよ。

508 :login:Penguin:04/08/04 12:40 ID:v3iZvD+s
>>507
申し訳ないです
もうちょっと調べてみます

http://www.wikiroom.com/GentooNagoya/?Tips#content_1_33
ここをみたらetc-updateは上書きしないで差分だけを書くためにあるものだと思ったもので。。。。


509 :login:Penguin:04/08/04 12:53 ID:qpm3VBCV
etc-updateだったか。
確かにハマリやすいな。

510 :login:Penguin:04/08/04 12:58 ID:9NYfLnPa
何度もなんどもetc-updateネタを書いてるやつって釣りだろ?
お前等もいい加減、初心者を装った釣りに騙されるなよ。

511 :login:Penguin:04/08/04 13:57 ID:56Clo3KL
QtのATOKX対応キター!

512 :login:Penguin:04/08/04 14:58 ID:gLfllLNE
どこに?

513 :login:Penguin:04/08/04 15:13 ID:qpm3VBCV
それよりGnomeの日本語入力がまともになってほすぃ。

514 :login:Penguin:04/08/04 15:35 ID:dfwKaL3X
>>513
Canna+kinput2
Anthy+uim
Anthy+jmode
Wnn7+xwnmo
どれも何の問題もなかったが。なんかあるの?

515 :login:Penguin:04/08/04 16:44 ID:gLfllLNE
漏れもGnomeの日本語入力で問題になったことない。

516 :login:Penguin:04/08/04 17:08 ID:sDiwj6Tk
>>513
/etc/make.confのフラグ
nls cjkとか忘れたの?

517 :login:Penguin:04/08/04 17:23 ID:qpm3VBCV
今みたらkinput2が抜けてた。
それだけでGTKアプリで日本語入力中に
突然アルファベットしか入力できなくなるんか?
だとしたらコンパイルやり直し _| ̄|○ そんな・・・

518 :login:Penguin:04/08/04 18:23 ID:7L2eZcgy
起動時にFSCKが走ってエラーでとまってしまうのですが、
このチェックをすっ飛ばすにはどうすればいいですか?

519 :login:Penguin:04/08/04 18:26 ID:kUUR8GnA
すっ飛ばすな

520 :login:Penguin:04/08/04 18:56 ID:MG9mPMhO
もうデータがなくなってるよ

521 :508:04/08/04 20:34 ID:n3llkyTR
>>518
私と同じでetc-updateでfstab消えちゃったんじゃないですか?
パスワード求められるやつですよね??

522 :login:Penguin:04/08/04 21:00 ID:D6FY/4S4
ネンチャクン?

523 :login:Penguin:04/08/04 21:03 ID:9NYfLnPa
放置

524 :login:Penguin:04/08/04 21:17 ID:yPsk5bOW
gentooでシリアルATAを使う場合参考になるようなホームページありませんか?
knoppixではkernel-2.6を使った場合問題なく認識されています。

525 :login:Penguin:04/08/04 21:27 ID:V97yDqGR
anthy + scim + uim-scim

526 :login:Penguin:04/08/04 21:29 ID:I8pv2OAD
前にSiliconImageのSATAの話が出てて、IDE扱いかSCSI扱いかって話が
あったけど、カーネルオプションが両方あるね。
で、どうもIDEの方はうまく動いてないっぽくて無効にしとかないとダメみたい
だな。

527 :login:Penguin:04/08/04 22:19 ID:s6pOo11r
combined モードにすれば、普通に ide-disk で動く。
つーか、knoppix で動いているなら、それの/proc 見ればいいと思うが。

528 :login:Penguin:04/08/04 22:41 ID:KIje+p7C
>>524
SATAにインストールするならlivecdが対応してなきゃ駄目だろうし
インストール後に増設するなら別にGentooに限った話じゃないんじゃない?
>>114あたりでSATAにインストール成功報告はあったから頑張れば
出来ると思われます。

529 :login:Penguin:04/08/05 02:57 ID:Gg63SPdp
>>524
http://www.gentoo.gr.jp/jpnews/org/20040726-release2004.2.xml


530 :login:Penguin:04/08/05 03:47 ID:yi9hxL2E
ide-disk をロードしたら普通に使えました
Sata対応なんて書いてあるんでドライバも起動時に自動で読み込んでいるものと勝手に思っていました(汗


531 :login:Penguin:04/08/05 06:13 ID:owZp3CDe
マシン起動時に keymap 読み込みに失敗するんで色々試したら、

# loadkeys jp106 keypad
Loading /usr/share/keymaps/i386/qwerty/jp106.map.gz
Loading /usr/share/keymaps/i386/include/keypad.map.gz
loadkeys: /usr/share/keymaps/i386/include/keypad.map.gz:10: adding map 2 violates explicit keymaps line

ってなるけど、jp106 や keypad 単独だとエラーにならない。。。

x86 で同じ症状の人、居ます?

532 :login:Penguin:04/08/05 08:37 ID:/y6HgJN7
うぐわ
KDEコンパイルでほぼ半日経過、multimediaでこけてる。
>>422と一緒。orz


533 :login:Penguin:04/08/05 08:39 ID:/y6HgJN7
ちなみに>>423のリンク先の解決法USE="arts"はもう設定してあった。orz
しかもエラーの出てるファイルが違う。

tag.cpp:30:28: taglib/mpcfile.h: No such file or directory
tag.cpp: In constructor `Tag::Tag(const QString&)':
tag.cpp:67: error: no class template named `MPC' in `TagLib'
tag.cpp:67: error: parse error before `(' token
tag.cpp:68: error: `file' undeclared (first use this function)
tag.cpp:68: error: (Each undeclared identifier is reported only once for each
function it appears in.)
tag.cpp: In member function `bool Tag::save()':
tag.cpp:103: error: no class template named `MPC' in `TagLib'
tag.cpp:103: error: parse error before `QFile'
make[3]: *** [tag.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/kdemultimedia-3.3.0_beta2/work/kdemultimedia-3.2.92/juk'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kdemultimedia-3.3.0_beta2/work/kdemultimedia-3.2.92/juk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdemultimedia-3.3.0_beta2/work/kdemultimedia-3.2.92'
make: *** [all] Error 2


534 :login:Penguin:04/08/05 08:57 ID:/y6HgJN7
なんかこれだね。パッチがあるみたいだけど・・・動かないってさ。
http://bugs.gentoo.org/show_bug.cgi?id=59301


535 :login:Penguin:04/08/05 12:09 ID:nDtKdj0+
ちょうどいい機会だからkde3.3.0beta2でgo

536 :独り言:04/08/06 00:29 ID:Fhm4uXla
このクソ忙しい時にmozillaのemergeでコケるの漏れだけ?
ログちゃんと見て調べないとダメかなぁ。マンドクサ。

537 :login:Penguin:04/08/06 01:14 ID:sSLD9wa8
mozillaがコケるかどうかは知らんが、こんな時間にクソ忙しいのは
おまいだけじゃないか?

538 :login:Penguin:04/08/06 04:08 ID:IfeTpsUt
>>537
いや、漏れも超忙しいハズなんだけど・・・もうあと3週間だ orz

539 :login:Penguin:04/08/07 06:40 ID:c/8rcQxE
おまいら、NTVで ジェンツー ペンギンが出てますよ。

540 :login:Penguin:04/08/07 10:05 ID:BeU2J0dV
media-fonts/jisx0213-fonts-20040425でDigests do not matchが出るんで
ミラーサイトを変えてみたけどどれもアウトです。
どうしたらいいんでしょうか?
試したサイト:
ftp://ftp.ecc.u-tokyo.ac.jp/GENTOO
http://gentoo.gg3.net/
ftp://gg3.net/pub/linux/gentoo/
ftp://ftp2.tnc.edu.tw/pub1/Gentoo/

541 :login:Penguin:04/08/07 10:16 ID:KB68GkEo
# rm /usr/portage/media-fonts/jisx0213-fonts/files/digest-jisx0213-fonts-20040425
# rm /usr/portage/media-fonts/jisx0213-fonts/Manifest
# FEATURES="digest" emerge jisx0213-fonts

542 :login:Penguin:04/08/07 10:30 ID:yB4kKzM7
もしくは配布元から直接持ってくる。
ttp://www12.ocn.ne.jp/~imamura/jisx0213.html


543 :login:Penguin:04/08/07 12:45 ID:Vqd4bcNw
もう直っているので rm /usr/portage/distfiles/*.bdf.gz してから
emerge 再挑戦。digest を消すのはアップデートの意味がないような……

544 :login:Penguin:04/08/07 13:42 ID:WhZyf7Fi
ATOKXのインストールができません。
確実にインストールできる方法なんぞあるのでしょうか?


545 :login:Penguin:04/08/07 13:44 ID:oa6YUQ8G
>>544
無いよ♪

546 :540:04/08/07 16:08 ID:BeU2J0dV
>>541-543
レスサンクスです。
541さんの方法でemerge成功しました。

547 :login:Penguin:04/08/08 04:27 ID:Bz38xyhN
>>536
1.7.2でmilestone.pmが無いって言われない?

548 :login:Penguin:04/08/08 13:35 ID:P/fRtkKl
SUDENI INSTALL SARETEIRU PACKAGE GA
DONNA USE FLG GA SETTEISARETEIRUKA SIRABERUKOTOHA DEKIRU?

549 :login:Penguin:04/08/08 13:58 ID:H7aWhdum
なんかのconfigをいじりながら、/etc/init.dの下のスクリプトで起動とか停止を繰り返してると
たまに、プロセスは落ちてるのに xxx has already been started とか出て起動できなくなるんですが
これは何かのロックファイルみたいのがどこかに存在するんでしょうか・・・?
再起動しないと直りません。

550 :login:Penguin:04/08/08 14:08 ID:WweYpvaP
>>549
/etc/init.d/hogehoge zap

zap
Reset a service that is currently stopped, but still marked as started,
to the stopped state. Basically for killing zombie services.

551 :login:Penguin:04/08/08 16:41 ID:Fi7iwv6U

KDEのコンパイルに時間がかかるなんてぼやいてはいけません。Gentoo の醍醐味は、
だらだら流れる make のメッセージを読むこと、オナニーコンパイルにあり! だからです!

ともおもうけれど、やっぱり速いマシンで使いたいね。で、一台買っちまおうかと
財布を眺めているんだが、Athron64 デュアルで、Gentoo を動作させた実績のある方、
マザボなどハードウエア情報を教えてほしいです。最近、自作してないんで、
ひとの真似をしたい。
BTO業者に頼めよ、というんだったら、おすすめも知りたい。予算のことはひとまずおいて、
よかったらアドバイスください。

552 :login:Penguin:04/08/08 17:45 ID:ymSAUz1V
揚げ足とりだけど
Athlonだから・・・
それに、Athlon 64 はデュアル出来ない。。。

553 :login:Penguin:04/08/08 18:54 ID:FdBZ/Qlv
>>548
/varを探検してみよう!

554 :login:Penguin:04/08/08 21:58 ID:jfqVqguu
>>548
ex.1 cat /etc/make.conf | less
ex.2 ufed

555 :login:Penguin:04/08/08 22:04 ID:Pf55QilM
makeを眺めるのが好きです。
デフラグを眺めるのが好きです。
洗濯機を眺めるのが好きです。

556 :login:Penguin:04/08/08 22:16 ID:C8mAjjR7
俺も洗濯機見てるの好き!!
ってか、見てなきゃちゃんと洗濯されてるかわかんないじゃないの!!


557 :login:Penguin:04/08/08 22:18 ID:dH7W6Dox
見てないとサボる洗濯機。
飼い主に似るんだな。

558 :login:Penguin:04/08/08 23:00 ID:FJCLynsS
>>554
そもそもcatする必要はないような。
というかマージ後にmake.confのUSEを
書き換えちゃったらいくらmake.confを
眺めててもだめだよ。ufedも同じ。

正解は>>553なんだけど、
app-portage/gentoolkitをマージして
etcat -uを使ったほうが簡単だよ。

559 :login:Penguin:04/08/08 23:04 ID:Tnp+tNg9
cat /etc/make.conf | less

less /etc/make.conf
の違いを教えてください

560 :login:Penguin:04/08/08 23:07 ID:LNDaWdzd
見たまんま

561 :login:Penguin:04/08/09 08:27 ID:R1hjDFNy
>> 552
わはは。551ですが、わたしゃ Athlon の綴りも間違うようなレベルで、
まことにお恥ずかしいです。ともかく、dual できないアーキテクチャなんですか。
今後数年は使えそうなマシンを手に入れておきたかったんだが‥‥。


562 :login:Penguin:04/08/09 08:47 ID:JrSqu/j0
XeonとかOpteronとか買うつもりなのかな。
私は個人的にはコストパフォーマンス重視で買い換え派なのだけど。
高いCPUっていいことあるのか…

で、コンパイル速度考えたらAMDの方がいいの?
実際のベンチってどこかにある?

563 :login:Penguin:04/08/09 09:05 ID:lAloz4BR
>>559
560の書くように
>見たまんま
なわけだが、それではあまりにもアレだからマジレスしておこう。
上は標準出力(ようはディスプレイだ。普通)に出してるのをリダイレクトしてlessに入れてる
(lessは標準入力つまりキーボードから普通読むんだが、リダイレクトされてるので、標準出力=標準入力となってる)

下はファイルを開いてそれを読んでる。

ま、中の処理が違うだけだが。
たしか、こんなもんだったと。
・・・・・・・・細かな違いとかつっこまんでくれよw



564 :549:04/08/09 17:24 ID:HWvFq0Of
>>550
お、そんなオプションがあったんですねー。知りませんでした。
ありがとうございました。

565 :login:Penguin:04/08/09 22:16 ID:it1ouKhs
>>561
まあDual対応はOpteronと呼ばれててちょっと高い、ってだけで
考え方としてはAthlon64デュアルと思っても差し支えないと思う
んだけど。そんなに高くないし。

566 :login:Penguin:04/08/09 23:14 ID:oguEc3Ku
cat ファイル | less
とかのほうがいきなり
less ファイル
より直感的じゃない?
だから俺はいつも
cat ファイル | awk -F 'hogehoge' | sort | uniq | tail
とか絶対やるんだけど変かねぇ?

567 :login:Penguin:04/08/09 23:27 ID:CXVZeuUk
どっちでもいいよ。

568 :login:Penguin:04/08/09 23:51 ID:it1ouKhs
わけあって手動でmakeしたものをebuildで入ったことにしたいのですが、
どこをいじればいいでしょうか?

569 :login:Penguin:04/08/10 00:18 ID:DdlZ2OL8
>>568
emerge -i を使う。入ったことにしたいパッケージを指定するとき、
パッケージ名に加えてカテゴリー名とバージョン番号は必須。
たとえば
emerge -i sys-apps/portage-2.0.51_pre17
みたいなかんじで。

しかしながら今後これは廃止が予定されているらしいので、
/etc/portage/package.provided を使うことが推奨されている。

570 :login:Penguin:04/08/10 00:22 ID:4Iq9vRgZ
>>568
まあ、そのわけとやらはは訊かんが素直にebuildを書くことをすすめる。
/var/db/pkg/foo-bar/hoge-0.69/
のようなとこを見ればやる気なくすと思う。CONTENTSとかな。

571 :login:Penguin:04/08/10 00:39 ID:dm/qfWp4
>>569、570
サンクス。-iでできました。

572 :login:Penguin:04/08/10 02:11 ID:+GoG054J
>566
lv マンセー

573 :login:Penguin:04/08/10 02:38 ID:RaU3lif7
エルブイェイス
エルヴィス

574 :login:Penguin:04/08/10 05:15 ID:miuSuNcR
lv で q しても画面クリアされないようにしたい

575 :login:Penguin:04/08/10 08:50 ID:Z/RfuQEk
>>574
TERM=vt100 lv ...
とか?

576 :login:Penguin:04/08/10 10:32 ID:xVCftqLX
emerge -U worldの最後にいつも以下のエラーが出てしまうんですが、どうにか
修正できないでしょうか?

mail-client/mailx
selected: 8.1.2.20021129-r2
protected: 8.1.2.20021129-r3
omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging mail-client/mailx-8.1.2.20021129-r2...
No package files given... Grabbing a set.
/usr/sbin/ebuild.sh: /var/db/pkg/mail-client/mailx-8.1.2.20021129-r2/mailx-8.1.2.20021129-r2.ebuild: line 43: unexpected EOF while looking for matching `"'
/usr/sbin/ebuild.sh: /var/db/pkg/mail-client/mailx-8.1.2.20021129-r2/mailx-8.1.2.20021129-r2.ebuild: line 70: syntax error: unexpected end of file

!!! ERROR: mail-client/mailx-8.1.2.20021129-r2 failed.
!!! Function , Line 1294, Exitcode 1
!!! error sourcing ebuild

!!! FAILED prerm: 1


577 :login:Penguin:04/08/10 10:49 ID:zDrfJavb
>>576
http://forums.gentoo.org/viewtopic.php?t=185481

578 :login:Penguin:04/08/10 10:53 ID:Ng6DQb8+
>>576
その問題、JPのusers MLでも話題になってたよ。

579 :login:Penguin:04/08/10 11:11 ID:xVCftqLX
>>577,578
ありがとう
解決しました

580 :login:Penguin:04/08/10 14:51 ID:dm/qfWp4
>>511
入れてみたが>>441の現象は直らない。

581 :login:Penguin:04/08/10 19:10 ID:aygox0sL
起動時の初期化スクリプト群が出すメッセージ

Starting XXX...                  [OK]

みたいな奴、あれをファイルにログを取りたいのだけど、
何かいい方法ないですか?
途中で赤字で [!!] とか出てるのが見えるのだけど、
スクロールしてしまって良くわからないで困ってます・・・

582 :login:Penguin:04/08/10 19:32 ID:Ng6DQb8+
>>581
ログではないけど、
$ rc-status
を使えば各サービスの起動/停止の状態が把握できるし、
# rc default
とかすれば起動時と同じように各サービスを起動できるよ。

583 :login:Penguin:04/08/10 19:43 ID:zDrfJavb
>>581
シリアルコンソール

584 :login:Penguin:04/08/10 21:38 ID:aygox0sL
>>582-583
ありがとうございます。
んー、結局うまくやる標準的な方法はないみたいですね・・・

/sbin/rc の標準出力と標準エラー出力をログに取るラッパーを書いて
みることにします。


585 :login:Penguin:04/08/11 03:46 ID:OGWBtC0O
AMD64でthunderbird0.7.3をportageからemergeして使っています。
メールの読み書き自体は問題ないのですが、パスワードをずっと記憶してくれません。
Option->Advanced->Password and Securityの、
Manage stored mail server passwordsボタンを押しても、
小さなつぶれたウィンドウが出るだけです。リサイズしてみると、タイトルバーにGeckoとあり、
あとは真っ白で機能していないようです(他のManageボタンはきちんと機能します)。
パスワード管理はWin版のバイナリでは機能しているので、thunderbird全般にわたる問題ではないと思うのですが。
ほかに同じ症状の方いますでしょうか?


586 :login:Penguin:04/08/11 04:18 ID:h5vPEO47
>>585
athlon-xp(~x86)+thunderbird-0.7.1の環境では問題なく働いてます。
(0.7.3は現在emerge中)

587 :586:04/08/11 08:52 ID:5x9tQ+yb
0.7.3は >585 と同じで×でした。

588 :login:Penguin:04/08/11 09:48 ID:3Z0sZrOQ
Gentoo用語集(draft)
http://www.gentoo.gr.jp/jpmain/gentoo-glossary.xml

このページってどうなん?
「?」だらけだし。。

589 :login:Penguin:04/08/11 10:21 ID:AeVxyQaR
>>584
>/sbin/rc の標準出力と標準エラー出力をログに取るラッパーを書いて
>みることにします。

このスクリプト欲すぃ。うpして!

590 :login:Penguin:04/08/11 11:12 ID:ITOUsY7X
>>588
俺は「Gentoo=ジェントゥ」だし、「emerge=エマァジュ」だな。
好きに読んでいいのでは? 意味や機能の勝手な解釈はアカンけどな。

591 :login:Penguin:04/08/11 11:27 ID:fsHG/Czq
>581
何が起きたのか確認するだけだったら、dmesg とかに残ってないすか。
syslog にも何か吐かれてるんじゃないかと。

起動時のパラパラメッセージは「Scroll Lock」キーで一時停止できるでそ。

592 :login:Penguin:04/08/11 11:28 ID:nFz44r0e
>>584
inittab の rc default とかの後ろに 2>&1 | tee logfile を付け足したらうまくいったりしない?
やったことないからよくわからんけど。

593 :login:Penguin:04/08/11 11:33 ID:nFz44r0e
>>591
dmesg はカーネルだから今は関係ないね。

594 :login:Penguin:04/08/11 12:56 ID:OGWBtC0O
>>586
だめでしたか。
私も0.7.1の時は正常に動いていました。
アップデートが原因かと思い、unmergeしてから再度emergeしたり、
ホームディレクトリの.thunderbirdを消したりしてみましたが、
症状は同じでした。

595 :login:Penguin:04/08/11 17:47 ID:HDRm0JC0
>>590
エマァジュはキモいな…
こんな事言ってゴメン…

596 :login:Penguin:04/08/11 18:02 ID:ITOUsY7X
かまわないけど、そうなると「イーマージ」か?

597 :login:Penguin:04/08/11 18:10 ID:3PKATlNN
>596
「イーマージ」に一票

598 :login:Penguin:04/08/11 19:58 ID:6pP4623k
漏れも「イーマージ」に一票

だけど、個人的に「えめるげ」……

599 :login:Penguin:04/08/11 20:07 ID:r1rgltVJ
俺は「エーメーゲ」

600 :login:Penguin:04/08/11 22:08 ID:XeKjOBWb
余裕でイマージ
普通にジェントー
たまにリナクス

601 :login:Penguin:04/08/11 23:16 ID:9S9qT3XJ
イーマージ
ジェンツー
だな。mergeは普通日本語でもマージだし、ジェンツーペンギンは
子供の頃からそう呼んでるし。

602 :login:Penguin:04/08/12 01:59 ID:3GaL6qFm
俺は「イマージュ」だな

603 :login:Penguin:04/08/12 04:02 ID:6vRaSO5B
Gentoo入れました
いいですね、これ。
Windowsやめて
メインデスクトップにしようかと思っています。


604 :login:Penguin:04/08/12 05:39 ID:AfO5Rhk5
>>603
welcome!

605 :login:Penguin:04/08/12 08:09 ID:v887xeOE
ジェンツぅー!

606 :login:Penguin:04/08/12 09:11 ID:blMjqNL5
手っ取り早くデスクトップ使いたいならWindowMakerとOperaのstatic入れればいいのかな

607 :login:Penguin:04/08/12 10:26 ID:fH4M5k+x
XORGかXFreeの次に入れた時に、一番コンパクトなのはFluxboxだったよ。
といっても全部試したわけじゃないがね。

コンパクトつうのは、コンパイルするものの数が少ないってこと。
もちろんテーマとか入れれば、それだけ増える。

608 :login:Penguin:04/08/12 10:30 ID:YnZVBMpr
>>607
twm

609 :login:Penguin:04/08/12 10:42 ID:ohVb1xmW
pythonマンセーなヤシはemergeマンセーです

610 :login:Penguin:04/08/12 11:27 ID:EQuuxsRg
rubyマンセーは?

611 :login:Penguin:04/08/12 11:29 ID:mbetzgHN
言語を普及させるのに、オレディストリ作るってのはいい作戦なのかも。
もちろんその配布系が優れてないと人が集まらないけど。

612 :login:Penguin:04/08/12 11:57 ID:3q0jnJaQ
pythonを普及させたのはgentooではないよ

613 :login:Penguin:04/08/12 12:14 ID:mbetzgHN
>>612
誰もそんなことは言ってないのだが。

614 :login:Penguin:04/08/12 12:38 ID:tgIQT3r4
>610
momon...(ry

615 :login:Penguin:04/08/12 16:35 ID:y5sNRS/F
>>607
だけど最近納得いかないのが
fluxboxがenlightenmentよりもメモリ食ってるってところ

616 :login:Penguin:04/08/12 18:31 ID:fH4M5k+x
>>615
なるほど。
俺はデスクトップマシンしか使わないし最近スペック上げたから余裕。
スペック厳しいマシンやノートなんかだと、そういうとこが気になるだろうね。
今のマシンでスワップ発生したことないからメモリ気にしてなかったな。

617 :login:Penguin:04/08/12 18:31 ID:TuDr7Epo
mount -t iso9660 -o iocharset=euc-jp /dev/cdrom /mnt/cdrom
CDをマウントすると日本語ファイル名が「????」に文字化けするのですが。。。
何が原因なのでしょうか?分かる人お願いします。
kernel[2.6.7] util-linux[2.12-r4]

618 :login:Penguin:04/08/12 18:48 ID:ffZGlXje
File systems ---> Native Language Support --->

Japanese charsets (Shift-JIS, EUC-JP)
をmかyにする.

619 :login:Penguin:04/08/12 19:35 ID:y5sNRS/F
>>616
いや、別にWM一個でスワップなんか発生しないが
割に合わない = 不合理 なんで使う気すら起きなくなったってだけ

620 :login:Penguin:04/08/12 20:56 ID:TuDr7Epo
>>618
ありがとうございます。その通りでした。感謝してます。

621 :login:Penguin:04/08/13 01:24 ID:DbspMtZd
>>615
0.9.xは糞だから、ずっと0.1.14 + rememberパッチで使ってるよ。 そろそろ飽きて
きたからob3かwaimeaにでも乗り換えようかとも思ってるけど、慣れ親しんだ操作感と
存在意義が不明なツールバーが惜しいんだよなぁ。

622 :login:Penguin:04/08/13 01:35 ID:Lkom7Yuu
>>621
あれは時計のためだけにあるんだよ

623 :login:Penguin:04/08/13 07:22 ID:pa6ajyro
glibcの新しいバージョンの調子はどうですか?

624 :login:Penguin:04/08/13 11:01 ID:AfFRbrnb
なんかやっぱりGentooが安心するわ
momonga試してみたけど、Gentoo使い慣れた体には使いにくかった orz

625 :login:Penguin:04/08/13 11:07 ID:gl2auDsv
最近カーネルよく上るなあ。

626 :login:Penguin:04/08/13 11:57 ID:wP5eDfLq
changelog読んでラッキー

+gentoo-dev-sources-2.6.7-r14.ebuild:
Fix bug 59984 for sparc builds
Fix bug 60029 for ppc builds
All other arches don't have to update as there is nothing new for them in here.


627 :login:Penguin:04/08/13 12:59 ID:gl2auDsv
読まずにあんらっきょ〜_| ̄|○

628 :login:Penguin:04/08/13 15:27 ID:M/VHRhG3
what is 'Config file management support(preliminary)' ?
there are lots of files named ._cfg????_* in /etc/ directory.
please tell me what I have to do .

629 :login:Penguin:04/08/13 17:50 ID:RQ+Vs70J
>>628
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2&chap=4
音読汁

630 :login:Penguin:04/08/13 22:01 ID:M/VHRhG3
Thank you.

631 :login:Penguin:04/08/14 01:40 ID:PBCRM5n9
>>621
toolbar無しで組み立てられるし、0.9.x は
systemtrayとかぶち込めるけどね。

632 :login:Penguin:04/08/14 11:55 ID:kZQ5EAAs
atokxが使える状態になっている場合、少なくともどのプロセスが稼動している必要があるのでしょうか?

633 :login:Penguin:04/08/14 12:46 ID:Mim58Osf
ネットワークインストローリーは
どうやるんだ?
大まかでいいので教えてくれ。
どうぞよろしくお願い致します。

634 :login:Penguin:04/08/14 13:02 ID:ZLfpd0O5
>>622
漏れも時計として使ってるよ。

>>631
誤解を招く書き方をしてしまってすまそ。あれは他のwmに移行した時にツールバー
を失うのが惜しいという意でした。
0.9.xはなんかルートメニューの描画がやたら遅かったり、BBpagerが動かなかったり、
好きなスタイルCthulhainが崩れたり(リソースを書き直せば修正できるんだろうけど)
で使う気無くなったけど最近のは違うのかな。 ああ、スレ違いだね。

635 :login:Penguin:04/08/14 13:09 ID:shwRg0nX
>>633
http://www.gentoo.gr.jp/jpdoc/fd-install.xml

636 :login:Penguin:04/08/14 13:14 ID:Mim58Osf
>>635
ありがとう

637 :login:Penguin:04/08/14 13:15 ID:ZLfpd0O5
>>633
ネットワークインストールってのが何を指すのか分からないけど。
一番簡単なstage3なら

1)LiveCDでブート。
2)パーティションを切り、fs構築。
3)NICを認識させて、IFをup。
4)emerge でシステムを構築。(このときネットワーク接続が必要。ネット接続は今では必須ではないと思うけど)
5)仕上げ。(設定など)
6)HDからリブートして、遂にあなたもジェントゥーペンギン。

638 :login:Penguin:04/08/14 13:23 ID:Mim58Osf
>>637
御丁寧にありがとうございます。

639 :login:Penguin:04/08/14 14:49 ID:7RviKvl/
net-setup とか mount, chroot とか肝心なのが抜けてるような。
ネットワークインストールって、最新の stage1-3 を wget でとってくるとか
そういうことでない?まあ、それも普通のインストールのような気もするが...

640 :login:Penguin:04/08/14 15:11 ID:3QCL1sos
portage から vixie-cron をインストールしました。
/etc/crontab には

0 * * * * root rm -f /var/spool/cron/lastrun/cron.hourly
1 3 * * * root rm -f /var/spool/cron/lastrun/cron.daily
15 4 * * 6 root rm -f /var/spool/cron/lastrun/cron.weekly
30 5 1 * * root rm -f /var/spool/cron/lastrun/cron.monthly
*/10 * * * * root test -x /usr/sbin/run-crons && /usr/sbin/run-crons

こう書かれてますが、run-crons って何ですか?
/etc/cron.* ディレクトリを見に行って実行してくれるのかと思ったん
ですが動いてないみたいです。/etc/cron.* の中身を実行するには自分
で設定を追加しないと駄目ですか?上記の設定のまま、/etc/cron.hourly に

#!/bin/bash
ntpdate ntp.localdomain

とだけ書いたファイルを実行可能な状態で置いてみたんですが、/var/log/message
には実行の痕跡がありません。
test -x /usr/sbin/run-crons && /usr/sbin/run-crons
実行されてるんですが、それが実際に何をしたかが書いてない状態です。

641 :login:Penguin:04/08/14 15:33 ID:AsEdjWHQ
>>640
ログはそれで正しい。
出力が何かあれば root にメールで届く。

642 :login:Penguin:04/08/14 16:29 ID:OsEax+8R
終了するときにPowerdownと出たまま電源が落ちないんですわ
ついでにgdmからもエラーが出てるし
カーネルを新しくしても変わらずお手上げです
もっとスキルが欲しいです、はい

643 :login:Penguin:04/08/14 17:29 ID:f6qmJx7J
ACPIかしら

644 :login:Penguin:04/08/14 17:31 ID:rDAcl59h
apmとかacpiとか
gdmについてはxdmから上げてるからか?

645 :login:Penguin:04/08/14 19:24 ID:OsEax+8R
>>643-644
acpiはモジュールとして組み込むんですか?
/etc/modules.autoload.d/kernel-2.4に記述してもダメだったし
lsmodしてもそんなモジュールはなかったです

gdmは/etc/rc.confで
#DISPLAYMANAGER=xdm
DISPLAYMANAGER=gdm
と書いており
rc-update add xdm default
としております

何が悪いんでしょうかね?

646 :login:Penguin:04/08/15 03:28 ID:dmsK1Z+t
>>641
ありがとう。/var/spool/mail を覗いてみたら .keep というメールが
ポツンとあるだけ。MTA何もいれてないけど、それはいいのかな?
なんか最初から色々入ってる鳥が懐しくなってきた。

647 :login:Penguin:04/08/15 06:09 ID:Z9hl2j/0
>>646
MTA入れないとメールは届かないよ。
ssmtpが入ってるかも?

648 :login:Penguin:04/08/15 07:53 ID:dmsK1Z+t
>>647
何も入ってなかったから何かインスコしてみます。

649 :login:Penguin:04/08/15 14:41 ID:XRh3QOeq
wine-20040716を使っているのですが、
/usr/lib/wine/bin/にあるuninstallerとかregeditとかnotepad等を起動させようとすると、
以下のエラーメッセージが表示されて、起動しません。
/usr/lib/wine/bin/wine: error while loading shared libraries: libwine.so.1: cannot open shared object file: No such file or directory

そこでlibwine.so.1を検索したところ、以下のディレクトリにありました。
/usr/lib/wine/lib/libwine.so.1
ググって調べると、/usr/lib/にシンボリックリンクを張れば解決しそうなのですが、
勝手にリンクを張っても良いのでしょうか?

650 :login:Penguin:04/08/15 15:02 ID:tbXZcLYO
>>649
直リンすんな、ヴォケ

651 :login:Penguin:04/08/15 15:15 ID:sD6dWI8n
>>649
大丈夫だぉ。
別の手として、

# su
# echo "/usr/lib/win/lib" >>/etc/ld.so.conf
#ldconf

なんてのもあるぉ。


652 :login:Penguin:04/08/15 21:34 ID:6F4edGu+
>>650
それ、どういうネタ?

653 :login:Penguin:04/08/16 01:28 ID:zAJrjHJc
やおい板あたりの住人の真似w

654 :login:Penguin:04/08/16 01:30 ID:e763Jff1
kdemultimediaのバグがまだ取れない・・・

655 :login:Penguin:04/08/16 11:18 ID:OXuW7ETj
ただいまインストール中、はじめてのgentooだから本のとーりにしていますが、
#emerge sync
とすると"//rsync.jp.gentoo.org/gentoo-portage/"が見つからんと表示
#emerge-webrsync
で大丈夫でしたが、なぜ"emerge sync"が失敗するのでしょうか?
ルーターの設定のせいでしょうか?

656 :login:Penguin:04/08/16 11:25 ID:2VT8fqDM
漏れんとこだと
$grep -e "^SYNC" /etc/make.conf
SYNC="rsync://rsync.jp.gentoo.org/gentoo-portage"

657 :login:Penguin:04/08/16 12:06 ID:iVEFTfC2
漏れんとこだと

"rsync://rsync3.jp.gentoo.org/gentoo-x86-portage"

658 :login:Penguin:04/08/16 13:41 ID:fcfmM8N6
漏れんとこだと

#SYNC="rsync://rsync.jp.gentoo.org/gentoo-portage"

659 :login:Penguin:04/08/16 20:05 ID:lCALADZ0
コメントかよw

660 :login:Penguin:04/08/16 21:10 ID:MNYPLsoH
AMD64でGentoo構築するのに参考になるサイトってありませんか?
もちろん64bitカーネルで。

661 :login:Penguin:04/08/16 21:11 ID:+NBMPCLM
amd64なlivecdを使ってインスコすればいいんでないの

662 :login:Penguin:04/08/16 21:18 ID:MNYPLsoH
>>661
インスコ自体はそうでしょうが、その後の特有のはまり方とかないんでしょうか?
コンパイルエラーとか。そもそもlibは他ディストリみたいにlib64が別に作られる
のかどうかとか知りたいんですが。

663 :login:Penguin:04/08/16 22:32 ID:h5m+yYZT
>>662
これと言って問題なさげ。/libは/lib64のリンク。/lib32は/emul/linux/x86/lib。
べっこにemul-linux-x86-*とかいれる。別スレのパイ揉みは、微妙に64の勝ち。

664 :login:Penguin:04/08/16 22:44 ID:MNYPLsoH
>>663
サンクス。やってみてはまったらまた来ます。

665 :login:Penguin:04/08/16 23:29 ID:Whbj4gLh
Athlon64 マシンに gentoo をインストールして、デスクトップ
環境の構築中ですが、opera や konqueror でフラッシュが表示
されません。
emerge netscape-flash を実行して、/opt/netscape/plugins 以下に
プラグインはインストールされています。emul-linux-x86-* も同時に
インストールされて、ldd /opt/netscape/plugins/libflashplayer.so すると
ライブラリは全てリンクされています。
どうすればフラッシュが見れるようになりますか?

666 :login:Penguin:04/08/16 23:33 ID:FHgK8NCQ
本を買ってインストールに挑戦したんだけど再起動したらgrubからの起動途中で
"/#"
ってのがでて止まってしまいました。みなさんさようなら〜

667 :login:Penguin:04/08/16 23:55 ID:WLt8QSsd
>>666
ああ、それか。
漏れもそうなってたけど見ているインストールガイドが古くて
grub.confの設定が間違ってるのが原因だった。
当時はそれも分からずとりあえずgenkernel使うの止めて手動
でカーネルコンパイルしたら直ったな。

668 :login:Penguin:04/08/17 00:34 ID:tgV69DWn
dev-lang/swig-1.3.21 って emerge しようとするとエライ事にならんか?

669 :login:Penguin:04/08/17 00:35 ID:99z2HspD
>>665
漏れはemerge netscape-flashというのがあるのを知らなくて
いつもwww.macromedia.comからDLしてインスコしていたよ。

670 :666:04/08/17 00:37 ID:niJxbLJp
>>667
あっ、そうでしたか。今度休日に手動でコンパイルしてみます。
それでダメなら別のにします。

671 :login:Penguin:04/08/17 00:46 ID:99z2HspD
ところでみんなどのくらいの頻度でemerge -u worldしてる?
溜めるとあとで大変なのでこまめにやりたいところなんだけど、
トータルなビルド時間で言えば溜めてまとめた方がかかんない
んだよね。

ちなみに漏れは2週間に一回くらい。

672 :login:Penguin:04/08/17 01:11 ID:C2YmHoi+
毎週土曜日。
何かあっても休みだし。
時々やらないで、次の週に持ち越すこともあるけどねw

673 :login:Penguin:04/08/17 08:27 ID:Se8OZlzn
>>668
やってみたら確かになった。
でも perl 入れなおしたらいけた。

674 :login:Penguin:04/08/17 09:01 ID:Y1HesQgr
>#emerge sync
>とすると"//rsync.jp.gentoo.org/gentoo-portage/"が見つからんと表示

末尾の"/"が原因。漏れも以前つまづいた。ディレクトリだから"/"付けたくなるよね。


675 :login:Penguin:04/08/17 09:05 ID:Y1HesQgr
時々、emacsやfirefoxが起動に数分かかるようになるのですが、原因は何でしょうか?
CPUが働いてる訳でもなく、ハードディスクにアクセスしてる訳でもないのですが・・・・
再起動すれば直りますが、またしばらく使っていると同じ症状になります。

676 :login:Penguin:04/08/17 13:23 ID:1/uhTmqm
>>671
自分は
emerge -upv --deep world
して、バージョンあげても大丈夫そうなパッケージかどうか確認してから
emerge -u --deep world
ってのを、2日に1回位。


677 :login:Penguin:04/08/17 14:26 ID:bDuscfCM
>>675
メモリとHDDのチェックをしてみては?
メモリはLiveCDつっこんでmemtestが便利

678 :あさひ:04/08/17 16:11 ID:cTDRBMRO
みんなこんなところに隠れていたんですね!


679 :login:Penguin:04/08/17 17:37 ID:99z2HspD
wacomのUSBタブレット使ってる人いますか?

カーネルオプションでwacomを追加して再構築、しネットの情報を
参考にXF86Configを編集したのですが、ログに

Cannot open device /dev/input/event0 No such device.

と出ます。XF86Configにevent0と書いているのに実際には無いから
エラーなのはわかるのですが、event0が無いのは何か間違っている
からでしょうか? それともevent0以外のところに信号が行ってい
て、XF86Configを書き換えれば良いのでしょうか?

680 :login:Penguin:04/08/17 19:23 ID:APtowkkw
> それともevent0以外のところに信号が行ってい
> て、XF86Configを書き換えれば良いのでしょうか?

yes

681 :login:Penguin:04/08/17 20:03 ID:XZPPHyoF
>>676
-pを-aに変えるとemergeの実行が一回で済むよ
知ってたらすまん


682 :login:Penguin:04/08/17 20:20 ID:3biccB5z
>>681
すまん、今手元にGentooないんで確認できんのだが、
-aつけたら更新する前に確認のプロンプトでも出してくれるのか?
676は内容見てヤバそうなパッケージないか確認してから更新するって事だから
どーしても2回いるんじゃないか?と思えるんだが。
いや、煽りとかじゃなくてマジでわからんので教えてほしい。

683 :login:Penguin:04/08/17 21:49 ID:bnWDFCZU
>>682
マージを実行する前に、どの ebuild と tbz2 ファイルがインストールされるのか、--pretend を実行す
るのと同じ形式で表示したあと、マージするか中止するか尋ねる。 --ask を使うのは、--pretend を 使
っ て確認したのち --pretend なしで同じコマンドを実行するのより効率がよい。依存関係を計算する必
要が一度だけで済むからである

684 :login:Penguin:04/08/17 23:44 ID:D5zIEoLz
>>679
そのネットの情報には
/dev/input/event*
をつかうにはカーネルで
Event interface(CONFIG_INPUT_EVDEV)
を有効にしろって書いてないの?

685 :login:Penguin:04/08/18 01:07 ID:NFt6GNdR
あ、やべATOKXネタに乗り遅れた。。

emacsでATOKX使ってる香具師いますか?
普通にemergeしたemacsじゃだめだよね?

686 :login:Penguin:04/08/18 01:13 ID:hBo2mLlJ
kernel-2.6.8にした人手あげろゴラァ

687 :login:Penguin:04/08/18 01:14 ID:7GS7G41K
ハックション

688 :login:Penguin:04/08/18 01:17 ID:Btzc4e6N
>>684
サンクス。
他のディストリの情報なんでデフォでevent*が作られるようになっているようです。
早速再構築してみます。

>>686
ついでに2.6.8にあげます。

689 :login:Penguin:04/08/18 01:25 ID:hBo2mLlJ
>>688
2.6.8.1まで待ってみれば?

690 :login:Penguin:04/08/18 01:59 ID:6cU5ti9m
>>686
ノシ

>>689
2.6.8には2.6.8.1のパッチも含まれているよ。

691 :login:Penguin:04/08/18 03:04 ID:rJ4xXGRt
XWNMOだと文字化けするんで
ずっとWnn7+egg-Wnn7でEmacs使ってきたんだが、
なにも弄った覚えないのに最近CTRL+\でXWNMO動く。
文字化けもなし。

まさか、、、学習してんのかGentoo?

692 :679:04/08/18 03:10 ID:Btzc4e6N
>>684
おかげさまでオプションつけて再構築したらevent2で認識しました。
でも、ちらちらして挙動不審。

2.6.8今のところ問題なし。良くなった感じも特になしでつ。

693 :login:Penguin:04/08/18 04:09 ID:Btzc4e6N
>>685
ATOKXさえちゃんと入っていれば普通にemergeで入れた
emacsでATOKX動くよ。

694 :login:Penguin:04/08/18 06:57 ID:jhJ82sxG
>>690
そうだったんだ。じゃあ早速導入してみまつ。

695 :login:Penguin:04/08/18 08:47 ID:hf6j3RNK
ちょっと遅れたけど俺のemerge -uDav worldの頻度はたぶん一週間おきくらい。ただ
ttp://packages.gentoo.org/
を一応毎日チェックしてるから特に更新する必要ないなと感じたら何もしないし、
前々からGentooでのバージョンアップを待っていたやつのebuildがきたら一週間経ってなくてもやる。

696 :login:Penguin:04/08/18 12:46 ID:uwsPmSD/
I can't install atokx.
Keet it in your mind.

697 :login:Penguin:04/08/18 15:46 ID:pJ+dMK/e
Gentoo業務用途で使ってる人ってどのくらいいますか?

DBサーバ用途で検討中なんですが、商用ディストリはサポート期限が
過ぎるとアップデートできなくなったり、カーネル再構築がサポート外
だったりとかえって不便な気がしてきて、それだったらGentooのほうが
いいじゃん、って思ったんです。

これまではRHEL使ってますた。

698 :login:Penguin:04/08/18 19:43 ID:z15E+9q8
業務にはDebianの方が適しています。
悩むぐらいの技術力しかないのならGentooは不向きです。

699 :login:Penguin:04/08/18 19:55 ID:pJ+dMK/e
>>698
>業務にはDebianの方が適しています。

それはどの辺にアドバンテージがあるんでしょうか。やっぱりソースからビルド
するのは運用上時間がかかりすぎるとかその辺でしょうか?

700 :login:Penguin:04/08/18 20:40 ID:Rg+n0+rt
その程度の業務ならなんでもええよ(w


701 :login:Penguin:04/08/18 21:02 ID:ZWpVu8XC
>697 FreeBSD とか Windorz とかは?
Debian な話は当該スレとテンプレ見てください。
ttp://pc5.2ch.net/test/read.cgi/linux/1089465537/

ポリシーが違う。stable ならド安定。アプリケーションの
バージョンはそのままで独自にバグフィックスやセキュリティー
パッチがあてられていく。

サーバーには Debian で、デスクトップには最新追っかけの
Gentoo にしてます。で週末には distcc で Debian にもコン
パイルを手伝わせてます。

ところで、distccd が動いてくれる 1 CD Linux ってないかなぁ。

702 :login:Penguin:04/08/18 22:29 ID:UAiNKUxZ
LiveCDなかったっけ?そこら辺で暇ぶっこいてるマシンに突っ込んでdistcc動かす用の。
Gentooのサイトで拾ったと思うけど701が真剣に探して見付からないなら漏れの勘違いかも知れん。

703 :login:Penguin:04/08/18 22:35 ID:jhJ82sxG
PHP-5.0.1まだ?

704 :login:Penguin:04/08/18 22:36 ID:jhJ82sxG
もうありますた

705 :login:Penguin:04/08/18 22:48 ID:hT0QgJBW
Sargeは不安定だな

706 :login:Penguin:04/08/19 00:12 ID:XSVJneD7
XFree86の環境をX.Orgにかえるのって簡単ですか?

707 :login:Penguin:04/08/19 00:13 ID:k1BOhVA4
ああ

708 :login:Penguin:04/08/19 00:23 ID:sb/Z1aIC
>>706
後からxorgをインストールしたらstartxでちゃんとxorgが立ち上がるように
なったよ。startxが実際に何してるのか知らないけど。

709 :login:Penguin:04/08/19 00:34 ID:XSVJneD7
XFree86のアンインスコはしなくてもいい?

710 :701:04/08/19 01:05 ID:PycyEyCL
>702 さんありがとう。
Gentoo の distcc が使える LiveCD は
livecd-kde-distcc-06-03-2003.iso かなぁ。最近のはちとわからなかった。
もちっと探してみます。

で、distccKNOPPIX っていうのを見つけました。
http://opendoorsoftware.com/cgi/http.pl?cookies=1&p=distccKNOPPIX

distccKNOPPIX is a directly bootable and self-configuring Linux system
on a small iso (~45MB) running a distccd daemon.
* gcc versions 2.95, 3.2, 3.3, 3.4
* distcc version 2.16
* boot options for gcc version
* Run from RAM or HD with toram and tohd boot options

これなら、gcc の各バージョンを選べるので、distcc のクライアントが
Gentoo でも Debian でもその他のディストリビューションでも大丈夫
なので、便利かもしれない。

Gentoo から離れぎみな話題でごめんなさい。

711 :login:Penguin:04/08/19 01:07 ID:sb/Z1aIC
>>709
アンインスコしたんだけどx使うebuildがまた勝手にインスコしちゃった。
うちは両方入ってるけど別に問題なく動いてるよ。

712 :login:Penguin:04/08/19 01:30 ID:06SY61hN
>>711
詳しく調べてないからあれだけど、依存関係がちょっと?だね。
最近はどっちも入れとかないとうまく入らない感じ?


713 :login:Penguin:04/08/19 05:45 ID:a/0bgWdv
gentooにg77ってないんですか?

714 :login:Penguin:04/08/19 06:02 ID:0qIJqrm5
USEにf77

715 :login:Penguin:04/08/19 07:30 ID:kW4mOzAb
>>706
http://forums.gentoo.org/viewtopic.php?t=158911

>>711
入れんなよ。

716 :login:Penguin:04/08/19 09:46 ID:a/0bgWdv
>>714
それはUSEにf77を加えてgccを再構築するという意味でよいのでしょうか?

717 :login:Penguin:04/08/19 10:48 ID:0qIJqrm5
>>716
gccのebuildみりゃ分るだろ。それぐらい自分で確認しろよ。

718 :login:Penguin:04/08/19 11:00 ID:06SY61hN
>>715
結構面倒なんだね。「不具合あったらXF86に戻そう」ってわけには
いかないな。

719 :login:Penguin:04/08/19 11:38 ID:P5W3Ohaj
何をいまさら...

720 :login:Penguin:04/08/19 16:16 ID:PPYQKn26
>>718
xfreeとxorg-x11のバイナリーパッケージを作っておけば出来なくはないと思う。

721 :login:Penguin:04/08/19 19:49 ID:idYHOtYl
おい、おまいら。
gentoo入れてみたんだが、
イイ!イイじゃねーか。

722 :login:Penguin:04/08/19 19:50 ID:hYAcsQiM
Gentooと、FedoreCore2

どっちが良いでしょうか?

723 :login:Penguin:04/08/19 20:22 ID:PycyEyCL
ソースディストリビューションに興味があるなら Gentoo
バイナリディストリビューションが好きなら Fedora Core 2
Linux と心中してもいいと思えば Linux From Scratch
実は UNIX に浮気したい FreeBSD
すんごい暇なら↓にあるやつ全部ご賞味あれ。

ttp://www.distrowatch.com/

どっちが良いと聞かれても、あなたの好みがわからない。
だから、あなた好みの女になれない私。

724 :login:Penguin:04/08/19 20:40 ID:vn31778t
ttp://www.mozilla-japan.org/
これ設立されてFirefoxとThunderbirdの正式な日本語版というのがでるようになったから
portageJPでいいからebuildを追加してほすぃ。。。

725 :login:Penguin:04/08/19 20:41 ID:vn31778t
ごめん、悪い冗談
ってかなんか間違えましたです。。。

726 :login:Penguin:04/08/19 20:41 ID:2cPRHwB+
Gentooスレってなんでこんなに厨房臭いんだ

727 :login:Penguin:04/08/19 20:45 ID:b8B019g/
>>726
厨度が高いのは、小難しげな事を鳥側で自動でやってくれてるのにも関わらず
自分のお手柄だと勘違いして 「ウホッ 俺って高スキル!」なんて思っちゃってる香具師が
多いから。

728 :login:Penguin:04/08/19 21:53 ID:vn31778t
X上でemacsを起動しようとすると
Warning: Cannot convert string "-*-courier-medium-r-*-*-*-120-*-*-*-*-iso8859-*" to type FontStruct
Warning: Cannot convert string "-*-helvetica-medium-r-*--*-120-*-*-*-*-iso8859-1" to type FontStruct
と警告がでてメニューバー以外の全てのフォントが□になってしまっています。
この二つのフォントファミリーはどのパッケージに入っているのですか?

729 :login:Penguin:04/08/19 22:44 ID:hYAcsQiM
>>723
面白いレスありがとう。

Fedore Core 2を自宅用メインPCに有る程度カスタマイズしましたが、GNOME結構重い(;´Д`)
って事で、FC2でも出来るけど、どうせなら勉強がてらに、色々ディストリ試してみようと、FC2アンインストール。

PlamoLinux入れて遊びましたけど、萌え萌え要素に泣け、デスクトップマスコットに逆ギレし...

知り合いのカプンコ社員が使っているというGentoo試してみようと思って、このスレに辿り着きました。
実際、FC2は設定ウィンドウが豊富なので簡単に出来てしまい、スキルは全然上昇しません。

Blackbox + emacsな感じで軽快にgccで勉強したいわけなんですが....

GRUB,LILOのロゴも出来ればカッコイイ感じが良いなと思う厨でした。

730 :login:Penguin:04/08/19 22:59 ID:gCHrdDDY
>>729
こっちでやりなよ。

オススメLinuxディストリビューションは? Part5
http://pc5.2ch.net/test/read.cgi/linux/1089797203/

731 :665:04/08/19 23:50 ID:RHLJPuvx
別のマシンから libXm.so.2.1 を持ってきて /emul/linux/x86/lib
にコピーして ldconfig を実行したら、opera ではフラッシュが
動くようになりました。

しかし、konqueror では動作しません。
ついでに opera でも音がでない。はぁ...

732 :login:Penguin:04/08/20 00:33 ID:l4XN6lCD
>>731
konqではmotifを有効にしないと使えんよ

733 :login:Penguin:04/08/20 06:42 ID:2HLewYel
gentoo-dev-sources-2.6.8以降、ati-driversが使えなくなってる?
Xorgが立ち上がらなくなった。以前のに戻したら動いた。


734 :login:Penguin:04/08/20 15:07 ID:OpQ7PQsU
Qtを3.3.3に上げたらqtアプリでATOKが起動しなくなりました。
これまではjpのパッチなしでも起動していました(ただしカーソ
ル問題はあり)。

みなさんはどうでつか?

735 :login:Penguin:04/08/20 15:55 ID:Ioj7DH3t
>>734
再起動汁!


736 :login:Penguin:04/08/20 16:02 ID:OpQ7PQsU
もちろん再起動しました。

737 :login:Penguin:04/08/20 16:30 ID:As1IgfnZ
opera7.54 にしたらシフト&スペースで
skkinputが起動しなくなった、、orz

opera以外のアプリは大丈夫みたいなんだけど。


738 :login:Penguin:04/08/20 17:19 ID:jPEAsYmw
>>734 >>736
うちもだめになったよ.
てか,734さんがいうまで気がつかんかった.

739 :login:Penguin:04/08/20 17:24 ID:YDFCRXzH
>>733
$ uname -r
2.6.8-gentoo-r1
$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9200SE DDR Generic
OpenGL version string: 1.3 (X4.3.0-3.11.1)
動いてるよ

/usr/src/linuxちゃんと新しいのにリンクしてる?
module作りなおした時、ati-driversも入れ直してる?


740 :login:Penguin:04/08/20 17:26 ID:OpQ7PQsU
こうなったらQtソースハックしよう。手伝ってくれる人キボンヌ。

741 :login:Penguin:04/08/20 17:40 ID:OpQ7PQsU
漏れの認識

・QtのIMまわりの実装はかなりいいかげん。
・ATOKは他のIMと違って癖がある。
・各商用ディストリは独自にパッチを作っているからATOKが動く。Gentooは
 すっぴんのQtだから動かない(または挙動があやしい)
・jpに上がってるQtのebuildはATOK用にパッチを当ててビルドするが、
 そのパッチ自体が不完全なものなので解決には至らない。

というわけで
・過去のQtパッチを元に問題点を洗い出し、3.3.3に対応した完全なパッチを作る。
・今後Qtのバージョンが上がるたびにメンテする。

というのが必要な仕事、かな? まず同じようなことをやってる人が既にいるの
かどうか探すところからだと思うけど、その辺詳しい人いない?

742 :login:Penguin:04/08/20 18:48 ID:OpQ7PQsU
とりあえず見つけた情報

Immodule for Qt
http://immodule-qt.freedesktop.org/Software/immodule-qt

Qt-devel ML過去ログ
http://www.KDE.gr.jp/ml/Qt-devel/thrd18.html

Immodule for QtはATOK問題よりはもっと大きなプロジェクトだな。
ATOKが使えるのならいいけど。

743 :login:Penguin:04/08/20 18:57 ID:hQqNqRQi
まあ qt-3.3.2 以降を使ってて atokx をバンドルしてるディストリはない罠

744 :login:Penguin:04/08/20 20:57 ID:Pv27bvdT
qtのバージョンを調べるにはどうすればいいの?

745 :login:Penguin:04/08/20 21:22 ID:OpQ7PQsU
emerge -pv qt

746 :login:Penguin:04/08/20 21:31 ID:Pv27bvdT
>>745
ありがとうございました。

ところでgentooはとっても良いのですが
アプリケーションのインストールを重ねると、結局は
欲しくもないパッケージがどんどん入ってきますね。

postgresqlインストールするのにどうしてantが必要なんだろう・・・・


747 :login:Penguin:04/08/20 21:36 ID:OpQ7PQsU
ポスグレのビルドにantが必要なんじゃないだろうか。わからんけど。

748 :login:Penguin:04/08/20 21:58 ID:Pv27bvdT
今現在、ポスグレがインストールされているんだけど
antはインストールされていません。

この状態でアップデートを試みる前準備問として
emerge -vp postgresql
をして調べてみるとantもインストールされちゃんですよね・・・
どう考えてもantなしでもいいと思う。コンパクトに逝きたいのに・・・・

749 :login:Penguin:04/08/20 22:04 ID:wUWIEDBf
>>748
JDBC ドライバをコンパイルするときに ant が必要になるのでは?
Java から接続する必要がなければとりあえず USE に -java を指定すれば ant は不要。

$ USE="-java" emerge -pv postgresql

750 :login:Penguin:04/08/20 22:13 ID:Pv27bvdT
なるほどぉ・・・色々な組み合わせを試す必要があるのですね。
勉強になりました。

751 :login:Penguin:04/08/20 22:15 ID:bdYj6ID8
詳しくないのにあえて補足しちゃうと、
ebuildを見た限りではantはランタイムではいらないみたいだよ。
ビルド後でantだけアンマージしてもいいかもね。

emerge -p depcleanを使えば要らないパッケージを
確認できたんだっけかな?

752 :login:Penguin:04/08/20 22:36 ID:AqQrFTEh
Qtってiccでビルドできるみたいだけどどの位効果あるんでしょうか

753 :login:Penguin:04/08/20 23:02 ID:nzBW/W4w
iccでコンパイルするとatokxは使えますか

754 :649:04/08/21 00:33 ID:yo6Yfj6c
>>651
お礼を言うのが遅くなってすみません。
質問した事をすっかり忘れていました。(ぉ

教えて頂いた方法でうまくいきました。
ご親切にありがとうございました。

755 :login:Penguin:04/08/21 01:38 ID:ZM4Nardd
Qt3.3.3にしたらcanna + kinupt2でもkdeアプリに日本語入力できないじゃんorz

756 :login:Penguin:04/08/21 01:43 ID:8jOy+sYr
やっぱそうか。要するにQtがIM非対応でビルドされてるんだ。
つーことはebuildでconfigureだけいじれば少なくとも3.3.2
の状態では動作する可能性があるかもな。

757 :login:Penguin:04/08/21 01:44 ID:8jOy+sYr
Kitaで読みながらおちゅ〜しゃで書き込んでる漏れって・・・。

758 :login:Penguin:04/08/21 04:52 ID:R7Tp0WqD
>>734-
どうもすみません。immodule for Qt のパッケージングの際にミス
してしまったようです(自分で cp したファイルが残っていて自分の
ところでは問題出ていませんでした)。とりあえず
mv /usr/qt/3/plugins/inputmethods/* /usr/qt/3/plugins/input
として inputmethods の中身を全部 input に移動すれば直ると思い
ます。cjk の開発者でも相談していたのですが、immodule for Qt
のコンパイルに最初 cjk USE フラグを使うことにしたのですが、
いろいろあって immqt もしくは immqt-bc という USE フラグを
設定した場合のみビルドするように変更しました。(そういうわけ
で、今回いろいろ不具合があった方には申し訳ないのですが、今後
はよく分からず巻き込まれるということはないと思います)
inputmethods と input というディレクトリ名の問題は、immodule
for Qt の upstream ですでに名前を変えているところなので、
そちらに合わせる形でパッチを作り直します。どうもご迷惑をおかけ
しています。

759 :login:Penguin:04/08/21 04:56 ID:R7Tp0WqD
書き忘れました。ほとんどの人は /usr/qt/3/plugins/input
というディレクトリがそもそも存在しないでしょうから、
mv の前にディレクトリを作成してください。

760 :login:Penguin:04/08/21 07:10 ID:WUew7QHc
USEフラグにcjkをつけずにgentooをインストールしてしまいました。
いまからcjkを追加して emerge -u world すれば問題ないですか?

761 :login:Penguin:04/08/21 07:31 ID:w7ADFEnh
USEフラグにcjk nlsをつけて、emerge kdeで
やり直してくれるような気がする。

僕は、再インストールの形を取ったんだけど。

762 :login:Penguin:04/08/21 08:00 ID:HbtED6oX
>>760
何入れたのかにもよる。
nlsはデフォで有効になってるし、実はそのままでokかも。
ためしにLANGなり設定して動かしてみて、
ダメなやつをemergeしなおした方が早い。


763 :login:Penguin:04/08/21 08:22 ID:WUew7QHc
>>761>>762
ありがとう。駄目なやつだけ入れなおしてみます。
その際は -u オプションつけない方がいいですか?

764 :名無しさん@Emacs:04/08/21 08:25 ID:rAihp+dW
>>760
emerge -epv world|grep cjk

で出てきたパッケージをコンパイルしなおす.

765 :login:Penguin:04/08/21 09:16 ID:ZM4Nardd
>>758-759
情報ありがとうございます。
今朝再ビルドしました。
これをkonqueror + atokxで書いてます。
USE="-iimqt -iimqt-bc" :)

766 :login:Penguin:04/08/21 13:17 ID:pForw7Ms
はじめてgentooをインストールしました。
make menuconfigでカーネルを再構築したのですが、保存して終了すると
make:warnning:Clock skew detected. Your build may be incomplete.
と最後に表示されます。どこを変更すればよいのでしょうか?

767 :login:Penguin:04/08/21 14:04 ID:wjkJO/l7
>>766
時計にゆがみが見つかった。完全にはコンパイルできなかったって言うような
エラーメッセージ(直訳に近いが)だから、時間がずれてるんでは?
BIOSの時間からチェックしてみてはどーだろ?



768 :766:04/08/21 14:22 ID:pForw7Ms
>>767
ありがとうございます。一応ネットで調べているのですがBIOSの時間も
#data
の時間も合っています。
#make modlues すると
#make : Warnning:File 'Rules.make' has modification time 2.2e+04 s in the future
#make :*** No rule to make target 'modlues'. Stop
となります。

769 :login:Penguin:04/08/21 14:34 ID:HWmcxjny
>>768
ソースの時間が未来になってるから、入れなおしたら直る。

770 :login:Penguin:04/08/21 14:37 ID:MP5SKbNo
>>766

# cd /usr/src/linux
# find . -print |xargs touch

771 :login:Penguin:04/08/21 15:46 ID:ZKZc1eVt
gentooってインストールの時はBIOS時計をUTCとして読み込むからなんか変に
なるのか?libperlとかも作り直さないとダメな場合がある。

まあ、一晩置けば大丈夫なんだけどね

772 :login:Penguin:04/08/21 16:47 ID:UUCgngbl
2ヶ月近くemerge syncしていなかったけど、XOrgマンセーをアナウンスしましたな。
最初から入れなおそうかなあ。



773 :766:04/08/21 18:32 ID:jd9nRPQX
>>769
ありがとうございます。その通りでした。
>>770
それもありなんですね。

774 :766:04/08/21 18:43 ID:jd9nRPQX
>>771
だから時間が狂ってる表示されたんですね。

775 :login:Penguin:04/08/22 01:36 ID:vj3foyW0
なんでnanoなの?インストールのとき。
http://www.gentoo.org/doc/ja/gentoo-x86-install.xml

自分はすぐvi入れてviで設定したけど・・・。

776 :login:Penguin:04/08/22 01:49 ID:xXSadp++
いいかげんこの手の質問ウザいな…
無視でいいよね

777 :login:Penguin:04/08/22 02:07 ID:4Jx5t4MK
無視したいなら黙っててもいいと思うよ。

778 :login:Penguin:04/08/22 03:13 ID:c+Z1TDtc
vi使いたきゃ、vi使えばいいじゃねえかw

779 :login:Penguin:04/08/22 03:22 ID:ZfFl6L7n
nanoなの。

声に出して読みたい日本語。

780 :login:Penguin:04/08/22 07:37 ID:7j7fnfJH
libstdc++のメジャーバージョンが違うバイナリが共存することはよくないですか?

781 :login:Penguin:04/08/22 07:45 ID:pIaaRxSR
http://www.bidders.co.jp/item/36805948

782 :login:Penguin:04/08/22 10:28 ID:w81Bft2f
qt-3.3.3-complemental-patch-for-immodule-20040814.dif

乙デス

783 :login:Penguin:04/08/22 20:34 ID:tDC9iLRK
vi が使えないなら vim を使えばいいじゃない

784 :login:Penguin:04/08/22 23:18 ID:e879XN1o
本家の portage と portagejp に同じパッケージがあって,
portagejp を優先させたいときはどうしたらいいのですか?

たとえば,kterm を使う場合,本家は,kterm-6.2.0-r2 が最新ですが,
portagejp は kterm-6.2.0-r3 が最新です.
手動で,portagejp の方を emerge しても
emerge -up world するときに本家の方にダウングレードされてしまいます.

785 :login:Penguin:04/08/22 23:41 ID:Cb/LgMtw
-Up ではだめ?

786 :login:Penguin:04/08/23 03:53 ID:IFYFKlcI
初めてgentoo入れてみました。
gentoo.jpの「インストールガイド」および「デスクトップ構築ガイド」を参考にしました。
一度emergeした物を、make.confのUSEフラグを追加して再度emergeした場合、
追加したUSEフラグが有効になった状態でリコンル(?)されるんでしょうか?

何を気にしているかと言うと…kdeをemergeし始めた後にcjk、nlsがUSEフラグに書いてなくて、
kdeの「デスクトップ設定ウィザード」の時に[en]しか選べませんでした。
cjk、nlsを追加してemerge kdeしたんですが、やっぱり[en]しか選べませんでした。
kde-i18nはjaでemergeしたんですが…
今、emerge -e kdeしてるんですが色々調べたらどうも何かが間違っているのかな?と言う感じで、
ココに質問なのです。
>764 の方法を取るのが正解だったのでしょうか?

787 :login:Penguin:04/08/23 04:40 ID:Vm92uGeI
>786

されます。なので心配ならばKDEだけコンパイルしなおせばよいです。

どのフラグが適用されるかは、
emerge -pv kde
とかで確認できます。

788 :login:Penguin:04/08/23 07:34 ID:0ocIDOfx
>>786
漏れもcjk,nlsは明示的に入れる指定はしてないけど、kde-i18nをいれたら
問題なく日本語でたよ。
漏れは普通にKDE入れた後、
LINGUAS="ja" emerge kde-i18n

でkde-i18nを入れて、念のためホームディレクトリのKDE関係の設定ファイル消して
KDE起動。
これで言語の選択メニューでたよ。
だから、cjk,nlsの問題は心配ないと思う。


789 :login:Penguin:04/08/23 10:13 ID:CXx7ZCII
UML(user-mode-linux)のカーネルを作ろうとしてるんだが、
最後のリンク(vmlinuxとくっつけてlinuxを作成しようとしてるところ)で
コケてしまってます。

同様の人いないかなと思っていたら、
ttp://bugs.gentoo.org/show_bug.cgi?id=57225
にあるように、うまくいってない人がそれなりにいるみたいです。

さて、どうしたものでしょう。
i386上でやってます。
> スレッドモデル: posix
> gcc バージョン 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2, pie-8.7.6)
なgcc、2.6.7-mm6カーネル上で行ってます。


790 :login:Penguin:04/08/23 15:35 ID:TvWXMVRo
>>785
どうもです.うまくいきました.

ところで,私は >>457 で kterm 中で less とか vim で PageDown PageUp が効かないと言っていた者なのですが,
ほかのディストリビューションの kterm のリソースファイルを参考にしていじったらうまくいくようになりました.
以下パッチです.私と同じような症状の人はお試しあれ.Vine のものを参考にしました.

http://v.isp.2ch.net/up/f2ce14a02980.patch

791 :login:Penguin:04/08/23 17:23 ID:55DmziZv
ポカをやってハマッたので記念カキコ。

/etc/rc.confが反映されない!(KEYMAP="jp106"とかCLOCK="local"とか。)
と思ったら
オリジナルの/etc/rc.confを/etc/rc.conf.defaultにリネーム保存していたのが原因ですた。

792 :login:Penguin:04/08/23 22:36 ID:TCdtm/qY
gentoo、インストールできました!でも起動するとき8139cpがロードできない、みたいな表示がでたのです。
ネットワークカードは8139tooで動作するのでネットにはつながるのですが、気持悪いのでいろいろ調べて、
/etc/hotplug/blacklistに8139cpを書き込んだら表示されなくなりました。
無事に動いているみたいなのですが、これで良かったのでしょうか?
前にも8139cpに関する質問があったみたいですがなにか問題でもあるのでしょうか?

793 :login:Penguin:04/08/23 23:16 ID:U2ehuh0L
>>792
次回カーネルをコンパイルするときに、8139 C +のチェックを外しておけばいいような気が汁。

794 :485:04/08/24 04:20 ID:e8q6wgP8
>>792
上で質問したものです。
私も 8139cp を blacklist にいれて対処しました。
結果書き込んでなくてすいません。


795 :login:Penguin:04/08/24 12:28 ID:rswUWRTI
厨な質問で悪いが、時刻設定がよくわからん

グーグル先生に聞いてみて
# ln -s /usr/share/zoneinfo/Japan /etc/localtime

# TZ=JST
# export TZ

をやってからntpdateで時刻を合わせたのだが、
やっぱり無理だん

今の実行結果
# date; date -u
2004年 8月 24日 火曜日 03:24:57 JST
2004年 8月 24日 火曜日 03:24:57 UTC

ってなるのん

796 :login:Penguin:04/08/24 13:11 ID:GaIMV49O
インストールマニュアルどおり
# ln -sf /usr/share/zoneinfo/Japan /etc/localtime
と /etc/rc.conf の CLOCK="UTC" を CLOCK="local" にしただけで問題ありませんが?



797 :login:Penguin:04/08/24 14:21 ID:bgk8Cl8y
>>795
漏れも同じようにやってみたんだが、確かにずれる。
ただし、
># TZ=JST
># export TZ
をやらなければ問題ないから、これが問題だ。


798 :795:04/08/24 17:28 ID:rswUWRTI
>>796-797
ありがと
TZを設定しければうまく行ったよ
TZは設定しなくていいんだね

799 :login:Penguin:04/08/25 14:22 ID:rYCshIHx
>>784
亀気味だけど、動作確認後 /etc/portage/package.keywords に
=x11-terms/kterm-6.2.0-r3 ~x86
とか書いちゃうのはどう?
今後portageの仕様変更があるけど
-Uは意図を汲めなくなるので危険との話があったと思うけど

800 :login:Penguin:04/08/25 15:37 ID:DW/zDfEu
>>799
どうもです.
portagejp の方の ebuild を見ると確かに ~x86 が指定されていますね.
とりあえず,package.keywords に x11-terms/kterm ~x86 でうまくいきました.


801 :login:Penguin:04/08/26 08:37 ID:3uCAhDwc
既出かも知れませんが教えて下さい。
cupsとfoomaticをインストールして、lipsVv+のドライバを設定して
ネットワークプリンタで印刷(lpd://hogehoge/lp)するように設定しました。
http://client1:631 からCUPSの設定画面に入って、テストページを印刷すると
ちゃんと出てくるんですが、lprやcupsdoprintでpsファイルを印刷しようと
しても印刷されません。
設定画面から再印刷させると「client-error-not-possible」というエラーが出ます。

cupsd.confに
Allow from 192.168.0.*

等も入れてみましたが、状況が全く変わりません。

802 :801:04/08/26 08:39 ID:3uCAhDwc
すみません。
http://client1:631 じゃなくて http://localhost:631 でした。

803 :login:Penguin:04/08/26 13:11 ID:4+Zi3RVX
emerge -P と emerge -C の違いは何?
両方依存性を無視して強制的に削除するらしいけど。

804 :login:Penguin:04/08/26 16:44 ID:h7R5w/gG
>>801
ちょっと忘れたけど、僕の場合はデスクトップがKDEなんで、
Konqurer(スペルはこうだった?)ブラウザから印刷する前に、
「拡張on」→
   「現在の印刷システム」→
     「CUPS(Common Unix Printer System)」
を選択する必要があったような記憶があります。

805 :login:Penguin:04/08/26 19:27 ID:ZahM1nHC
水族館でペンギン見てきました

ジェンツー・ペンギン

と表記されてました

806 :login:Penguin:04/08/26 23:39 ID:4OVRe9aK
フォントが追加できません。
# emerge mplus-fonts
でインストールしたあと、/etc/X11/xorg.confの
FontPathに
"/usr/share/fonts/mplys"を追加。
# fc-cache -fv してもrebootしても、KDEコントロール
センターのフォント変更欄に出てこない。

誤りがあれば、ご指摘願います。

807 :login:Penguin:04/08/26 23:55 ID:slQhbRvt
/etc/X11/fs/config かな

808 :login:Penguin:04/08/26 23:57 ID:lkkYUAZn
>803
-C 強制削除。
-P 最新版だけは残す。

詳しくは man emerge

809 :login:Penguin:04/08/26 23:57 ID:slQhbRvt
/etc/fonts/fonts.conf かな

810 :login:Penguin:04/08/27 00:50 ID:uH06GUEY
>807 >809
両方ともにパスを記述しているのですが・・・
どうにもなりません。
皆さんできているのですよね?
信じられない・・・TrueTypeに追加したほかの
フォントはOKなんですけどね・・・

811 :login:Penguin:04/08/27 01:21 ID:9ETFmrPw
ひさしぶりにemerge -u worldしたらカーネルがモジュールにしたドライバよまなくなちゃったよ...
おれが何かわるいことしたか

812 :login:Penguin:04/08/27 02:22 ID:zCPc1AgZ
install-x86-universal-2004.2.isoを焼いたCDで
インスト中です。GRPでインストしたいんですけれど
Code Listing 8.4: GRPファイルのコピー
# cp -R /mnt/cdrom/distfiles /mnt/gentoo/usr/portage/distfiles
# cp -a /mnt/cdrom/packages /mnt/gentoo/usr/portage/packages

この2行目の/mnt/cdrom/packagesというディレクトリが上記のliveCDに
ないんです。とおもって英文のガイドをみたら2行目がないですね。

がんばりま。



813 :786:04/08/27 02:44 ID:y6J1yGBQ
>>787
>>788
激しく遅レスで申し訳無いです。
コメントありがとうございました。
勉強になりましたm(_ _)m

814 :login:Penguin:04/08/27 08:31 ID:CXNwank6
>>808
サンクス!

815 :login:Penguin:04/08/27 13:20 ID:jyHyBITy
>>806
/etc/fonts/local.conf

816 :login:Penguin:04/08/27 15:16 ID:F4IyZlNE
ビットマップフォントだから
いったんAA無効にしてKDE再起動したら
KDEコントロールセンターのメニューに現れる。
どういうわけか、我が家ではその後AA有効にしてもメニューに残る




817 :login:Penguin:04/08/27 18:07 ID:zCPc1AgZ
celeron566 128M でgenkerne allを
実行したところ、かれこれ2時間ほど

>>compiling 2.4.26-gentoo-r6 bzImage,,,
>>compiling 2.4.26-gentoo-r6 modules...

と表示されたままなのですが、カーネル
コンパイルにこんなに時間かかるもんで
しょうか?



818 :login:Penguin:04/08/27 18:50 ID:OZRNwOsw
そのスペックならかかるかもね?

819 :login:Penguin:04/08/27 18:50 ID:ThIMWcnH
>>817
CPU負荷はどうなっている?


820 :login:Penguin:04/08/27 18:59 ID:zCPc1AgZ
>>818、819
放置していたら終わってました。
レスありです。

ただいま、fstab編集中です。もうすこしで
gentoハァハァ。



821 :820:04/08/27 20:51 ID:zCPc1AgZ
嗚呼、HDDからブートしない。/bootを
/dev/hdb2にしたのにgrub.confでhd(0,0)の
ままにしたからなのか。よくわからんです。

最初からはつらいしなあ。なんとか書き換える
方法ないですか?




822 :login:Penguin:04/08/27 20:54 ID:WL+UfOAs
>>821
grubのプロンプトは出るの?

823 :login:Penguin:04/08/27 21:06 ID:F+2tDOkC
LiveCDで立ち上げて、インストール時と同じようにマウントして(フォーマットせずに)
chroot, env-update, source /etc/profile
とすればいい。そこからもう一回 grub と打って
grub> root (hd1,1)
grub> setup (hd?)
grub> quit
でオケ

824 :login:Penguin:04/08/27 21:14 ID:zCPc1AgZ
>>822
出ていると思います。
縦に縞模様が入ったように画面がくずれてますが
GNU GRUB version 数字 linux loader
と上に、枠の中にGentoo Linux2.4.26-r6と
表示され選択してEnterを押すと、エラー画面に
なります。

この画面でeを押すと編集できるっぽいですね。
画面が激しくくずれていて全部読めないのが
痛い。。





825 :login:Penguin:04/08/27 21:19 ID:ThIMWcnH
ガン( ゜д゜)ガレ


826 :login:Penguin:04/08/27 21:25 ID:WL+UfOAs
>>824
うむ、splashimageの読み取りに失敗するとそうなるみたいね。
cを押せばプロンプトに落ちて起動のコマンドを直に入力することもできるよ。
とにかくどうにかしてLinuxを立ち上げてからgrub.confを編集だね。
>>823の方法でもいいと思うよ。

827 :823:04/08/27 21:32 ID:F+2tDOkC
ああ、grub.confの問題だったのね。>823で立ち上げてnanoで編集してください。
当然、kernelづくりに失敗して立ち上がらない時も、同じようにして作り直したりも
できます。

828 :login:Penguin:04/08/27 21:40 ID:zCPc1AgZ
liveCDで立ち上げてマウントしましたら、grub.confを
再編集できました。いろいろ試してHDDから起動
させたいですな。ひとまずお礼をthx。

829 :login:Penguin:04/08/27 22:28 ID:DbB5e7pT
linux26-hdeaders 環境完成記念カキコ.
xorg + XFCE4 でとくに問題無し.

830 :login:Penguin:04/08/28 00:02 ID:p1E1xwie
もう一回1から入れ直します。
次は完全なスリムな環境をつくろーっと。

831 :806:04/08/28 00:46 ID:GkJJDNir
>815 >816
アドバイスありがとうございます!
今、外出先で家に帰れるのが明日以降に
なりますが、試してみます

832 :login:Penguin:04/08/28 12:53 ID:tWTjppLA
gnome使ってるひと、終了するときおかしくないですか?私の環境だと、仮想コンソールで
暴走したりシャットダウンの手続きが行われず終了してしまいます(その後無事にたちあがりますが…)

833 :login:Penguin:04/08/28 12:56 ID:wqDfdD0r
>>832
同じく。
なぜかシャットダウンするとgnomeが再起動して
もう一度シャットダウンするとちゃんと落ちたりする。

834 :login:Penguin:04/08/28 13:09 ID:p1E1xwie
fluxbox使ってるんだけど
shutdown -h now
を実行しても画面が落ちない。見た目にはフリーズした状態。
でも裏でシャットダウンは行われてるようだ。
gnomeの問題じゃないのかもね。

835 :login:Penguin:04/08/28 15:59 ID:vCh8ns+E
xorg+gnomeの環境にxfce4を入れて、
何を思ったのかgnomeターミナルからstartx xfce4をしたら、
gnome上でxfceが起動した状態(?)になってしまって、
rebootしても直りません。
どうしたらいいんでしょうか?
今はふてくされてemerge -u worldしてます。

836 :(stable)おまいら:04/08/28 16:23 ID:r6q94CG+
最新版のmm-sourcesのカーネルだと
gcc 3.3.4-r1のemergeにこけるど
注意!!

837 :login:Penguin:04/08/28 16:50 ID:i6LIdl9t
>835 ワロタ、まじなのかわからんが
startx xfce4
  ↓
startxfce4


http://www.dayomon.net/xfce/xfce4-use.html#xfce4-getting-started

838 :835:04/08/28 17:16 ID:vCh8ns+E
>>837
レスありがとうございます。
そのページは参考にさせていただきます。

が、現状でgnomeが使い物になりません。
gnomeでログインするとgnomeのタスクバーの上に
xfceのパネルが2つ表示されて、画面の上にxfceのタスクバーが出ます。
そのまま「○○マネージャはすでに起動されています」(うろ覚えですみません)が
いくつも表示されて、なぜかその後xorgが終了→ログオン画面に戻る、という状況です。

あまりにレベルの低い質問の仕方で申し訳ないです。
今emerge -u world中なので終わったら再挑戦(何したらいいのかわからないけど)して、
もうちょと詳しく状況を説明したいと思います。

>>835は動転していきなり書き込んでしまいました。
emerge -u worldで流れる画面を見てたらちょっと落ち着いてきました。

839 :login:Penguin:04/08/28 17:27 ID:i6LIdl9t
rm -rf ~/.gnome*
で最初からやりなおしたら?

840 :login:Penguin:04/08/28 20:07 ID:ABf28EzB
>>838
WM,Xのライブラリが一部、傷物になってる可能性大。
おそらく、revdep-rebuildするとgnomeの何かがリストアップされるはず。
そいつを再emergeしたほうがよいのでわ。


841 :login:Penguin:04/08/29 08:01 ID:gwqIyiR9
終了時にgdmがストップできなかったという表示が出ます。どこ調べてみればいいのでしょう?電源はちゃんと落ちるしその後普通に起動もするんですが

842 :login:Penguin:04/08/29 08:08 ID:hwRTwHyK
Xは使ってないのですが、/etc/init.d/gdmとかの起動スクリプトを見てみれば
いいのでは。動作に問題がないのなら、なんかのファイルがないとか
そういうちょっとした問題だと思いますがどうでしょう。

843 :login:Penguin:04/08/29 09:14 ID:jh9cA2xR
gnomeを
emerge unmerge gnome
でアンインストールしたつもりなのですが、
qpkg --installed
で調べてみると
gnome-base/*
gnome-extra/*
等様々なパッケージが残っています。
全部まとめて消すようなことは出来ないのでしょうか?

844 :login:Penguin:04/08/29 10:29 ID:GvfRPNQP
>>843
emerge --depclean


845 :login:Penguin:04/08/29 10:32 ID:GvfRPNQP
/etc/make.confに
USE="-gnome"
も要るかな。

846 :login:Penguin:04/08/29 13:01 ID:HBMqgH2S
GentooのLiveCD立ち上げオプションに時間のロケールのってあり
ましたっけ?なければ入れて欲しい。LiveCD起動で作業した
ファイルのタイムスタンプが全部9時間後になっちゃって、あとの
作業がめんどくさい。
気が付いた時には date -s で9時間前(というかUTC時間)にセット
してますが、大体忘れちゃう。

時間が遅れる、あるいは進んでも bootstrap の間に解消されちゃう
地域の人が主だから気づいてないのかな?


847 :login:Penguin:04/08/29 16:51 ID:FRXfgqS1
>>841
それはinitスクリプトからストップできなかったということ。
initが止める前にgdmは終了している。
initは終了させるべきプロセスを見つけられないのでエラーを出してるだけ。
だから問題ない。

848 :login:Penguin:04/08/29 17:43 ID:y4klKlFo
emerge semi すると

Tagifying mime-ui-ja.info ...
Tagifying mime-ui-ja.info done
Formatting Info file...done.
Select coding system (default euc-jp):

のところで止まる.
今までこんなことなかったのに,
何か変更あった?


849 :login:Penguin:04/08/29 17:51 ID:hwRTwHyK
Gentooと関係あるかどうか分らないんだけど、
ldd で実行ファイルを見ると、linux-gate.so.1
というファイルをリンクしてますが、これって
一体なんなんでしょうか?

850 :login:Penguin:04/08/29 18:02 ID:925rTISV
>>841
どうして幹になるのなら /etc/init.d/xdm の 101行目の retval=1 を retval=0 にするといいですよ

851 :841:04/08/29 20:58 ID:wnmpPMcb
>>842
>>847
アドバイスありがとうございます。
>>850
確かに指示どうり、なくなりました。
もっと詳しくシステムの勉強せねば

852 :login:Penguin:04/08/29 23:22 ID:Ck0fF33Y
Gentoo上でVMWareを動かしていたのですが、
以下のエラーが出るようになりました。

** WARNING **: Unable to load module: libpixbufloader-png.so: libpng.so.2: 共有 オブジェクトファイルを開けません: そのようなファイルやディレクトリはありません

/usr/lib/vmware/lib にライブラリはあるのですが見れてないようです。
どうすれば直るでしょうか?

853 :852:04/08/29 23:32 ID:Ck0fF33Y
追加です。
gccのアップデートをしたのが原因のような気がします。

vmware-config.plをすると

As of March 2003, gcc version 3 and later is not yet a supported compiler by the
Linux kernel development team. Have a look at Documentation/Changes in your
kernel source directory to get the correct compiler installed. Do you want to go
with compiler "/usr/bin/gcc" version "3.3.4"?

とでます。

854 :login:Penguin:04/08/30 04:33 ID:64BTmCJe
>>848
info ファイルが足りないからインストールしてほしいというのを
解決したときに紛れ込んだバグでした。直しておきました。
どうも報告ありがとうございました。

855 :login:Penguin:04/08/30 14:18 ID:nX70X0Se
どこで、質問するか悩んだのですが一応ここで質問。

cloopをemergeしようとしたらkernelでzilbをサポートしろというエラーメッセージが出てきたので
再構築しようと、menuconfigをみたところそれらしき項目が見あたりません。
ネットで調べたところlibrary routineの項目にあるみたいなのですが無いです。
何かパッチが必要なのでしょうか? あるいは、それをサポートしたカーネルがportageにないのでしょうか。
ちなみに現在は、gs-sourcesの2.4系を利用しています。

856 :login:Penguin:04/08/30 15:13 ID:8O4JJpje
>>855
genntoo-sources-2.4.にはある

857 :login:Penguin:04/08/30 17:11 ID:h7IyB1Uo
freeswanを入れようと思ったんですが、distfilesにはあるのにemergeでサーチしても出てきません。
手動で落としてemergeで入れたいんですが、そんなことは可能でしょうか・・・?

858 :857:04/08/30 19:08 ID:h7IyB1Uo
自己レス。>>488 見て解決しました。スレ汚しスマソ

859 :855:04/08/30 20:23 ID:nX70X0Se
>>856
サンクス。でも、gentoo-sourcesでもmenuconfigからはできなかった。
.configを見てみると項目があった。そこを直接編集してmakeしたらできました。

でも、なんでmenuconfigからできないんだろう.....

860 :login:Penguin:04/08/30 21:45 ID:t3gk+1MA
portagejpとportageに同じパッケージあるのですが、
普通にfmergeするとportageのものがインストールされます。

portagejpを優先させるにはどうすればいいのでしょうか?

861 :login:Penguin:04/08/30 23:22 ID:FrUSrHdV
もうここ2週間は更新してないよ・・・orz

862 :login:Penguin:04/08/31 00:05 ID:hQtmLog9
>>860
同じパッケージで同じバージョンなら portagejp のほうが入るけれど、
バージョン違ったらケースバイケース。具体的にどのパッケージが書いた
ほうがいいんじゃないでしょうか。そうしたら直せるものなら直せるし。

863 :login:Penguin:04/08/31 01:21 ID:LPEbR4Np
すまん。もうこんな厨なこと聞きませんから、ぜひとも教えてください。

インストール用のステージ1のCDのISOイメージをDLしたいと思ってるんですが
どれをDLしていいかわからない。。。。。

PentiumMをつんだノートなんですが、ミラーのどれが適当なのかわからんのです。

恥ずかしい質問ですが、なんとか教えてください

864 :login:Penguin:04/08/31 01:27 ID:wFqbSqqo
stage1 からなら
releases/x86/2004.2/livecd/install-x86-minimal-2004.2.iso
でいいよ。
コースター作らないようにね。

865 :login:Penguin:04/08/31 02:13 ID:YoxK+NE5
いや、gentoo.gr.jpを見ても分らないよなぁ。

866 :login:Penguin:04/08/31 11:33 ID:v+r6enPA
>>488
サンクス。858みてソレが書かれてるのに気付いたんだが、
おかげでこれ
ttp://www.kde-look.org/content/show.php?content=10567
ためしてみれるよ。
ありがd

867 :login:Penguin:04/08/31 14:32 ID:v9trPIY7
システム標準のコンパイラとして、gcc-3.4系だけが
インストールされた状態にするには、どうすればいいですか?
~x86上で今のままだとgcc-3.3.4をどうしても入れようとしてきます。

868 :login:Penguin:04/08/31 16:16 ID:Z+6qNNxT
# rm /etc/make.profile
# ln -s /usr/portage/profiles/gcc34-x86-2004.2 /etc/make.profile

869 :login:Penguin:04/08/31 17:00 ID:v9trPIY7
>>868
ありがとうございます

870 :login:Penguin:04/09/01 03:19 ID:KmtSDYWZ
x86のstage1。何回fdisk〜bootstrap.shしても、gettextのエラーで止まる。
チキショー

871 :login:Penguin:04/09/01 11:02 ID:+yElRa+9
>>870
なんとかしたいんなら、いくらなんでももうちょっと情報を書かないとね。
CFLAGSが悪いんでは?とかテキトーなことしかいえないよ。

872 :login:Penguin:04/09/01 12:51 ID:sY9g1nhk
>>870
同じもの使って結果が違う方が困る。所詮PC/AT機なんだから
フォーラムでも見てみれば?

873 :login:Penguin:04/09/01 13:08 ID:lpYWo/qK
gettextは最新版バグ残ってなかった?
なんかマスクしたような気がする。

874 :login:Penguin:04/09/01 15:06 ID:oQ7fDFnO
Bug 57839
bootstrap failed while building gettext-0.12.1 with Segmentation Fault
http://bugs.gentoo.org/show_bug.cgi?id=57839

これかな?

875 :login:Penguin:04/09/01 17:51 ID:8szDdtYa
kde-baseに該当するgnomeのebuildは、gnome-lightで良い?
色々なものを入れ過ぎたく無いから、出来るだけシンプルなgnomeにしたい。

876 :login:Penguin:04/09/01 21:15 ID:vEygSRui

GNU の Fortran をインストールしてみたいんだが、Gentoo 上じゃあ
どうやって emerge したらいいんですか?
emerge -s でそれっぽいパッケージを探しても出てこないようだし、
USE flag にでもあるかと思ったら違うようだし。
なにとぞおしえてくださいませ。

877 :login:Penguin:04/09/01 21:55 ID:hLeXzZW/
>>876
>713,714

878 :870:04/09/02 01:20 ID:Ab6y+G/T
>871-874
Thx. 色々やってみまつ。詳細はまた今度ね。

879 :login:Penguin:04/09/02 04:45 ID:xeB5LeW+
前々から疑問に思ってたことなんだけどさ、
パッケージのバージョン管理ってもちろんportageでやるわけだけど、
emerge -u したあとに前のバージョンが消える場合と残る場合とあるじゃん?
あれって、どういう基準で決まってるのかな?入れてる全パッケージ検査して
このパッケージにはこのバージョンが必要だから残しておこうとか、そういう判断してるのかな?
そうじゃなかったら、そのパッケージのみ単体で古いバージョンの処分を決めてるってことだよね?
そしたら、全然使わないのに、実はすごく古いバージョンが残ってるよ、なんて事態にならない?
どうも、kportageで見てみると、赤い箱のずれたやつ(2つ以上バージョンが入っているとなる)が
けっこう出てきてさー、バージョン見てみると、gtk+とかは1.x系列と2.x系列で依存しているパッケージが
それぞれにあるからいいようなものの、gpgpとかpypgpとかちょっと正確な名前忘れちゃったけど
けっこう細々したパッケージでいくつかそういうの見つかるんだよね。
こういうパッケージ管理の仕方でいいんだろうか?rpmだとその辺のことも含めてある程度は
現状に見合ったバージョン管理してくれるんだよね?
Gentooはそこらへんどういう哲学でやってるんだろう???
1年以上使ってたんだけどふと疑問に思ったので。


880 :login:Penguin:04/09/02 06:19 ID:g9EAxcf1
>>879
ebuild毎にSLOTが設定してある。
SLOTがかぶらないバージョンは共存できるようになってる。
例えば、
kde-3.2.xはSLOT=3.2
kde-3.3.xはSLOT=3.3
で3.2系と3.3系で共存する。
と、俺は思ってる。違うかもね。

881 :login:Penguin:04/09/02 07:11 ID:1ji7afFr
>>877
f77 のインストール法をおたずねした者です。スレをひととおり検索してから
質問を上げたつもりだったのに、既出でしたか。失礼いたしました。


882 :login:Penguin:04/09/02 09:44 ID:a8Ca5r7z
>>879
>>880 で正しくて、それは kportage がちゃんと SLOT を扱えてない
という kportage のバグなんじゃないかなあ。(kportage 使ったこと
ないけど) まあ emerge もちゃんと SLOT 扱えてないので仕方ない気
はする。apache1 と apache2 が入っている状況で apache1 に更新が
あっても apache1 のアップデートは検出してくれないよね。(もしか
していまは違う?) SLOT ごとに最新版を検出してくれないとなー。

883 :login:Penguin:04/09/02 10:56 ID:mq9jicgg
>>879

使ってるライブラリとかを他が使ってるから残ってるとか・・・
んなこはないか・・・・

RPMだとライブラリの依存でアップデートできないとか
結構あるからね。


884 :login:Penguin:04/09/02 12:27 ID:FPXdxATO
etc-update を実行したら、インターネットにつながらなくなってしまいまし
た。ssh で LAN 上の他のホストにログインすることはできます。LAN から外
に出られないと言ったらよいのでしょうか。
使用機種は Sony Vaio C1-XF で、Buffalo の無線LANカードを使用してます。

$ ping 使用プロバイダの DNS アドレス
connect: Network is unreachable

$ /sbin/ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: xxxx::xxx:xxx:xxxx:xxxx/10 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:12823 errors:0 dropped:0 overruns:0 frame:0
TX packets:12547 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:6349132 (6.0 Mb) TX bytes:3232809 (3.0 Mb)
Interrupt:3 Base address:0x100

こんな感じなんですが、どこをどうイジればよいでしょうか。

885 :login:Penguin:04/09/02 13:23 ID:9HXcCj2W
routeの実行結果見て、defaultの宛先がどこ向きかをみてみては?
その内容が変なら/etc/conf.d/netのgatewayじゃないかな


886 :login:Penguin:04/09/02 13:57 ID:1Iu3tSNo
>>884
解答にはなってないかも知れないけど、うちのGentoo も
etc-update 後に繋がらなくなったよ。
/etc/conf.d/net の記述を、古い記述から新しい記述に変えたら
繋がった。
ん 原因はそこじゃなかったかもしれないけど今は問題なく
使えてます。

887 :886:04/09/02 13:59 ID:1Iu3tSNo
ごめん、間違えた。
解決策にはなってないです。
スレ汚しすまそ

888 :879:04/09/02 14:06 ID:ymJzVfcz
>>880>>882
文章がへたくそでスマソ。自分で読み返しても良くわからん。orz
えーと、そのKDEの例で言うと、SLOTが違うから残るというのは
理解してるんだけど、そのSLOTの動きというか理念って正しいのかな?と。
KDE3.3入れててなおかつ3.2も残しておきたい人っている?・・・いるからそうなってるのかな?
漏れはそういう場合(ほかのパッケージが3.2に依存していなければ)は3.2は消して欲しいんだけど、
現行の仕様だと、ただemerge -u kde しただけでは残ってしまうんだよね?
>>883
いま手元でそういううふうな古いバージョンが残っているのって、全部SLOT違いのやつだと思うんだけど
その中で全然使われてないやつがあると思うんですよ。portageというかebuildでは依存関係まで
チェックしてないですよね?入れるときには依存関係は関係ありますけど、消すときには何がその
パッケージに依存してるかまで参照してないですよね?
そういうふうにして残ったままのを自動で消す手立てってGentooではないんでしょうかねー?

889 :login:Penguin:04/09/02 17:36 ID:i76pmJbA
違うかもしれないが
ttp://callisto.comlab.soft.iwate-pu.ac.jp/~g031y177/gentoo/ebuilds1.html#omake
とか


890 :login:Penguin:04/09/02 19:34 ID:a8Ca5r7z
>>888
どちらかというと KDE みたいなのがちょっと特殊で、どちらかと
いうと複数バージョン入れておきたいライブラリみたいのを SLOT
で分けていれるから、依存されているかぎりは消してもらっちゃ
困るんじゃないかな? emerge depclean すると依存されていない
パッケージ全部消えるので、これでお望みのことはできると思うけど。
自分も KDE に関しては SLOT じゃなくていいとは思う。

891 :login:Penguin:04/09/02 20:45 ID:FPXdxATO
>>885, 886
まさしくそのトーリでした。ありがと。
以後、/etc/conf.d/net は、CONFIG_PROTECT で保護しときます。

892 :login:Penguin:04/09/02 21:00 ID:1ji7afFr

g77 コンパイラ使いたいなら USE に f77 だ、といわれて疑問解消したけど、
gcj はどうなりますか?
f77 の件も、Gentoo Linux Use Variable Descriptions なんかには載っていない
気がします。どこで知り得るのですか、このへんの魔法は?

893 :login:Penguin:04/09/02 21:12 ID:9Jb8Z569
>>892
普通emergeする前にebuildを読むのは当たり前でしょ。
Makefile読まされてるわけじゃないんだし。

894 :login:Penguin:04/09/02 21:15 ID:YdH6Jh7v
emerge -pv gcc で怪しそうな flag を ufed で確認するかなぁ。

895 :login:Penguin:04/09/02 21:16 ID:aViLZEh8
>>892
etcat -u gcc

896 :login:Penguin:04/09/02 21:20 ID:YdH6Jh7v
>>893
普通読まないと思う。

897 :login:Penguin:04/09/02 21:29 ID:NEAx3ffD
>>896
今後は読もうな。

898 :login:Penguin:04/09/02 21:31 ID:E+pcF45o
読むわけ無いじゃん。
てかさ、お前も読まないだろ?

899 :login:Penguin:04/09/02 21:37 ID:1ji7afFr

わたしにゃ emerge -pv が一番あっているな。 etcat なんていう
コマンド、インストールされてないし。

900 :login:Penguin:04/09/02 21:55 ID:aViLZEh8
>>899
use.desc, use.local.descが同時に引けるので892のお好みかなぁと。
まあ、俺もメインはemerge -pvだし、
好みの問題だから好きにしてもらって構わないと思う。
ただ、app-portage/gentoolkitはインストールしておいても損はないよ。

901 :879:04/09/02 22:42 ID:DBiqfHQd
>>890
「依存されている限りは消してもらっちゃ困る」というのは、もちろん異議はないんですよ。
問題は、「依存されているかどうか」をバージョンアップの時にチェックしてない(ですよね?)ことなのです。
それやり出すとemerge に時間が掛かって仕方ないだろうから、そういう仕様になっていないのかと思いますが、
そうなると、バージョンアップした場合にSLOTが別になってる場合は、事後に前のバージョンに依存しているか
手作業で調べて、ほかに依存されてなさそうだったら消す、という作業が必要になってくると思います。
(容量に余裕のある人は放置してていいんでしょうが)。
でも、それでいいのでしょうか?という疑問なんですが。分かっていただけますでしょうか。

それから、
>>889さんに紹介していただいたサイトは前から知っていましたが、いま改めて見てみると、
そのスクリプトがこなす仕事と私の希望とはちょっと違っているようです。
そのスクリプトは複数入っているパッケージだと最新版について検索して、依存するパッケージを
探しますよね?前のバージョンを消して良いかどうかの判断には使えないんじゃないですかね?
もしあったら便利なスクリプトとしては、複数バージョンがインストされているパッケージを抽出して
その中で古いバージョンに依存しているほかのパッケージがあるかどうか探して、無いようだったら
その古いパッケージをunmergeしてくれる、というものになるかと思います。


902 :879:04/09/02 22:47 ID:DBiqfHQd
続けて失礼します。

で、いま、具体的にもっとわかりやすいパッケージの例を示そうと思って
kportageを起動しようとしたのですが、どうもkportageって消えてしまったんですね?
portageツリーからはapp-portage/kportage-0.6.1で入っていたのですが、最新のツリーからは
消えてしまっています。しかも、KDE3.2->3.3の更新に伴って起動不可になりました。
代わりに何か無いか探して、kentooというのを見つけたのですが、こっちはkportageほど高機能ではなく・・・。orz

たとえば、t1libとかは 1.3.1 と 5.0.2 というバージョンが混在してたりするのですが。。。
こういうのって、1.3.1は消したらいけないのか判断に苦しみます。

903 :login:Penguin:04/09/02 22:59 ID:bMiU/unn
>>879
emerge depclean じゃ不満なのか?

904 :login:Penguin:04/09/02 23:18 ID:9hMlrx3U
KDEとGNOMEをアンマージしてからemerge depcleanしたら、mplayerが動かなくなりました。
新たに emerge unmerge mplayer ; emerge mplayer しても動きません。





905 :879:04/09/02 23:32 ID:DBiqfHQd
>>903
これは知りませんでした。
man読んだところ、なかなかよさげです。
実行したらエラー出て止まってしまいましたが。(自力解決目指します。)

Calculating depclean dependencies \
!!! all ebuilds that could satisfy "x11-misc/xcompmgr" have been masked.
!!! possible candidates are:
- x11-misc/xcompmgr-0.1_pre20040821-r1 (masked by: package.mask)
- x11-misc/xcompmgr-0.1_pre20031201 (masked by: package.mask)
!!! (dependency required by "x11-base/xserver-freedesktop-0.1_pre20031201" [ebuild])

!!! Problem with ebuild x11-base/xserver-freedesktop-0.1_pre20031201
!!! Possibly a DEPEND/*DEPEND problem.


906 :login:Penguin:04/09/02 23:34 ID:Ab6y+G/T
ポマード、チック、デップ、グリース

907 :879:04/09/03 00:02 ID:nDZkEM2c
>>903
これ、目指しているものと違いました。
エラーが出た箇所の依存関係解決して(一時的にマスク外した)、最後emerge depcleanしたところ
31個のパッケージが表示されました。
しかし、そのどれも単一バージョンしかインストールされておらず、しかも、明らかに自分にとっては
必要なパッケージも含まれていました。
どうも、このオプションは、ほかのパッケージとまったくDEPEND,RDEPEND関係を持たない「孤立」した
パッケージを不要だと判断して消すだけのようです。
私が希望しているのは、「複数バージョンが混在している場合」に限って、そのうちの古い方の依存関係を
調べて、ほかで必要とされていなければ消すというものです。


908 :login:Penguin:04/09/03 00:23 ID:On3KHgV5
>>907
言わんとするところのことは分かったと思うけど、ちょっと難しそう。
たとえば xdvik は >=media-libs/t1lib-1.3 なんだけど、これはビルド
されたときの t1lib のバージョンに依存する。でも Portage 的には
t1lib-5.0 が入っていようが t1lib-1.3 が入っていようが依存関係は
満たされるので、t1lib-1.3 を入れたあと t1lib-5.0 を入れて t1lib-1.3
を消してもよいことになる。(実際のところこういうことをすると xdvik
が必要なライブラリを見つけられなくて起動しなくなる) パッケージが
それぞれ自分がビルドされたときの依存関係のバージョンを覚えていて
くれたらよいのだけど、そうすると今度入れ直さないでいいときはどう
するんだ、という問題が。「このパッケージを入れたあとはこちらの
パッケージは再ビルド必要ですよ」みたいなことを ebuild で書ければ
いいのだけど、いまのところそういう仕組みがないので python-updater
とか revdep-rebuild とかそういうツールで壊れた依存関係を調べないと
いけないのは、ちょっとださいなー。

909 :login:Penguin:04/09/03 00:24 ID:bvGg12j7
>>907
http://forums.gentoo.org/viewtopic.php?t=142475
これの -P がそれっぽいが、完璧じゃない。
うちでやると、gtk+-1.2 が候補に出てくるけど、
実は imlib が依存してるから消してはいけない。

910 :879:04/09/03 00:50 ID:nDZkEM2c
>>908-909
やっぱりGentoo的にはかなり難しいのですね。
了解しました。中の人の奮闘を祈念します。ナムナム

911 :login:Penguin:04/09/03 00:55 ID:SnxKHJkd
他のディストリもゴミは溜まってくもんではないの?
linuxみたいにいろんな人が分散して開発していくってやり方の宿命
みたいなものだと思ってたけど...

912 :login:Penguin:04/09/03 01:16 ID:orRptRKM
てが長文うざ。

913 :login:Penguin:04/09/03 03:40 ID:nDZkEM2c
>>912
無駄レスうざ。

914 :login:Penguin:04/09/03 03:56 ID:1bCvv9Ob
bmobile 使いたいんですけどうまくいきません。
kernel-2.4.26-gentoo-r6 で ppp はモジュールとして入れています。
/etc/init.d/pcmcia start して、カードをさすと
ttyS01 at port 0x02f8 (irq = 3) is a TI16750
と認識されるようですが、
/etc/conf.d/net.ppp0 の
PEER, USERNAME, PASSWORD, NUMBER, を書き換えて、
/etc/init.d/net.ppp0 start しても、
/sbin/ifconfig -a に ppp0 が現れません。

log には
[pppd] pppd 2.4.1 started by root, uid 0
[chat] abort on (BUSY)
[chat] abort on (ERROR)
[chat] abort on (NO ANSWER)
[chat] abort on (NO CARRIER)
[chat] abort on (NO DIALTONE)
[chat] expect (OK)
[chat] alarm
[chat] Failed
[pppd] Connect script failed
[pppd] Exit.
となっています。

/etc/conf.d/net.ppp0 の
MODEPORT="/dev/ttyS1" を
MODEPORT="/dev/ttyS01" にしてみると、
/usr/sbin/pppd: unrecognized option '/dev/ttyS01'
となり /etc/init.d/net.ppp0 start に失敗します。

どこに問題があるのでしょうか?


915 :login:Penguin:04/09/03 23:23 ID:dpgLN+bY
shutdown、rebootコマンドがなくなった!
なぜ??
これらのコマンドが入っているパッケージって?

916 :login:Penguin:04/09/03 23:34 ID:VDxuEnoQ
$ qpkg -f /sbin/shutdown -v
sys-apps/baselayout-1.9.4-r3 *
と言っている。

917 :login:Penguin:04/09/03 23:45 ID:dpgLN+bY
>>916
ありがとう!
baselayout削除した覚えがあまりないんだけど、再度入れます。

918 :login:Penguin:04/09/04 00:48 ID:Qu2SEAZ8
>>915
まさかとは思うが、一般ユーザーでやってない?
suに「-」つけ忘れてたり。
いや、まさかとは思うけどね。

919 :login:Penguin:04/09/04 01:42 ID:42z+tNw+
あるある

920 :login:Penguin:04/09/04 07:55 ID:RJ9Yn8Jx
>>914
pppではなくて、chatスクリプトが間違ってるとかじゃないのかな?

921 :login:Penguin:04/09/04 11:55 ID:trQsQFVg
>>915
フルパスで実行してもだめか?

922 :login:Penguin:04/09/04 12:48 ID:o6YAfcdR
すまんもす、教えてくれ。
windowsからsshを介してgentoolinuxのインストール作業中なんだけど(stage2)、
emerge -u systemを実行したら百数十メガバイトもコンパイルしているんだ。
かなり時間が掛かりそうなのでwindows機だけでもシャットダウンしたいんだが、
windowsのsshクライアントを終了すると、gentooのコンパイルやインストールも
その時点で終了しちゃうの?
再度windows機を立ち上げたときに、またsshクライアントからインストールの続きを
行いたいんだけど、そんな方法ってある?
もし知っていたら教えてくれ、お願いします。

923 :login:Penguin:04/09/04 12:58 ID:K83Mt1eJ
質問です。

emerge -vp postgresql
を実行すると
+java は表示されても -javaは表示されません。

しかし、-javaのUSE flg は有効です。

+があれば -があると考えて良いのでしょうか?
とすれば、-vp時の+-はなにを表すのでしょうか?

924 :login:Penguin:04/09/04 12:59 ID:r7Nyc56C
>>922
man screen

925 :login:Penguin:04/09/04 13:01 ID:eQ/hJyEP
screenだろうな。
ふと思ったんだけど、nohupってサブシェルにも有効なのかな?

926 :login:Penguin:04/09/04 14:37 ID:8cGfJ43V
USE='-unicode' emerge canfep が通らない。
unicodeってつけるものなの?

927 :login:Penguin:04/09/04 14:56 ID:FwCD1pRj
>>922
続きだけならそのまんま、emerge -u systemってやればいけると思うが。

もしターミナル閉じてもやらしとくんなら、
emerge -u system
をシェルかなんかに入れといて(ここではes.shと名前しとく。適時変えてくれ)
#!/bin/bash
/usr/bin/emerge -u system
(こんな感じかな。フルパスでコマンド書くのがミソ)
nohup es.sh &
こうすればターミナル閉じてもバックグランドでやってくれる。

ただし、LiveCDにnohupコマンドまで入ってるかはシンネ。
自分で調べてみてくれ。


928 :login:Penguin:04/09/04 14:57 ID:r7Nyc56C
>>923
IUSEにあるうち現在USEに設定されてるフラグが+、ないのが-

929 :922:04/09/04 15:21 ID:o6YAfcdR
むふ〜、教えてくれてありがとう。
出来るという事は充分解ったよ。
後は自分で調べてみるよ。

930 :login:Penguin:04/09/04 16:24 ID:TNBMwBQw
emerge vlc
でvlc media playerを入れる途中でエラーが出てしまいます。
同じ症状が出たことある方いますか?
make[4]: *** [liblibmpeg2_plugin_a-libmpeg2.o] Error 1
make[4]: Leaving directory `/var/tmp/portage/vlc-0.6.2/work/vlc-0.6.2/modules/codec'
make[3]: *** [all-libmpeg2] Error 1
make[3]: Leaving directory `/var/tmp/portage/vlc-0.6.2/work/vlc-0.6.2/modules/codec'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/vlc-0.6.2/work/vlc-0.6.2/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/vlc-0.6.2/work/vlc-0.6.2'
make: *** [all] Error 2

!!! ERROR: media-video/vlc-0.6.2 failed.
!!! Function src_compile, Line 177, Exitcode 2
!!! make failed

こんな感じです。

931 :login:Penguin:04/09/04 16:45 ID:TthZ7EF5
どうでもいいけど、貼り付けるべきエラー箇所がずれてますよ。

932 :login:Penguin:04/09/04 17:58 ID:kkkw9EIa
>>930
/etc/portage/packge.keywordsに
media-video/ffmpeg ~x86
media-video/vlc ~x86
# emerge vlc でどう?


933 :login:Penguin:04/09/04 19:16 ID:8hHs2t6W
KDE3.3 いつ頃マスク外れるのかなー。

934 :login:Penguin:04/09/04 20:08 ID:TNBMwBQw
>>932
アドバイスありがとうございます。
gentooフォーラムを見ながら必死で頑張ってますが、なかなかうまくいきません。
成功者がいるみたいなんでもうちょいやってみようかと思います。

935 :login:Penguin:04/09/04 21:05 ID:ju6F9z8R
[ebuild N ] media-libs/libdvbpsi-0.1.4
[ebuild N ] media-libs/libcaca-0.9
[ebuild N ] media-plugins/live-2004.07.20
[ebuild N ] media-video/vlc-0.7.2-r1

漏れのところだとこんなんだね。これからトライしてみるわ

936 :login:Penguin:04/09/04 21:48 ID:tVYhIf5V
>>934
問題なかった。
~x86にしてみれば?

937 :login:Penguin:04/09/04 21:49 ID:tVYhIf5V
あれ?935=936ね。

938 :login:Penguin:04/09/04 22:14 ID:FG396OWG
>>936
libmpeg2 ffmpeg libdvbpsiのバージョンを上げたら
vlc0.7.2が入りました!ありがとうございました。

939 :login:Penguin:04/09/05 00:03 ID:eGgIp1De
>>920
/etc/ppp/peers/hoge から読み込まれる
/etc/ppp/chat-hoge がおかしいということでしょうか?
リナザウの /etc/ppp/peers/DIALUP* をみると
chat の引数にいろいろ指定しているのですが、
これをまねして /etc/ppp/chat-hoge を編集してみます。
リナザウでは connect の他にもいろいろ書いてあるんですが、
丸写ししていいんでしょうか?


940 :login:Penguin:04/09/05 01:26 ID:MNhiI7K8
_| ̄|○ 最近どれもコンパイルが通らなくなった。
could not read symbols: File truncated と出る…
調べるか…

941 :login:Penguin:04/09/05 01:28 ID:ay6T2EAS
Y-Windowsかxdirectfb入れてる香具師居ますか?


942 :login:Penguin:04/09/05 02:38 ID:TsFkRvag
>>926
自分のところではコンパイルできるみたい。
gcc とか glibc や Canna のバージョンなんかは?

943 :login:Penguin:04/09/05 12:36 ID:1O6RoP2e
>>942
そういう意味じゃなくて、canfep-1.0.ebuildみると
USE=unicodeの時にしかcanfep_utf8.diffをダウンロードしないのに
USE=-unicodeでもこのパッチを当てに行くという
ちなみに、USE=unicodeだとコンパイルは通ってるので御安心を
でも、Out of pty'sとか言われて動かないので使うのやめちゃった

944 :login:Penguin:04/09/05 18:01 ID:Kj8M1gD6
Gentoo で TeX 環境構築で参考になるところを教えてもらえないでしょうか?

emerge ptex vflib gv ghostscript ghostview yatex dvipdfmx ptex-jisfonts
として一通り環境をインストールしたのですが,うまくタイプセットできないで困っています.

具体的に言いますと,jarticle を使うと,
! LaTeX Error: File `jarticle.cls' not found.
といわれるので /usr/share/texmf/ptex/platex/base/jarticle.cls を指定してやると,今度は
! LaTeX Error: File `jsize10.clo' not found.
といわれるので /usr/share/texmf/ptex/platex/base/jsize10.clo を指定してやると,ようやくタイプセットできます.
しかし,できた dvi をみると,Virtual character 32381 in font min10 ignored. みたいなエラーがでて表示ができません.

クラスファイルが見当たらないのは mktexlsr しても直りませんでした.

945 :login:Penguin:04/09/05 18:35 ID:1O6RoP2e
漏れのとこだと、その変ではトラブってないなぁ
むしろ、なにも設定らしいものもしてないけど
/usr/share/texmf/ptex/platex/base/jarticle.cls
を読み込んでるね。ちなみに、vflib dvipdfmx ptex-jisfontsは入れてない


946 :login:Penguin:04/09/05 22:00 ID:infVRG4N
>>939
/etc/conf.d/net.ppp0 で AUTOCFGFILES="no" にして、
/etc/ppp/chat-hoge をリナザウのを参考に書き換えたら、
ppp0 がでてくるようになりました。
/etc/resolve.conf が変更されないため、
nameserver を自分で書き加えてやると、
ちゃんと google に ping が通りました。
でも、w3m で google に行こうとすると反応がありません。
ちゃんと IP アドレスをもらえているのに、
つながらないのは何故でしょうか?


947 :543:04/09/06 04:44 ID:1ftq94kZ
いくら最適化してもgtk2って描画が遅い。どうすれば早くなりますか?

948 :login:Penguin:04/09/06 07:13 ID:z8y2V+D3
自分でプログラムを書き変えるか、速いマシンを買ってくる

949 :login:Penguin:04/09/06 12:01 ID:iut3uSEC
>>946
default route gateway


950 :944:04/09/06 18:32 ID:gVMC4Gt5
自己解決
どういうわけか,ptex を emerge したときに tetex も一緒に emerge されて
環境がめちゃくちゃになってしまったようです.
一旦,TeX 関係を全部 unmerge して,/usr/share/texmf を消して,
USE="-tetex" として TeX 関係を入れ直したら,直りました.
また,kochi フォントが,/usr/share/fonts/kochi-substitute/ 以下に入っていたので,
/usr/share/texmf/xdvi/vfontcap の内容を変更しました.

951 :login:Penguin:04/09/06 21:43 ID:n8WgpY51
デフォルトでインストールされるバージョンはどういった基準で決められているのでしょうか?
最新のバージョンってわけでもなさそうですし・・・・




952 :login:Penguin:04/09/06 22:22 ID:q9So1j3p
>>951
誤爆?意味わからん

953 :login:Penguin:04/09/06 22:41 ID:CHy/+vfb
ebuildのACCEPT_KEYWORDSは書いた人の独断だっけ?
stableの基準とかみた事ないな
たまに、stableだったバージョンがmaskされたりするし。

ebuild自体は最新のがすぐでるから、
ACCEPT_KEYWORDS=x86
とかにしてるなら、ebuild書いてる人がstableと判断したバージョンが入るんだとおもう。
~x86とかならほぼ最新。

954 :login:Penguin:04/09/07 02:53 ID:pMDSLgRU
>>953
独断ではなくて、ebuildをコミットした人がテストできる環境の
unstableから始まり(例: ACCEPT_KEYWORDS="~x86")、担当者が
stableだと判断すればstableになります。ガイドラインとしては
「入れてから1ヶ月経ったものでその間バグ報告がないもの」と
いうものがありますが、あまり守られてはいません。このあたり
は本家の Gentoo Developer Handbook に書いてあります。

守られない典型例としてはx86以外のアーキテクチャ(最初から
stableでコミットされたり、他のアーキテクチャではunstable
なのに特定のアーキテクチャだけstableだったり)、それと入れ
ただけで忘れ去られてずっとunstableのままのパッケージ、
などがあります。

955 :login:Penguin:04/09/07 03:03 ID:pMDSLgRU
補足すると、ebuildをコミットする人(開発者)はebuildを書いた人
(典型的には bugzilla に投稿したユーザ)の環境がなんであれ、また、
書いた人がいかにそのパッケージはかくかくの環境ではstableだ、
と言ったとしても、自分がテストできない環境のキーワードはいじって
はいけません。

stableのパッケージがmaskされるのは主にセキュリティ上の理由です。
emerge -p でmaskされた理由が表示されるはずです(開発版のportage
だけの機能かも)。キーワードの変更も一応ChangeLogに記録を残すこと
になっている(unstableをstableにする場合は必ずしも残っていませんが)
ので、stableだったものがunstableになったりmaskされたりした場合は
ChangeLogを確認してみてください。

956 :login:Penguin:04/09/07 07:12 ID:hJ9G+RE/
>>949
ヒントありがとうございます。

usepeerdns
defaultroute

を付け加えて (下のはいらないかも知れませんが)
/etc/ppp/resolv.conf ができるようになったので、
ip-up.local, ip-down.local をつくって
DNS を引けるようになりました。
あと w3m で google にいけなかったのは
他の環境で設定していたプロクシのせいでした。

しかし ppp で gentoo つかうのは無理あるかなあ。
全然更新してなかったせいか
emerge sync に一晩以上かかってる。


957 :login:Penguin:04/09/07 08:12 ID:QZvzJQV5
>>956
まじで? それって通信速度のせい?

958 :厳冬さん:04/09/07 16:42 ID:TQ0W4bx7
emerge manpage-ja
にて、日本語マニュアルを読もうとしたのですが、次にどうすればいいのか判りません。
/etc/man.conf
に何か設定するのでしょうか?
それとも
jman
とかの専用のコマンドがあるのでしょうか?
くだらない質問ですが、判らず、困っています。
助けてください。


959 :login:Penguin:04/09/07 18:34 ID:TGsfWLvt
>>958
man は man です。
$LANG と $PAGER を適切に設定すればOKです。
$PAGERはjlessをお薦めします。
もしなければ emerge jless で。

960 :login:Penguin:04/09/07 22:40 ID:Wwd9DpTS
gtk+やqtをUSEフラグにいれた時の効果は解るのですが、
KDEやGNOMEのサポートとは具体的にどんな効果があるのでしょうか?

961 :login:Penguin:04/09/08 00:50 ID:f5xg+3Yf
>>959
USEフラグにcjkがついてれば
lessやmanやgroffをemergeしなおすだけで日本語でいけた。
jman,jlessに相当するパッチがあてられるようだ。

962 :login:Penguin:04/09/08 00:50 ID:zUnEwiTr
/etc.init.d/pppd でネットワークにつないでいます
普段は快調なのですがしばしばふいにネットワークが繋がらなくなり
ping を使ってもどこからも応答できない状態になります。
ただし接続が切れたのかと思って ifconfig で確認しても ppp0 は
存在したままで,ps aux|grep pppd としても
root 30006 0.0 0.4 2192 964 ttyACM0 Ss+ 00:22 0:00
/usr/sbin/pppd lock defaultroute asyncmap 00000000 mru 768
mtu 768 user ACCOUNT remotename ISP demand ktune idle 600
holdoff 60 /dev/ttyACM0 460800 ipparam ppp0 linkname ppp0
call ISP noauth hide-password
となり動いたままで、現在はこうなる度に/etc/init.d/net.ppp0 restart
として手動で再起動をかけています。
せめて接続が切れたときはプロセスも停止して欲しいのですが
何が問題でこのような症状になるのか御存じの方、教えてください

963 :login:Penguin:04/09/08 01:05 ID:N39XVCBs
zlibのセキュリティパッチを当てて入れる場合
linkしてる他の物も入れなおさないとだめですか?

964 :login:Penguin:04/09/08 10:59 ID:0d+LnqYc
>>963
動的リンクしてるだけならサービスを再起動するだけでいいはず。
ソースを取り込んでたり静的リンクの場合は別途アナウンスがあると思う。

965 :login:Penguin:04/09/08 16:05 ID:q40OB9ny
>>961
kdeだとKメニューから起動できるようにするための
アイコンと hoge.desktopがインストールされるのが大半だと思う

そんなことより、scimを1.0.0にしたら(0.9.9が消されたから)
qtconfigのInterfaceのDefault Input MethodをSCIMにしてたときに
/usr/lib/scim-1.0/scim-launcher-daemonとかありもしないファイルを
起動して、ことごとくKDEアプリの起動が遅い


966 :login:Penguin:04/09/08 16:23 ID:q40OB9ny
USE=gtk gnomeとか増えてたのね。素直にskim使うよ
お騒がせスマソ

967 :login:Penguin:04/09/09 00:41 ID:6Gys66gV
emerge sync して、emerge -p world すると U のついたパッケージの表示は
ないのに、emerge -pv pkgname とすると、U がゾロゾロでてくる。どうして
なんでしょう? emerge -p world としたときに U のパッケージを全部表示す
るにはどうしたよいのでしょうか?




968 :login:Penguin:04/09/09 06:47 ID:1F8bZ/6N
>967
uDpv
外したら、すまんこ

969 :login:Penguin:04/09/09 09:26 ID:rmfKOTa0
faubackup のソースを gentoo でコンパイルして
実行してみたら、下記のエラーが出たんだけど
/usr/local/sbin/faubackup-scatter: error while loading shared libraries: snprintf: cannot open shared object file: No su
ch file or directory

snprintf を含む shared libraries って何?

970 :login:Penguin:04/09/09 09:42 ID:wKYgYICq
>>958
http://www.wikiroom.com/GentooNagoya/index.php?install-next#content_1_10

ただしこのままだとman以外が文字化けするから、
1行目の export LANG="ja_JP.eucJP" は削除、
もしくは export LANG="ja_JP.UTF-8"にして、
manの時だけja_JP.eucJPになるようにailasを設定すればOK。
だと思った。
間違ってたら誰かフォローお願い。

971 :login:Penguin:04/09/09 18:44 ID:NtvmIl/R
~x86にxorg-x11-6.8.0キタ━━━━━━(゚∀゚)━━━━━━ !!

972 :login:Penguin:04/09/09 18:46 ID:2rON5kpw
>>971
おooO!キタ!

973 :login:Penguin:04/09/09 19:24 ID:D5j9HhTT
freebsdスレみたいな
Gentoo Linuxスレの
過去ログ公開しているサイト
ありませんでしょうか

974 :login:Penguin:04/09/09 20:07 ID:6ECvzrjL
>973
http://ml.gentoo.gr.jp/users/ 他以下のリンクにて探して
http://www.gentoo.gr.jp/jpmain/about-gentoojp.xml#doc_chap4

975 :login:Penguin:04/09/09 20:20 ID:NtvmIl/R
>>973
存在して無くて、需要があるようなら置けるけど?
まあ、どっかにupするのがいいけど。

976 :login:Penguin:04/09/09 23:11 ID:4GVYQs+Z
xorg-x11-6.8.0 ビルド完了
speedo モジュールがなくなってて,
キーボードのドライバの名前が Keyboard から keyboard に変更されたみたい.

977 :login:Penguin:04/09/09 23:43 ID:2VEhBfum
同じく xorg-x11-6.8.0 ビルド完了
nvidia のドライバで X が起動しなくなった (´・ω・`)

nvidia-kernel と nvidia-glx を emerge し直して
opengl-update nvidia を実行しても NG
Driver "nv" なら OK

/var/log/Xorg.0.log には
Symbol fbWinPrivateIndex from module /usr/X11R6/lib64/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbWinPrivateIndex from module /usr/X11R6/lib64/modules/drivers/nvidia_drv.o is unresolved!
というエラーが大量に...

GeForce FX 5700 Ultra
nvidia-kernel-1.0.6111
nvidia-glx-1.0.6111

nvidia のドライバで xorg-x11-6.8.0 を
起動できた人いますか?

978 :login:Penguin:04/09/10 00:04 ID:lH2Gx7Sr
Gentoo 航海日誌(2004-08-31)をみると、
ハッカーにやられたんだろうか?
へんなリンク元(アダルト?)が一杯ある。
しかも皆666となってる。。。
クリックしてしもうた。。。

979 :login:Penguin:04/09/10 00:09 ID:apGBOK04
>>978
「Refererスパム」っつーやっちゃね。

980 :login:Penguin:04/09/10 00:20 ID:lH2Gx7Sr
>>979
最近噂になってる奴ですか。
困ったもんだ。

981 :976:04/09/10 00:50 ID:N9O25MKu
>>977
FX5200 使ってるけどちゃんと動いてるよ.
たぶん,そっちの x86-64 環境が原因じゃないかな.
こっちは普通の x86 マシンです(AthlonXP).

982 :login:Penguin:04/09/10 00:53 ID:tZXgIf/s
>>977
問題ないよ。FX5600(nvidia+Nvagp)
普通のathlon-xp(+nForce2), linux-2.4.25-r9だけどね。

>976 のkeyboard(kbd)で最初に立ち上がらなくてちょっと焦ったけど

983 :login:Penguin:04/09/10 10:36 ID:9fAx4t2j
x86 kde3.3 キター

984 :login:Penguin:04/09/10 10:40 ID:pxpO4z7w
kde3.2をちゃんと抹消しとけや
ハゲ

985 :login:Penguin:04/09/11 01:48:45 ID:x+OSMJSw
xorg-x11は漏れもkbdはまった。
speedo, xtt も無いのね。

あと、i865GのVGAなんだけど、これのDRIが有効にならない。
普通にX起動すると、i915のモジュールを探す。
本当はi830なんだけど。
で、i830.koをロードしてからX起動すると、凄い負荷で固まる。

あと、カーネルを更新したからかもしれないけど。
intel_mch_agpじゃだめで、intel_agpにしないと駄目になった。

986 :login:Penguin:04/09/11 08:11:06 ID:QLxyvkU2
xorg-x11-6.8.0 だけど X から他のコンソールに移れないです(Ctrl+Alt+F* が効かない).
他におんなじことになっている方いませんか?
emerge とかするとき不便です.

987 :login:Penguin:04/09/11 08:16:13 ID:cYKl/0nj
ebuildの作成方法について詳しく書かれているサイトってありませんか?
googleで適当に調べた結果だと「他のebuildを参考にして作れ」みたいなことしか書いてないのですが。


988 :login:Penguin:04/09/11 08:35:19 ID:a3GC+4hd
>>986
こちらは問題出てないですね。

それよりも
フォントの扱いが変わってしまったようで・・・苦労しました。
gtk-1.x系のアプリだけ、更新後にどうしてもtruetypeのフォントが利用できなかったのですが
xorg.confファイル中のドライバモジュールにfreetypeが入ってなかったのが原因でした。
(6.7.xxのときはXF86Configを使い回してて、その中には入っていなかったのですが・・・謎)


989 :login:Penguin:04/09/11 11:28:53 ID:TQSGOk/V
GCC のマニュアル見てたら -march=pentium-m
が追加されたようなので、指定して gentoo をインストール。

bootstrap.sh でそんなフラグはねえよと言われますた・・
stage2 以降に使えるようになるのかな。
とりあえず pentium3 で十分なんだろうけど。

990 :login:Penguin:04/09/11 13:23:13 ID:hvZLwODI
>>986
Option "DontVTSwitch"
が有効になってるとか?

>>987
実際人の書いたebuildまねるのが一番手っ取り早いけど、ちゃんと自分で調べなきゃ
気持ち悪いというなら、
http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml


991 :login:Penguin:04/09/11 13:51:27 ID:Zp1pC0q7
postgresqlを動かせた方いらっしゃいますか?

emerge postgresql
ebuild /var/db/pkg/dev-db/postgresql-7.3.3/postgresql-7.3.3.ebuild config

この後の設定はどうすればいいのでしょうか?
アドバイスお願いします。

992 :login:Penguin:04/09/11 16:01:46 ID:bXdg/TaH
>>986
xkbdisable な時はそうなった。
で、/usr/X11R6/lib/X11/xkb/xkbcomp が壊れてたのを
/usr/X11R6/bin からコピーして直し、xkbが有効になるようにしたらOKだった。



993 :login:Penguin:04/09/11 17:20:59 ID:Xj/BDXwb
>>991
config したときに、

Success. You can now start the database server using:

/etc/init.d/postgresql start

って言われなかった?
config で初期化までしてくれるので、後は postmaster を起動して
データベースを作ってという作業になる。
もう Gentoo は関係なくて PostgreSQL の話だよ。

http://www.atmarkit.co.jp/flinux/rensai/postgres02/postgres02.html
この記事の initdb までが終わった段階。
( $ postmaster -S -i は gentoo だと /etc/init.d/postgresql start )

994 :login:Penguin:04/09/11 17:32:41 ID:I2VHC7ro
>>993
ありがとうございます。WEBを見て早速試してみます。

995 :login:Penguin:04/09/11 17:47:34 ID:I2VHC7ro
甘えて質問させてもらいます。
ebuild /var/db/pkg/dev-db/postgresql-7.3.3/postgresql-7.3.3.ebuild config
でコンフィグレーションした場合には

POSTGRES_HOME
PGLIB
PGDATA
MANPATH
LD_LIBRARY_PATH

をどのように設定すればいいのでしょうか?
すれ違い気味で本当に申し訳ありません。アドバイスよろしくお願いします。

996 :login:Penguin:04/09/11 17:59:40 ID:Xj/BDXwb
>>995
POSTGRES_HOME=/usr
PGLIB=/usr/lib
PGDATA=/var/lib/postgresql/data

997 :login:Penguin:04/09/11 18:07:45 ID:j3LpuJJ5
朝雲支流が997げっとだぜ!

998 :login:Penguin:04/09/11 18:17:59 ID:OPm/tbOg
998っと

999 :login:Penguin:04/09/11 18:18:37 ID:OPm/tbOg
999っと、1000どぞ

1000 :login:Penguin:04/09/11 18:27:14 ID:5OlxxQtw
1000get-
  _, ._
(;゚ Д゚)

1001 :1001:Over 1000 Thread
このスレッドは1000を超えました。
もう書けないので、新しいスレッドを立ててくださいです。。。

272 KB
★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.04.00 2017/10/04 Walang Kapalit ★
FOX ★ DSO(Dynamic Shared Object)